The SPDX license identifier should have the form
// SPDX-License-Identifier:
for a .c source file. File hfa384x_usb.c has instead the form
/* SPDX-License-Identifier: */
which is the form for C header files. Hence this patch corrects it.
Issue identified by checkpatch.
Signed-off-by: Himadri
On 10/04/19 4:12 PM, Dan Carpenter wrote:
On Wed, Apr 10, 2019 at 03:30:22PM +0530, Himadri Pandya wrote:
Fix checkpatch warning "Alignment should match open parenthesis".
Signed-off-by: Himadri Pandya
---
drivers/staging/fbtft/fb_tinylcd.c | 2 +-
1 file changed, 1 inser
Resolve checkpatch warning for using symbolic permissions by replacing
them with octal permissions.
Signed-off-by: Himadri Pandya
---
drivers/staging/gasket/gasket_sysfs.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/gasket/gasket_sysfs.h
b/drivers
Fix checkpatch warning "Alignment should match open parenthesis".
Signed-off-by: Himadri Pandya
---
drivers/staging/fbtft/fb_tinylcd.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/fbtft/fb_tinylcd.c
b/drivers/staging/fbtft/fb_tinylcd.c
index 94
Decrement the reference count on port while returning out of the loop.
Signed-off-by: Himadri Pandya
---
net/dsa/dsa2.c | 14 ++
1 file changed, 10 insertions(+), 4 deletions(-)
diff --git a/net/dsa/dsa2.c b/net/dsa/dsa2.c
index a1917025e155..396e7433dd8f 100644
--- a/net/dsa/dsa2
Rename following macro arguments to fix checkpatch warning: Avoid
CamelCase and make the arguments more readable, understandable.
__pIeeeDev -> __ieee_dev
__pTa -> __address
Signed-off-by: Himadri Pandya
---
drivers/staging/rtl8192e/dot11d.
On 13/02/19 2:36 PM, Greg KH wrote:
A: http://en.wikipedia.org/wiki/Top_post
Q: Were do I find info about this thing called top-posting?
A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thi
Rename function cpMacAddr to copy_mac_addr in order to fix checkpatch
warning: Avoid CamelCase and make the function name more readable,
understandable.
Signed-off-by: Himadri Pandya
---
Changes in V2:
Properly wrap commit message at 72 columns.
---
drivers/staging/rtl8192e/dot11d.h | 4
On 13/02/19 1:25 AM, Dan Carpenter wrote:
On Wed, Feb 13, 2019 at 01:14:38AM +0530, Himadri Pandya wrote:
Rename function cpMacAddr to copy_mac_addr in order to fix checkpatch
warning: Avoid CamelCase and make the function name more readable,
understandable.
---
Changes in V2
I guess this patch has not been reviewed yet. Please let me know if it
needs revision.
Thank you.
- Himadri
On 10/02/19 2:13 PM, Himadri Pandya wrote:
Rename following macro arguments to fix checkpatch warning: Avoid
Camelcase and make the arguments more readable, understandable
Rename function cpMacAddr to copy_mac_addr in order to fix checkpatch
warning: Avoid CamelCase and make the function name more readable,
understandable.
---
Changes in V2:
Properly wrap commit message at 72 columns.
Signed-off-by: Himadri Pandya
---
drivers/staging/rtl8192e/dot11d.h | 4
Rename function Dot11d_Channelmap to dot11d_channel_map to fix
checkpatch warning: Avoid CamelCase.
Signed-off-by: Himadri Pandya
---
drivers/staging/rtl8192e/dot11d.c| 4 ++--
drivers/staging/rtl8192e/dot11d.h| 2 +-
drivers/staging/rtl8192e/rtl8192e/rtl_core.c | 2
ed-off-by: Himadri Pandya
---
drivers/staging/rtl8192e/dot11d.c | 30 +++---
1 file changed, 15 insertions(+), 15 deletions(-)
diff --git a/drivers/staging/rtl8192e/dot11d.c
b/drivers/staging/rtl8192e/dot11d.c
index 3e66e01138db..fdf6d951384c 100644
--- a/drivers/staging/rtl8192e
Rename function Dot11d_UpdateCountryIe to dot11d_update_country to fix
checkpatch warning: Avoid CamelCase.
Signed-off-by: Himadri Pandya
---
drivers/staging/rtl8192e/dot11d.c| 2 +-
drivers/staging/rtl8192e/dot11d.h| 2 +-
drivers/staging/rtl8192e/rtllib_rx.c | 2 +-
3 files changed, 3
Rename function DOT11D_ScanComplete to dot11d_scan_complete to fix
checkpatch warning: Avoid CamelCase.
Signed-off-by: Himadri Pandya
---
drivers/staging/rtl8192e/dot11d.c | 2 +-
drivers/staging/rtl8192e/dot11d.h | 2 +-
drivers/staging/rtl8192e/rtllib_softmac.c | 4 ++--
3
Rename following parameters of function dot11d_update_country to fix
checkpatch warning: Avoid CamelCase and make the parameter names more
readable, understandable.
pTaddr -> address
CoutryIeLen -> country_len
pCoutryIe -> country
Signed-off-by: Himad
Rename following macro arguments to fix checkpatch warning: Avoid
Camelcase and make the arguments more readable, understandable.
__pIeeeDev -> __ieee_dev
__pTa -> __address
Signed-off-by: Himadri Pandya
---
drivers/staging/rtl8192e/dot11d.
Rename function Dot11d_Reset to dot11d_reset to fix checkpatch warning:
Avoid CamelCase.
Signed-off-by: Himadri Pandya
---
drivers/staging/rtl8192e/dot11d.c | 4 ++--
drivers/staging/rtl8192e/dot11d.h | 2 +-
drivers/staging/rtl8192e/rtllib_softmac.c | 2 +-
3 files changed, 4
Rename function cpMacAddr to copy_mac_addr in order to fix checkpatch
warning:Avoid CamelCase and make the function name more readable,
understandable.
Signed-off-by: Himadri Pandya
---
drivers/staging/rtl8192e/dot11d.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a
Rename following members of struct rtllib_device to fix checkpatch
warning: Avoid CamelCase
pDot11dInfo -> dot11d_info
bGlobalDomain -> global_domain
IbssStartChnl -> bss_start_channel
Signed-off-by: Himadri Pandya
---
Changes in V2:
Rename "Ibs
ountry_watchdog
MaxTxPwrDbmList -> max_tx_power_list
State -> state
Signed-off-by: Himadri Pandya
---
Changes in V2:
Fix typo in new name "max_tx_power_list" in commit
message(mac_tx_power_list -> max_tx_power_list).
---
drivers/staging/rtl8192e/dot11d.c | 28 +++
Rename following members of chnl_txpow_triple to fix checkpatch
warning: Avoid CamelCase
FirstChnl -> first_channel
NumChnls -> num_channels
MaxTxPowerInDbm -> max_tx_power
Signed-off-by: Himadri Pandya
---
Changes in V2:
Rename "FirstChnl" to "f
On 05/02/19 11:52 PM, Greg KH wrote:
On Tue, Feb 05, 2019 at 07:22:11PM +0100, Greg KH wrote:
On Tue, Feb 05, 2019 at 09:42:39AM -0800, Himadri Pandya wrote:
Rename following members of struct rtllib_device to fix checkpatch
warning: Avoid CamelCase
pDot11dInfo -> dot11d_i
On 05/02/19 11:53 PM, Greg KH wrote:
On Tue, Feb 05, 2019 at 09:42:38AM -0800, Himadri Pandya wrote:
Rename following members of struct rt_dot11d_info to avoid checkpatch
warning: Avoid CamelCase
bEnabled -> enabled
CountryIelen -> country_len
Countr
On 05/02/19 11:51 PM, Greg KH wrote:
On Tue, Feb 05, 2019 at 09:42:37AM -0800, Himadri Pandya wrote:
Rename following members of struct chnl_txpow_triple to avoid
checkpatch warning: Avoid CamelCase
FirstChnl -> first_chnl
NumChnls -> num_chnls
We do have vowels, how
ountry_watchdog
MaxTxPwrDbmList -> mac_tx_power_list
State -> state
Signed-off-by: Himadri Pandya
---
drivers/staging/rtl8192e/dot11d.c | 28 ++--
drivers/staging/rtl8192e/dot11d.h | 30 +++---
2 files changed, 29 insertions(+), 29 del
Rename following members of struct rtllib_device to fix checkpatch
warning: Avoid CamelCase
pDot11dInfo -> dot11d_info
bGlobalDomain -> global_domain
IbssStartChnl -> ibss_start_chnl
Signed-off-by: Himadri Pandya
---
drivers/staging/rtl8192e/dot11d.c
Rename following members of struct chnl_txpow_triple to avoid
checkpatch warning: Avoid CamelCase
FirstChnl -> first_chnl
NumChnls -> num_chnls
MaxTxPwrInDbm -> max_tx_power
Signed-off-by: Himadri Pandya
---
drivers/staging/rtl8192e/dot1
Fix checkpatch warning: Avoid CamelCase by renaming following parameters of
function dot11d_update_country_ie
pTaddr -> p_taddr
CoutryIeLen -> coutry_ie_len
pCoutryIe -> p_coutry_ie
Signed-off-by: Himadri Pandya
---
drivers/staging/rtl8192e/dot1
Fix checkpatch warning: Avoid CameCase by renaming following local
variables of function dot11d_update_country_ie
NumTriples -> num_triples
MaxChnlNum -> max_chnl_num
pTriple -> p_triple
Signed-off-by: Himadri Pandya
---
drivers/staging/rtl8192e/dot1
ScanComplete -> dot11d_scan_complete
Signed-off-by: Himadri Pandya
---
drivers/staging/rtl8192e/dot11d.c| 12 ++--
drivers/staging/rtl8192e/dot11d.h| 12 ++--
drivers/staging/rtl8192e/rtl8192e/rtl_core.c | 2 +-
drivers/staging/rtl8192e/rtllib_rx.c | 2 +-
drivers/s
Fix checkpatch warning: Avoid CamelCase by renaming following structure
members of struct rtllib_device
pDot11dInfo -> p_dot11d_info
bGlobalDomain -> b_global_domain
IbssStartChnl -> ibss_start_chnl
Signed-off-by: Himadri Pandya
---
drivers/staging/rtl8192e
Fix checkpatch warning: Avoid CamelCase by renaming following macro
arguments
__pIeeeDev -> __p_ieee_dev
__pTa -> __p_ta
Signed-off-by: Himadri Pandya
---
drivers/staging/rtl8192e/dot11d.h | 30 +++---
1 file changed, 15 insertions(+), 15 del
t; b_enabled
CountryIelen -> country_ie_len
CountryIeBuf -> country_ie_buf
CountryIeSrcAddr -> country_ie_src_addr
CountryWatchdog -> country_watchdog
MaxTxPwrDbmList -> mac_tx_pwr_dbm_list
State -> state
Signed-off-by: Himadri Pandya
---
drivers/
34 matches
Mail list logo