Remove the dead code protected by in_user in dgnc_tty_write() because it is set
to 0 and never changed to 1 thus the code in ifs never gets executed.
Signed-off-by: Giedrius Statkevičius
---
v2: Just remove the dead code protected by in_user and join the first and third
patches.
drivers/staging
count doesn't get changed in between identical checks in dgnc_tty_write() so
remove the second check
Signed-off-by: Giedrius Statkevičius
---
v2: no change
drivers/staging/dgnc/dgnc_tty.c | 6 --
1 file changed, 6 deletions(-)
diff --git a/drivers/staging/dgnc/dgnc_tty.c b/drivers/staging/
count doesn't change between the last check a few lines before so remove this
redundant check
Signed-off-by: Giedrius Statkevičius
---
drivers/staging/dgnc/dgnc_tty.c | 6 --
1 file changed, 6 deletions(-)
diff --git a/drivers/staging/dgnc/dgnc_tty.c b/drivers/staging/dgnc/dgnc_tty.c
index
do
if (blah) foo();
bar();
instead of
if (blah) {
foo();
bar();
} else {
bar();
}
Signed-off-by: Giedrius Statkevičius
---
drivers/staging/dgnc/dgnc_tty.c | 8 +++-
1 file changed, 3 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/dgnc/dgnc_tty.c b/driv
A mutex should be used here (and it's name even says that) so remove the hiding
of a semaphore behind a #define and use a real mutex that the kernel provides.
Signed-off-by: Giedrius Statkevičius
---
drivers/staging/dgnc/dgnc_tty.c | 12
1 file changed, 4 insertions(+), 8 deletions(
outer.c:1337:1: warning: symbol
'lnet_rtrpool_init' was not declared. Should it be static?
Signed-off-by: Giedrius Statkevicius
---
drivers/staging/lustre/lnet/lnet/router.c | 18 +-
1 file changed, 9 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/lustre/lne
On 2014.10.19 12:55, Fabio Falzoi wrote:
> Clean up the code in rtsx_reset_chip function defining two new helper
> functions rtsx_reset_aspm and rtsx_enable_pcie_intr.
> Specifically, the following checkpatch warnings are corrected:
> * PARENTHESIS_ALIGNMENT at rows 271, 302, 343 and 346
> * LONG_L
From: Giedrius Statkevičius
This patch set is a general code style clean up for rtsx_chip.c. After
this patch set checkpatch.pl without --strict doesn't complain anything
about at all and with --strict it only complains about unmatched
parantheses in those few places where I can't fix them becaus
From: Giedrius Statkevičius
Convert labels from Camel Case to lower case, remove unnecessary
parantheses around operands of dereference operators and remove unneeded
empty lines before }.
Gets rid of a checkpatch.pl "check" that code should avoid Camel Case,
also the code had a bunch of &(a) whe
From: Giedrius Statkevičius
Make all divided lines aligned to the opening paranthesis.
Basically makes all lines aligned to the opening paranthesis to make the
code more readable and it also gets rid of a lot of checkpatch.pl
"checks".
Signed-off-by: Giedrius Statkevičius
---
drivers/staging/
From: Giedrius Statkevičius
This patch set is a general code style clean up for rtsx_chip.c. After
this patch set checkpatch.pl without --strict doesn't complain anything
about at all and with --strict it only complains about unmatched
parantheses in those few places where I can't fix them becaus
From: Giedrius Statkevičius
Join together chained if's where possible to lower the indentation
level.
In a lot of places of this code the indentation level is already very
high.
As a result, this patch increases the code flow and readability.
Signed-off-by: Giedrius Statkevičius
---
drivers/s
From: Giedrius Statkevičius
Make a couple of lines shorter than the max limit by diving them and
also make sure to align them properly where possible.
Signed-off-by: Giedrius Statkevičius
---
drivers/staging/rts5208/rtsx_chip.c | 31 ++-
1 file changed, 22 insertion
From: Giedrius Statkevičius
Convert code in format of if (a) if(b) { [...] } to one line with a
simple ternary operation to avoid unnecesary increase of indentation
level.
Signed-off-by: Giedrius Statkevičius
---
drivers/staging/rts5208/rtsx_chip.c | 90 ++---
1
From: Giedrius Statkevičius
Convert code in format of if (a) if(b) { [...] } to one line with a simple
ternary operation to avoid unnecesary increase of indentation level.
Signed-off-by: Giedrius Statkevičius
---
drivers/staging/rts5208/rtsx_chip.c | 90 ++---
From: Giedrius Statkevičius
Make a couple of lines shorter than the max limit by diving them and also make
sure to align them properly where possible.
Signed-off-by: Giedrius Statkevičius
---
drivers/staging/rts5208/rtsx_chip.c | 31 ++-
1 file changed, 22 insertio
From: Giedrius Statkevičius
Align divided lines to the first line's opening paranthesis
Where two or more if's are in form 'if (a) if (b) { [...] }' convert them into
one to lower the indentation level.
Use the ternary operator in places where there is code in format of: 'if (a) {
b = foo1; } e
From: Giedrius Statkevičius
Convert labels from Camel Case to lower case, remove unnecessary parantheses
around operands of dereference operators and remove unneeded empty lines before
}.
Signed-off-by: Giedrius Statkevičius
---
drivers/staging/rts5208/rtsx_chip.c | 52 +++---
From: Giedrius Statkevičius
Make all divided lines aligned to the opening paranthesis
Signed-off-by: Giedrius Statkevičius
---
drivers/staging/rts5208/rtsx_chip.c | 87 +++--
1 file changed, 45 insertions(+), 42 deletions(-)
diff --git a/drivers/staging/rts5208
From: Giedrius Statkevičius
Join together chained if's where possible to lower the indentation level.
Signed-off-by: Giedrius Statkevičius
---
drivers/staging/rts5208/rtsx_chip.c | 100
1 file changed, 44 insertions(+), 56 deletions(-)
diff --git a/drivers
thout
creating more functions and moving code to them.
This patch is against Greg KH's staging-next tree.
Signed-off-by: Giedrius Statkevicius
---
Changes in v3:
- Change blocks that have form of if (a) { b = 1; } else { b = 0; } to 'b = a
? 1 : 0;' and use ternary operator other
On 2014.10.02 14:45, Joe Perches wrote:
> On Thu, 2014-10-02 at 14:13 +0300, Giedrius Statkevicius wrote:
>> Fix 10 occurences of coding style errors where the line exceeds 80
>> characters by breaking them into more lines.
>> Checkpatch.pl reports these errors as: &
ckpatch.pl reports these errors as: 'WARNING: void function return
statements are not generally useful'
Lastly it combines two if statements into one in rtsx_reset_chip()
Patch is against Greg KH's staging-next tree.
Signed-off-by: Giedrius Statkevicius
---
Changes in v2:
- Combines t
ckpatch.pl reports these errors as: 'WARNING: void function return
statements are not generally useful'
Patch is against Greg KH's staging-next tree.
Signed-off-by: Giedrius Statkevicius
---
drivers/staging/rts5208/rtsx_chip.c | 40 -
1 file chan
24 matches
Mail list logo