Replaces CVMX_WAIT_FOR_FIELD32 macro with equivalent function.
Signed-off-by: Georgios Tsotsos
---
drivers/staging/octeon-usb/octeon-hcd.c | 56 +
1 file changed, 29 insertions(+), 27 deletions(-)
diff --git a/drivers/staging/octeon-usb/octeon-hcd.c
b/drivers
Yes reseeding in a better way seems logical, i even got lost
with the patch series. I will return with more consistent
series.
On Mon, 30 Jul 2018 at 11:51, Greg Kroah-Hartman
wrote:
>
> On Mon, Jul 30, 2018 at 01:29:36AM +0300, Georgios Tsotsos wrote:
> > Replaced -1 with define
Thank you, i found a few case on this module i will try to fix them
and send a new patch series.
On Sun, 29 Jul 2018 at 20:33, Joe Perches wrote:
>
> On Sun, 2018-07-29 at 17:43 +0300, Georgios Tsotsos wrote:
> > Fixing coding style for a few lines that were reported t
Replaced -1 with defined error code EINVAL
Signed-off-by: Georgios Tsotsos
---
v2: Apply coding style to function cvmx_usb_poll_channel
v3: Break down function cvmx_usb_poll_channel
v4: Return defined error code and applying coding style for function calls
v5: Fixing wrong patch applied before
Replacing CVMX_WAIT_FOR_FIELD32 macro with equivalent function, and used
simpler approach for new function's parameters.
Signed-off-by: Georgios Tsotsos
---
v3: Changed CVMX_WAIT_FOR_FIELD32 macro to function according as refereed in
commit message and suggested by Greg Kroah-Hartman
v4:
Hi,
Indeed there was a mix-up with patches i will send correction asap.
On Sun, 29 Jul 2018 at 23:21, Aaro Koskinen wrote:
>
> Hi,
>
> On Sun, Jul 29, 2018 at 05:33:38PM +0300, Georgios Tsotsos wrote:
> > diff --git a/drivers/staging/octeon-usb/octeon-hcd.c
> > b/dr
ok. (I hope with less versions :))
On Sun, 29 Jul 2018 at 15:43, Greg Kroah-Hartman
wrote:
>
> On Sun, Jul 29, 2018 at 02:41:53PM +0300, Georgios Tsotsos wrote:
> > In order to make this function more clear a new function created that
> > controls
> > channels halt on no
Fixing coding style for a few lines that were reported to check from
checkpatch.pl in minor cases for alignment and ending with parenthesis.
Signed-off-by: Georgios Tsotsos
---
drivers/staging/octeon/ethernet.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a
Replaced -1 with defined error code EINVAL
Signed-off-by: Georgios Tsotsos
---
v2: Apply coding style to function cvmx_usb_poll_channel
v3: Break down function cvmx_usb_poll_channel
v4: Return defined error code and applying coding style for function calls
drivers/staging/octeon-usb/octeon
Assign to variable the result of CVMX_USBCX_GRSTCTL instead of multiple
calling a macro.
Signed-off-by: Georgios Tsotsos
---
v2: It wasn't exist in this or earlier versions of patch series
v3: It seems a logical to avoid multiple calls of CVMX_USBCX_GRSTCTL that will
also help cleaning up
Replacing CVMX_WAIT_FOR_FIELD32 macro with equivalent function.
Signed-off-by: Georgios Tsotsos
---
v2: Changed CVMX_WAIT_FOR_FIELD32 syntax to avoid checkpatch check notice and
tried to make the macro more readable.
v3: Changed CVMX_WAIT_FOR_FIELD32 macro to function according as refereed in
In order to make this function more clear a new function created that controls
channels halt on no DMA mode.
Signed-off-by: Georgios Tsotsos
---
drivers/staging/octeon-usb/octeon-hcd.c | 81 +
1 file changed, 53 insertions(+), 28 deletions(-)
diff --git a
Changed the function in order to use only values instead passing unions
i think its better than passing pointers there.
Georgios Tsotsos (1):
Staging: octeon-usb: Breaks down cvmx_usb_poll_channel().
drivers/staging/octeon-usb/octeon-hcd.c | 81 +
1 file
Assign to variable the result of CVMX_USBCX_GRSTCTL instead of multiple
calling a macro.
Signed-off-by: Georgios Tsotsos
---
drivers/staging/octeon-usb/octeon-hcd.c | 20 ++--
1 file changed, 10 insertions(+), 10 deletions(-)
diff --git a/drivers/staging/octeon-usb/octeon-hcd.c
Replying to previous message, i changed CVMX_WAIT_FOR_FIELD32 macro to function
and altered a multiple calling of CVMX_USBCX_GRSTCTL call to single call and
stored to variable.
Georgios Tsotsos (2):
Staging: octeon-usb: Change multiple calling of CVMX_USBCX_GRSTCTL
Staging: octeon-usb
Replacing CVMX_WAIT_FOR_FIELD32 macro with equivalent function.
Signed-off-by: Georgios Tsotsos
---
drivers/staging/octeon-usb/octeon-hcd.c | 65 +++--
1 file changed, 38 insertions(+), 27 deletions(-)
diff --git a/drivers/staging/octeon-usb/octeon-hcd.c
b/drivers
I will change it into function, as i checked so far i will need to
change USB_SET_FIELD32 for the same reason.
On Fri, 27 Jul 2018 at 18:15, Greg Kroah-Hartman
wrote:
>
> On Thu, Jul 26, 2018 at 06:41:52PM +0300, Georgios Tsotsos wrote:
> > Fixing coding style for CVMX_WAIT_FOR
Indeed i should probably either use pointer
or pass the values, i will do some more testing
and update this.
Thanks
On Thu, 26 Jul 2018 at 19:31, Joe Perches wrote:
>
> On Thu, 2018-07-26 at 18:41 +0300, Georgios Tsotsos wrote:
> > In order to make this function more clear a new func
In order to make this function more clear a new function created that controls
channels halt on no DMA mode.
Signed-off-by: Georgios Tsotsos
---
drivers/staging/octeon-usb/octeon-hcd.c | 83 +
1 file changed, 54 insertions(+), 29 deletions(-)
diff --git a
Adding appropriate SPDX-License-Identifier (GPL-2) that were missing
from code, header and make files.
Signed-off-by: Georgios Tsotsos
---
drivers/staging/octeon-usb/Makefile | 1 +
drivers/staging/octeon-usb/octeon-hcd.c | 1 +
drivers/staging/octeon-usb/octeon-hcd.h | 1 +
3 files changed
Fixing coding style for CVMX_WAIT_FOR_FIELD32 was confusing. Also
encapsulates into parentheses timeout_usec.
Signed-off-by: Georgios Tsotsos
---
drivers/staging/octeon-usb/octeon-hcd.c | 44 +
1 file changed, 23 insertions(+), 21 deletions(-)
diff --git a
eadability and keeping it
under 80 columns.
Georgios Tsotsos (3):
Staging: octeon-usb: Adding SPDX license identifier
Staging: octeon-usb: Change coding style of CVMX_WAIT_FOR_FIELD32 marco.
Staging: octeon-usb: Breaks down cvmx_usb_poll_channel().
drivers/staging/octeon-usb/Makefile
CVMX_WAIT_FOR_FIELD32
macro.
It could improve readability and maintenance of this module if function
cvmx_usb_poll_channel() break down (and probably some others too)
Georgios Tsotsos (4):
Staging: octeon-usb: Adds SPDX License Identifier
Staging: octeon-usb: Applying coding style for column width
Changes coding style and encapsulate into parentheses timeout_usec.
Signed-off-by: Georgios Tsotsos
---
drivers/staging/octeon-usb/octeon-hcd.c | 44 +
1 file changed, 23 insertions(+), 21 deletions(-)
diff --git a/drivers/staging/octeon-usb/octeon-hcd.c
b
Signed-off-by: Georgios Tsotsos
---
drivers/staging/octeon-usb/octeon-hcd.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/octeon-usb/octeon-hcd.c
b/drivers/staging/octeon-usb/octeon-hcd.c
index cded30f145aa..cff5e790b196 100644
--- a/drivers/staging/octeon-usb/octeon-hcd.c
Signed-off-by: Georgios Tsotsos
---
drivers/staging/octeon-usb/octeon-hcd.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/octeon-usb/octeon-hcd.h
b/drivers/staging/octeon-usb/octeon-hcd.h
index 3353aefe662e..769c36cf6614 100644
--- a/drivers/staging/octeon-usb/octeon-hcd.h
This patch resolves the warnings as its refereed to TODO list.
There are also a code style issues that could be resolved via breaking
down cvmx_usb_poll_channel().
Signed-off-by: Georgios Tsotsos
---
drivers/staging/octeon-usb/octeon-hcd.c | 10 ++
1 file changed, 6 insertions(+), 4
Signed-off-by: Georgios Tsotsos
---
drivers/staging/octeon-usb/octeon-hcd.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/octeon-usb/octeon-hcd.c
b/drivers/staging/octeon-usb/octeon-hcd.c
index cded30f145aa..cff5e790b196 100644
--- a/drivers/staging/octeon-usb/octeon-hcd.c
Changes coding style and encapsulate into parentheses timeout_usec.
Signed-off-by: Georgios Tsotsos
---
drivers/staging/octeon-usb/octeon-hcd.c | 44 +
1 file changed, 23 insertions(+), 21 deletions(-)
diff --git a/drivers/staging/octeon-usb/octeon-hcd.c
b
are resolved,also a notice about CVMX_WAIT_FOR_FIELD32
macro.
It could improve readability and maintenance of this module if function
cvmx_usb_poll_channel() break down (and probably some others too)
Georgios Tsotsos (4):
Staging: octeon-usb: Adds SPDX License Identifier
Staging: octeon-usb
Signed-off-by: Georgios Tsotsos
---
drivers/staging/octeon-usb/octeon-hcd.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/octeon-usb/octeon-hcd.h
b/drivers/staging/octeon-usb/octeon-hcd.h
index 3353aefe662e..769c36cf6614 100644
--- a/drivers/staging/octeon-usb/octeon-hcd.h
Signed-off-by: Georgios Tsotsos
---
drivers/staging/octeon-usb/octeon-hcd.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/octeon-usb/octeon-hcd.h
b/drivers/staging/octeon-usb/octeon-hcd.h
index 3353aefe662e..769c36cf6614 100644
--- a/drivers/staging/octeon-usb/octeon-hcd.h
This patch resolves the warnings as its refereed to TODO list.
There are also a code style issues that could be resolved via breaking
down cvmx_usb_poll_channel().
Signed-off-by: Georgios Tsotsos
---
drivers/staging/octeon-usb/octeon-hcd.c | 10 ++
1 file changed, 6 insertions(+), 4
Signed-off-by: Georgios Tsotsos
---
drivers/staging/octeon-usb/octeon-hcd.c | 55 ++---
drivers/staging/octeon-usb/octeon-hcd.h | 1 +
2 files changed, 31 insertions(+), 25 deletions(-)
diff --git a/drivers/staging/octeon-usb/octeon-hcd.c
b/drivers/staging/octeon
34 matches
Mail list logo