On Mon, Aug 16, 2021 at 8:06 PM Leon Krieg wrote:
>
> Sorry to bother you with this low-effort patch but I'd really like to get
> my feet in the water and this whole process is making me nervous. I'd
> really appreciate you taking the time to look over this diff and
> hopefully I did not screw up
Hi,
On Fri, Feb 12, 2021 at 8:59 AM shivang upadhyay wrote:
>
> Signed-off-by: shivang upadhyay
There's no description here. Even though this seems like a trivial
patch, it should still be there. Your commit message would look
something like
ks7010: enclose non-trivial defines in parenthes
On Sun, Nov 4, 2018 at 11:51 AM Sergio Paracuellos
wrote:
>
> Function 'mt7621_pcie_init_ports' is never called in atomic context.
> It calls mdelay() to busily wait, which is not necessary. mdelay()
> can be replaced with msleep().
>
> Signed-off-by: Sergio Paracuellos
> ---
> drivers/staging/m
On Wed, Apr 11, 2018 at 2:04 AM, Stephen Hemminger
wrote:
> The development version had ring size as a module parameter, but
> then it was made a fixed value. The code to set the size of
> the ring buffer binary file was lost in the transistion.
transition
Cheers,
Frans
_
On Tue, Nov 21, 2017 at 3:04 PM, Christian Gromm
wrote:
> This patch removes the function get_channel_by_iface that walks a list of
> all registered interfaces and returns a pointer to a channel when matched.
> Instead the private field of the interface structure is used to directly
> access the c
On Tue, Sep 12, 2017 at 2:40 AM, Liam Ryan wrote:
> Fix checkpath-reported unbalanced braces in the following areas
>
> 221: FILE: drivers/staging/rtl8712/hal_init.c:221:
> 392: FILE: drivers/staging/rtl8712/os_intfs.c:392:
> 363: FILE: drivers/staging/rtl8712/rtl8712_cmd.c:363:
> 889: FILE: drive
On Tue, Sep 12, 2017 at 10:49 PM, Greg KH wrote:
> On Tue, Sep 12, 2017 at 01:40:15AM +0100, Liam Ryan wrote:
>> Fix checkpath-reported unbalanced braces in the following areas
>>
>> 221: FILE: drivers/staging/rtl8712/hal_init.c:221:
>> 392: FILE: drivers/staging/rtl8712/os_intfs.c:392:
>> 363: FI
On Thu, Jul 13, 2017 at 5:50 PM, PY wrote:
> From: Pavlenko Yurii
>
> ---
> drivers/staging/fbtft/fbtft_device.c | 16
> 1 file changed, 8 insertions(+), 8 deletions(-)
>
> diff --git a/drivers/staging/fbtft/fbtft_device.c
> b/drivers/staging/fbtft/fbtft_device.c
> index 0d9747
On Thu, Jul 13, 2017 at 10:41 PM, Frans Klaver wrote:
> On Thu, Jul 13, 2017 at 5:50 PM, PY wrote:
>> Hello,
>>
>> I found some coding style warnings for fbtft_device.c
>> I fixed it in the patch.
>
> What patch?
Oh, found it.
_
On Thu, Jul 13, 2017 at 5:50 PM, PY wrote:
> Hello,
>
> I found some coding style warnings for fbtft_device.c
> I fixed it in the patch.
What patch?
Frans
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailm
Almost there on the subject. Stuff between brackets is removed by git,
so you should rather use something like
[PATCH v2] staging: lirc: Clean up zilog error codes
On Wed, Jul 12, 2017 at 9:17 PM, Yves Lemée wrote:
> According the coding style guidelines, the ENOSYS error code must be returned
>
On Wed, Jul 12, 2017 at 6:44 PM, Aviv Palivoda wrote:
> On Wed, Jul 12, 2017 at 07:26:08AM +0200, Frans Klaver wrote:
>> On Tue, Jul 11, 2017 at 9:51 PM, Aviv Palivoda wrote:
>> > Fix the following sparse warning:
>> > drivers/staging//wlan-ng/prism2sta.c:1691:20:
On Fri, Jun 30, 2017 at 8:39 PM, Mark Rogers wrote:
> Thank you for your feedback. I guess when making this patch I had the
> preferred coding style in mind, but didn't ask myself if making the code
> conform to it would truly improve readability.
>
> I agree with all of your comments. Do you thin
On Tue, Jul 11, 2017 at 7:57 PM, Yves Lemée wrote:
> According the coding style guidelines, the ENOSYS error code must be returned
> in case of a non existent system call. This code has been replaced with
> the ENOTTY error code indicating, a missing functionality.
>
> Signed-off-by: Yves Lemée
On Tue, Jul 11, 2017 at 9:51 PM, Aviv Palivoda wrote:
> Fix the following sparse warning:
> drivers/staging//wlan-ng/prism2sta.c:1691:20: warning: incorrect type in
> assignment (different base types)
>
> (a) Change struct hfa384x_authenticate_station_data status member type to
> __le16.
> (b) A
Hi,
Again, your subject is too generic.
On Wed, Jul 12, 2017 at 6:51 AM, Joseph Wright wrote:
> Declare private function static to fix sparse warning:
>
> ion_cma_heap.c:109:5: warning: symbol '__ion_add_cma_heaps' \
> was not declared. Should it be static?
>
> Signed-off-by: Joseph Wri
Hi,
please consider changing your subject to something like
staging: android/ion: declare two functions
Perhaps you can make it more on-topic. It's more useful than "fix
sparse warning"
On Wed, Jul 12, 2017 at 6:51 AM, Joseph Wright wrote:
> Declare functions to fix sparse warnings:
>
> ion_ca
On Mon, Jul 10, 2017 at 9:09 AM, AndyS wrote:
> Subject: [PATCH] Staging:ks7010:ks_wlan_net.c: unneeded type casting removed
[PATCH] staging: ks7010: remove unneeded type casting
> removed undesired type casting. Warning was raised by checkpatch.pl
> This patch is for eudyptula challenge
>
> Sig
On Mon, Jul 10, 2017 at 6:46 AM, Viresh Kumar wrote:
> Hi Mitchell,
>
> On 09-07-17, 20:25, Mitchell Tasman wrote:
>> Adjust formatting of various statements to keep line length within
>> the 80 column limit preferred by the Linux kernel coding style.
>
> We try to follow that most of the time, bu
On Sat, Jul 8, 2017 at 1:55 PM, SnazyMan wrote:
> [PATCH] Coding style fixes for /drivers/staging/ccree/. This is for the
> eudyptula challenge.
That's way too generic. Also, these patches are for the kernel, not
Little Penguin :D. It really isn't that important to the kernel that
you submit thi
On Thu, Jul 6, 2017 at 9:13 AM, Jaya Durga wrote:
> Subject: Staging: lustre :lustre: include :lustre_compat.h: Prefer using the
> BIT macro
Don't overdo it ;-).
Subject: staging: lustre: lustre_compat.h: Prefer using the BIT macro
> Replace all instances of (1 << 27) with BIT(27) to fix
> che
On Fri, Jun 30, 2017 at 6:52 AM, Mark Rogers wrote:
> Trivial style changes. There are still 3 "line over 80 characters"
> checkpatch.pl warnings, but I think they are best left alone as
> breaking the first two warning lines could hurt readability. The third
> warning is a message that should not
On Thu, Jun 29, 2017 at 7:03 PM, Brian Masney wrote:
> tsl2x7x_i2c_read() would call i2c_smbus_write_byte() and
> i2c_smbus_read_byte(). These two i2c functions can be replaced with a
> single call to i2c_smbus_read_byte_data(). This patch removes the
> tsl2x7x_i2c_read() function and replaces all
On Tue, Jun 27, 2017 at 9:27 AM, Gilad Ben-Yossef wrote:
> Align block comments according to coding style.
>
> Signed-off-by: Gilad Ben-Yossef
> ---
> drivers/staging/ccree/cc_hw_queue_defs.h | 8
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/staging/ccree/c
On Thu, Jun 29, 2017 at 12:25 PM, Jaya Durga wrote:
> Fix checkpatch.pl issue
> WARNING: Use of volatile is usually wrong:
> see Documentation/process/volatile-considered-harmful.rst
Now I've only had a very quick look at the code using this. Could you
elaborate on why just removing the volatile
Hi,
On Wed, Jun 28, 2017 at 2:50 PM, Simo Koskinen wrote:
> Fixed following warnings found by checkpatch.pl script:
>
> WARNING: Prefer using '"%s...", __func__' to using '',
> this function's name, in a string
>
> Signed-off-by: Simo Koskinen
> ---
> drivers/staging/rts5208/rtsx.c |
Hi,
On Wed, Jun 28, 2017 at 4:49 AM, Quytelda Kahja wrote:
> Replace the literal function name "visorbus_create_instance" with the format
> specifier "%s" so it can be dynamically filled by the __func__ macro.
On a general note, I think the actual change or effect is more import
to mention in th
On Tue, Jun 27, 2017 at 9:48 AM, Jaya Durga wrote:
> Fix checkpatch.pl warning of the form "CHECK" Macro argument 'x'
> may be better as '(x)' to avoid precedence issues.
>
> Signed-off-by: Jaya Durga
> ---
> drivers/staging/rtl8712/osdep_intf.h | 5 -
> 1 file changed, 4 insertions(+), 1 de
On Fri, Jun 23, 2017 at 07:37:28PM -0400, Julia Lawall wrote:
>
>
> On Sat, 24 Jun 2017, Frans Klaver wrote:
>
> > Hm. For some reason the great mail filtering scheme decided to push
> > this past my inbox :-/
> >
> > On Sat, Jun 17, 2017 at 12:44 AM, Joe P
On Mon, Jun 26, 2017 at 11:11 AM, Geert Uytterhoeven
wrote:
> On Mon, Jun 26, 2017 at 7:45 AM, AbdAllah-MEZITI
> wrote:
>> This patch
>> - will always take the lock
>
> Why?
>
> "The current code only takes the lock if multiple instances are in use.
> This is error-prone, and confuses static ana
On Sat, Jun 24, 2017 at 1:37 AM, Julia Lawall wrote:
>
>
> On Sat, 24 Jun 2017, Frans Klaver wrote:
>
>> Hm. For some reason the great mail filtering scheme decided to push
>> this past my inbox :-/
>>
>> On Sat, Jun 17, 2017 at 12:44 AM, Joe Perches wrote:
&g
There's no version number. Which one is the correct one?
On Mon, Jun 26, 2017 at 7:45 AM, AbdAllah-MEZITI
wrote:
> This patch
> - will always take the lock
> - fix the sparse warning:
> drivers/staging/sm750fb/sm750.c:159:13: warning: context imbalance in
> 'lynxfb_ops_fillrect' - different lock
On Sun, Jun 25, 2017 at 11:39 PM, AbdAllah-MEZITI
wrote:
> Subject: [PATCH] staging: sm750fb: always take the lock
When sending a new version of your patch, include a version number:
Subject: [PATCH V2] staging: ...
Frans
___
devel mailing list
de...@
On 25 June 2017 21:10:36 CEST, AbdAllah-MEZITI
wrote:
>This patch fixes the following sparce warnings: different lock contexts
>for basic block.
>
>drivers/staging/sm750fb//sm750.c:159:13: warning: context imbalance in
>'lynxfb_ops_fillrect' - different lock contexts for basic block
>drivers/st
On Fri, Jun 16, 2017 at 12:05 PM, Jaya Durga wrote:
> when building with make C=1 CF=-D__CHECK_ENDIAN__
>
> drivers/staging/wlan-ng/hfa384x_usb.c:3383:36: warning: cast to restricted
> __le16
>
> fixed by using the le16_to_cpus function.
>
> Signed-off-by: Jaya Durga
> ---
> drivers/staging/wla
Hm. For some reason the great mail filtering scheme decided to push
this past my inbox :-/
On Sat, Jun 17, 2017 at 12:44 AM, Joe Perches wrote:
> On Fri, 2017-06-16 at 19:45 +0200, Frans Klaver wrote:
>> The header field in struct pd_message is declared as an __le16 type. The
>&
benefit we don't get fishy results on big endian systems anymore.
Signed-off-by: Frans Klaver
---
drivers/staging/typec/fusb302/fusb302.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/typec/fusb302/fusb302.c
b/drivers/staging/typec/fusb302/
worked on the patch and modified commit message as per the
> recommendations from Frans Klaver and Greg K-H.
>
> - Patch was tested and built on next-20170609 and staging-testing.
> ---
> drivers/staging/wlan-ng/hfa384x.h| 18 +-
> drivers/staging/wla
On Mon, Jun 12, 2017 at 7:15 PM, wrote:
> From: Suniel Mahesh
>
> The following type mismatch warnings reported by sparse
> have been amended:
> warning: cast to restricted __le16
> warning: incorrect type in assignment (different base types)
Why not change the type of the struct fields to __le
adds value to the patch, as it's just for a personal
goal.
It is also custom to reply _below_ the (part of the) message you're
responding to by the way ;-).
Cheers,
Frans
> On 27/03/17 15:05, Frans Klaver wrote:
>> On Mon, Mar 27, 2017 at 1:52 PM, aviyae wrote:
>>> Fro
On Mon, Mar 27, 2017 at 1:52 PM, aviyae wrote:
> From: Aviya Erenfeld
>
> staging: goldfish: Fix style issues in macros
>
> Fix coding style issues in macros:
> 1. Add parenthesis around macros argument
> 2. Avoid arguments reuse in macros
>
> (For the eudyptula challenge)
How is that relevant?
It appears that our coding style prefers that logical continuations
have the operator at the end of the line. Fix that.
While at it, stick the 'if' after 'else' where it belongs.
Signed-off-by: Frans Klaver
---
drivers/staging/wlan-ng/prism2mgmt.c | 11 +--
1 file c
On Wed, Aug 19, 2015 at 12:00 PM, Sudip Mukherjee
wrote:
> On Tue, Aug 18, 2015 at 01:31:00PM -0300, Fabio Estevam wrote:
>> On Tue, Aug 18, 2015 at 12:18 PM, Sudip Mukherjee
>> wrote:
>> > According to the kernel coding style the NULL check should not be
>> > written as [variable] == NULL or [va
On Fri, Aug 14, 2015 at 11:42 AM, Adrian Remonda
wrote:
> This patch fixes the warning generated by sparse: "Using plain integer
> as NULL pointer" by replacing the offending 0 with NULL.
>
> Signed-off-by: Adrian Remonda
> ---
> v6: styling. Change the NULL test to comply with the Kernel coding
On Wed, Aug 12, 2015 at 1:19 PM, Pali Rohár wrote:
> On Wednesday 12 August 2015 11:12:49 Shah, Yash (Y.) wrote:
>> From: Yash Shah
>>
>> Fix line over 80 characters warning as detected by checkpatch.pl
>>
>> Signed-off-by: Yash Shah
>> ---
>> drivers/staging/media/bcm2048/radio-bcm2048.c | 3 +
Hi,
On Thu, Jul 23, 2015 at 8:20 AM, Incarnation P. Lee
wrote:
> drivers/staging/lustre/lustre/obdclass/cl_page.c
It is custom that you write slightly more introductory text here. Just
a file name is pointless.
The subject should probably contain [PATCH 0/5]. This would be
automatically fixed f
On 20 July 2015 21:42:39 CEST, Luis de Bethencourt
wrote:
>On Mon, Jul 20, 2015 at 09:54:56PM +0300, Dan Carpenter wrote:
>> On Mon, Jul 20, 2015 at 06:35:42PM +0200, Luis de Bethencourt wrote:
>> > Remove explicit true/false comparisons to bool variables.
>> >
>> > Signed-off-by: Luis de Bethen
Hi,
On Thu, Jul 16, 2015 at 8:17 AM, Incarnation P. Lee
wrote:
> Signed-off-by: Li Pan (Incarnation P. Lee)
>
> Fix one file coding sytle issue on linux-next-20150708, including macro
> aligned, missing blank lines after variable declarnation and brace missing
> in one line if structure.
Oh
On Tue, Jul 7, 2015 at 1:53 PM, SF Markus Elfring
wrote:
>> I think that as far as these kernel mailing lists are concerned,
>> the date of the update suggestion is the date on which you submitted the
>> patch,
>> rather than the date you originally committed it to your local tree.
>
> I imagine
On Tue, Jul 7, 2015 at 9:54 AM, SF Markus Elfring
wrote:
>> No need to try and preserve it.
>
> I find that it might occasionally help to share and keep the record
> on timestamps about the evolution for an original update suggestion.
I think that as far as these kernel mailing lists are concern
On Tue, Jul 7, 2015 at 8:21 AM, SF Markus Elfring
wrote:
>>> From: Markus Elfring
>>> Date: Sat, 27 Jun 2015 15:56:57 +0200
>>
>> Why is this in the body of the email?
>
> Does the canonical patch format support to preserve
> specific details about a shown commit by specification
> of fields like
On Mon, Jun 29, 2015 at 10:18 PM, Ravi Teja Darbha wrote:
>
> Fix line over 80 characters warning.
>
> Signed-off-by: Ravi Teja Darbha
> ---
> drivers/staging/rtl8712/rtl8712_recv.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/staging/rtl8712/rtl8712_recv.
On Tue, Jun 23, 2015 at 3:59 PM, Luis de Bethencourt
wrote:
> On Tue, Jun 23, 2015 at 03:37:20PM +0200, Frans Klaver wrote:
>> On Tue, Jun 23, 2015 at 3:21 PM, Luis de Bethencourt
>> wrote:
>>
>> >> > if (dm_digtable.dig_algorithm_switch) {
>&
On Tue, Jun 23, 2015 at 3:44 PM, Dmitry Kalinkin
wrote:
>
>> On 23 Jun 2015, at 16:21, Frans Klaver wrote:
>>
>> You left one in the function declarations (vme_user_write).
>
> If you mean forward declarations, they are already gone in Greg’s tree:
> https://git.ke
On Tue, Jun 23, 2015 at 3:21 PM, Luis de Bethencourt
wrote:
>> > if (dm_digtable.dig_algorithm_switch) {
>> > @@ -3062,7 +3062,8 @@ static void dm_dynamic_txpower(struct net_device
>> > *dev)
>> > priv->bDynamicTxLowPower = false;
>> > } else {
>>
On Tue, Jun 23, 2015 at 2:42 PM, Dmitry Kalinkin
wrote:
> Signed-off-by: Dmitry Kalinkin
You left one in the function declarations (vme_user_write).
> ---
> drivers/staging/vme/devices/vme_user.c | 33 +
> 1 file changed, 17 insertions(+), 16 deletions(-)
>
> di
On Tue, Jun 23, 2015 at 2:52 PM, Luis de Bethencourt
wrote:
> Remove explicit true/false comparations to bool variables.
>
> Signed-off-by: Luis de Bethencourt
> ---
> drivers/staging/rtl8192u/r8192U_core.c | 7 ---
> drivers/staging/rtl8192u/r8192U_dm.c | 21 +++--
> 2 fi
On Tue, Jun 23, 2015 at 2:52 PM, Luis de Bethencourt
wrote:
> Remove explicit true/false comparations to bool variables.
>
> Signed-off-by: Luis de Bethencourt
> ---
> drivers/staging/rtl8192u/r8192U_core.c | 7 ---
> drivers/staging/rtl8192u/r8192U_dm.c | 21 +++--
> 2 fi
On Thu, Jun 18, 2015 at 1:54 PM, Guenter Roeck wrote:
> On 06/17/2015 11:53 PM, Frans Klaver wrote:
>>
>> On Thu, Jun 18, 2015 at 3:04 AM, Stephen Boyd
>> wrote:
>>>
>>> On 10/06/2014 10:28 PM, Guenter Roeck wrote:
>>>>
>>>> Various
On Thu, Jun 18, 2015 at 3:04 AM, Stephen Boyd wrote:
> On 10/06/2014 10:28 PM, Guenter Roeck wrote:
>> Various drivers implement architecture and/or device specific means to
>> remove power from the system. For the most part, those drivers set the
>> global variable pm_power_off to point to a fun
On Mon, Jun 8, 2015 at 9:31 PM, Greg KH wrote:
> On Wed, Jun 03, 2015 at 03:43:47PM +0530, Aparna Karuthodi wrote:
>> Added a space before the open paranthesis '('
If you're having to resend anyway: s,paranthesis,parenthesis,
Frans
___
devel mailing li
Hi,
On Fri, May 29, 2015 at 2:00 PM, Dan Carpenter wrote:
> On Fri, May 29, 2015 at 01:06:58PM +0200, Jason A. Donenfeld wrote:
>> --- a/drivers/staging/ozwpan/ozusbsvc1.c
>> +++ b/drivers/staging/ozwpan/ozusbsvc1.c
>> @@ -390,10 +390,15 @@ void oz_usb_rx(struct oz_pd *pd, struct oz_elt *elt)
>>
62 matches
Mail list logo