The unconditioned jump will prohibit to ever reach the break-statement.
Deleting this needless statement, the code becomes more understandable.
Signed-off-by: Fabian Krueger
Signed-off-by: Michael Scheiderer
Cc:
---
drivers/staging/kpc2000/kpc2000_spi.c | 1 -
1 file changed, 1 deletion
Replaced 'unsigned' with it's equivalent 'unsigned int' to reduce
confusion while reading the code.
Signed-off-by: Fabian Krueger
Signed-off-by: Michael Scheiderer
Cc:
---
drivers/staging/kpc2000/kpc2000_spi.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions
Instead of using the function name hard coded as string, using __func__
and the '%s'-placeholder will always give the current name of the
function. When renaming a function, the debugging-messages won't have to
be rewritten.
Signed-off-by: Fabian Krueger
Signed-off-by: Michael
Added spaces on the left side of parenthesis and on both sides of binary
operators. Also realigned else and else if so it matches the
parenthesis line.
This refactoring makes the code more readable.
Signed-off-by: Fabian Krueger
Signed-off-by: Michael Scheiderer
Cc:
---
drivers/staging
Removed brackets on around one-lined if-cases.
This refactoring makes the code more readable.
Signed-off-by: Fabian Krueger
Signed-off-by: Michael Scheiderer
Cc:
---
drivers/staging/kpc2000/kpc2000_spi.c | 30 +--
1 file changed, 10 insertions(+), 20 deletions(-)
diff
Replaced __attribute__((packed)) with __packed. Both ways of attributing
are equivalent, but being shorter, __packed should be preferred.
This refactoring makes the core more readable.
Signed-off-by: Fabian Krueger
Signed-off-by: Michael Scheiderer
Cc:
---
drivers/staging/kpc2000
After the declarations in a function, there should be a blank line, so
that the declaration part is visibly separated from the rest.
This refactoring makes the code more readable.
Signed-off-by: Fabian Krueger
Signed-off-by: Michael Scheiderer
Cc:
---
drivers/staging/kpc2000/kpc2000_spi.c | 4
A patch-series that will remove warnings, errors and check-messages,
noted and highlighted by the checkpatch.pl script concerning
kpc2000_spi.c.
Signed-off-by: Fabian Krueger
Signed-off-by: Michael Scheiderer
Cc:
Fabian Krueger (8):
staging: kpc2000: add line breaks
staging: kpc2000
To fix some checkpatch-warnings some lines of this module had to be
shortened so that they do not exceed 80 characters per line.
This refactoring makes the code more readable.
Signed-off-by: Fabian Krueger
Signed-off-by: Michael Scheiderer
Cc:
---
drivers/staging/kpc2000/kpc2000_spi.c | 34
Replaced 'unsigned' with it's equivalent 'unsigned int' to reduce
confusion while reading the code.
Signed-off-by: Fabian Krueger
Signed-off-by: Michael Scheiderer
---
drivers/staging/kpc2000/kpc2000_spi.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
dif
Added spaces on the left side of parenthesis and on both sides of binary
operators.
This refactoring makes the code more readable.
Signed-off-by: Fabian Krueger
Signed-off-by: Michael Scheiderer
---
drivers/staging/kpc2000/kpc2000_spi.c | 15 ++-
1 file changed, 6 insertions(+), 9
Replaced __attribute__((packed)) with __packed. Both ways of attributing
are equivalent, but being shorter, __packed should be preferred.
This refactoring makes the core more readable.
Signed-off-by: Fabian Krueger
Signed-off-by: Michael Scheiderer
---
drivers/staging/kpc2000/kpc2000_spi.c | 6
Removed brackets on around one-lined if-cases.
This refactoring makes the code more readable.
Signed-off-by: Fabian Krueger
Signed-off-by: Michael Scheiderer
---
drivers/staging/kpc2000/kpc2000_spi.c | 27 +--
1 file changed, 9 insertions(+), 18 deletions(-)
diff --git
The unconditioned jump will prohibit to ever reach the break-statement.
Deleting this needless statement, the code becomes more understandable.
Signed-off-by: Fabian Krueger
Signed-off-by: Michael Scheiderer
---
drivers/staging/kpc2000/kpc2000_spi.c | 1 -
1 file changed, 1 deletion(-)
diff
To fix some checkpatch-warnings some lines of this module had to be
shortened so that they do not exceed 80 characters per line.
This refactoring makes the code more readable.
Signed-off-by: Fabian Krueger
Signed-off-by: Michael Scheiderer
Cc:
---
drivers/staging/kpc2000/kpc2000_spi.c | 77
After the declarations in a function, there should be a blank line, so
that the declaration part is visibly separated from the rest.
This refactoring makes the code more readable.
Signed-off-by: Fabian Krueger
Signed-off-by: Michael Scheiderer
---
drivers/staging/kpc2000/kpc2000_spi.c | 4
A patch-series that will remove warnings, errors and check-messages,
noted and highlighted by the checkpatch.pl script concerning
kpc2000_spi.c.
Signed-off-by: Fabian Krueger
Signed-off-by: Michael Scheiderer
Cc:
Fabian Krueger (8):
staging: kpc2000: add line breaks
staging: kpc2000
Instead of using the function name hard coded as string, using __func__
and the '%s'-placeholder will always give the current name of the
function. When renaming a function, the debugging-messages won't have to
be rewritten.
Signed-off-by: Fabian Krueger
Signed-off-by: Mic
18 matches
Mail list logo