On Fri, 2020-05-29 at 12:16 +0200, Johan Hovold wrote:
> [External]
>
> On Fri, May 22, 2020 at 11:22:07AM +0300, Alexandru Ardelean wrote:
> > This assignment is the more peculiar of the bunch as it assigns the parent
> > of the platform-device's device (i.e. pdev->dev.parent) as the IIO device's
On Sun, 2020-05-03 at 12:37 +0100, Jonathan Cameron wrote:
> [External]
>
> On Wed, 29 Apr 2020 10:21:29 +0300
> Alexandru Ardelean wrote:
>
> > From: Dragos Bogdan
> >
> > If the serial interface is used, the 8-bit address should be latched using
> > the rising edge of the WR/FSYNC signal.
>
On Sat, 2020-05-02 at 19:25 +0100, Jonathan Cameron wrote:
> On Tue, 28 Apr 2020 12:31:28 +0300
> Alexandru Ardelean wrote:
>
> > This change cleans up the driver's probe function to use only devm_
> > function variants. This also gets rid of the remove function and moves the
> > clock & regulato
On Tue, 2020-04-07 at 11:26 +0200, Markus Elfring wrote:
> [External]
>
> How do you think about a patch subject like “iio: Increase use of
> iio_device_attach_kfifo_buffer()”?
>
>
> > This change does that.
>
> I suggest to improve also this commit message.
>
> * Would you like to consider a
On Sun, 2020-04-05 at 11:49 +0100, Jonathan Cameron wrote:
> [External]
>
> On Wed, 1 Apr 2020 15:59:36 +0300
> Alexandru Ardelean wrote:
>
> > This driver calls iio_kfifo_allocate() vs devm_iio_kfifo_allocate(). But
> > the conversion is still simpler here, and cleans-up/reduces some error
> >
On Sun, 2020-04-05 at 11:46 +0100, Jonathan Cameron wrote:
> [External]
>
> On Wed, 1 Apr 2020 15:59:34 +0300
> Alexandru Ardelean wrote:
>
> > This change adds the iio_device_attach_kfifo_buffer() helper/short-hand,
> > which groups the simple routine of allocating a kfifo buffers via
> > devm_
On Wed, 2020-03-04 at 00:09 +0530, Nishant Malpani wrote:
> [External]
>
> This patch fixes the checkpatch.pl warning:
>
> CHECK: Alignment should match open parenthesis
> +static void ad7192_get_available_filter_freq(struct ad7192_state *st,
> +
On Wed, 2019-12-04 at 17:00 +, Mark Brown wrote:
> On Wed, Dec 04, 2019 at 07:18:15AM +0000, Ardelean, Alexandru wrote:
>
> > One example (for spi-cpha):
> > if (of_property_read_u32(nc, "spi-cpha", &tmp) == 0) {
> >
On Sun, 2019-12-01 at 11:42 +, Jonathan Cameron wrote:
> [External]
>
> On Mon, 25 Nov 2019 07:55:39 +
> "Ardelean, Alexandru" wrote:
>
> > On Sat, 2019-11-23 at 20:35 -0300, Rodrigo Carvalho wrote:
> > > [External]
> > >
> > >
On Tue, 2019-12-03 at 16:51 +, Jonathan Cameron wrote:
> On Tue, 3 Dec 2019 16:38:50 +
> Mark Brown wrote:
>
> > On Sun, Dec 01, 2019 at 11:40:32AM +, Jonathan Cameron wrote:
> >
> > > +CC Mark as we probably need a more general view point on
> > > the question of whether SPI mode sh
On Tue, 2019-10-29 at 18:29 +0200, Beniamin Bia wrote:
> [External]
>
> From: Paul Cercueil
>
> AD7091 is 4-Channel, I2C, Ultra Low Power,12-Bit ADC.
>
> Datasheet:
> Link:
> https://www.analog.com/media/en/technical-documentation/data-sheets/ad7091r-5.pdf
>
> Signed-off-by: Paul Cercueil
>
On Sat, 2019-11-23 at 20:35 -0300, Rodrigo Carvalho wrote:
> [External]
>
> According to the datasheet, this driver supports only SPI mode 3,
> so we should enforce it and call spi_setup() on probe function.
>
> Signed-off-by: Rodrigo Ribeiro Carvalho
> ---
> V5:
> - Add this patch to the patc
On Sat, 2019-11-23 at 11:41 +, Jonathan Cameron wrote:
> On Sat, 23 Nov 2019 02:19:27 -0300
> Rodrigo Carvalho wrote:
>
> > This patch add device tree binding documentation for ADIS16240.
> >
> > Signed-off-by: Rodrigo Ribeiro Carvalho
My bad for the late timing on this.
I'm slightly more
On Wed, 2019-10-16 at 22:25 +0800, Chuhong Yuan wrote:
> ad9834_probe misses a check for devm_clk_get and may cause problems.
> Add a check like what ad9832 does to fix it.
>
This could also use a Fixes tag, but not a big deal.
Reviewed-by: Alexandru Ardelean
> Signed-off-by: Chuhong Yuan
> -
On Thu, 2019-09-12 at 18:39 -0300, Rodrigo Carvalho wrote:
> This patch add device tree binding documentation for ADIS16240.
>
> Signed-off-by: Rodrigo Ribeiro Carvalho
> ---
> V2:
> - Remove true constant for spi-cpha and spi-cpol
> - Add description field for spi-cpha and spi-cpol
> - Add
On Tue, 2019-08-13 at 16:31 -0300, Rodrigo Ribeiro wrote:
> [External]
>
> Replace shift and minus operation by GENMASK macro and remove the local
> variables used to store intermediate data.
>
Reviewed-by: Alexandru Ardelean
> Signed-off-by: Rodrigo Ribeiro Carvalho
> ---
> v2:
>- Leave
On Fri, 2019-07-26 at 19:07 +0800, Chuhong Yuan wrote:
> [External]
>
> Use device-managed API to simplify the code.
> The remove function is redundant now and can
> be deleted.
Reviewed-by: Alexandru Ardelean
>
> Signed-off-by: Chuhong Yuan
> ---
> drivers/staging/iio/resolver/ad2s1210.c |
On Fri, 2019-07-26 at 01:38 +0530, Kartik Kulkarni wrote:
> Add the of_device_id struct and the respective
> of_match_device entry to complete device tree support.
>
This would be a [V2] I suppose.
This change also does the rename of the driver name in a single go.
Since it's a trivial change, i
On Wed, 2019-06-05 at 17:35 -0300, Renato Lui Geh wrote:
> [External]
>
>
> On 05/26, Jonathan Cameron wrote:
> > On Fri, 24 May 2019 22:26:30 -0300
> > Renato Lui Geh wrote:
> >
> > > This patch adds a YAML binding for the Analog Devices AD7780/1 and
> > > AD7170/1 analog-to-digital converters
On Fri, 2019-05-24 at 10:50 -0300, Marcelo Schmitt wrote:
> [External]
>
>
> Hi Alexandru,
>
> On 05/24, Alexandru Ardelean wrote:
> > On Fri, May 24, 2019 at 6:30 AM Rodrigo Ribeiro
> > wrote:
> > >
> > > This patch adds of_match_table entry in device driver in order to
> > > enable spi fall
On Sun, 2019-05-19 at 12:32 +0100, Jonathan Cameron wrote:
> [External]
>
>
> On Sat, 18 May 2019 19:41:12 -0300
> Renato Lui Geh wrote:
>
> > This patch adds a YAML binding for the Analog Devices AD7780/1 and
> > AD7170/1 analog-to-digital converters.
> >
> > Signed-off-by: Renato Lui Geh
>
On Fri, 2019-05-10 at 17:34 +0300, andriy.shevche...@linux.intel.com wrote:
> [External]
>
>
> On Fri, May 10, 2019 at 09:15:27AM +0000, Ardelean, Alexandru wrote:
> > On Wed, 2019-05-08 at 16:22 +0300, Alexandru Ardelean wrote:
> > > On Wed, 2019-05-08 at 15:18 +0200
On Fri, 2019-05-10 at 14:01 +0300, Dan Carpenter wrote:
> [External]
>
>
> On Fri, May 10, 2019 at 09:13:26AM +0000, Ardelean, Alexandru wrote:
> > On Wed, 2019-05-08 at 16:26 +0300, Alexandru Ardelean wrote:
> > > On Wed, 2019-05-08 at 15:20
On Wed, 2019-05-08 at 16:22 +0300, Alexandru Ardelean wrote:
> On Wed, 2019-05-08 at 15:18 +0200, Greg KH wrote:
> >
> >
> > On Wed, May 08, 2019 at 04:11:28PM +0300, Andy Shevchenko wrote:
> > > On Wed, May 08, 2019 at 02:28:29PM +0300, Alexandru Ardelean wrote:
> > > > This change re-introduces
On Wed, 2019-05-08 at 16:26 +0300, Alexandru Ardelean wrote:
> On Wed, 2019-05-08 at 15:20 +0300, Dan Carpenter wrote:
> >
> >
> > On Wed, May 08, 2019 at 02:28:35PM +0300, Alexandru Ardelean wrote:
> > > -static const char * const phy_types[] = {
> > > - "emmc 5.0 phy",
> > > - "emmc 5.1
On Wed, 2019-05-08 at 15:20 +0300, Dan Carpenter wrote:
>
>
> On Wed, May 08, 2019 at 02:28:35PM +0300, Alexandru Ardelean wrote:
> > -static const char * const phy_types[] = {
> > - "emmc 5.0 phy",
> > - "emmc 5.1 phy"
> > -};
> > -
> > enum xenon_phy_type_enum {
> > EMMC_5_0_PHY,
On Wed, 2019-05-08 at 15:18 +0200, Greg KH wrote:
>
>
> On Wed, May 08, 2019 at 04:11:28PM +0300, Andy Shevchenko wrote:
> > On Wed, May 08, 2019 at 02:28:29PM +0300, Alexandru Ardelean wrote:
> > > This change re-introduces `match_string()` as a macro that uses
> > > ARRAY_SIZE() to compute the
On Wed, 2019-05-08 at 14:28 +0300, Alexandru Ardelean wrote:
> The documentation the `_match_string()` helper mentions that `n`
> should be:
> * @n: number of strings in the array or -1 for NULL terminated arrays
>
> The behavior of the function is different, in the sense that it exits on
> the f
On Tue, 2019-05-07 at 17:44 -0300, Melissa Wen wrote:
> [External]
>
>
> On 05/06, Ardelean, Alexandru wrote:
> > On Sat, 2019-05-04 at 13:43 +0300, Alexandru Ardelean wrote:
> > > [External]
> > >
> > >
> > > On Sat, May 4, 2019 at 1:25
On Sat, 2019-05-04 at 13:43 +0300, Alexandru Ardelean wrote:
> [External]
>
>
> On Sat, May 4, 2019 at 1:25 AM Melissa Wen wrote:
> >
> > Use the bitfield macro FIELD_GET, and GENMASK to do the shift and mask
> > in
> > one go. This makes the code more readable than explicit masking
> > followe
On Sat, 2019-03-02 at 19:08 +, Jonathan Cameron wrote:
> [External]
>
>
> On Sat, 2 Mar 2019 19:07:16 +
> Jonathan Cameron wrote:
>
> > On Fri, 1 Mar 2019 07:17:04 +
> > "Ardelean, Alexandru" wrote:
> >
> > >
On Sun, 2019-03-03 at 14:53 +, Jonathan Cameron wrote:
> [External]
>
>
> On Sun, 3 Mar 2019 11:01:09 -0300
> Renato Lui Geh wrote:
>
> > On 03/01, Ardelean, Alexandru wrote:
> > > On Thu, 2019-02-28 at 11:24 -0300, Renato Lui Geh wrote:
> > > &g
On Sat, 2019-03-02 at 19:11 +, Jonathan Cameron wrote:
> [External]
>
>
> On Fri, 1 Mar 2019 07:38:45 +
> "Ardelean, Alexandru" wrote:
>
> > On Thu, 2019-02-28 at 11:25 -0300, Renato Lui Geh wrote:
> > >
> > >
> > > T
On Thu, 2019-02-28 at 11:23 -0300, Renato Lui Geh wrote:
>
The patch-series is a bit big.
I guess that the intent is to move this out-of-staging, but various patches
are holding this in it's place.
For patch series above a certain size, you could get many re-spins
[V2,3,4... so on].
You could se
On Thu, 2019-02-28 at 11:24 -0300, Renato Lui Geh wrote:
>
>
> The ad7780 supports both the ad778x and ad717x families. Each chip has
> a corresponding ID. This patch provides a mask for extracting ID values
> from the status bits and also macros for the correct values for the
> ad7170, ad7171, a
On Thu, 2019-02-28 at 11:25 -0300, Renato Lui Geh wrote:
>
>
> To maintain consistency between ad7780_probe and ad7780_remove orders,
> regulator initialization has been moved to after GPIO initializations.
>
> Signed-off-by: Renato Lui Geh
> ---
> drivers/staging/iio/adc/ad7780.c | 26 +++
On Thu, 2019-02-28 at 11:24 -0300, Renato Lui Geh wrote:
>
>
> The AD7780 driver contains status pattern bits designed for checking
> whether serial transfers have been correctly performed. Pattern macros
> were previously generated through bit fields. This patch sets good
> pattern values direct
On Thu, 2019-02-28 at 11:24 -0300, Renato Lui Geh wrote:
>
>
> This patch adds the new feature of reading the filter odr value for
> ad778x chips. This value is stored in the chip's state struct whenever a
> read or write call is performed on the chip's driver.
>
> This feature requires sharing
On Thu, 2019-02-28 at 11:23 -0300, Renato Lui Geh wrote:
>
>
> Previously, the AD7780 driver only supported gpio for the 'powerdown'
> pin. This commit adds suppport for the 'gain' and 'filter' pin.
>
> Signed-off-by: Renato Lui Geh
> Signed-off-by: Giuliano Belinassi
> Co-developed-by: Giulia
On Mon, 2018-12-10 at 21:27 +, Jonathan Cameron wrote:
> On Sat, 8 Dec 2018 22:10:43 +0100
> Greg KH wrote:
>
> > On Sat, Dec 08, 2018 at 04:56:45PM -0200, Marcelo Schmitt wrote:
> > > Parts of this work came from contributions of Alexandru Ardelean and
> > > Dragos Bogdan, I and Gabriel woul
On Tue, 2018-11-27 at 06:11 -0500, Popa, Stefan Serban wrote:
> On Lu, 2018-11-26 at 17:24 -0200, Giuliano Belinassi wrote:
> Hi, please see bellow
>
One note from me here.
> > Hi, thank you for the review
> >
> > >
> > > On Thu, 22 Nov 2018 11:01:00 +
> > > "Popa, Stefan Serban" wrote:
>
On Fri, 2018-11-23 at 22:23 -0200, Matheus Tavares wrote:
> Move ad2s90 resolver driver out of staging to the main tree.
>
Acked-by: Alexandru Ardelean
> Signed-off-by: Matheus Tavares
> Signed-off-by: Victor Colombo
> ---
> Changes in v3:
> - none
>
> Changes in v2:
> - Disabled git move
On Tue, 2018-11-20 at 22:30 +0530, Shreeya Patel wrote:
> ADT7316 driver no more uses platform data and hence use device tree
> data instead of platform data for assigning irq_type field.
> Switch case figures out the type of irq and if it's the default case
> then assign the default value to the i
On Sun, 2018-11-18 at 02:25 -0200, Matheus Tavares wrote:
> From: Alexandru Ardelean
>
> This patch adds a max frequency check at the beginning of ad2s90_probe
> function so that when it is set to a value above 0.83Mhz, dev_err is
> called with an appropriate message and -EINVAL is returned.
>
>
On Sun, 2018-11-18 at 02:25 -0200, Matheus Tavares wrote:
> This patch adds device tree support to ad2s90 with standard
> device tree id table.
>
Hey,
Comment inline
> Signed-off-by: Matheus Tavares
> ---
> Changes in v2:
> - none
>
> drivers/staging/iio/resolver/ad2s90.c | 7 +++
> 1 f
On Sun, 2018-11-18 at 02:25 -0200, Matheus Tavares wrote:
> This patch adds the device tree binding documentation for the ad2s90
> resolver-to-digital converter.
>
One minor comment inline.
> Signed-off-by: Matheus Tavares
> ---
> Changes in v2:
> - Rewritten 'spi-cpol and spi-cpha' item to sa
On Wed, 2018-11-14 at 23:16 +0530, Nishad Kamdar wrote:
> Add device tree table for matching vendor ID.
>
This could have been just one patch.
Something like
[PATCH v4] staging: iio: ad7816: Add device tree table.
It's no longer a series, because the other patches were applied already.
I do
On Sun, 2018-11-11 at 12:58 +, Jonathan Cameron wrote:
> On Thu, 8 Nov 2018 13:44:17 +
> "Ardelean, Alexandru" wrote:
>
> > On Thu, 2018-11-08 at 11:03 -0200, Giuliano Belinassi wrote:
> > > Only the ad778x have the 'gain' status bit. Check it
On Sun, 2018-11-11 at 14:30 +, Jonathan Cameron wrote:
> On Tue, 6 Nov 2018 09:24:44 +
> "Ardelean, Alexandru" wrote:
>
> > On Mon, 2018-11-05 at 17:14 -0200, Renato Lui Geh wrote:
> > > The ad7780 driver previously did not read the correct device
On Fri, 2018-11-09 at 13:05 +0530, Nishad Kamdar wrote:
> Use the gpiod interface for rdwr_pin, convert_pin and busy_pin
> instead of the deprecated old non-descriptor interface.
>
Patch looks good.
I do have some thoughts about it. See inline.
> Signed-off-by: Nishad Kamdar
> ---
> drivers/s
On Fri, 2018-11-09 at 13:08 +0530, Nishad Kamdar wrote:
> Add device tree table for matching vendor ID.
One comment inline for this.
Thanks
Alex
>
> Signed-off-by: Nishad Kamdar
> ---
> drivers/staging/iio/adc/ad7816.c | 7 +++
> 1 file changed, 7 insertions(+)
>
> diff --git a/drivers/s
On Fri, 2018-11-09 at 08:05 +, Ardelean, Alexandru wrote:
> On Fri, 2018-11-09 at 13:05 +0530, Nishad Kamdar wrote:
> > Use the gpiod interface for rdwr_pin, convert_pin and busy_pin
> > instead of the deprecated old non-descriptor interface.
> >
>
> Patch l
On Thu, 2018-11-08 at 11:03 -0200, Giuliano Belinassi wrote:
> Previously, all pattern_masks and patterns in the chip_info table were
> hardcoded. Now they are generated using the PAT macros, as described in
> the datasheets.
One comment about indentation/whitespace.
Rest looks good.
Alex
>
>
On Thu, 2018-11-08 at 11:03 -0200, Giuliano Belinassi wrote:
> Only the ad778x have the 'gain' status bit. Check it before updating
> through a new variable is_ad778x in chip_info.
>
Looks good.
Alex
> Signed-off-by: Giuliano Belinassi
> ---
> Changes in v2:
> - Squashed is_ad778x declar
On Wed, 2018-11-07 at 16:50 -0200, Giuliano Belinassi wrote:
> Previously, all pattern_masks in the chip_info table were hardcoded. Now
> they
> are generated using the PAT macros, as described in the datasheets.
>
I like this change :)
I only have nitpicks.
See inline.
> Signed-off-by: Giulian
On Wed, 2018-11-07 at 16:50 -0200, Giuliano Belinassi wrote:
> Only the ad778x have the 'gain' status bit. Check it before updating.
>
This looks good.
The only note is that it can be squashed with the 1st patch (which I noted
on the 1st patch).
> Signed-off-by: Giuliano Belinassi
> ---
> driv
On Wed, 2018-11-07 at 16:49 -0200, Giuliano Belinassi wrote:
> This patch allows further checking of whatever the chip is (ad778x or
> ad717x).
Hey,
The patch looks good overall.
I only have one nitpick for this patch. See inline.
And you can squash this patch with patch `[PATCH 2/3] staging: ii
On Mon, 2018-11-05 at 17:16 -0200, Renato Lui Geh wrote:
> This patch removes the unnecessary field int_vref_mv in ad7780_state
> referring to the device's voltage.
>
Looks good from my side.
Alex
> Signed-off-by: Renato Lui Geh
> ---
> Changes in v3:
> - removed unnecessary int_vref_mv
On Mon, 2018-11-05 at 17:14 -0200, Renato Lui Geh wrote:
> The ad7780 driver previously did not read the correct device output, as
> it read an outdated value set at initialization. It now updates its
> voltage on read.
>
Looks good from my side.
Alex
> Signed-off-by: Renato Lui Geh
> ---
> Ch
Good catch.
Acked-by: Alexandru Ardelean
On Thu, 2018-11-01 at 11:43 -0300, Renato Lui Geh wrote:
> Variable val subtracted an uninitialized value on IIO_CHAN_INFO_OFFSET.
> This was fixed by assigning the correct value instead.
>
> Signed-off-by: Renato Lui Geh
> ---
> drivers/staging/iio/ad
On Thu, 2018-11-01 at 11:43 -0300, Renato Lui Geh wrote:
> The ad7780 driver previously did not read the correct device output, as
> it read an outdated value set at initialization. It now updates its
> voltage on read.
>
> Signed-off-by: Renato Lui Geh
> ---
> Changes in v3:
> - removed in
On Thu, 2018-11-01 at 11:43 -0300, Renato Lui Geh wrote:
> This patch removes the unnecessary field int_vref_mv in ad7780_state
> referring to the device's voltage.
>
> Signed-off-by: Renato Lui Geh
> ---
> Changes in v3:
> - removed unnecessary int_vref_mv from ad7780_state
>
> drivers/s
On Tue, 2018-02-06 at 01:08 +0530, Shreeya Patel wrote:
> In the ade7758 file, read raw does not require iio_dev->mlock for
> reads. It can run concurrently as resource protection is handled
> by buf_lock in read register.
Removed linux-kernel list and Greg from reply list.
>
> Signed-off-by: Sh
On Tue, 2018-02-06 at 01:10 +0530, Shreeya Patel wrote:
> iio_dev->mlock is to be used only by the IIO core for protecting
> device mode changes between INDIO_DIRECT and INDIO_BUFFER.
>
> This patch replaces the use of mlock with the already established
> buf_lock mutex.
>
> Introducing 'unlocked
64 matches
Mail list logo