export only the device-managed
functions of it's API. That's a long way to go and this a small step in
that direction.
Signed-off-by: Alexandru Ardelean
---
drivers/staging/iio/frequency/ad9834.c | 64 +-
1 file changed, 31 insertions(+), 33 deletions(-)
di
On Mon, 8 Mar 2021 at 18:42, Lars-Peter Clausen wrote:
>
> On 3/8/21 3:54 PM, Alexandru Ardelean wrote:
> > The 'delay_usecs' field was handled for backwards compatibility in case
> > there were some users that still configured SPI delay transfers with
> > this
The 'delay' field in the spi_transfer struct is meant to replace the
'delay_usecs' field. However some cleanup was required to remove the
uses of 'delay_usecs'. Now that it's been cleaned up, we can remove it
from the kernel tree.
Signed-off-by: Alexand
The 'delay_usecs' field is no longer present on the spi_transfer struct.
This change updates the doc to mention the usage of the (relatively) new
'delay' field.
Signed-off-by: Alexandru Ardelean
---
Documentation/spi/spi-summary.rst | 7 +--
1 file changed, 5 insert
The 'delay_usecs' field is being removed from the spi_transfer struct.
This change removes it from the SPI FSL ESPI driver.
Signed-off-by: Alexandru Ardelean
---
drivers/spi/spi-fsl-espi.c | 17 +
1 file changed, 5 insertions(+), 12 deletions(-)
diff --git a/drivers/s
The 'delay_usecs' field is being removed from the spi_transfer struct.
This change removes it from the SPI Falcon driver.
Signed-off-by: Alexandru Ardelean
---
drivers/spi/spi-falcon.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/spi/spi-falcon.c b/drive
converting to microseconds and since
the result of spi_delay_to_ns() is int, the delay is being computed in 32
bits and then clamped between 0 & U16_MAX.
Signed-off-by: Alexandru Ardelean
---
drivers/staging/greybus/spilib.c | 5 -
1 file changed, 4 insertions(+), 1 deletion(-)
diff --gi
The 'delay_usecs' field was handled for backwards compatibility in case
there were some users that still configured SPI delay transfers with
this field.
They should all be removed by now. So we can remove the 'delay_usecs'
handling in this driver.
Signed-off-by: Alexandru Ar
The 'delay_usecs' field is going away. The replacement for it is the
'delay' field. So, we should print the 'delay.value' value instead.
Signed-off-by: Alexandru Ardelean
---
drivers/spi/spi-sh.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff
The 'delay_usecs' field is going away. The replacement for it is the
'delay' field. So, we should check for 'delay.value' being non-zero.
Signed-off-by: Alexandru Ardelean
---
drivers/spi/spi-bcm-qspi.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
di
The 'delay_usecs' field was handled for backwards compatibility in case
there were some users that still configured SPI delay transfers with
this field.
They should all be removed by now.
Signed-off-by: Alexandru Ardelean
---
drivers/spi/spi-bcm63xx.c | 2 +-
1 file changed, 1 inser
The 'delay_usecs' field was handled for backwards compatibility in case
there were some users that still configured SPI delay transfers with
this field.
They should all be removed by now.
Signed-off-by: Alexandru Ardelean
---
drivers/spi/spi-axi-spi-engine.c | 12
1 fi
the SPI subsystem and use
only the 'delay' field.
This changeset adapts all SPI drivers to do without 'delay_usecs'.
Additionally, for greybus we need to adapt it to use the 'delay' in
nano-seconds and convert it to micro-seconds.
Alexandru Ardelean (10):
spi: s
This assignment is the more peculiar of the bunch as it assigns the parent
of the platform-device's device (i.e. pdev->dev.parent) as the IIO device's
parent.
It's unclear whether this is intentional or not.
Hence it is in it's own patch.
Signed-off-by: Alexandru Ardelean
uot; $file)"
fi
done
---
The output is bearable [after the semantic patch is applied].
There is a mix of trigger assignments with some iio device parent
assignments that are removed via this patch.
Signed-off-by: Alexandru Ardelean
---
drivers/iio/accel/kxcjk-1013.c|
.
In the next patch all devm_iio_device_alloc() calls will be handled.
Signed-off-by: Alexandru Ardelean
---
drivers/iio/dummy/iio_simple_dummy.c | 14 --
drivers/iio/industrialio-core.c | 11 ++-
drivers/platform/x86/toshiba_acpi.c | 3 +--
ent.
3 of them are removed by the semantic patch, as the comment removed (by
spatch) would be for an empty line.
Signed-off-by: Alexandru Ardelean
---
drivers/iio/adc/ad7476.c | 1 -
drivers/iio/adc/ad7887.c | 1 -
drivers/iio/dac/ad5446.c | 1 -
drivers/staging/iio/cdc/ad774
into 2 transfers
with a single byte, and CS change in-between.
Signed-off-by: Dragos Bogdan
Signed-off-by: Alexandru Ardelean
---
drivers/staging/iio/resolver/ad2s1210.c | 17 -
1 file changed, 12 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/iio/resolver/ad2s1210.c
This change cleans up the driver's probe function to use only devm_
function variants. This also gets rid of the remove function and moves the
clock & regulator de-initializations to the 'ad5933_cleanup()' callback.
Signed-off-by: Alexandru Ardelean
---
.../staging/iio/impeda
This driver calls iio_kfifo_allocate() vs devm_iio_kfifo_allocate(). But
the conversion is still simpler here, and cleans-up/reduces some error
paths.
Signed-off-by: Alexandru Ardelean
---
.../staging/iio/impedance-analyzer/ad5933.c | 28 ---
1 file changed, 5 insertions
n't make any difference [at this point in time].
Signed-off-by: Alexandru Ardelean
---
drivers/iio/accel/sca3000.c| 18 ++
drivers/iio/accel/ssp_accel_sensor.c | 13 -
drivers/iio/adc/ina2xx-adc.c | 13 +
uffer will be tied to 'indio_dev->dev'. Previously it
was open-coded, and each driver does it slightly differently. Most of them
tied it to the parent device, some of them to 'indio_dev->dev'.
This shouldn't be a problem, and may be a good idea when adding more
buff
ry by introducing a variable holding the PROD_ID register of the
device.
Signed-off-by: Nuno Sá
Signed-off-by: Alexandru Ardelean
---
drivers/iio/imu/Kconfig | 1 +
drivers/iio/imu/adis.c | 63 ++--
include/linux/iio/imu/adis.h | 15 -
3 files ch
From: Nuno Sá
All of the actions done in `adis16460_initial_setup()` are now done in
`__adis_initial_startup()` so, there's no need for code duplication.
Signed-off-by: Nuno Sá
Signed-off-by: Alexandru Ardelean
---
drivers/iio/imu/adis16460.c | 37 ++-
a
rst pin). This is actually fixing a potential bug since `adis_reset()` was
being called after configuring the device which is obviously a problem.
Signed-off-by: Nuno Sá
Signed-off-by: Alexandru Ardelean
---
drivers/iio/imu/adis16480.c | 55 -
1 file change
From: Nuno Sá
This patch adds a dedicated self_test_reg variable. This is also a step
to let new drivers make use of `adis_initial_startup()`. Some devices
use MSG_CTRL reg to request a self_test command while others use the
GLOB_CMD register.
Signed-off-by: Nuno Sá
Signed-off-by: Alexandru
river.
An alternative solution would have been to rename the function, but it
doesn't look like it's being used outside of this driver, so just make it
static.
Signed-off-by: Alexandru Ardelean
---
drivers/staging/rtl8188eu/core/rtw_efuse.c| 2 +-
drivers/staging/rtl8188eu/include/
From: Michael Hennerich
For the special case when fbtft_mkdirty() is called with with -1 for the y
coordinate, the height is truncated by 1.
This isn't required, and causes the last line to not update.
Signed-off-by: Michael Hennerich
Signed-off-by: Alexandru Ardelean
---
drivers/st
doing some
cosmetic changes, which are aimed at grouping the users of
`match_string()`.
Signed-off-by: Alexandru Ardelean
---
Changelog v1 -> v2:
* split the initial series into just 3 patches that fix the
`match_string()` helper and start introducing a new version of this
helper, wh
reviewed by each subsystem.
Signed-off-by: Alexandru Ardelean
---
include/linux/string.h | 9 +
1 file changed, 9 insertions(+)
diff --git a/include/linux/string.h b/include/linux/string.h
index 7149fcdf62df..34491b075449 100644
--- a/include/linux/string.h
+++ b/include/linux/string.h
differs.
Signed-off-by: Alexandru Ardelean
---
arch/powerpc/xmon/xmon.c | 2 +-
arch/x86/kernel/cpu/mtrr/if.c| 2 +-
drivers/ata/pata_hpt366.c| 2 +-
drivers/ata/pata_hpt37x.c| 2 +-
drivers/base/d
On Fri, May 24, 2019 at 6:30 AM Rodrigo Ribeiro wrote:
>
> This patch adds of_match_table entry in device driver in order to
> enable spi fallback probing.
>
> Signed-off-by: Rodrigo Ribeiro
> Reviewed-by: Marcelo Schmitt
> ---
> drivers/staging/iio/accel/adis16240.c | 1 +
> 1 file changed, 1
On Sun, May 19, 2019 at 8:53 PM Jonathan Cameron wrote:
>
> On Sat, 18 May 2019 19:44:35 -0300
> Bárbara Fernandes wrote:
>
I don't have anything else on top of what Jonathan added.
Acked-by: Alexandru Ardelean
CC-ing my work-email
There are some issues with it and ma
On Sun, May 19, 2019 at 8:18 PM Jonathan Cameron wrote:
>
> On Sat, 18 May 2019 19:15:58 -0300
> Tallys Martins wrote:
>
CC-ing my work-email
There are some issues with it and mailing lists; I'll hopefully sort
them out in the next weeks.
> > The driver currently has no devicetree documentation
On Sun, May 19, 2019 at 8:38 PM Jonathan Cameron wrote:
>
> On Sat, 18 May 2019 22:04:56 -0300
> Melissa Wen wrote:
>
> > According to the AD7150 configuration register description, bit 7 assumes
> > value 1 when the threshold mode is fixed and 0 when it is adaptive,
> > however, the operation th
Bárbara Fernandes
> > Signed-off-by: Wilson Sales
> > Co-developed-by: Wilson Sales
> Looks good to me.
>
> Applied to the togreg branch of iio.git and pushed out as testing
> for the autobuilders to play with it.
>
> Thanks,
Also,
Acked-by: Alexandru Ardelean
CC
On Sun, May 19, 2019 at 8:17 PM Jonathan Cameron wrote:
>
> On Sat, 18 May 2019 17:48:25 -0300
> João Seckler wrote:
>
> > Add a of_device_id struct variable and subsequent call to
> > MODULE_DEVICE_TABLE macro to support device tree.
> >
> > Signed-off-by: João Seckler
> > Signed-off-by: Anders
The `generic_edid_name` is a static array of strings.
Using match_string() (which computes the array size via ARRAY_SIZE())
is possible.
The change is mostly cosmetic.
No functionality change.
Signed-off-by: Alexandru Ardelean
---
drivers/gpu/drm/drm_edid_load.c | 2 +-
1 file changed, 1
The `sched_feat_names` array is a static array of strings.
Using match_string() (which computes the array size via ARRAY_SIZE())
is possible.
The change is mostly cosmetic.
No functionality change.
Signed-off-by: Alexandru Ardelean
---
kernel/sched/debug.c | 2 +-
1 file changed, 1 insertion
The `rdmacg_resource_names` array is a static array of strings.
Using match_string() (which computes the array size via ARRAY_SIZE())
is possible.
The change is mostly cosmetic.
No functionality change.
Signed-off-by: Alexandru Ardelean
---
kernel/cgroup/rdma.c | 2 +-
1 file changed, 1
The `lcd_types` array is a static array of strings.
Using match_string() (which computes the array size via ARRAY_SIZE())
is possible.
This reduces the array by 1 element, since the NULL (at the end of the
array) is no longer needed.
Signed-off-by: Alexandru Ardelean
---
drivers/video/fbdev
The `DRIVER_STRING` array is a static array of strings.
Using match_string() (which computes the array size via ARRAY_SIZE())
is possible.
The change is mostly cosmetic.
No functionality change.
Signed-off-by: Alexandru Ardelean
---
drivers/staging/gdm724x/gdm_tty.c | 3 +--
1 file changed, 1
-by: Alexandru Ardelean
---
drivers/pinctrl/mvebu/pinctrl-armada-37xx.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/pinctrl/mvebu/pinctrl-armada-37xx.c
b/drivers/pinctrl/mvebu/pinctrl-armada-37xx.c
index 07a5bcaa0067..68b0db5ef5e9 100644
--- a/drivers/pinc
computed automatically,
which would only help if they ever get expanded.
Signed-off-by: Alexandru Ardelean
---
mm/vmpressure.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/mm/vmpressure.c b/mm/vmpressure.c
index d43f33139568..b8149924f078 100644
--- a/mm/vmpressure.c
The change is mostly cosmetic.
The `energy_perf_strings` array is static, so match_string() can be used
(which will implicitly do a ARRAY_SIZE(energy_perf_strings)).
The only small benefit here, is the reduction of the array size by 1
element.
Signed-off-by: Alexandru Ardelean
---
drivers
in the series will focus on doing some
cosmetic changes, which are aimed at grouping the users of
`match_string()`.
Signed-off-by: Alexandru Ardelean
---
lib/string.c | 5 -
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/lib/string.c b/lib/string.c
index 3ab861c1a857
The change is also cosmetic, but it also does a tighter coupling between
the enums & the string values. This way, the ARRAY_SIZE(phy_types) that is
implicitly done in the match_string() macro is also a bit safer.
Signed-off-by: Alexandru Ardelean
---
drivers/mmc/host/sdhci-xenon-phy.c
doing some
cosmetic changes, which are aimed at grouping the users of
`match_string()`.
Signed-off-by: Alexandru Ardelean
---
lib/string.c | 5 -
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/lib/string.c b/lib/string.c
index 3ab861c1a857..76edb7bf76cb 100644
--- a/lib
n't), but this fixes
that.
Signed-off-by: Alexandru Ardelean
---
arch/x86/kernel/cpu/mtrr/if.c | 10 ++
1 file changed, 6 insertions(+), 4 deletions(-)
diff --git a/arch/x86/kernel/cpu/mtrr/if.c b/arch/x86/kernel/cpu/mtrr/if.c
index 4ec7a5f7b94c..e67820a044cc 100644
--- a/arch/x86/kerne
This change re-introduces `match_string()` as a macro that uses
ARRAY_SIZE() to compute the size of the array.
The macro is added in all the places that do
`match_string(_a, ARRAY_SIZE(_a), s)`, since the change is pretty
straightforward.
Signed-off-by: Alexandru Ardelean
---
drivers/clk/bcm
ge-able way.
The first patch is important, the others can be dropped.
Signed-off-by: Alexandru Ardelean
Alexandru Ardelean (16):
lib: fix match_string() helper when array size is positive
treewide: rename match_string() -> __match_string()
lib,treewide: add new match_string() helper/mac
and ignore the NULL.
Signed-off-by: Alexandru Ardelean
---
sound/pci/oxygen/oxygen_mixer.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/sound/pci/oxygen/oxygen_mixer.c b/sound/pci/oxygen/oxygen_mixer.c
index 13c2fb75fd71..961fd1cbc712 100644
--- a/sound/pci/oxygen
ositive value does
not make any difference: the iteration will stop at the first NULL
element.
Signed-off-by: Alexandru Ardelean
---
arch/powerpc/xmon/xmon.c | 2 +-
arch/x86/kernel/cpu/mtrr/if.c| 2 +-
drivers/ata/pata_h
struct), so
using the match_string() (which does an ARRAY_SIZE((con->endpoint)) should
be fine.
The recent change to match_string() (to ignore NULL entries up to the size
of the array) shouldn't affect this.
Signed-off-by: Alexandru Ardelean
---
drivers/base/devcon.c | 2 +-
1 file ch
NULL.
This would technically allow for "reserved" regs, though here it's not the
case.
Signed-off-by: Alexandru Ardelean
---
arch/powerpc/xmon/xmon.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/powerpc/xmon/xmon.c b/arch/powerpc/xmon/xmon.c
ind
On Sat, May 4, 2019 at 2:12 PM Alexandru Ardelean
wrote:
>
> On Sat, May 4, 2019 at 1:24 AM Melissa Wen wrote:
> >
> > This patchset solves readability issues in AD7150 code, such as clarify
> > register and mask definition, fashion improvement of mask uses, reduce
&
On Sat, May 4, 2019 at 1:24 AM Melissa Wen wrote:
>
> This patchset solves readability issues in AD7150 code, such as clarify
> register and mask definition, fashion improvement of mask uses, reduce
> tedious operation and useless comments.
>
Hey,
Two patches seem a bit noisy/un-needed.
The othe
On Sat, May 4, 2019 at 1:25 AM Melissa Wen wrote:
>
> Use the bitfield macro FIELD_GET, and GENMASK to do the shift and mask in
> one go. This makes the code more readable than explicit masking followed
> by a shift.
>
This looks neat.
I'd have to remember to ack it from my work email.
One minor
On Sat, May 4, 2019 at 1:26 AM Melissa Wen wrote:
>
> Since i2c_smbus_write_byte_data returns no-positive value, this commit
> making the treatment of its return value less verbose.
>
> Signed-off-by: Melissa Wen
> ---
> drivers/staging/iio/cdc/ad7150.c | 10 +++---
> 1 file changed, 3 inser
On Sat, May 4, 2019 at 1:25 AM Melissa Wen wrote:
>
> Use the suffix REG to make the register addresses clear
> and indentation to highlight field names.
>
I'm inclined to say that this change is a bit too much noise versus added value.
While the REG suffix does make sense (generally), since it h
On Wed, Apr 3, 2019 at 11:46 PM Lucas Oshiro wrote:
>
> Replace bitshifts on lines 54, 56 and 78 of ad7746.c.
>
Hey,
This is only partially done.
If doing conversions to BIT(x) macro, I would say to do them for all cases.
Thanks
Alex
> Signed-off-by: Lucas Oshiro
> ---
> drivers/staging/iio/c
On Mon, Apr 1, 2019 at 7:13 PM Jonathan Cameron
wrote:
>
> On Mon, 1 Apr 2019 11:25:29 -0300
> Marcelo Schmitt wrote:
>
> > Hello,
> >
> > I was looking for some work on staging: iio: ad9832 and made some
> > observations while reading the driver.
> >
> > Apparently it had no devicetree documenta
On Mon, Apr 1, 2019 at 5:38 PM Marcelo Schmitt
wrote:
>
> Add a devicetree documentation for the ad9832 direct digital
> synthesizer, waveform generator.
>
> Signed-off-by: Marcelo Schmitt
> ---
> .../bindings/iio/frequency/ad9832.txt | 26 +++
> 1 file changed, 26 insert
On Thu, Mar 21, 2019 at 9:39 PM Marcelo Schmitt
wrote:
>
> Hello, would anyone mind helping me test ad5933 driver on actual
> hardware? I went through this
> (https://oslongjourney.github.io/linux-kernel/experiment-one-iio-dummy/)
> tutorial so I was able to load iio_simple_dummy driver, create a
On Sun, Mar 10, 2019 at 11:23 PM Karen Palacio
wrote:
>
> Add spaces around minus operator to fix readibility.
>
> Signed-off-by: Karen Palacio
> ---
> drivers/staging/iio/adc/ad7192.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/staging/iio/adc/ad7192.c
> b/
On Sun, Mar 3, 2019 at 3:52 PM Renato Lui Geh wrote:
>
> Hi Alexandru,
>
> Thanks for the review. Some questions inline.
>
> Thanks,
> Renato
>
> On 03/01, Ardelean, Alexandru wrote:
> >On Thu, 2019-02-28 at 11:23 -0300, Renato Lui Geh wrote:
> >>
> >
> >The patch-series is a bit big.
> >I guess t
On Sat, Jan 26, 2019 at 8:13 PM Jonathan Cameron wrote:
>
> On Fri, 25 Jan 2019 22:14:32 -0200
> Rodrigo Ribeiro wrote:
>
> > Em sex, 25 de jan de 2019 às 21:46, Rodrigo Ribeiro
> > escreveu:
> > >
> > > Em sex, 25 de jan de 2019 às 06:20, Alexandru Ar
On Sat, Jan 26, 2019 at 8:09 PM Jonathan Cameron wrote:
>
> On Fri, 25 Jan 2019 10:19:54 +0200
> Alexandru Ardelean wrote:
>
> > On Thu, Jan 24, 2019 at 9:35 PM Rodrigo Ribeiro
> > wrote:
> > >
> > > Remove the checkpatch.pl check:
> > >
On Thu, Jan 24, 2019 at 9:35 PM Rodrigo Ribeiro wrote:
>
> Remove the checkpatch.pl check:
>
> CHECK: 'RESEVERD' may be misspelled - perhaps 'RESERVED'?
Hey,
A bit curios about this one.
Are you using this chip/driver ?
Thing is: the part is nearing EOL, and it could be an idea to be
marked for
On Fri, Jan 25, 2019 at 12:41 AM Stephen Boyd wrote:
>
> Quoting Jonathan Cameron (2018-12-16 02:07:41)
> > Rob, Clk experts, questions for you below.
> >
> > Jonathan
> >
> >
> > On Thu, 13 Dec 2018 17:39:22 -0800
> > Stephen Boyd wrote:
> >
> > > Quoting Jonathan Cameron (2018-12-08 07:29:54)
>
70 matches
Mail list logo