ppc64_defconfig
arm randconfig-c002-20220113
ia64 allmodconfig
ia64defconfig
ia64 allyesconfig
m68k allmodconfig
m68kdefconfig
On Thursday 13 January 2022 12:50:23 CET Kalle Valo wrote:
> Jerome Pouiller writes:
>
> > From: Jérôme Pouiller
> >
> > Apache-2.0 is not allowed in the kernel.
> >
> > Signed-off-by: Jérôme Pouiller
> > ---
> > drivers/staging/wfx/hif_api_cmd.h | 2 +-
> > drivers/staging/wfx/hif_api_gen
On Wed, 12 Jan 2022 at 19:24, Jérôme Pouiller
wrote:
>
> On Wednesday 12 January 2022 18:48:48 CET Pali Rohár wrote:
> > CAUTION: This email originated from outside of the organization. Do not
> > click links or open attachments unless you recognize the sender and know
> > the content is safe.
>
Jerome Pouiller writes:
> From: Jérôme Pouiller
>
> Apache-2.0 is not allowed in the kernel.
>
> Signed-off-by: Jérôme Pouiller
> ---
> drivers/staging/wfx/hif_api_cmd.h | 2 +-
> drivers/staging/wfx/hif_api_general.h | 2 +-
> drivers/staging/wfx/hif_api_mib.h | 2 +-
> 3 files change
From: Jérôme Pouiller
Since the WF200 VID/PID are not reliable, it's recommended to declare it
in the DT. Until now, if the device was not declared, the driver just
printed a warning and continue. But, the risk of a collision is too
high, the driver now returns an error.
Signed-off-by: Jérôme Po
From: Jérôme Pouiller
"config-file" is too broad. Replace it by "silabs,antenna-config-file"
which is more explicit.
The attribute "config-file" is probably not widely used. This patch
obviously breaks setups that use this attribute.
Signed-off-by: Jérôme Pouiller
---
.../devicetree/bindings/
From: Jérôme Pouiller
Values "silabs,wfx-sdio" and "silabs,wfx-spi" are deprecated for a while
now. We take advantage of getting out of the staging tree to drop them
and start from a blank sheet.
Signed-off-by: Jérôme Pouiller
---
.../devicetree/bindings/net/wireless/silabs,wfx.yaml | 3 +--
From: Jérôme Pouiller
There is currently, a mismatch between the location of the firmware in
linux-firmware and the path written in the driver.
We take this opportunity to relocate the WF200 firmware in wfx/ instead
of silabs/.
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/bus_sdio.c
From: Jérôme Pouiller
"WF200" only designates the chip. To make a WiFi board, the chip must be
associated with an antenna. The antenna configuration is located in
separate files (aka PDS files in Silabs wording). Currently, user has to
write in his DT something like:
compatible = "silabs,wf2
From: Jérôme Pouiller
ps_timeout should be in nl80211, not in debugfs. Let's remove it until
the driver is accepted.
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/debug.c | 23 ---
drivers/staging/wfx/main.c | 1 -
drivers/staging/wfx/sta.c | 8 ++--
drive
From: Jérôme Pouiller
It is not necessary to prefix error logs with the function name when an
error message is unique in the code.
Note this patch still prefixes the message 'received event for
non-existent vif' with the function name since it is used several
times.
Signed-off-by: Jérôme Pouill
From: Jérôme Pouiller
It seems that BUILD_BUG_ON_MSG() is a bit more popular.
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/data_tx.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/wfx/data_tx.c b/drivers/staging/wfx/data_tx.c
index ca2f24b92d2
From: Jérôme Pouiller
Prefer fully named labels to handle errors instead of err0, err1, ...
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/bus_sdio.c | 9 -
drivers/staging/wfx/main.c | 31 +++
2 files changed, 19 insertions(+), 21 deletions(-)
From: Jérôme Pouiller
Some structs members were not properly aligned.
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/bus_sdio.c | 12 ++---
drivers/staging/wfx/bus_spi.c | 12 ++---
drivers/staging/wfx/debug.c| 2 +-
drivers/staging/wfx/fwio.c | 6 +--
drivers/staging/wfx/ma
From: Jérôme Pouiller
Until now, this driver was written in 80 columns style. However, since
all the functions are prefixed with "wfx_", this constraint is no more
respected in the last patches.
From the perspective of kernel Coding Style, it is not a problem since
it is now allowed to write cod
From: Jérôme Pouiller
Until now, this driver was written in 80 columns style. However, since
all the functions are prefixed with "wfx_", this constraint is no more
respected in the last patches.
From the perspective of kernel Coding Style, it is not a problem since
it is now allowed to write cod
From: Jérôme Pouiller
All the types related to a driver should use the same prefix.
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/bh.c | 12 +--
drivers/staging/wfx/data_rx.c | 2 +-
drivers/staging/wfx/data_rx.h | 4 +-
drivers/staging/wfx/data_tx.c
From: Jérôme Pouiller
All the types related to a driver should use the same prefix.
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/bus.h | 2 +-
drivers/staging/wfx/bus_sdio.c | 2 +-
drivers/staging/wfx/bus_spi.c | 2 +-
drivers/staging/wfx/data_tx.c | 38 +--
From: Jérôme Pouiller
tx_policy_is_equal() was the only function from data_tx.c without the
prefix wfx_.
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/data_tx.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/wfx/data_tx.c b/drivers/staging/
From: Jérôme Pouiller
All the functions related to a driver should use the same prefix.
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/bh.c | 8 +--
drivers/staging/wfx/fwio.c | 78 ++--
drivers/staging/wfx/hif_tx.c | 2 +-
drivers/staging/wfx/hwio.c | 135
From: Jérôme Pouiller
All the functions related to a driver should use the same prefix.
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/debug.c | 6 +++---
drivers/staging/wfx/debug.h | 6 +++---
drivers/staging/wfx/hif_tx.c | 8
3 files changed, 10 insertions(+), 10 deletion
From: Jérôme Pouiller
All the functions related to a driver should use the same prefix.
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/data_tx.c| 2 +-
drivers/staging/wfx/debug.c | 2 +-
drivers/staging/wfx/hif_rx.c | 103 +-
drivers/staging/wfx/hif_tx
From: Jérôme Pouiller
The prefix 'ieee80211' is reserved for mac80211. It should not been
used.
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/scan.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/wfx/scan.c b/drivers/staging/wfx/scan.c
index
From: Jérôme Pouiller
The prefix 'ieee80211' is reserved for mac80211. It should not been
used.
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/data_tx.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/wfx/data_tx.c b/drivers/staging/wfx/data_tx.c
From: Jérôme Pouiller
The hardware fills struct hif_ind_startup with little endian values. So,
declare it with little endian fields.
It is now a bit more verbose to access to fields of struct
hif_ind_startup, but it is less confusing.
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/bh.
From: Jérôme Pouiller
Magic values are not recommended.
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/hif_rx.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/wfx/hif_rx.c b/drivers/staging/wfx/hif_rx.c
index 6963b54d5593..5e675d2c3e82 100644
--- a/
From: Jérôme Pouiller
Magic values are not recommended.
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/hwio.c | 6 --
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/wfx/hwio.c b/drivers/staging/wfx/hwio.c
index a2a37efc51a6..977b9325f496 100644
--- a/
From: Jérôme Pouiller
It "IS_ALIGNED(ptr, 4)" is more explicit than "ptr & 3".
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/bus_sdio.c | 9 +
drivers/staging/wfx/hwio.c | 5 +++--
2 files changed, 8 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/wfx/bus_sdio.
From: Jérôme Pouiller
In the old days, this file was shared with other projects. Obviously,
this "#ifdef __KERNEL__" have no reasons to be in the kernel.
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/hif_api_general.h | 6 --
1 file changed, 6 deletions(-)
diff --git a/drivers/st
From: Jérôme Pouiller
Braces are not necessary for single statement blocks
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/main.c | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/wfx/main.c b/drivers/staging/wfx/main.c
index 858d778cc589..ddc95ea1
From: Jérôme Pouiller
I have got questions about this line from several reviewers. A comment
is definitively welcome.
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/Makefile | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/wfx/Makefile b/drivers/staging/wfx/Makefile
From: Jérôme Pouiller
Using DMA with stack allocated buffers is not supported, whatever the
value of CONFIG_VMAP_STACK.
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/hwio.c | 12
drivers/staging/wfx/hwio.h | 4
2 files changed, 4 insertions(+), 12 deletions(-)
diff
From: Jérôme Pouiller
Each headers files should include every types it needs to compile (ie.
"gcc $CFLAGS -xc file.h" should compile)
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/bh.h | 1 +
drivers/staging/wfx/hif_tx.h | 4
drivers/staging/wfx/hif_tx_mib.h | 7 +
From: Jérôme Pouiller
Apache-2.0 is not allowed in the kernel.
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/hif_api_cmd.h | 2 +-
drivers/staging/wfx/hif_api_general.h | 2 +-
drivers/staging/wfx/hif_api_mib.h | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
diff --g
From: Jérôme Pouiller
Most of the patches of this series are the result of the review process on
linux-wireless[1].
The patches 1 to 25 are cosmetics. The last 3 patches are not fully backward
compatible. I believe it is not a problem in the staging area.
[1]:
https://lore.kernel.org/netdev/20
From: Jérôme Pouiller
License was missing in Kconfig.
Makefile license was GPL-2.0 while rest of the driver use GPL-2.0-only.
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/Kconfig | 1 +
drivers/staging/wfx/Makefile | 2 +-
2 files changed, 2 insertions(+), 1 deletion(-)
diff --git
36 matches
Mail list logo