On Thu, Jan 14, 2021 at 09:56:41AM -0800, Joe Perches wrote:
> On Thu, 2021-01-14 at 18:35 +0100, Mauro Carvalho Chehab wrote:
> > Instead of using 1/0 for true/false, change the type to boolean
> > and change the returned value.
> []
> > diff --git a/drivers/staging/hikey9xx/phy-hi3670-usb3.c
> >
Buenos días
Os informamos desde FOESCO (Formación Estatal Continua) que nos encontramos
organizando el Calendario de Cursos Bonificables 2021 para empleados en activo
o en ERTE.
Rogamos respondáis a este mismo correo electrónico eligiendo una de las
opciones que a continuación indicamos:
1
On Mon, Jan 18, 2021 at 05:02:45PM +0100, Mauro Carvalho Chehab wrote:
> Mark Brown escreveu:
> > If for some reason the PMIC is sufficiently fragile to need a delay
> > between enables it's not clear why the driver is doing it before
> > enabling rather than after, presumably there's issues with
Em Mon, 18 Jan 2021 13:54:40 +
Mark Brown escreveu:
> On Mon, Jan 18, 2021 at 02:28:12PM +0100, Mauro Carvalho Chehab wrote:
>
> > index f385146d2bd1..3b23ad56b31a 100644
> > --- a/Documentation/devicetree/bindings/mfd/hisilicon,hi6421-spmi-pmic.yaml
> > +++ b/Documentation/devicetree/bindin
On Mon, 18 Jan 2021, Mauro Carvalho Chehab wrote:
> Em Mon, 18 Jan 2021 15:12:27 +
> Lee Jones escreveu:
>
> > On Mon, 18 Jan 2021, Mauro Carvalho Chehab wrote:
> >
> > > This driver is ready for mainstream. So, move it out of staging.
> > >
> > > Signed-off-by: Mauro Carvalho Chehab
> >
On Mon, 18 Jan 2021 14:28:11 +0100, Mauro Carvalho Chehab wrote:
> This driver is ready for mainstream. So, move it out of staging.
>
> Signed-off-by: Mauro Carvalho Chehab
> ---
> .../mfd/hisilicon,hi6421-spmi-pmic.yaml | 133 +++
> MAINTAINERS | 7
Em Mon, 18 Jan 2021 15:12:27 +
Lee Jones escreveu:
> On Mon, 18 Jan 2021, Mauro Carvalho Chehab wrote:
>
> > This driver is ready for mainstream. So, move it out of staging.
> >
> > Signed-off-by: Mauro Carvalho Chehab
> > ---
> > .../mfd/hisilicon,hi6421-spmi-pmic.yaml | 133 ++
On Mon, 18 Jan 2021, Mauro Carvalho Chehab wrote:
> This driver is ready for mainstream. So, move it out of staging.
>
> Signed-off-by: Mauro Carvalho Chehab
> ---
> .../mfd/hisilicon,hi6421-spmi-pmic.yaml | 133 +++
> MAINTAINERS | 7 +
> drivers/m
The interrupt support for Advantech PCI-1730 currrently supports only
rising edge inputs for the trigger sources. Each of four interrupt
sources (each with its own Comedi subdevice) can be set to trigger on
either a rising edge or a falling edge. Add support for choosing the
edge during set-up of
From: Bernd Harries
On the Advantech PCI-1730, four digital inputs (DI0, DI1, IDI0 and IDI1)
can be used as external interrupt sources. Each input can be programmed
to latch an interrupt bit on either a rising edge or a falling edge (but
not both).
Add a new Comedi subdevice for each interrupt
These patches add interrupt support handling to Advantech PCI-1730,
using comedi's asynchronous command support to allow values to be read
from subdevices in response to interrupts triggered by signals on
external digital inputs.
The first patch is mostly by Bernd Harries with a bit of input from
From: Bernd Harries
On the ADLink PCI-7230, digital input channels 0 and 1 can be used as
external interrupt sources. A rising edge on each input latches a
corresponding local interrupt input of the PCI interface chip. Writing
a "clear IRQ" register clears both latches.
Add a new Comedi subdev
On Mon, Jan 18, 2021 at 02:28:12PM +0100, Mauro Carvalho Chehab wrote:
> index f385146d2bd1..3b23ad56b31a 100644
> --- a/Documentation/devicetree/bindings/mfd/hisilicon,hi6421-spmi-pmic.yaml
> +++ b/Documentation/devicetree/bindings/mfd/hisilicon,hi6421-spmi-pmic.yaml
> @@ -60,6 +60,8 @@ required:
This driver is ready for mainstream. So, move it out of staging.
Signed-off-by: Mauro Carvalho Chehab
---
.../mfd/hisilicon,hi6421-spmi-pmic.yaml | 133 +++
MAINTAINERS | 7 +
drivers/mfd/Kconfig | 15 +
drivers/mfd/Makefil
The Hisilicon 6421v600 SPMI driver is ready for mainstream.
So, move it from staging.
Signed-off-by: Mauro Carvalho Chehab
---
.../spmi/hisilicon,hisi-spmi-controller.yaml | 75
MAINTAINERS | 7 +
drivers/spmi/Kconfig | 9 +
Instead of storing regulator LDO configuration inside the DT, move
it to be part of the driver itself.
Signed-off-by: Mauro Carvalho Chehab
---
.../staging/hikey9xx/hi6421v600-regulator.c | 380 +++---
1 file changed, 152 insertions(+), 228 deletions(-)
diff --git a/drivers/stagin
As all regulator-specific properties got moved to be part of the
driver, remove them from the DT spec.
Signed-off-by: Mauro Carvalho Chehab
---
.../hikey9xx/hisilicon,hi6421-spmi-pmic.yaml | 106 +++---
1 file changed, 40 insertions(+), 66 deletions(-)
diff --git a/drivers/staging/
In preparation for de-staging, do some cleanups:
- Return error codes from hi6421_spmi_pmic_rmw();
- Remove a debug message;
- Change the module description;
- a few minor coding style adjustments.
Signed-off-by: Mauro Carvalho Chehab
---
.../staging/hikey9xx/hi6421v600-regulator.c | 35 +
This driver is ready for mainstream. Move it out of staging.
Signed-off-by: Mauro Carvalho Chehab
---
.../mfd/hisilicon,hi6421-spmi-pmic.yaml | 2 +
MAINTAINERS | 7 +-
drivers/regulator/Kconfig | 8 +
drivers/regulator/Makefile
Move it to be inside the private data struct.
Signed-off-by: Mauro Carvalho Chehab
---
drivers/staging/hikey9xx/hi6421v600-regulator.c | 10 ++
1 file changed, 6 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/hikey9xx/hi6421v600-regulator.c
b/drivers/staging/hikey9xx/hi6421
Fix a few warnings produced by make dt_binding_check.
Signed-off-by: Mauro Carvalho Chehab
---
.../hisilicon,hisi-spmi-controller.yaml | 19 ---
1 file changed, 16 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/hikey9xx/hisilicon,hisi-spmi-controller.yaml
b/dr
While those were useful during port time from downstream
version, let's get rid of them for good, as it is possible to
get about the same things by enabling regulator debugging code.
Signed-off-by: Mauro Carvalho Chehab
---
.../staging/hikey9xx/hi6421v600-regulator.c | 47 ++-
Hi Mark,
This patch series finish addressing support for Hikey 970
SPMI controller, PMIC and regulators.
I removed some unrelated DT patches from this series,
plus the Hikey 970 PHY USB3 code from it, in order to avoid
mixing different stuff on this series[1].
[1] Those unrelated patches were su
Sparse complains about __be32 conversions:
drivers/spmi/hisi-spmi-controller.c
drivers/spmi/hisi-spmi-controller.c:164:24: warning: cast to restricted
__be32
drivers/spmi/hisi-spmi-controller.c
drivers/spmi/hisi-spmi-controller.c:164:24: warning: cast to restricted
__be32
Use C99 comments at the beginning of the file and remove
uneeded includes.
Signed-off-by: Mauro Carvalho Chehab
---
.../staging/hikey9xx/hi6421v600-regulator.c | 43 +++
1 file changed, 16 insertions(+), 27 deletions(-)
diff --git a/drivers/staging/hikey9xx/hi6421v600-regulato
Adds support to control the PWM bus available in official Raspberry Pi
PoE HAT. Only RPi's co-processor has access to it, so commands have to
be sent through RPi's firmware mailbox interface.
Signed-off-by: Nicolas Saenz Julienne
---
Changes since v6:
- Use %pe
- Round divisions properly
- Use d
Use devm_rpi_firmware_get() so as to make sure we release RPi's firmware
interface when unbinding the device.
Signed-off-by: Nicolas Saenz Julienne
Reviewed-by: Florian Fainelli
---
drivers/staging/vc04_services/interface/vchiq_arm/vchiq_arm.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(
The PWM bus controlling the fan in RPi's official PoE hat can only be
controlled by the board's co-processor.
Signed-off-by: Nicolas Saenz Julienne
Reviewed-by: Rob Herring
---
Changes since v4:
- Rename compatible string to be more explicit with the bus' limitations
Changes since v3:
- Fix
Use devm_rpi_firmware_get() so as to make sure we release RPi's firmware
interface when unbinding the device.
Signed-off-by: Nicolas Saenz Julienne
Reviewed-by: Florian Fainelli
---
drivers/soc/bcm/raspberrypi-power.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/s
This is an example on how to enable the fan on top of RPi's official PoE
hat.
Signed-off-by: Nicolas Saenz Julienne
---
arch/arm/boot/dts/bcm2711-rpi-4-b.dts | 54 +++
1 file changed, 54 insertions(+)
diff --git a/arch/arm/boot/dts/bcm2711-rpi-4-b.dts
b/arch/arm/boot/dt
There is no use for the firmware interface after getting the touch
buffer address, so release it.
Signed-off-by: Nicolas Saenz Julienne
Acked-by: Dmitry Torokhov
Reviewed-by: Florian Fainelli
---
Changes since v5:
- Correct commit message
Changes since v3:
- Release firmware handle in probe
Use devm_rpi_firmware_get() so as to make sure we release RPi's firmware
interface when unbinding the device.
Signed-off-by: Nicolas Saenz Julienne
Reviewed-by: Florian Fainelli
---
drivers/reset/reset-raspberrypi.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/res
Use devm_rpi_firmware_get() so as to make sure we release RPi's firmware
interface when unbinding the device.
Signed-off-by: Nicolas Saenz Julienne
Reviewed-by: Florian Fainelli
Acked-by: Bartosz Golaszewski
---
drivers/gpio/gpio-raspberrypi-exp.c | 2 +-
1 file changed, 1 insertion(+), 1 dele
The aim of this series is to add support to the fan found on RPi's PoE
HAT. Some commentary on the design can be found below. But the important
part to the people CC'd here not involved with PWM is that, in order to
achieve this properly, we also have to fix the firmware interface the
driver uses t
It'll simplify the firmware handling for most consumers.
Suggested-by: Bartosz Golaszewski
Signed-off-by: Nicolas Saenz Julienne
Reviewed-by: Florian Fainelli
Reviewed-by: Bartosz Golaszewski
---
Changes since v4:
- Rearrange function calls for clarity, same functionality
Changes since v2:
Use devm_rpi_firmware_get() so as to make sure we release RPi's firmware
interface when unbinding the device.
Signed-off-by: Nicolas Saenz Julienne
Reviewed-by: Florian Fainelli
Acked-by: Stephen Boyd
drivers/clk/bcm/clk-raspberrypi.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
dif
When unbinding the firmware device we need to make sure it has no
consumers left. Otherwise we'd leave them with a firmware handle
pointing at freed memory.
Keep a reference count of all consumers and introduce rpi_firmware_put()
which will permit automatically decrease the reference count upon
un
Hi,
Thanks for working on this
On Fri, Jan 15, 2021 at 09:01:29PM +0100, Paul Kocialkowski wrote:
> The v4l2_async_notifier_parse_fwnode_endpoints helper is getting
> deprecated in favor of explicit parsing of the endpoints.
>
> Implement it instead of using this deprecated function.
>
> Since
38 matches
Mail list logo