Hi Suraj,
Thank you for the patch! Yet something to improve:
[auto build test ERROR on staging/staging-testing]
url:
https://github.com/0day-ci/linux/commits/Suraj-Upadhyay/staging-kpc2000-Replace-depracated-MSI-API/20200718-213859
base: https://git.kernel.org/pub/scm/linux/kernel/git
Em Tue, 14 Jul 2020 09:23:50 -0400
B K Karthik escreveu:
> changed symbols N_SHORT_PACKET_LUT_ENTRIES, N_LONG_PACKET_ENTRIES,
> N_CSI_RX_FE_CTRL_DLANES, N_CSI_RX_BE_SID_WIDTH to static because they
> were not declared earlier.
This patch is broken:
ERROR: modpost: "N_CSI_RX_FE_CTRL_DLANES"
[dr
Instead of declaring all those consts everywhere when the
headers are included, just place them on a single place.
This change shuts up lots of warnings when built with W=1:
In file included from drivers/staging/media/atomisp/pci/ia_css_acc_types.h:23,
from drivers/staging/media/
On Sat, Jul 18, 2020 at 06:56:32PM +0530, Suraj Upadhyay wrote:
> Replace depracated pci_enable_msi with pci_alloc_irq_vectors.
> And as a result modify how the returned value is handled.
>
> Signed-off-by: Suraj Upadhyay
> ---
> drivers/staging/media/atomisp/pci/atomisp_v4l2.c | 4 ++--
> 1 fil
On Sat, Jul 18, 2020 at 09:10:30PM +0530, Suraj Upadhyay wrote:
> Replace depracated pci_enable_msi with pci_alloc_irq_vectors.
>
> Signed-off-by: Suraj Upadhyay
> ---
> drivers/staging/rts5208/rtsx.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
Hii, don't merge this patch.
It
On Sat, Jul 18, 2020 at 09:19:51PM +0530, Suraj Upadhyay wrote:
> Replace depracated pci_enable_msi with pci_alloc_irq_vectors.
> And as a result modify how the returned value is handled.
>
> Signed-off-by: Suraj Upadhyay
> ---
> Changes:
> v2: Removed the undefined variable.
> Re
Drop the repeated word "the" in a comment.
Signed-off-by: Randy Dunlap
Cc: Greg Kroah-Hartman
Cc: Arve Hjønnevåg
Cc: Todd Kjos
Cc: Martijn Coenen
Cc: Joel Fernandes
Cc: Christian Brauner
Cc: Hridya Valsaraju
Cc: Suren Baghdasaryan
Cc: de...@driverdev.osuosl.org
---
include/uapi/linux/and
Hi K,
Thank you for the patch! Yet something to improve:
[auto build test ERROR on staging/staging-testing]
url:
https://github.com/0day-ci/linux/commits/B-K-Karthik/staging-rtl8188eu-include-fixed-multiple-blank-space-coding-style-issues/20200718-172103
base: https://git.kernel.org/pub
On Mon, Jul 13, 2020 at 02:41:19PM +0100, Ian Abbott wrote:
> On 13/07/2020 14:34, Greg KH wrote:
> > On Sun, Jul 12, 2020 at 12:36:28PM +0530, Saurav Girepunje wrote:
> > > Remove below warning in das1800.c
> > > WARNING: possible condition with no effect (if == else)
> > >
> > > Signed-off-by: S
Hi K,
Thank you for the patch! Perhaps something to improve:
[auto build test WARNING on staging/staging-testing]
url:
https://github.com/0day-ci/linux/commits/B-K-Karthik/staging-rtl8188eu-include-fixed-multiple-blank-space-coding-style-issues/20200718-172103
base: https://git.kernel.org
As syzkaller detected, wlan-ng driver submits bulk urb without checking
that the endpoint type is actually bulk, add usb_urb_ep_type_check()
Reported-and-tested-by: syzbot+c2a1fa67c02faa0de...@syzkaller.appspotmail.com
Link: https://syzkaller.appspot.com/bug?extid=c2a1fa67c02faa0de723
Signed-off-b
Replace depracated pci_enable_msi with pci_alloc_irq_vectors.
And as a result modify how the returned value is handled.
Signed-off-by: Suraj Upadhyay
---
Changes:
v2: Removed the undefined variable.
Reported by kernel-bot.
drivers/staging/kpc2000/kpc2000/core.c | 2 +-
1 fil
Replace depracated pci_enable_msi with pci_alloc_irq_vectors.
Signed-off-by: Suraj Upadhyay
---
drivers/staging/rts5208/rtsx.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rts5208/rtsx.c b/drivers/staging/rts5208/rtsx.c
index e28e162d004e..b39d3f8b54df
On Sat, Jul 18, 2020 at 06:48:56PM +0530, Suraj Upadhyay wrote:
> Replace depracated pci_enable_msi with pci_alloc_irq_vectors.
>
> Signed-off-by: Suraj Upadhyay
> ---
> drivers/staging/rts5208/rtsx.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/staging/r
Hello,
Acknowledge please if you still use this e-mail. There is a heritage that has
your surname. get in touch at:zhuq...@gmail.com
Thanks,
Qi
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo
Hi Suraj,
Thank you for the patch! Yet something to improve:
[auto build test ERROR on staging/staging-testing]
url:
https://github.com/0day-ci/linux/commits/Suraj-Upadhyay/staging-kpc2000-Replace-depracated-MSI-API/20200718-213859
base: https://git.kernel.org/pub/scm/linux/kernel/git
On Sat, 2020-07-18 at 05:18 -0400, B K Karthik wrote:
> placed constant on the right side of the test
> to fix warnings issued by checkpatch
[]
> diff --git a/drivers/staging/rtl8188eu/include/wifi.h
> b/drivers/staging/rtl8188eu/include/wifi.h
[]
> @@ -326,7 +326,7 @@ static inline unsigned char
Replace depracated pci_enable_msi with pci_alloc_irq_vectors.
Signed-off-by: Suraj Upadhyay
---
drivers/staging/kpc2000/kpc2000/core.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/kpc2000/kpc2000/core.c
b/drivers/staging/kpc2000/kpc2000/core.c
index 358d7b
On Sat, Jul 18, 2020 at 9:17 AM Joe Perches wrote:
>
> On Sat, 2020-07-18 at 05:18 -0400, B K Karthik wrote:
> > placed constant on the right side of the test
> > to fix warnings issued by checkpatch
> []
> > diff --git a/drivers/staging/rtl8188eu/include/wifi.h
> > b/drivers/staging/rtl8188eu/in
Replace depracated psi_enable_msi with pci_alloc_irq_vectors.
And as a result modify how the returned value is handled.
Signed-off-by: Suraj Upadhyay
---
drivers/staging/media/ipu3/ipu3.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/media/ipu3/ipu3.c
b
Replace depracated pci_enable_msi with pci_alloc_irq_vectors.
And as a result modify how the returned value is handled.
Signed-off-by: Suraj Upadhyay
---
drivers/staging/media/atomisp/pci/atomisp_v4l2.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/media
Replace depracated pci_enable_msi with pci_alloc_irq_vectors.
Signed-off-by: Suraj Upadhyay
---
drivers/staging/rts5208/rtsx.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rts5208/rtsx.c b/drivers/staging/rts5208/rtsx.c
index e28e162d004e..adc80e766412
Hi K,
Thank you for the patch! Yet something to improve:
[auto build test ERROR on staging/staging-testing]
url:
https://github.com/0day-ci/linux/commits/B-K-Karthik/staging-rtl8188eu-include-fixed-multiple-blank-space-coding-style-issues/20200718-172103
base: https://git.kernel.org/pub
Hi K,
Thank you for the patch! Perhaps something to improve:
[auto build test WARNING on staging/staging-testing]
url:
https://github.com/0day-ci/linux/commits/B-K-Karthik/staging-rtl8188eu-include-fixed-multiple-blank-space-coding-style-issues/20200718-172103
base: https://git.kernel.org
From: Anoop S
This fixes the following checkpatch.pl warning
WARNING: Prefer using '"%s...", __func__' to using 'rtw_tkip_decrypt', this
function's name, in a string.
Signed-off-by: Anoop S
---
drivers/staging/rtl8188eu/core/rtw_security.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
There is an abstraction at the code in order to support
32 or 64 bits address/data length. However, for all
Atom chipsets supported by this version, the size is fixed.
So, cleanup the mess, removing the uused code and placing
the data sizes on a single place.
The end goal is to completely remove
There are several static vars declared inside the
system local headers. This causes lots of warnings when W=1.
Remove the unused ones.
Signed-off-by: Mauro Carvalho Chehab
---
.../media/atomisp/pci/isp2400_system_local.h | 38 ---
.../media/atomisp/pci/isp2401_system_local.h |
After removing the unused 32-bits data, the isp2401_system_local.h
now contains everything that it is needed, either by isp2401 or
by isp2400.
So, remove code duplication.
Signed-off-by: Mauro Carvalho Chehab
---
.../media/atomisp/pci/isp2400_system_local.h | 149 -
.../media/atomi
Right now, there are two versions of system_global.h headers.
Both share a lot of common code. There are some ISP2401 specific
types on one of the headers, but it doesn't conflict with the
ISP2400 ones.
Also, the common code is identical.
So, remove code duplication by moving such code into a
co
placed constant on the right side of the test
to fix warnings issued by checkpatch
Signed-off-by: B K Karthik
---
drivers/staging/rtl8188eu/include/rtw_mlme.h | 4 ++--
drivers/staging/rtl8188eu/include/wifi.h | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/sta
enclosed macros starting with if inside do-while loops to
avoid possible if-else logic defects
Signed-off-by: B K Karthik
---
drivers/staging/rtl8188eu/include/odm_debug.h | 28 +++
1 file changed, 16 insertions(+), 12 deletions(-)
diff --git a/drivers/staging/rtl8188eu/include/
fixed multiple parentheses coding style issues reported by checkpatch.
Signed-off-by: B K Karthik
---
drivers/staging/rtl8188eu/include/ieee80211.h | 4 +--
.../staging/rtl8188eu/include/osdep_service.h | 4 +--
drivers/staging/rtl8188eu/include/wifi.h | 34 +--
3 files ch
fixed multiple blank space coding style issues
reported by checkpatch
Signed-off-by: B K Karthik
---
drivers/staging/rtl8188eu/include/hal_com.h | 2 +-
drivers/staging/rtl8188eu/include/osdep_service.h | 2 +-
drivers/staging/rtl8188eu/include/rtl8188e_hal.h | 2 +-
drivers/staging/rt
On Fri, 3 Jul 2020 at 02:04, Ard Biesheuvel wrote:
>
> On Thu, 2 Jul 2020 at 20:21, Ard Biesheuvel wrote:
> >
> > On Thu, 2 Jul 2020 at 19:50, Eric Biggers wrote:
> > >
> > > [+linux-wireless, Marcel Holtmann, and Denis Kenzior]
> > >
> > > On Thu, Jul 02, 2020 at 12:19:44PM +0200, Ard Biesheuve
There is an abstraction at the code in order to support
32 or 64 bits address/data length. However, for all
Atom chipsets supported by this version, the size is fixed.
So, cleanup the mess, removing the uused code and placing
the data sizes on a single place.
The end goal is to completely remove
There are several static vars declared inside the
system local headers. This causes lots of warnings when W=1.
Remove the unused ones.
Signed-off-by: Mauro Carvalho Chehab
---
.../media/atomisp/pci/isp2400_system_local.h | 38 ---
.../media/atomisp/pci/isp2401_system_local.h |
36 matches
Mail list logo