On 2020-07-13 17:50 +0530, Suraj Upadhyay wrote:
> Simplify while loops into more readable and simple for loops.
>
> Signed-off-by: Suraj Upadhyay
> ---
[...]
> @@ -1824,7 +1821,7 @@ static struct sk_buff *ql_build_rx_skb(struct
> ql_adapter *qdev,
> sbq_desc->p.skb = NULL;
On Mon, 13 Jul 2020 20:41:11 -0700 Eric Biggers wrote:
> On Tue, Jul 14, 2020 at 11:32:52AM +0800, Hillf Danton wrote:
> >
> > Add FALLOC_FL_NOBLOCK and on the shmem side try to lock inode upon the
> > new flag. And the overall upside is to keep the current gfp either in
> > the khugepaged conte
On Tue, Jul 14, 2020 at 11:32:52AM +0800, Hillf Danton wrote:
>
> Add FALLOC_FL_NOBLOCK and on the shmem side try to lock inode upon the
> new flag. And the overall upside is to keep the current gfp either in
> the khugepaged context or not.
>
> --- a/include/uapi/linux/falloc.h
> +++ b/include/u
Mon, 13 Jul 2020 17:32:19 -0700
> syzbot has found a reproducer for the following crash on:
>
> HEAD commit:11ba4688 Linux 5.8-rc5
> git tree: upstream
> console output: https://syzkaller.appspot.com/x/log.txt?x=13f1bf4710
> kernel config: https://syzkaller.appspot.com/x/.config?x
syzbot has found a reproducer for the following crash on:
HEAD commit:11ba4688 Linux 5.8-rc5
git tree: upstream
console output: https://syzkaller.appspot.com/x/log.txt?x=175391fb10
kernel config: https://syzkaller.appspot.com/x/.config?x=a160d1053fc89af5
dashboard link: https://syzk
syzbot has found a reproducer for the following crash on:
HEAD commit:11ba4688 Linux 5.8-rc5
git tree: upstream
console output: https://syzkaller.appspot.com/x/log.txt?x=13f1bf4710
kernel config: https://syzkaller.appspot.com/x/.config?x=a160d1053fc89af5
dashboard link: https://syzk
On 7/13/20 1:28 PM, Ivan Safonov wrote:
On 7/13/20 5:23 PM, Dan Carpenter wrote:
On Mon, Jul 13, 2020 at 04:16:07PM +0300, Dan Carpenter wrote:
On Sun, Jul 12, 2020 at 03:38:21PM +0300, Ivan Safonov wrote:
Remove unused members of struct xmit_buf: alloc_sz, ff_hwaddr,
dma_transfer_addr, bpendi
On 7/13/20 5:23 PM, Dan Carpenter wrote:
On Mon, Jul 13, 2020 at 04:16:07PM +0300, Dan Carpenter wrote:
On Sun, Jul 12, 2020 at 03:38:21PM +0300, Ivan Safonov wrote:
Remove unused members of struct xmit_buf: alloc_sz, ff_hwaddr,
dma_transfer_addr, bpending and last.
Signed-off-by: Ivan Safonov
This patch fixes the checkpatch.pl warning:
WARNING: Prefer 'unsigned int' to bare use of 'unsigned'
Signed-off-by: Baidyanath Kundu
---
.../staging/vc04_services/bcm2835-audio/bcm2835-vchiq.c | 4 ++--
.../vc04_services/include/linux/raspberrypi/vchiq.h | 8
.../vc04_services/
The legacy API wrappers in include/linux/pci-dma-compat.h
should go away as it creates unnecessary midlayering
for include/linux/dma-mapping.h APIs, instead use dma-mapping.h
APIs directly.
The patch has been generated with the coccinelle script below
and compile-tested.
- PCI_DMA_BIDIRECTIO
On Mon, Jul 13, 2020 at 04:16:07PM +0300, Dan Carpenter wrote:
> On Sun, Jul 12, 2020 at 03:38:21PM +0300, Ivan Safonov wrote:
> > Remove unused members of struct xmit_buf: alloc_sz, ff_hwaddr,
> > dma_transfer_addr, bpending and last.
> >
> > Signed-off-by: Ivan Safonov
> > ---
> > drivers/stag
On Mon, Jul 13, 2020 at 05:52:22PM +0530, Suraj Upadhyay wrote:
> Use direct assignment instead of using memset with just one byte as an
> argument.
> Issue found by checkpatch.pl.
>
> Signed-off-by: Suraj Upadhyay
> ---
> Hii Maintainers,
> Please correct me if I am wrong here.
> ---
>
>
On Mon, Jul 13, 2020 at 05:50:14PM +0530, Suraj Upadhyay wrote:
> Simplify while loops into more readable and simple for loops.
>
I don't think either is more clear that the other. Walter Harms hates
count down loops and he's not entirely wrong...
regards,
dan carpenter
___
On 11/07/2020 14:38, Christophe JAILLET wrote:
Le 11/07/2020 à 14:35, Suraj Upadhyay a écrit :
The legacy API wrappers in include/linux/pci-dma-compat.h
should go away as it creates unnecessary midlayering
for include/linux/dma-mapping.h APIs, instead use dma-mapping.h
APIs directly.
The patch
On 13/07/2020 14:34, Greg KH wrote:
On Sun, Jul 12, 2020 at 12:36:28PM +0530, Saurav Girepunje wrote:
Remove below warning in das1800.c
WARNING: possible condition with no effect (if == else)
Signed-off-by: Saurav Girepunje
---
drivers/staging/comedi/drivers/das1800.c | 6 --
1 file cha
On Mon, Jul 13, 2020 at 05:50:14PM +0530, Suraj Upadhyay wrote:
> Simplify while loops into more readable and simple for loops.
>
> Signed-off-by: Suraj Upadhyay
> ---
> drivers/staging/qlge/qlge_main.c | 49 ++--
> 1 file changed, 22 insertions(+), 27 deletions(-)
T
On Mon, Jul 13, 2020 at 03:35:27PM +0200, Greg Kroah-Hartman wrote:
> On Mon, Jul 13, 2020 at 12:52:24PM +0530, Baidyanath Kundu wrote:
> > This patch fixes the checkpatch.pl error:
> >
> > ERROR: code indent should use tabs where possible
> >
> > Signed-off-by: Baidyanath Kundu
> > ---
> > ...
On Mon, Jul 13, 2020 at 12:52:24PM +0530, Baidyanath Kundu wrote:
> This patch fixes the checkpatch.pl error:
>
> ERROR: code indent should use tabs where possible
>
> Signed-off-by: Baidyanath Kundu
> ---
> .../staging/vc04_services/vchiq-mmal/mmal-vchiq.c | 14 +++---
> 1 file change
On Sun, Jul 12, 2020 at 12:36:28PM +0530, Saurav Girepunje wrote:
> Remove below warning in das1800.c
> WARNING: possible condition with no effect (if == else)
>
> Signed-off-by: Saurav Girepunje
> ---
> drivers/staging/comedi/drivers/das1800.c | 6 --
> 1 file changed, 6 deletions(-)
>
> d
On Sun, Jul 12, 2020 at 03:38:21PM +0300, Ivan Safonov wrote:
> Remove unused members of struct xmit_buf: alloc_sz, ff_hwaddr,
> dma_transfer_addr, bpending and last.
>
> Signed-off-by: Ivan Safonov
> ---
> drivers/staging/rtl8188eu/include/rtw_xmit.h | 5 -
> drivers/staging/rtl8188eu/os_d
Use direct assignment instead of using memset with just one byte as an
argument.
Issue found by checkpatch.pl.
Signed-off-by: Suraj Upadhyay
---
Hii Maintainers,
Please correct me if I am wrong here.
---
drivers/staging/qlge/qlge_ethtool.c | 4 ++--
1 file changed, 2 insertions(+), 2 de
Simplify while loops into more readable and simple for loops.
Signed-off-by: Suraj Upadhyay
---
drivers/staging/qlge/qlge_mpi.c | 32 +++-
1 file changed, 15 insertions(+), 17 deletions(-)
diff --git a/drivers/staging/qlge/qlge_mpi.c b/drivers/staging/qlge/qlge_mpi.c
Simplify while loops into more readable and simple for loops.
Signed-off-by: Suraj Upadhyay
---
drivers/staging/qlge/qlge_main.c | 49 ++--
1 file changed, 22 insertions(+), 27 deletions(-)
diff --git a/drivers/staging/qlge/qlge_main.c b/drivers/staging/qlge/qlge_mai
Issue found by checkpatch.pl
Signed-off-by: Suraj Upadhyay
---
drivers/staging/qlge/qlge.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/qlge/qlge.h b/drivers/staging/qlge/qlge.h
index 48bc494028ce..483ce04789ed 100644
--- a/drivers/staging/qlge/qlge.h
+++ b/drivers/staging
Simplify while loops into more readable and simple for loops.
Signed-off-by: Suraj Upadhyay
---
drivers/staging/qlge/qlge_dbg.c | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/qlge/qlge_dbg.c b/drivers/staging/qlge/qlge_dbg.c
index 32fbd30a6a2e..985a6c341
Issue found with checkpatch.pl
Signed-off-by: Suraj Upadhyay
---
drivers/staging/qlge/qlge.h | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/qlge/qlge.h b/drivers/staging/qlge/qlge.h
index 05e4f47442a3..48bc494028ce 100644
--- a/drivers/staging/qlge/qlge
Hii,
This patchest aims to remove several of the checkpatch.pl
warnings and refactor some ugly while loops into for loops for better
readability.
Some of the issues are found with checkpatch and others were listed in
qlge/TODO.
Thanks,
Suraj Upadhyay (6):
staging: qlge: qlge.h: Function
Rationale:
Reduces attack surface on kernel devs opening the links for MITM
as HTTPS traffic is much harder to manipulate.
Deterministic algorithm:
For each file:
If not .svg:
For each line:
If doesn't contain `\bxmlns\b`:
For each link, `\bhttp://[^# \t\r\n]*(?:\w|/)`:
This patch fixes the checkpatch.pl error:
ERROR: code indent should use tabs where possible
Signed-off-by: Baidyanath Kundu
---
.../staging/vc04_services/vchiq-mmal/mmal-vchiq.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/vc04_services/vch
29 matches
Mail list logo