writes:
> Luc,
>
> Thanks for your patch...
>
> On 28/06/2020 at 20:32, Luc Van Oostenryck wrote:
>> The method ndo_start_xmit() is defined as returning an 'netdev_tx_t',
>> which is a typedef for an enum type defining 'NETDEV_TX_OK' but this
>> driver returns '0' instead of 'NETDEV_TX_OK'.
>>
>
On Thu, Jul 02, 2020 at 12:50:04AM -0400, B K Karthik wrote:
> add blank spaces for improved code readability.
>
> Signed-off-by: B K Karthik
> ---
> drivers/staging/rtl8188eu/include/rtw_cmd.h | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/staging/rtl8188eu/in
add blank spaces to improve code readability.
Signed-off-by: B K Karthik
---
drivers/staging/rtl8188eu/include/rtw_pwrctrl.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8188eu/include/rtw_pwrctrl.h
b/drivers/staging/rtl8188eu/include/rtw_pwrctrl.h
inde
add parentheses since complex valued macros must be enclosed within parentheses.
Signed-off-by: B K Karthik
---
drivers/staging/rtl8188eu/include/rtw_pwrctrl.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8188eu/include/rtw_pwrctrl.h
b/drivers/stagi
added blank spaces to improve code readability. (coding style issue)
Signed-off-by: B K Karthik
---
drivers/staging/rtl8188eu/include/rtl8188e_xmit.h | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/rtl8188eu/include/rtl8188e_xmit.h
b/drivers/stag
added blank spaces to improve code readability.
Signed-off-by: B K Karthik
---
drivers/staging/rtl8188eu/include/rtw_recv.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8188eu/include/rtw_recv.h
b/drivers/staging/rtl8188eu/include/rtw_recv.h
index e383c
On Thu, Jul 02, 2020 at 12:48:42AM -0400, B K Karthik wrote:
> added blank spaces to improve code readability.
>
> Signed-off-by: B K Karthik
> ---
> drivers/staging/rtl8188eu/include/rtl8188e_xmit.h | 12 ++--
> 1 file changed, 6 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/s
add blank spaces to improve code readability.
Signed-off-by: B K Karthik
---
drivers/staging/rtl8188eu/include/rtw_pwrctrl.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8188eu/include/rtw_pwrctrl.h
b/drivers/staging/rtl8188eu/include/rtw_pwrctrl.h
inde
add parentheses since complex valued macros must be enclosed within parentheses.
Signed-off-by: B K Karthik
---
drivers/staging/rtl8188eu/include/rtw_pwrctrl.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8188eu/include/rtw_pwrctrl.h
b/drivers/stagi
add blank spaces for improved code readability.
Signed-off-by: B K Karthik
---
drivers/staging/rtl8188eu/include/rtw_cmd.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8188eu/include/rtw_cmd.h
b/drivers/staging/rtl8188eu/include/rtw_cmd.h
index fa5e212f
added blank spaces to improve code readability.
Signed-off-by: B K Karthik
---
drivers/staging/rtl8188eu/include/rtl8188e_xmit.h | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/rtl8188eu/include/rtl8188e_xmit.h
b/drivers/staging/rtl8188eu/include
rhel-kconfig
powerpc allmodconfig
powerpc allnoconfig
i386 randconfig-a002-20200701
i386 randconfig-a001-20200701
i386 randconfig-a006-20200701
i386 randconfig-a005-20200701
i386
From: Jérôme Pouiller
[ Upstream commit 29de523a6270a308d12d21f4fecf52dac491e226 ]
The function hif_scan() return the timeout for the completion of the
scan request. It is the only function from hif_tx.c that return another
thing than just an error code. This behavior is not coherent with the
re
Patchset Summary:
Enhance a PCIe host controller driver. Because of its unusual design
we are foced to change dev->dma_pfn_offset into a more general role
allowing multiple offsets. See the 'v1' notes below for more info.
v6:
Commit "device core: Introduce DMA range map":
-- of_dma_get
The new field 'dma_range_map' in struct device is used to facilitate the
use of single or multiple offsets between mapping regions of cpu addrs and
dma addrs. It subsumes the role of "dev->dma_pfn_offset" which was only
capable of holding a single uniform offset and had no region bounds
checking.
This series applies minor cleanups for rtl8712 staging driver.
Mauro Dreissig (2):
staging: rtl8712: Replace FIELD_OFFSET() with offsetof()
staging: rtl8712: base_types: Remove unused macros
drivers/staging/rtl8712/basic_types.h | 8
drivers/staging/rtl8712/hal_init.c
Use the existing offsetof() macro instead of duplicating code.
Signed-off-by: Mauro Dreissig
---
drivers/staging/rtl8712/basic_types.h | 1 -
drivers/staging/rtl8712/hal_init.c| 4 ++--
drivers/staging/rtl8712/rtl871x_ioctl_linux.c | 4 ++--
3 files changed, 4 insertions(+),
Those #define's are not used anywhere, get rid of them.
Signed-off-by: Mauro Dreissig
---
drivers/staging/rtl8712/basic_types.h | 7 ---
1 file changed, 7 deletions(-)
diff --git a/drivers/staging/rtl8712/basic_types.h
b/drivers/staging/rtl8712/basic_types.h
index b8ecd92ca9d4..aecded87dd4
tree/branch:
https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core.git
debugfs_cleanup
branch HEAD: 80e37912bf208f2c9ceeedb16213f0ff0a743f0a debugfs: remove return
value of debugfs_create_devm_seqfile()
elapsed time: 3430m
configs tested: 128
configs skipped: 13
The following c
Many defined constants in wifi.h are unused and/or available from
, some with slightly different names. Use the
common ones, rename where necessary and remove unused.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_ap.c | 12 ++---
drivers/staging/rtl8188eu/core/rtw_m
Remove unused parameter 'padapter' from rtw_os_xmit_resource_alloc().
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_xmit.c | 6 +++---
drivers/staging/rtl8188eu/include/xmit_osdep.h | 3 +--
drivers/staging/rtl8188eu/os_dep/xmit_linux.c | 3 +--
3 files changed, 5 i
This patch fixes the checkpatch.pl warning:
Prefer using '"%s...", __func__' to using '',
this function's name, in a string
Signed-off-by: Baidyanath Kundu
---
.../atomisp/pci/base/refcount/src/refcount.c | 28 +--
1 file changed, 14 insertions(+), 14 deletions(-)
diff --git a
Many defined constants in wifi.h are unused and/or available from
, some with slightly different names. Use the
common ones, rename where necessary and remove unused.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8712/rtl871x_ioctl_linux.c | 2 +-
drivers/staging/rtl8712/rtl871x_mlme.c
This patch adds the usb driver source file most_usb.c and
modifies the Makefile and Kconfig accordingly.
Signed-off-by: Christian Gromm
---
v2:
Reported-by: Greg Kroah-Hartman
- don't remove usb driver from staging area
- don't touch staging/most/Kconfig
- remove subdirec
Use %s and __func__ in place of function names.
This solves following checkpatch.pl warning
WARNING: Prefer using '"%s...", __func__' to using 'rtw_do_join', this
function's name, in a string
Signed-off-by: Puranjay Mohan
---
V1: Add staging in the subject.
---
drivers/staging/rtl8188eu/core/r
From: Jérôme Pouiller
When multiple interface on different channels are in use. It is
necessary to advertise the AP that the device is no more awake before to
switch to the other channel.
Until now, PS-Poll was the preferred mechanism for that. However. The
new firmwares (>= 3.7) now nicely sup
From: Jérôme Pouiller
The device is able to send multiple Tx confirmations in the one reply.
In this case, there is only one vif identifier for all the
confirmations.
Unfortunately, to generate this kind of messages the device squashes all
the confirmations whatever their vif ID and use the vif
From: Jérôme Pouiller
When a station go to sleep, the driver receive the status REQUEUE and
forward this answer to mac80211. So, neither the driver, neither the
hardware buffer the frames. So the call to ieee80211_sta_set_buffered is
useless.
In add, it seems that mac80211 does not expect to rec
From: Jérôme Pouiller
We don't want mac80211 try to check MMIC and other security mechanisms.
So, the driver remove all the data related to the encryption (IV, ICV,
MMIC).
However, enabling RX_FLAG_PN_VALIDATED is sufficient for that.
So, drop the useless function wfx_drop_encrypt_data() and en
From: Jérôme Pouiller
Hello,
This series fixes a few issues/improvements discovered during the last months.
Jérôme Pouiller (13):
staging: wfx: associate tx_queues to vifs
staging: wfx: check the vif ID of the Tx confirmations
staging: wfx: correctly retrieve vif ID from Tx confirmation
From: Jérôme Pouiller
As discussed here[1], if a message was smaller than the size of the
message header, it could be incorrectly processed.
[1] https://lore.kernel.org/driverdev-devel/2302785.6C7ODC2LYm@pc-42/
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/bh.c | 36 +
From: Jérôme Pouiller
It is useful to check which queue the driver choose to send to the
hardware.
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/queue.c | 3 +++
drivers/staging/wfx/traces.h | 51
2 files changed, 54 insertions(+)
diff --git a/d
From: Jérôme Pouiller
Since the driver does not call ieee80211_sta_set_buffered() anymore, it
is no more necessary to maintain a counter of buffered frames for each
stations.
This change allows to simplify the processing in multiple places in the
driver.
Signed-off-by: Jérôme Pouiller
---
dri
From: Jérôme Pouiller
To enable the TKIP/CCMP replay protection, the frames has to be
processed in the right order. However, the device is not able to
re-order the frames during BlockAck sessions.
Mac80211 is able to reorder the frames, but it need the information
about the BlockAck sessions sta
From: Jérôme Pouiller
The device handles 4 queues (one per AC) for each virtual interface (and
maximum 4 virtual interfaces). Until now the driver unified the queue of
all interfaces and handled only 4 queues for whole device.
This architecture did not allow to balance the traffic between the vi
From: Jérôme Pouiller
During the loading of the firmware, the WFX_DCA_GET register provide the
number available bytes in the receiving buffer. It is not necessary to
access to the WFX_DCA_GET after sent of each firmware fragment.
This patch allows to send the firmware:
- in 64ms instead of 130
From: Jérôme Pouiller
In some advanced usage or debug scenarios, it could interesting to
change the value of ps_timeout or eventually to force use of PS-Poll
frames.
The wext API (used by iwconfig) provide a way to change ps_timeout.
However, this API is obsolete and it seems a little weird to u
From: Jérôme Pouiller
It seems that in the old days, the RSSI information could be missing. In
this case, in order to not pollute the RSSI stats, the frame was
dropped (!).
It is far better to mark the frame with the flag RX_FLAG_NO_SIGNAL_VAL.
In add, the problem seems now fixed in the firmwar
From: Jérôme Pouiller
When the driver has sent a frame on a virtual interface (vif), it
expects to receive the confirmation on the same vif.
This patch add a check for that.
Signed-off-by: Jérôme Pouiller
---
drivers/staging/wfx/queue.c | 6 +-
1 file changed, 5 insertions(+), 1 deletion(
Use %s and __func__ in place of function names.
This solves following checkpatch.pl warning
WARNING: Prefer using '"%s...", __func__' to using 'rtw_do_join', this
function's name, in a string
Signed-off-by: Puranjay Mohan
---
drivers/staging/rtl8188eu/core/rtw_ioctl_set.c | 2 +-
1 file change
On Fri, Jun 19, 2020 at 04:50:26PM +0530, Vaibhav Agarwal wrote:
> Currently you can't enable the Gey Bus Audio Codec because there is no
> entry for it in the Kconfig file. Originally the config name was going
> to be AUDIO_MSM8994 but that's not correct because other types of
> hardware are suppo
On Fri, 3 Apr 2020 13:15:29 -0300, Helen Koike wrote:
> Move the bindings out of drivers/staging and place them in
> Documentation/devicetree/bindings instead.
>
> Also, add DT nodes for RK3399 and verify with make ARCH=arm64 dtbs_check
> and make ARCH=arm64 dt_binding_check.
>
> Tested by verify
(adding Ulf)
On Wednesday 01 July 2020 09:55:15 Pali Rohár wrote:
> On Tuesday 30 June 2020 03:17:01 ajay.kat...@microchip.com wrote:
> > On 29/06/20 6:56 pm, Pali Rohár wrote:
> > > EXTERNAL EMAIL: Do not click links or open attachments unless you know
> > > the content is safe
> > >
> > > On T
On Tuesday 30 June 2020 03:17:01 ajay.kat...@microchip.com wrote:
> On 29/06/20 6:56 pm, Pali Rohár wrote:
> > EXTERNAL EMAIL: Do not click links or open attachments unless you know the
> > content is safe
> >
> > On Tuesday 23 June 2020 11:00:04 ajay.kat...@microchip.com wrote:
> >> This patch s
Hello Linus,
On Tuesday 30 June 2020 10:21:33 CEST Linus Walleij wrote:
>
> The code has the functionality to insert the GPIO lines using
> the global GPIO numbers through module parameters.
>
> As we are clearly deprecating the use of global GPIO numbers
> look up the GPIO descriptors from the
On Fri, 19 Jun 2020 17:30:07 +0300, Dan Carpenter wrote:
> The devm_ioremap() function doesn't return error pointers, it returns
> NULL on error.
>
> Fixes: f20387dfd065 ("media: allegro: add Allegro DVT video IP core driver")
> Signed-off-by: Dan Carpenter
Reviewed-by: Michael Tretter
> ---
>
46 matches
Mail list logo