comedi_open() invokes comedi_dev_get_from_minor(), which returns a
reference of the COMEDI device to "dev" with increased refcount.
When comedi_open() returns, "dev" becomes invalid, so the refcount
should be decreased to keep refcount balanced.
The reference counting issue happens in one excepti
Hi all
On 19/04/2020 18:55, Stefano Brivio wrote:
Hi Oscar,
On Sat, 18 Apr 2020 15:45:53 +0200
Oscar Carter wrote:
Replace the for loop by a ternary operator whose condition is an AND
bitmask against the priv->basic_rates variable.
The purpose of the for loop was to check if any of bits fro
Hi Oscar,
On Sat, 18 Apr 2020 15:45:53 +0200
Oscar Carter wrote:
> Replace the for loop by a ternary operator whose condition is an AND
> bitmask against the priv->basic_rates variable.
>
> The purpose of the for loop was to check if any of bits from RATE_54M to
> RATE_6M was set, but it's not
These functions are only used by rxtx so move them and their arrays
used with them abbreviating the function description.
Signed-off-by: Malcolm Priestley
---
drivers/staging/vt6656/baseband.c | 139 --
drivers/staging/vt6656/baseband.h | 13 ---
drivers/staging/vt66
Cleanup indentation style in qlge_main.c.
Fix 2 warnings found by checkpatch.pl.
Signed-off-by: Mathieu Dolmen
---
drivers/staging/qlge/qlge_main.c | 16
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/qlge/qlge_main.c b/drivers/staging/qlge/qlge_ma
vnt_update_pre_ed_threshold needs to be updated more often so
call from vnt_config where it updated on any of config changes.
It must have maximum sensitivity when the device is off channel
or idle.
Remove all the other calls in scanning and bss.
Signed-off-by: Malcolm Priestley
---
drivers/st
Buenos días
Se encuentra abierto el plazo de inscripción de Cursos Bonificables para
empleados en activo y en situación de ERTE.
Todos los cursos son totalmente Bonificables con cargo al Crédito de Formación
2020 que dispone las empresa.
Se realizan desde casa en modalidad individual E-lear
Check the return value of vnt_control_out_* function calls. When
necessary modify the function prototype to be able to return the new
checked error code.
It's safe to modify all the function prototypes without fix the call
because the only change is the return value from void to int. If before
the
This patch series checks the return value of vnt_control_out_* function
calls.
The first patch checks the return value and when necessary modify the
function prototype to be able to return the new checked error code.
The second patch removes the documentation of functions that their
prototype has
Remove the functions' documentation as the names of the functions are
clear enought. Also, the actual documentation it's not correct in all
cases.
Signed-off-by: Oscar Carter
---
drivers/staging/vt6656/card.c | 79 --
drivers/staging/vt6656/mac.c | 52 -
The firmware function are not that complicated so
move them into main_usb as static functions in callers
visibility
Firmware definitions moved to device.h and MODULE_FIRMWARE
move to below module_usb_driver.
Signed-off-by: Malcolm Priestley
---
drivers/staging/vt6656/Makefile | 3 +-
driver
On Sun, Apr 19, 2020 at 10:22:50AM +0100, Malcolm Priestley wrote:
>
>
> On 19/04/2020 08:47, Oscar Carter wrote:
> > On Sat, Apr 18, 2020 at 07:05:53PM +0100, Malcolm Priestley wrote:
> >> Actually I don't really think the function descriptions are needed at all
> >> the
> >> names of the functio
Replace the for loops of the vnt_update_top_rates function by the fls
function.
The purpose of the two for loops is to find the most significant bit set
in a range of bits. So, they can be replace by the fls function (find
last set) with a previous mask to define the range.
This way avoid the ite
On 19/04/2020 08:47, Oscar Carter wrote:
> On Sat, Apr 18, 2020 at 07:05:53PM +0100, Malcolm Priestley wrote:
>> Actually I don't really think the function descriptions are needed at all the
>> names of the functions are enough.
>>
> Then, it would be better leave the documentation as it was bef
From: porfavorde
Fixed a checkpatch.pl warning: the constant should be in
the right side of the comparison.
Signed-off-by: porfavorde
---
drivers/staging/rtl8188eu/core/rtw_pwrctrl.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_pwrctrl.
On Sat, Apr 18, 2020 at 07:05:53PM +0100, Malcolm Priestley wrote:
> Actually I don't really think the function descriptions are needed at all the
> names of the functions are enough.
>
Then, it would be better leave the documentation as it was before or remove it?
> card.c needs to be removed the
16 matches
Mail list logo