[driver-core:debugfs_cleanup] BUILD REGRESSION 6cdbeae3773b0bb611d8caf5e84650f58a02748b

2020-04-06 Thread kbuild test robot
onfig | |-- drivers-gpu-drm-drm_debugfs.c:error:conflicting-types-for-drm_debugfs_remove_files | `-- drivers-gpu-drm-drm_debugfs.c:note:in-expansion-of-macro-EXPORT_SYMBOL |-- alpha-randconfig-a001-20200406 | |-- drivers-gpu-drm-drm_debugfs.c:error:conflicting-types-for-drm_debugfs_remove_files | `-- drivers

[driver-core:debugfs_remove_return_value] BUILD SUCCESS 5607303ec5411cf9e24005053ea4064f43f8911d

2020-04-06 Thread kbuild test robot
generic-64bit_defconfig x86_64 randconfig-a003-20200406 i386 randconfig-a002-20200406 x86_64 randconfig-a002-20200406 x86_64 randconfig-a001-20200406 i386 randconfig-a001-20200406 i386 randconfig-a003

[staging:staging-testing] BUILD SUCCESS 28910cbdc813ef8d7fa14b78d220457388c05c61

2020-04-06 Thread kbuild test robot
generic-64bit_defconfig x86_64 randconfig-a003-20200406 i386 randconfig-a002-20200406 x86_64 randconfig-a002-20200406 x86_64 randconfig-a001-20200406 i386 randconfig-a001-20200406 i386 randconfig-a003-20200406 mips

[PATCH 2/2 v2] staging: vt6656: rxtx remove rate change and current_rate.

2020-04-06 Thread Malcolm Priestley
There is no longer any need to change power in vnt_tx_packet. Remove current_rate in vnt_tx_packet and struct vnt_private as it is no longer used elsewhere. Signed-off-by: Malcolm Priestley --- v2 Patch 1 had wrong array. drivers/staging/vt6656/device.h | 1 - drivers/staging/vt6656/rxtx.c

[PATCH 1/2 v2] staging: vt6556: vnt_rf_setpower convert to use ieee80211_channel.

2020-04-06 Thread Malcolm Priestley
ieee80211_channel contains all the necessary information to change power according to tx mode required. vnt_rf_setpower is moved and so that vnt_rf_set_txpower the only caller becomes static. Signed-off-by: Malcolm Priestley --- v2 ARRAY_SIZE(priv->ofdm_pwr_tbl) pointing to wrong array. driver

Re: [PATCH 1/2] staging: vt6556: vnt_rf_setpower convert to use ieee80211_channel.

2020-04-06 Thread Malcolm Priestley
Drop these patches I have just noticed a mistake. Regards Malcolm ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

[PATCH 2/2] staging: vt6656: rxtx remove rate change and current_rate.

2020-04-06 Thread Malcolm Priestley
There is no longer any need to change power in vnt_tx_packet. Remove current_rate in vnt_tx_packet and struct vnt_private as it is no longer used elsewhere. Signed-off-by: Malcolm Priestley --- drivers/staging/vt6656/device.h | 1 - drivers/staging/vt6656/rxtx.c | 15 --- 2 files

[PATCH 1/2] staging: vt6556: vnt_rf_setpower convert to use ieee80211_channel.

2020-04-06 Thread Malcolm Priestley
ieee80211_channel contains all the necessary information to change power according to tx mode required. vnt_rf_setpower is moved and so that vnt_rf_set_txpower the only caller becomes static. Signed-off-by: Malcolm Priestley --- drivers/staging/vt6656/main_usb.c | 16 ++- drivers/staging/vt

Re: [PATCH 2/3] staging: vt6656: Use define instead of magic number for tx_rate

2020-04-06 Thread Greg Kroah-Hartman
On Mon, Apr 06, 2020 at 06:38:36PM +0200, Oscar Carter wrote: > On Mon, Apr 06, 2020 at 04:22:12PM +0200, Greg Kroah-Hartman wrote: > > On Sat, Apr 04, 2020 at 04:13:59PM +0200, Oscar Carter wrote: > > > Use the define RATE_11M present in the file "device.h" instead of the > > > magic number 3. So

Re: [PATCH 2/3] staging: vt6656: Use define instead of magic number for tx_rate

2020-04-06 Thread Oscar Carter
On Mon, Apr 06, 2020 at 04:22:12PM +0200, Greg Kroah-Hartman wrote: > On Sat, Apr 04, 2020 at 04:13:59PM +0200, Oscar Carter wrote: > > Use the define RATE_11M present in the file "device.h" instead of the > > magic number 3. So the code is more clear. > > > > Signed-off-by: Oscar Carter > > Revie

Re: [PATCH 1/3] staging: vt6656: Use ARRAY_SIZE instead of define RATE_54M

2020-04-06 Thread Oscar Carter
On Mon, Apr 06, 2020 at 02:13:23PM +0300, Dan Carpenter wrote: > On Sat, Apr 04, 2020 at 04:13:58PM +0200, Oscar Carter wrote: > > Use ARRAY_SIZE to replace the define RATE_54M so we will never have a > > mismatch. In this way, avoid the possibility of a buffer overflow if > > this define is change

[driver-core:debugfs_cleanup 1/3] drivers/gpu/drm/drm_debugfs.c:232:5: error: conflicting types for 'drm_debugfs_remove_files'

2020-04-06 Thread kbuild test robot
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core.git debugfs_cleanup head: 6cdbeae3773b0bb611d8caf5e84650f58a02748b commit: a05adcf1157e64eb2bf411cb92896af1082a26b9 [1/3] drm: make .debugfs_init and drm_debugfs_create_files() return void config: i386-allyesconfig (atta

Re: [PATCH 2/3] staging: vt6656: Use define instead of magic number for tx_rate

2020-04-06 Thread Greg Kroah-Hartman
On Sat, Apr 04, 2020 at 04:13:59PM +0200, Oscar Carter wrote: > Use the define RATE_11M present in the file "device.h" instead of the > magic number 3. So the code is more clear. > > Signed-off-by: Oscar Carter > Reviewed-by: Dan Carpenter > --- > drivers/staging/vt6656/baseband.c | 3 ++- > 1

[PATCH] staging: comedi: dt2815: fix writing hi byte of analog output

2020-04-06 Thread Ian Abbott
The DT2815 analog output command is 16 bits wide, consisting of the 12-bit sample value in bits 15 to 4, the channel number in bits 3 to 1, and a voltage or current selector in bit 0. Both bytes of the 16-bit command need to be written in turn to a single 8-bit data register. However, the driver c

Re: [PATCH] Staging: rtl8192e: remove set but not used variable 'tmpRegC'

2020-04-06 Thread Greg KH
On Tue, Apr 07, 2020 at 08:36:04AM -0400, Wang Hai wrote: > Fixes gcc '-Wunused-but-set-variable' warning: > > drivers/staging/rtl8192e/rtl8192e/r8192E_dev.c: In function > rtl92e_start_adapter: > drivers/staging/rtl8192e/rtl8192e/r8192E_dev.c:693:15: warning: variable > ‘tmpRegC’ set but not us

Re: [PATCH] staging: rtl8192u: Remove some set but not used variables

2020-04-06 Thread Greg KH
On Tue, Apr 07, 2020 at 08:07:44AM -0400, Wang Hai wrote: > Fixes gcc '-Wunused-but-set-variable' warning: > > drivers/staging/rtl8192u/r8192U_core.c: In function rtl8192_hard_data_xmit: > drivers/staging/rtl8192u/r8192U_core.c:905:6: warning: variable ‘ret’ set but > not used [-Wunused-but-set-v

Re: [PATCH] Staging: comedi: dt2815: remove set but not used variable 'hi'

2020-04-06 Thread Ian Abbott
On 07/04/2020 13:59, Wang Hai wrote: Fixes gcc '-Wunused-but-set-variable' warning: drivers/staging/comedi/drivers/dt2815.c: In function dt2815_ao_insn: drivers/staging/comedi/drivers/dt2815.c:91:19: warning: variable 'hi' set but not used [-Wunused-but-set-variable] commit d6a929b7608a ("Stag

[PATCH 08/11] staging: wfx: place hif_tx_mib functions into a .c file

2020-04-06 Thread Jerome Pouiller
From: Jérôme Pouiller Until now, all functions from hif_tx_mib.h are declared "static inline". However, they are not time critical. So, it does not make so much sense. We prefer to place them in a .c file as for other hif functions. Signed-off-by: Jérôme Pouiller --- drivers/staging/wfx/Makef

[PATCH 09/11] staging: wfx: allow to connect an IBSS with an existing SSID

2020-04-06 Thread Jerome Pouiller
From: Jérôme Pouiller With current code, chip is not able to join an existing IBSS network. Signed-off-by: Jérôme Pouiller --- drivers/staging/wfx/hif_tx.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/wfx/hif_tx.c b/drivers/staging/wfx/hif_tx.c index 4459

[PATCH 06/11] staging: wfx: fix endianness of hif API

2020-04-06 Thread Jerome Pouiller
From: Jérôme Pouiller The chip expects little endian in all structs it sends/receives. This patch fixes the hif API to reflect this fact. Sparse should now report meaningful errors. Signed-off-by: Jérôme Pouiller --- drivers/staging/wfx/hif_api_cmd.h | 120 - driver

[PATCH 02/11] staging: wfx: relocate LINK_ID_NO_ASSOC and MAX_STA_IN_AP_MODE to hif API

2020-04-06 Thread Jerome Pouiller
From: Jérôme Pouiller The definitions LINK_ID_NO_ASSOC and MAX_STA_IN_AP_MODE are imposed by the hardware. Therefore, they should be located in the hardware interface API. Signed-off-by: Jérôme Pouiller --- drivers/staging/wfx/data_tx.c | 2 +- drivers/staging/wfx/hif_api_cmd.h | 3 +++ dr

[PATCH 01/11] staging: wfx: drop unused WFX_LINK_ID_GC_TIMEOUT

2020-04-06 Thread Jerome Pouiller
From: Jérôme Pouiller The definition WFX_LINK_ID_GC_TIMEOUT is not used anymore since commit d6aeba575f27 ("staging: wfx: simplify the link-id allocation") Signed-off-by: Jérôme Pouiller --- drivers/staging/wfx/data_tx.c | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/staging/wfx/da

[PATCH 07/11] staging: wfx: align members declarations in hif API

2020-04-06 Thread Jerome Pouiller
From: Jérôme Pouiller Hardware API headers were not uniformly aligned. Signed-off-by: Jérôme Pouiller --- drivers/staging/wfx/hif_api_cmd.h | 484 +- drivers/staging/wfx/hif_api_general.h | 272 +++ drivers/staging/wfx/hif_api_mib.h | 388 ++-

[PATCH 00/11] staging: wfx: clean up HIF API

2020-04-06 Thread Jerome Pouiller
From: Jérôme Pouiller Hello all, This series try to clean up the Hardware InterFace (HIF) API of the wfx driver. Notice it intended to be applied on top of Pull-Request named "staging: wfx: rework the Tx queue". Jérôme Pouiller (11): staging: wfx: drop unused WFX_LINK_ID_GC_TIMEOUT staging

Re: [PATCH 1/2] staging: rtl8188eu: remove unnecessary asignment

2020-04-06 Thread Dan Carpenter
On Sun, Apr 05, 2020 at 01:22:29PM +0200, Michael Straube wrote: > Remove unnecessary asignment in SwLedBlink1(). The code path with the > asignment 'pLed->BlinkTimes = 0' is only executed when > 'pLed->BlinkTimes' is already zero and the value is not changed between > the test 'if (pLed->BlinkTime

Re: [PATCH 1/2] staging: rtl8188eu: remove unnecessary asignment

2020-04-06 Thread Dan Carpenter
On Mon, Apr 06, 2020 at 02:25:20PM +0300, Dan Carpenter wrote: > On Sun, Apr 05, 2020 at 01:22:29PM +0200, Michael Straube wrote: > > Remove unnecessary asignment in SwLedBlink1(). The code path with the > > asignment 'pLed->BlinkTimes = 0' is only executed when > > 'pLed->BlinkTimes' is already ze

[PATCH 11/11] staging: wfx: send just necessary bytes

2020-04-06 Thread Jerome Pouiller
From: Jérôme Pouiller Size of hif_mib_template_frame must be sufficient to contains bytes declared by frame_length and cannot exceed 700bytes. Change the API to reflect that. Signed-off-by: Jérôme Pouiller --- drivers/staging/wfx/hif_api_mib.h | 4 +++- drivers/staging/wfx/hif_tx_mib.c | 3 +

[PATCH 10/11] staging: wfx: make hif_ie_table_entry const

2020-04-06 Thread Jerome Pouiller
From: Jérôme Pouiller In wfx_update_filtering(), filter_ies is never modified. So, make it constant. Signed-off-by: Jérôme Pouiller --- drivers/staging/wfx/hif_tx_mib.c | 4 ++-- drivers/staging/wfx/hif_tx_mib.h | 4 ++-- drivers/staging/wfx/sta.c| 2 +- 3 files changed, 5 insertions(+

[PATCH 03/11] staging: wfx: relocate TX_RETRY_POLICY_MAX and TX_RETRY_POLICY_INVALID to hif API

2020-04-06 Thread Jerome Pouiller
From: Jérôme Pouiller The definitions TX_RETRY_POLICY_MAX and TX_RETRY_POLICY_INVALID are imposed by the hardware. Therefore, they should be located in the hardware interface API. Signed-off-by: Jérôme Pouiller --- drivers/staging/wfx/data_tx.c | 16 +++- drivers/staging/wfx/da

[PATCH 04/11] staging: wfx: remove unused definitions from the hif API

2020-04-06 Thread Jerome Pouiller
From: Jérôme Pouiller Until now, hif API was directly imported from firmware sources. However, it does not make sense to keep ton of unused structures in the driver. Moreover, the hif API is now stable enough to be keep in sync by importing delta from firmware. So, drop unused definitions from t

[PATCH 05/11] staging: wfx: remove useless defines

2020-04-06 Thread Jerome Pouiller
From: Jérôme Pouiller Several values defined in hif API are only here to define length of some arrays. In most cases, they do not provide any extra information about the size of the array (ie. "API_FIRMWARE_LABEL_SIZE" is only used to define the size of member "firmware_label"). Remove these use

Re: [PATCH 3/3] staging: vt6656: Remove unnecessary local variable initialization

2020-04-06 Thread Dan Carpenter
Reviewed-by: Dan Carpenter regards, dan carpenter ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Re: [PATCH 2/3] staging: vt6656: Use define instead of magic number for tx_rate

2020-04-06 Thread Dan Carpenter
On Sat, Apr 04, 2020 at 04:13:59PM +0200, Oscar Carter wrote: > Use the define RATE_11M present in the file "device.h" instead of the > magic number 3. So the code is more clear. > > Signed-off-by: Oscar Carter > --- > drivers/staging/vt6656/baseband.c | 3 ++- > 1 file changed, 2 insertions(+),

Re: [PATCH 1/3] staging: vt6656: Use ARRAY_SIZE instead of define RATE_54M

2020-04-06 Thread Dan Carpenter
On Sat, Apr 04, 2020 at 04:13:58PM +0200, Oscar Carter wrote: > Use ARRAY_SIZE to replace the define RATE_54M so we will never have a > mismatch. In this way, avoid the possibility of a buffer overflow if > this define is changed in the future to a greater value. > Future proofing is not really a

Re: [PATCH 3/3] staging: iio: ad5933: use iio_device_attach_kfifo_buffer() helper

2020-04-06 Thread Ardelean, Alexandru
On Sun, 2020-04-05 at 11:49 +0100, Jonathan Cameron wrote: > [External] > > On Wed, 1 Apr 2020 15:59:36 +0300 > Alexandru Ardelean wrote: > > > This driver calls iio_kfifo_allocate() vs devm_iio_kfifo_allocate(). But > > the conversion is still simpler here, and cleans-up/reduces some error > >

Re: [PATCH 1/3] iio: kfifo: add iio_device_attach_kfifo_buffer() helper

2020-04-06 Thread Ardelean, Alexandru
On Sun, 2020-04-05 at 11:46 +0100, Jonathan Cameron wrote: > [External] > > On Wed, 1 Apr 2020 15:59:34 +0300 > Alexandru Ardelean wrote: > > > This change adds the iio_device_attach_kfifo_buffer() helper/short-hand, > > which groups the simple routine of allocating a kfifo buffers via > > devm_