The `rtl8188eu` driver is built as a kmod in order to avoid symbol
conflicts (at link-time) with other Realtek drivers.
Internally, we use this driver as builtin [vs kmod], and we've identified
the `efuse_power_switch()` symbol to be conflicting at link-time with the
one from the `rtlwifi` driver.
> #ifndef VCHI_BULK_GRANULARITY
> # if __VCCOREVER__ >= 0x0400
> -# define VCHI_BULK_GRANULARITY 32 // Allows for the need to do cache
> cleans
> +#define VCHI_BULK_GRANULARITY 32 // Allows for the need of cache cleans
> # else
> # define VCHI_BULK_GRANULARITY 16
> #
Add space betwen operator to fix check warning.
Issue detected by checkpatch tool.
Signed-off-by: Jules Irenge
---
drivers/staging/vc04_services/interface/vchi/vchi_cfg.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/vc04_services/interface/vchi/vchi_cfg
Fix line over 80 characters checks warning.
Issue detected by checkpatch tool.
Signed-off-by: Jules Irenge
---
.../vc04_services/interface/vchi/vchi_cfg.h | 150 ++
1 file changed, 88 insertions(+), 62 deletions(-)
diff --git a/drivers/staging/vc04_services/interface/vchi/vchi
Fix "alignment should mactch open parenthesis" check.
Issue detected by checkpatch tool
Signed-off-by: Jules Irenge
---
drivers/staging/media/meson/vdec/codec_mpeg12.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/media/meson/vdec/codec_mpeg12.c
b/drivers/s
On Tue, Oct 15, 2019 at 09:32:08PM +0200, Michiel Schuurmans wrote:
> Replace formatting as suggested by checkpatch.
>
> Signed-off-by: Michiel Schuurmans
> ---
> drivers/staging/rtl8192e/rtllib_crypt_ccmp.c | 5 ++---
> 1 file changed, 2 insertions(+), 3 deletions(-)
Hi,
This is the friendly
Replace formatting as suggested by checkpatch.
Signed-off-by: Michiel Schuurmans
---
drivers/staging/rtl8192e/rtllib_crypt_ccmp.c | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/rtl8192e/rtllib_crypt_ccmp.c
b/drivers/staging/rtl8192e/rtllib_crypt_ccmp.c
On Mon, Oct 14, 2019 at 06:00:09PM -0500, Bjorn Helgaas wrote:
> From: Bjorn Helgaas
>
> Dexuan, the important thing here is the first patch, which is your [1],
> which I modified by doing pci_restore_state() as well as setting to D0:
>
> pci_set_power_state(pci_dev, PCI_D0);
> pci_restore_s
> From: Bjorn Helgaas
> Sent: Monday, October 14, 2019 4:00 PM
> ...
>
> Dexuan, the important thing here is the first patch, which is your [1],
> which I modified by doing pci_restore_state() as well as setting to D0:
>
> pci_set_power_state(pci_dev, PCI_D0);
> pci_restore_state(pci_dev);
On Tuesday, October 15, 2019 1:00:16 AM CEST Bjorn Helgaas wrote:
> From: Bjorn Helgaas
>
> 27e20603c54b ("PCI/MSI: Move D0 check into pci_msi_check_device()")
> moved the power state check into pci_msi_check_device(), which was
> subsequently renamed to pci_msi_supported(). This didn't change t
On Tuesday, October 15, 2019 1:00:15 AM CEST Bjorn Helgaas wrote:
> From: Bjorn Helgaas
>
> Documentation/power/pci.rst is wrapped to fit in 80 columns, but directory
> structure changes made a few lines longer. Wrap them so they all fit in 80
> columns again.
>
> Signed-off-by: Bjorn Helgaas
On Tuesday, October 15, 2019 1:00:14 AM CEST Bjorn Helgaas wrote:
> From: Bjorn Helgaas
>
> Some of the power management ops use this style:
>
> struct device_driver *drv = dev->driver;
> if (drv && drv->pm && drv->pm->prepare(dev))
> drv->pm->prepare(dev);
>
> while others use this:
>
On Tuesday, October 15, 2019 1:00:13 AM CEST Bjorn Helgaas wrote:
> From: Bjorn Helgaas
>
> pci_pm_resume() and pci_pm_restore() call pci_pm_default_resume(), which
> runs resume fixups before disabling wakeup events:
>
> static void pci_pm_default_resume(struct pci_dev *pci_dev)
> {
> p
On Tuesday, October 15, 2019 1:00:12 AM CEST Bjorn Helgaas wrote:
> From: Bjorn Helgaas
>
> Previously, pci_pm_resume_noirq() cleared the PME Status bit in the Root
> Status register only if the device had no driver or the driver did not
> implement legacy power management. It should clear PME S
On Tuesday, October 15, 2019 1:00:11 AM CEST Bjorn Helgaas wrote:
> From: Bjorn Helgaas
>
> According to the documentation, pci_pm_thaw_noirq() did not put the device
> into the full-power state and restore its standard configuration registers.
> This is incorrect, so update the documentation to
Hi!
Sorry for late reponse, technical issues...
Dne sreda, 02. oktober 2019 ob 23:54:47 CEST je Paul Kocialkowski napisal(a):
> Hi,
>
> On Wed 02 Oct 19, 21:35, Jernej Skrabec wrote:
> > It seems that for some H264 videos at least one bitstream parsing
> > trigger must be called in order to be d
On Tuesday, October 15, 2019 1:00:10 AM CEST Bjorn Helgaas wrote:
> From: Dexuan Cui
>
> pci_pm_thaw_noirq() is supposed to return the device to D0 and restore its
> configuration registers, but previously it only did that for devices whose
> drivers implemented the new power management ops.
>
>
Convert the local variables max_ampdu_len and min_mpdu_spacing from
unsigned char to u8 and remove unnecessary castings to u8 pointer.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_wlan_util.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/dri
Remove blank lines to reduce whitespace and improve readability.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_wlan_util.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_wlan_util.c
b/drivers/staging/rtl8188eu/core/rtw_wlan_util.c
Rename local variables to avoid mixed case.
max_AMPDU_len -> max_ampdu_len
min_MPDU_spacing -> min_mpdu_spacing
Signed-off-by: Michael Straube
---
.../staging/rtl8188eu/core/rtw_wlan_util.c| 24 +--
1 file changed, 12 insertions(+), 12 deletions(-)
diff --git a/drivers/stag
Ah that's fine then. And since wr_flags[hw->d2h_last_id] is just
true/false then it doesn't matter if it races.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverde
On Tue, Oct 15, 2019 at 04:19:55PM +0300, Dan Carpenter wrote:
> On Tue, Oct 15, 2019 at 01:24:50PM +0200, Alexander Gordeev wrote:
> > On Thu, Oct 10, 2019 at 02:30:34PM +0300, Dan Carpenter wrote:
> > > On Thu, Oct 10, 2019 at 10:51:45AM +0200, Alexander Gordeev wrote:
> > > > On Wed, Oct 09, 201
devm_regulator_get may return an error but mipi_csis_phy_init misses
a check for it.
This may lead to problems when regulator_set_voltage uses the unchecked
pointer.
This patch adds a check for devm_regulator_get to avoid potential risk.
Signed-off-by: Chuhong Yuan
---
Changes in v2:
- Add a ch
On Tue, Oct 15, 2019 at 01:24:50PM +0200, Alexander Gordeev wrote:
> On Thu, Oct 10, 2019 at 02:30:34PM +0300, Dan Carpenter wrote:
> > On Thu, Oct 10, 2019 at 10:51:45AM +0200, Alexander Gordeev wrote:
> > > On Wed, Oct 09, 2019 at 09:53:23PM +0300, Dan Carpenter wrote:
> > > > > > > + u32 *rd_fla
On Tue, Oct 15, 2019 at 04:03:21PM +0530, Vinod Koul wrote:
> what kind of device is this? I dont think we want these and the ones
> coming below as part of kernel kconfig!
Yes, I have already been pointed out on this and will put those as
kernel module parameters in the next version. The device i
On Tue, Oct 15, 2019 at 02:41:08PM +0300, Dan Carpenter wrote:
> > > > > > > > + spin_lock(lock);
> >
> > [*]
>
> [ snip ]
>
> > I struggle to realize how the spinlock I use (see [*] above) does not
> > protect the reader.
>
> Argh I'm really sorry. I completely didn't see the spinl
Null check before kfree is redundant, so remove it.
This is detected by coccinelle.
Signed-off-by: YueHaibing
---
v2: remove unnecessary 'hwxmits'
---
drivers/staging/rtl8723bs/core/rtw_xmit.c | 5 +
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/drivers/staging/rtl8723bs/core/
On Tue, Oct 15, 2019 at 07:40:53PM +0800, YueHaibing wrote:
> Null check before kfree is redundant, so remove it.
> This is detected by coccinelle.
>
> Signed-off-by: YueHaibing
> ---
> drivers/staging/rtl8723bs/core/rtw_xmit.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
> diff
Null check before kfree is redundant, so remove it.
This is detected by coccinelle.
Signed-off-by: YueHaibing
---
drivers/staging/rtl8723bs/core/rtw_xmit.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8723bs/core/rtw_xmit.c
b/drivers/staging/rtl8723bs
On Tue, Oct 15, 2019 at 01:24:50PM +0200, Alexander Gordeev wrote:
> On Thu, Oct 10, 2019 at 02:30:34PM +0300, Dan Carpenter wrote:
> > On Thu, Oct 10, 2019 at 10:51:45AM +0200, Alexander Gordeev wrote:
> > > On Wed, Oct 09, 2019 at 09:53:23PM +0300, Dan Carpenter wrote:
> > > > > > > + u32 *rd_fla
On Tue, 15 Oct 2019, Wambui Karuga wrote:
> Remove unnecessary casts in pointer types passed to kfree.
>
> Signed-off-by: Wambui Karuga
Acked-by: Julia Lawall
> ---
> drivers/staging/rtl8723bs/core/rtw_mlme.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/driv
Remove unnecessary casts in pointer types passed to kfree.
Signed-off-by: Wambui Karuga
---
drivers/staging/rtl8723bs/core/rtw_mlme.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8723bs/core/rtw_mlme.c
b/drivers/staging/rtl8723bs/core/rtw_mlme.c
ind
On Thu, Oct 10, 2019 at 02:30:34PM +0300, Dan Carpenter wrote:
> On Thu, Oct 10, 2019 at 10:51:45AM +0200, Alexander Gordeev wrote:
> > On Wed, Oct 09, 2019 at 09:53:23PM +0300, Dan Carpenter wrote:
> > > > > > + u32 *rd_flags = hw->dma_desc_table_rd.cpu_addr->flags;
> > > > > > + u32 *wr_flags
On 09-10-19, 12:12, Alexander Gordeev wrote:
> +config AVALON_DMA_CTRL_BASE
> + hex "Avalon DMA controllers base"
> + default "0x"
what kind of device is this? I dont think we want these and the ones
coming below as part of kernel kconfig!
> +// SPDX-License-Identifier: GPL-2.0
>
The ANX7625 is an ultra-low power 4K Mobile HD Transmitter designed
for portable device. It converts MIPI DSI/DPI to DisplayPort 1.3 4K.
The ANX7625 can support both USB Type-C PD feature and MIPI DSI/DPI
to DP feature. This driver only enabled MIPI DSI/DPI to DP feature.
Signed-off-by: Xin Ji
-
Hi all,
The following series add initial support for the Slimport ANX7625 transmitter, a
ultra-low power Full-HD 4K MIPI to DP transmitter designed for portable device.
This is the initial version, any mistakes, please let me know, I will fix it in
the next series.
Thanks,
Xin
Xin Ji (2):
dt-
The ANX7625 is an ultra-low power 4K Mobile HD Transmitter designed
for portable device. It converts MIPI to DisplayPort 1.3 4K.
You can add support to your board with binding.
Example:
anx7625_bridge: encoder@58 {
compatible = "analogix,anx7625";
reg = <0x
[ These are automated text from the 0-day bot -dan ]
Hi Xin,
Thank you for the patch! Perhaps something to improve:
url:
https://github.com/0day-ci/linux/commits/Xin-Ji/dt-bindings-drm-bridge-anx7625-MIPI-to-DP-transmitter-binding/20191014-043019
If you fix the issue, kindly add following
Add cast to fix the following sparse warning:
warning: restricted __be16 degrades to integer
Signed-off-by: Wambui Karuga
---
drivers/staging/octeon/ethernet-tx.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/octeon/ethernet-tx.c
b/drivers/staging/octeon/et
Hi Chuhong,
Thanks for the patch.
On Mon 14 Oct 2019 at 03:08, Chuhong Yuan wrote:
> devm_regulator_get may return an error but mipi_csis_phy_init misses
> a check for it.
> This may lead to problems when regulator_set_voltage uses the unchecked
> pointer.
> This patch adds a check for devm_regula
Hi all,
The following series add initial support for the Slimport ANX7625 transmitter, a
ultra-low power Full-HD 4K MIPI to DP transmitter designed for portable device.
This is the initial version, any mistakes, please let me know, I will fix it in
the next series.
Thanks,
Xin
Xin Ji (2):
dt
The ANX7625 is an ultra-low power 4K Mobile HD Transmitter designed
for portable device. It converts MIPI DSI/DPI to DisplayPort 1.3 4K.
The ANX7625 can support both USB Type-C PD feature and MIPI DSI/DPI
to DP feature. This driver only enabled MIPI DSI/DPI to DP feature.
Signed-off-by: Xin Ji
-
The ANX7625 is an ultra-low power 4K Mobile HD Transmitter designed
for portable device. It converts MIPI to DisplayPort 1.3 4K.
You can add support to your board with binding.
Example:
anx7625_bridge: encoder@58 {
compatible = "analogix,anx7625";
reg = <0x
43 matches
Mail list logo