On Thu 03 Oct 19, 23:19, Jernej Škrabec wrote:
> Dne četrtek, 03. oktober 2019 ob 22:58:57 CEST je Paul Kocialkowski
> napisal(a):
> > Hi,
> >
> > On Thu 03 Oct 19, 22:44, Jernej Škrabec wrote:
> > > Dne četrtek, 03. oktober 2019 ob 22:28:46 CEST je Paul Kocialkowski
> > >
> > > napisal(a):
> >
Dne četrtek, 03. oktober 2019 ob 22:58:57 CEST je Paul Kocialkowski
napisal(a):
> Hi,
>
> On Thu 03 Oct 19, 22:44, Jernej Škrabec wrote:
> > Dne četrtek, 03. oktober 2019 ob 22:28:46 CEST je Paul Kocialkowski
> >
> > napisal(a):
> > > Hi,
> > >
> > > On Thu 03 Oct 19, 07:16, Jernej Škrabec wrot
On 10/1/19 6:11 AM, Dan Carpenter wrote:
There is another one earlier in the function as well.
drivers/staging/rtl8188eu/os_dep/usb_intf.c
336
337 pnetdev = rtw_init_netdev(padapter);
338 if (!pnetdev)
339 goto free_adapter;
340 SE
On Thu, 3 Oct 2019, Nachammai Karuppiah wrote:
> Avoid typedefs to maintain kernel coding style. Issue found by
> checkpatch.pl
>
> Replace the enum typedef VCHIQ_REASON_T with vchiq_reason.
Would it be possible to get rid of them all? They seem to all go
together, since they start with the s
Hi,
On Thu 03 Oct 19, 22:44, Jernej Škrabec wrote:
> Dne četrtek, 03. oktober 2019 ob 22:28:46 CEST je Paul Kocialkowski
> napisal(a):
> > Hi,
> >
> > On Thu 03 Oct 19, 07:16, Jernej Škrabec wrote:
> > > Dne četrtek, 03. oktober 2019 ob 00:06:50 CEST je Paul Kocialkowski
> > >
> > > napisal(a):
Dne četrtek, 03. oktober 2019 ob 22:28:46 CEST je Paul Kocialkowski
napisal(a):
> Hi,
>
> On Thu 03 Oct 19, 07:16, Jernej Škrabec wrote:
> > Dne četrtek, 03. oktober 2019 ob 00:06:50 CEST je Paul Kocialkowski
> >
> > napisal(a):
> > > Hi,
> > >
> > > On Wed 02 Oct 19, 21:35, Jernej Skrabec wrot
Hi,
On Thu 03 Oct 19, 07:16, Jernej Škrabec wrote:
> Dne četrtek, 03. oktober 2019 ob 00:06:50 CEST je Paul Kocialkowski
> napisal(a):
> > Hi,
> >
> > On Wed 02 Oct 19, 21:35, Jernej Skrabec wrote:
> > > Reference index count in VE_H264_PPS should come from PPS control.
> > > However, this is no
Add ARM64-specific code to initialize the Hyper-V
hypervisor when booting as a guest VM. Provide functions
and data structures indicating hypervisor status that
are needed by VMbus driver.
This code is built only when CONFIG_HYPERV is enabled.
Signed-off-by: Michael Kelley
---
arch/arm64/hyperv
Update drivers/hv/Kconfig so CONFIG_HYPERV can be selected on
ARM64, causing the Hyper-V specific code to be built.
Signed-off-by: Michael Kelley
---
drivers/hv/Kconfig | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/hv/Kconfig b/drivers/hv/Kconfig
index 79e5356..11
Add hooks to enable/disable a per-CPU IRQ for VMbus. These hooks
are in the architecture independent setup and shutdown paths for
Hyper-V, and are needed by Linux guests on Hyper-V on ARM64. The
x86/x64 implementation is null because VMbus interrupts on x86/x64
don't use an IRQ.
Signed-off-by: Mi
hyperv-tlfs.h defines Hyper-V interfaces from the Hyper-V Top Level
Functional Spec (TLFS). The TLFS is distinctly oriented to x86/x64,
and Hyper-V has not separated out the architecture-dependent parts into
x86/x64 vs. ARM64. So hyperv-tlfs.h includes information for ARM64
that is not yet formally
Add ARM64-specific code to allocate memory with HV_HYP_PAGE_SIZE
size and alignment. These are for use when pages need to be shared
with Hyper-V. Separate functions are needed as the page size used
by Hyper-V may not be the same as the guest page size. Free
operations are rarely done, so no attemp
This series enables Linux guests running on Hyper-V on ARM64
hardware. New ARM64-specific code in arch/arm64/hyperv initializes
Hyper-V, including its interrupts and hypercall mechanism.
Existing architecture independent drivers for Hyper-V's VMbus and
synthetic devices just work when built for ARM
Add ARM64-specific code to make Hyper-V hypercalls and to
access virtual processor synthetic registers via hypercalls.
Hypercalls use a Hyper-V specific calling sequence with a non-zero
immediate value per Section 2.9 of the SMC Calling Convention
spec.
This code is architecture dependent and is m
Add functions to set up and remove kexec and panic
handlers, and to inform Hyper-V about a guest panic.
These functions are called from architecture independent
code in the VMbus driver.
This code is built only when CONFIG_HYPERV is enabled.
Signed-off-by: Michael Kelley
---
arch/arm64/hyperv/h
Add ARM64-specific code to set up and handle the interrupts
generated by Hyper-V for VMbus messages and for stimer expiration.
This code is architecture dependent and is mostly driven by
architecture independent code in the VMbus driver and the
Hyper-V timer clocksource driver.
This code is built
Avoid typedefs to maintain kernel coding style. Issue found by
checkpatch.pl
Replace the enum typedef VCHIQ_REASON_T with vchiq_reason.
Signed-off-by: Nachammai Karuppiah
---
drivers/staging/vc04_services/interface/vchiq_arm/vchiq_arm.c | 8
drivers/staging/vc04_services/interface/vc
Hi,
On 10/3/19 2:26 PM, Dan Carpenter wrote:
> On Wed, Oct 02, 2019 at 08:41:03PM +0300, Denis Efremov wrote:
>> The result variable in prism2_connect() can be used uninitialized on path
>> !channel --> ... --> is_wep --> sme->key --> sme->key_idx >= NUM_WEPKEYS.
>> This patch initializes result w
On Wed, Oct 02, 2019 at 10:35:19PM +0530, Rohit Sarkar wrote:
> Now that snprintf is replaced by scnprintf n >= MAX_WPA_IE_LEN doesn't
> make sense as the maximum value n can take is MAX_WPA_IE_LEN.
>
> Signed-off-by: Rohit Sarkar
> ---
Thanks!
Reviewed-by: Dan Carpenter
regards,
dan carpente
Cleanup comments in update_hw_ht_param to follow kernel coding style
and avoid line length over 80 characters.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_ap.c | 13 +
1 file changed, 5 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/rtl8188eu/co
Convert the local variables max_AMPDU_len and min_MPDU_spacing from
unsigned char to u8 and remove unnecessary castings to u8 pointer.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_ap.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/st
Replace tabs with spaces in declarations and reomve two blank lines in
update_hw_ht_param to cleanup whitespace and improve readability.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_ap.c | 6 ++
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/drivers/st
Cleanup code in function update_hw_ht_param().
Michael Straube (4):
staging: rtl8188eu: convert variables from unsigned char to u8
staging: rtl8188eu: rename variables to avoid mixed case
staging: rtl8188eu: cleanup whitespace in update_hw_ht_param
staging: rtl8188eu: cleanup comments in
Rename the local varibles max_AMPDU_len and min_MPDU_spacing to avoid
mixed case.
max_AMPDU_len -> max_ampdu_len
min_MPDU_spacing -> min_mpdu_spacing
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_ap.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
di
Or we could apply your other patch which trumps both this patch and the
patch to the TODO.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
I replied to your other thread and I added Saiyam Doshi to the CC list
there. Just to be clear this patch is a good cleanup and doesn't affect
runtime at all.
In the other thread, I suggested that we leave fs_sync() as a marker
even though it's dead code. But looking at it now, I think that it's
On Wed, Oct 02, 2019 at 03:01:35PM -0400, Valdis Klētnieks wrote:
> We've seen several incorrect patches for fs_sync() calls in the exfat driver.
> Add code to the TODO that explains this isn't just a delete code and refactor,
> but that actual analysis of when the filesystem should be flushed to d
On Wed, Oct 02, 2019 at 08:41:03PM +0300, Denis Efremov wrote:
> The result variable in prism2_connect() can be used uninitialized on path
> !channel --> ... --> is_wep --> sme->key --> sme->key_idx >= NUM_WEPKEYS.
> This patch initializes result with 0.
>
> Cc: Greg Kroah-Hartman
> Cc: sta...@vg
On Wed, Oct 02, 2019 at 08:47:03PM +0530, Saiyam Doshi wrote:
> fs_sync() is wrapper to bdev_sync(). When fs_sync is called with
> non-zero argument, bdev_sync gets called.
>
> Most instances of fs_sync is called with false and very few with
> true. Refactor this and makes direct call to bdev_sync
29 matches
Mail list logo