Dne četrtek, 03. oktober 2019 ob 00:23:07 CEST je Paul Kocialkowski
napisal(a):
> Hi,
>
> On Wed 02 Oct 19, 21:35, Jernej Skrabec wrote:
> > This is continuation of https://lkml.org/lkml/2019/5/30/1459 with several
> > patches removed (2 merged, others needs redesign) and one added.
>
> Thanks f
Dne četrtek, 03. oktober 2019 ob 00:06:50 CEST je Paul Kocialkowski
napisal(a):
> Hi,
>
> On Wed 02 Oct 19, 21:35, Jernej Skrabec wrote:
> > Reference index count in VE_H264_PPS should come from PPS control.
> > However, this is not really important, because reference index count is
> > in our ca
Hi,
On Wed 02 Oct 19, 21:35, Jernej Skrabec wrote:
> This is continuation of https://lkml.org/lkml/2019/5/30/1459 with several
> patches removed (2 merged, others needs redesign) and one added.
Thanks for the continued effort on this, these fixes are greatly appreciated
(and more generally, all t
Hi,
On Wed 02 Oct 19, 21:35, Jernej Skrabec wrote:
> Accessing capture queue structue directly is not safe. Use helpers for
> that.
Looks good to me, thanks!
Acked-by: Paul Kocialkowski
Cheers,
Paul
> Signed-off-by: Jernej Skrabec
> ---
> drivers/staging/media/sunxi/cedrus/cedrus.h |
Hi,
On Wed 02 Oct 19, 21:35, Jernej Skrabec wrote:
> Reference index count in VE_H264_PPS should come from PPS control.
> However, this is not really important, because reference index count is
> in our case always overridden by that from slice header.
Thanks for the fixup!
Our libva userspace a
Hi,
On Wed 02 Oct 19, 21:35, Jernej Skrabec wrote:
> It seems that for some H264 videos at least one bitstream parsing
> trigger must be called in order to be decoded correctly. There is no
> explanation why this helps, but it was observed that two sample videos
> with this fix are now decoded cor
It seems that for some H264 videos at least one bitstream parsing
trigger must be called in order to be decoded correctly. There is no
explanation why this helps, but it was observed that two sample videos
with this fix are now decoded correctly and there is no regression with
others.
Signed-off-b
Reference index count in VE_H264_PPS should come from PPS control.
However, this is not really important, because reference index count is
in our case always overridden by that from slice header.
Signed-off-by: Jernej Skrabec
---
drivers/staging/media/sunxi/cedrus/cedrus_h264.c | 8 ++--
1 f
This is continuation of https://lkml.org/lkml/2019/5/30/1459 with several
patches removed (2 merged, others needs redesign) and one added.
Patch 1 fixes h264 playback issue which happens in rare cases.
Patch 2 sets PPS default reference index count in register from PPS
control. Currently it was s
Accessing capture queue structue directly is not safe. Use helpers for
that.
Signed-off-by: Jernej Skrabec
---
drivers/staging/media/sunxi/cedrus/cedrus.h | 8 ++--
drivers/staging/media/sunxi/cedrus/cedrus_h264.c | 8 ++--
2 files changed, 12 insertions(+), 4 deletions(-)
diff --g
The majority of them were totally backwards. Change the logic
so that if DELAYED_SYNC *isn't* in the config, we actually flush to disk
before flagging the file system as clean.
That leaves two calls in the DELAYED_SYNC case. More detailed
analysis is needed to make sure that's what's really need
On Wed, 02 Oct 2019 20:47:03 +0530, Saiyam Doshi said:
> fs_sync() is wrapper to bdev_sync(). When fs_sync is called with
> non-zero argument, bdev_sync gets called.
>
> Most instances of fs_sync is called with false and very few with
> true. Refactor this and makes direct call to bdev_sync() where
We've seen several incorrect patches for fs_sync() calls in the exfat driver.
Add code to the TODO that explains this isn't just a delete code and refactor,
but that actual analysis of when the filesystem should be flushed to disk
needs to be done.
Signed-off-by: Valdis Kletnieks
---
diff --git
The result variable in prism2_connect() can be used uninitialized on path
!channel --> ... --> is_wep --> sme->key --> sme->key_idx >= NUM_WEPKEYS.
This patch initializes result with 0.
Cc: Greg Kroah-Hartman
Cc: sta...@vger.kernel.org
Signed-off-by: Denis Efremov
---
drivers/staging/wlan-ng/cf
Now that snprintf is replaced by scnprintf n >= MAX_WPA_IE_LEN doesn't
make sense as the maximum value n can take is MAX_WPA_IE_LEN.
Signed-off-by: Rohit Sarkar
---
drivers/staging/rtl8712/rtl871x_ioctl_linux.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/stagi
On Wednesday 2 October 2019 18:42:14 CEST Greg Kroah-Hartman wrote:
> On Wed, Oct 02, 2019 at 04:29:09PM +, Jerome Pouiller wrote:
[...]
> >
> > Hi Andrew,
> >
> > I did not forget your suggestion. However, if everyone is agree with that,
> > I'd
> > prefer to address it in a next pull request
On Wed, Oct 02, 2019 at 04:29:09PM +, Jerome Pouiller wrote:
> On Thursday 19 September 2019 18:34:48 CEST Andrew Lunn wrote:
> > On Thu, Sep 19, 2019 at 10:52:35AM +, Jerome Pouiller wrote:
> > > +static int wfx_sdio_copy_from_io(void *priv, unsigned int reg_id,
> > > +
On Thursday 19 September 2019 18:34:48 CEST Andrew Lunn wrote:
> On Thu, Sep 19, 2019 at 10:52:35AM +, Jerome Pouiller wrote:
> > +static int wfx_sdio_copy_from_io(void *priv, unsigned int reg_id,
> > + void *dst, size_t count)
> > +{
> > + struct wfx_sdio_priv
fs_sync() is wrapper to bdev_sync(). When fs_sync is called with
non-zero argument, bdev_sync gets called.
Most instances of fs_sync is called with false and very few with
true. Refactor this and makes direct call to bdev_sync() where
needed and removes fs_sync definition.
Signed-off-by: Saiyam D
On Wed, Oct 02, 2019 at 03:06:22PM +0300, Dan Carpenter wrote:
> You could remove it, but I feel like it's better to check for
> "== MAX_WPA_IE_LEN - 1". They're effectively the same, but to me it
> feels cleaner to be explicit how we're handling truncated data.
>
> regards,
> dan carpenter
I fe
On Wed, Oct 02, 2019 at 05:12:14PM +0530, Rohit Sarkar wrote:
> On Wed, Oct 02, 2019 at 01:57:22PM +0300, Dan Carpenter wrote:
> >
> > We could leave it as is or change it to "MAX_WPA_IE_LEN - 1". But I
> > feel like the default should be to leave it as is unless there is a good
> > reason.
>
>
On Wed, Oct 02, 2019 at 01:57:22PM +0300, Dan Carpenter wrote:
>
> We could leave it as is or change it to "MAX_WPA_IE_LEN - 1". But I
> feel like the default should be to leave it as is unless there is a good
> reason.
Makes sense, although greg has already merged this. I guess I will
remove th
On Wed, Oct 02, 2019 at 03:49:04PM +0530, Sumera Priyadarsini wrote:
> On Tue, Sep 24, 2019 at 8:47 PM Greg KH wrote:
> >
> > On Fri, Sep 13, 2019 at 11:31:01PM +0530, Sumera Priyadarsini wrote:
> > > Fixes indentation for if condition in the file r8190_rtl8256.c for better
> > > readability as s
On Wed, Oct 02, 2019 at 10:03:51AM +0530, Rohit Sarkar wrote:
> On Tue, Oct 01, 2019 at 10:00:56PM +0300, Dan Carpenter wrote:
> >
> > No. scnprintf() returns the number of characters *not counting the
> > NUL terminator*. So it can be a maximum of MAX_WPA_IE_LEN - 1.
> >
> > regards,
> > dan c
Someone already sent a patch to remove these functions. Generally there
should only be empty functions like this in a .h file.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/li
On Wed, Oct 02, 2019 at 03:49:04PM +0530, Sumera Priyadarsini wrote:
> On Tue, Sep 24, 2019 at 8:47 PM Greg KH wrote:
> >
> > On Fri, Sep 13, 2019 at 11:31:01PM +0530, Sumera Priyadarsini wrote:
> > > Fixes indentation for if condition in the file r8190_rtl8256.c for better
> > > readability as s
On Tue, Sep 24, 2019 at 8:47 PM Greg KH wrote:
>
> On Fri, Sep 13, 2019 at 11:31:01PM +0530, Sumera Priyadarsini wrote:
> > Fixes indentation for if condition in the file r8190_rtl8256.c for better
> > readability as suggested by Dan Carpenter.
>
> Please wrap your lines at 72 columns.
>
>
I will
Remove return variables, return the values
directly, as the functions all return 0 in all cases.
Signed-off-by: Saurav Girepunje
---
drivers/staging/rtl8723bs/os_dep/ioctl_linux.c | 15 +--
1 file changed, 5 insertions(+), 10 deletions(-)
diff --git a/drivers/staging/rtl8723bs/os_de
28 matches
Mail list logo