On Sun, Sep 08, 2019 at 08:19:21PM -0400, Valdis Klētnieks wrote:
> In that case, rather than removing it, shouldn't we be *adding*
> code to properly set it instead?
Right, setting the UtcOffset fields to 0 is the first step marking
them as invalid for now. This is also why access_time_ms did not
On Sun, Sep 08, 2019 at 10:43:02AM +0100, Okash Khawaja wrote:
> Sorry, I have only now got round to working on this. It's not complete
> yet but I have assimilated the feedback and converted subjective
> phrases, like "I think..." into objective statements or put them in
> TODO: so that someone el
This patch fixes the issue:
FILE: drivers/staging/fbtft/fb_agm1264k-fl.c:88:
CHECK: usleep_range is preferred over udelay; see
Documentation/timers/timers-howto.rst
+ udelay(20);
Signed-off-by: Sreeram Veluthakkal
---
drivers/staging/fbtft/fb_agm1264k-fl.c | 2 +-
1 file changed, 1 insert
On Sun, 08 Sep 2019 17:35:36 -, Valentin Vidic said:
> sbi parameter not used inside the function so remove it.
> Also cleanup unused variables generated by this change.
Tread carefully with this sort of patch - there's still a lot of places in the
code
where we have matching pairs of exfat_f
On Sun, 08 Sep 2019 16:10:14 -, Valentin Vidic said:
> Not used in the exfat-fuse implementation and spec defines
> this position should hold the value for CreateUtcOffset.
In that case, rather than removing it, shouldn't we be *adding*
code to properly set it instead?
pgpDFfdaGOzRf.pgp
Desc
On Sun, Sep 08, 2019 at 07:50:31PM +0100, Greg Kroah-Hartman wrote:
> Wait, how are these "duplicate"? The fields are in different order,
> don't these refer to things on-disk?
On-disk combines the values from these structures in a different form:
offset bits
DoubleSeconds 0 5
Minut
On Sun, Sep 08, 2019 at 07:54:24PM +0100, Greg Kroah-Hartman wrote:
> On Sun, Sep 08, 2019 at 05:35:37PM +, Valentin Vidic wrote:
> > +struct timestamp_t {
> > + u16 millisec; /* 0 ~ 999 */
>
> You added this field to this structure, why? You did not document that
> in t
On Sun, Sep 08, 2019 at 05:35:37PM +, Valentin Vidic wrote:
> Use timestamp_t for everything and cleanup duplicate code.
>
> Signed-off-by: Valentin Vidic
> ---
> drivers/staging/exfat/exfat.h | 35 +++---
> drivers/staging/exfat/exfat_super.c | 158
> 2 f
On Sun, Sep 08, 2019 at 05:35:37PM +, Valentin Vidic wrote:
> Use timestamp_t for everything and cleanup duplicate code.
Wait, how are these "duplicate"? The fields are in different order,
don't these refer to things on-disk?
Did you test this?
> -struct date_time_t {
> - u16 Year;
As the function argument and variables are defined as type 'bool',
remove local TRUE/FALSE define and change usage of those macros
with boolean value.
Signed-off-by: Saiyam Doshi
---
drivers/staging/emxx_udc/emxx_udc.c | 76 ++---
drivers/staging/emxx_udc/emxx_udc.h | 5
Use create_time_ms and modify_time_ms fields to store the millisecond
part of the file timestamp with the precision of 10 ms.
Signed-off-by: Valentin Vidic
---
drivers/staging/exfat/exfat_core.c | 28
1 file changed, 28 insertions(+)
diff --git a/drivers/staging/exf
Spec defines that UtcOffset fields should start in this
position instead.
Signed-off-by: Valentin Vidic
---
drivers/staging/exfat/exfat.h | 6 --
drivers/staging/exfat/exfat_core.c | 4 +++-
2 files changed, 7 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/exfat/exfat.h b/d
Use timestamp_t for everything and cleanup duplicate code.
Signed-off-by: Valentin Vidic
---
drivers/staging/exfat/exfat.h | 35 +++---
drivers/staging/exfat/exfat_super.c | 158
2 files changed, 55 insertions(+), 138 deletions(-)
diff --git a/drivers/staging
sbi parameter not used inside the function so remove it.
Also cleanup unused variables generated by this change.
Signed-off-by: Valentin Vidic
---
v2: split up into multiple patches
v3: split up some more
fix if statement braces
add utc offset fields
drivers/staging/exfat/exfat_super.c
On Sun, Sep 08, 2019 at 05:40:40PM +0100, Greg Kroah-Hartman wrote:
> On Sun, Sep 08, 2019 at 04:10:15PM +, Valentin Vidic wrote:
> > void fat_set_entry_time(struct dentry_t *p_entry, struct timestamp_t *tp,
> > u8 mode)
> > {
> > + u8 ms;
> > u16 t, d;
> > struc
On Sun, Sep 08, 2019 at 04:10:13PM +, Valentin Vidic wrote:
> Use timestamp_t for everything and cleanup duplicate code.
You dropped function parameters in here, which you did not describe in
this changelog text :(
Please only try to do "one logical thing" per patch to make it easier to
revie
On Sun, Sep 08, 2019 at 02:47:35PM +, Valentin Vidić wrote:
> On Sun, Sep 08, 2019 at 02:03:37PM +0100, Greg Kroah-Hartman wrote:
> > Please run checkpatch on your patches so that we don't have to go and
> > fix up those issues later on.
>
> Strange, it did not report anything for me:
>
> tot
On Sun, Sep 08, 2019 at 04:10:14PM +, Valentin Vidic wrote:
> Not used in the exfat-fuse implementation and spec defines
> this position should hold the value for CreateUtcOffset.
Then why not just put CreateUtcOffset in here instaed of deleting it?
I would much rather the fields match the sp
On Sun, Sep 08, 2019 at 04:10:15PM +, Valentin Vidic wrote:
> Use create_time_ms modify_time_ms fields to store the millisecond
> part of the file timestamp with the precision of 10 ms.
>
> Signed-off-by: Valentin Vidic
> ---
> drivers/staging/exfat/exfat_core.c | 30
Use create_time_ms modify_time_ms fields to store the millisecond
part of the file timestamp with the precision of 10 ms.
Signed-off-by: Valentin Vidic
---
drivers/staging/exfat/exfat_core.c | 30 ++
1 file changed, 30 insertions(+)
diff --git a/drivers/staging/exfat
Not used in the exfat-fuse implementation and spec defines
this position should hold the value for CreateUtcOffset.
Signed-off-by: Valentin Vidic
---
drivers/staging/exfat/exfat.h | 3 +--
drivers/staging/exfat/exfat_core.c | 1 -
2 files changed, 1 insertion(+), 3 deletions(-)
diff --git
Use timestamp_t for everything and cleanup duplicate code.
Signed-off-by: Valentin Vidic
---
v2: split up into multiple patches
drivers/staging/exfat/exfat.h | 35 +++---
drivers/staging/exfat/exfat_super.c | 174
2 files changed, 61 insertions(+), 148 deleti
Fixes checkpatch.pl warnings:
CHECK: spaces preferred around that '-' (ctx:VxV)
CHECK: spaces preferred around that '+' (ctx:VxV)
CHECK: spaces preferred around that '*' (ctx:VxV)
CHECK: spaces preferred around that '|' (ctx:VxV)
Signed-off-by: Valentin Vidic
---
v2: Use constants where
Replace manually generated values with predefined constants.
Signed-off-by: Valentin Vidic
---
v2: Use constants where possible
v3: Split up changes of constants
drivers/staging/exfat/exfat_core.c | 18 +-
drivers/staging/exfat/exfat_super.c | 8
2 files changed, 13 i
Fix checkpatch.pl warnings:
CHECK: No space is necessary after a cast
Signed-off-by: Valentin Vidic
---
v2: Use constants where possible
v3: Split up changes of constants
drivers/staging/exfat/exfat_core.c | 88 ++---
drivers/staging/exfat/exfat_super.c | 66
On Sun, Sep 08, 2019 at 02:03:37PM +0100, Greg Kroah-Hartman wrote:
> Please run checkpatch on your patches so that we don't have to go and
> fix up those issues later on.
Strange, it did not report anything for me:
total: 0 errors, 0 warnings, 0 checks, 439 lines checked
0001-staging-exfat-add-m
From: Sven Van Asbroeck
The devicetree bindings for anybus-controller were mistakenly
merged into the main Linux tree. Its driver resides in
staging/, so the bindings belong in staging/ too.
Cc: Greg Kroah-Hartman
Fixes: 20a980e957bf ("dt-bindings: anybus-controller: document devicetree
bindin
On Sun, Sep 08, 2019 at 02:58:41PM +0530, haripra...@osuosl.org wrote:
> From: Hariprasad Kelam
>
> fix below issue reported by coccicheck
> drivers/staging//exfat/exfat_super.c:2709:26-33: WARNING opportunity for
> kmemdup
>
> Signed-off-by: Hariprasad Kelam
> ---
> drivers/staging/exfat/exfa
On Sat, Sep 07, 2019 at 09:45:41PM +, Valentin Vidic wrote:
> Use constants and fix checkpatch.pl warnings:
>
> CHECK: No space is necessary after a cast
This really should be two different patches, one for the constant
changes, and one for the space issues. Can you break this up and resen
On Sun, Sep 08, 2019 at 12:48:08PM +, Valentin Vidic wrote:
> Drop duplicated date_time_t struct and add millisecond handling for
> create and modify time. Also drop millisecond field for access time
> since it is not defined in the the spec.
>
> Signed-off-by: Valentin Vidic
> ---
> drivers
Drop duplicated date_time_t struct and add millisecond handling for
create and modify time. Also drop millisecond field for access time
since it is not defined in the the spec.
Signed-off-by: Valentin Vidic
---
drivers/staging/exfat/exfat.h | 38 +++---
drivers/staging/exfat/exfat_core.c
Sorry, I have only now got round to working on this. It's not complete
yet but I have assimilated the feedback and converted subjective
phrases, like "I think..." into objective statements or put them in
TODO: so that someone else may verify. I have attached it to this
email.
Next step will be to
From: Hariprasad Kelam
fix below issue reported by coccicheck
drivers/staging//nvec/nvec.c:794:1-5: WARNING: Use
devm_platform_ioremap_resource for base
Signed-off-by: Hariprasad Kelam
---
drivers/staging/nvec/nvec.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/driver
From: Hariprasad Kelam
fix below issue reported by coccicheck
drivers/staging//exfat/exfat_super.c:2709:26-33: WARNING opportunity for
kmemdup
Signed-off-by: Hariprasad Kelam
---
drivers/staging/exfat/exfat_super.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/s
From: Hariprasad Kelam
Remove unused macro IS_MAC_ADDRESS_BROADCAST. In future if one wants use
it ,use generic API "is_broadcast_ether_addr"
Signed-off-by: Hariprasad Kelam
---
drivers/staging/rtl8723bs/core/rtw_ioctl_set.c | 7 ---
1 file changed, 7 deletions(-)
diff --git a/drivers/sta
rtw_malloc prevents the use of kmemdup/kzalloc and others.
Signed-off-by: Ivan Safonov
---
drivers/staging/rtl8188eu/core/rtw_ap.c| 4 ++--
drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 2 +-
.../staging/rtl8188eu/include/osdep_service.h | 3 ---
drivers/staging/rtl8188eu/os_dep/i
Fixes indentation for if condition in the file r8190_rtl8256.c for better
readability as suggested by Dan Carpenter.
Reported-by: Dan Carpenter
Signed-off-by: Sumera Priyadarsini
---
drivers/staging/rtl8192u/r8190_rtl8256.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git
On Tue, Aug 27, 2019 at 2:13 PM Dan Carpenter wrote:
>
> On Mon, Aug 26, 2019 at 11:39:09PM +0530, Sumera Priyadarsini wrote:
> > This patch fixes the file r8190_rtl8256.c to avoid the following
> > checkpatch.pl warnings:
> > CHECK: spaces preferred around that '<<' (ctx:VxV)
> > CHEC
38 matches
Mail list logo