When the checkpatch.pl script was run, it showed lines with length
more than 80 characters in rtl8712_recv.c file. Fixed by
breaking it up into two lines within 80 characters.
Signed-off-by: Merwin Trever Ferrao
---
drivers/staging/rtl8712/rtl8712_recv.c | 3 ++-
1 file changed, 2 insertions(+),
Hi Dan,
On 8/8/2019 4:18 PM, Dan Carpenter wrote:
>
> Hello Ajay Singh,
>
> The patch 9bc061e88054: "staging: wilc1000: added support to
> dynamically add/remove interfaces" from Jun 26, 2019, leads to the
> following static checker warning:
>
> drivers/staging/wilc1000/wilc_wlan.c:497 wi
Hi Xiang,
On 2019/8/13 11:57, Gao Xiang wrote:
> Hi Chao,
>
> On Tue, Aug 13, 2019 at 11:20:22AM +0800, Chao Yu wrote:
>> On 2019/8/13 10:30, Gao Xiang wrote:
>>> Kill all the remaining BUG_ON in EROFS:
>>> - one BUG_ON was used to detect xattr on-disk corruption,
>>>proper error handling sh
On 05.08.19 00:48, john.hubb...@gmail.com wrote:
> From: John Hubbard
>
> For pages that were retained via get_user_pages*(), release those pages
> via the new put_user_page*() routines, instead of via put_page() or
> release_pages().
>
> This is part a tree-wide conversion, as described in commit
Change return values of xmitframe_addmic from _SUCCESS and _FAIL to 0
and -ENOMEM respectively. Modify call sites to check for non-zero values
instead of _FAIL.
Also change return type from sint to int.
Signed-off-by: Nishka Dasgupta
---
drivers/staging/rtl8712/rtl871x_xmit.c | 12 ++--
Change return type of r8712_append_mpdu_unit from u8 to void and remove
its return statement as it always returns only _SUCCESS. Modify call
sites to simply call this function instead of checking its return value,
and execute all the statements in the if-block for when the function
returns _SUCCESS
Change return type of r8712_dump_aggr_xframe from u8 to void as it
always returns _SUCCESS and its return value is never used.
Signed-off-by: Nishka Dasgupta
---
drivers/staging/rtl8712/rtl8712_xmit.c | 6 ++
drivers/staging/rtl8712/rtl8712_xmit.h | 4 ++--
2 files changed, 4 insertions(+),
Change return type of r8712_xmitframe_aggr_1st from u8 to void as it
always returns _SUCCESS and its return value is never used.
Signed-off-by: Nishka Dasgupta
---
drivers/staging/rtl8712/rtl8712_xmit.c | 6 ++
drivers/staging/rtl8712/rtl8712_xmit.h | 4 ++--
2 files changed, 4 insertions(+)
On 12/08/19 8:07 PM, Greg KH wrote:
On Fri, Aug 09, 2019 at 10:53:43AM +0530, Nishka Dasgupta wrote:
Change the return values in _r8712_init_xmit_priv from _SUCCESS/_FAIL to
0/-ENOMEM respectively. Change return type from sint to int.
Signed-off-by: Nishka Dasgupta
I only received 9 patches
The procfs provides many useful information for debugging, but it may be
too much for normal usage, routines like proc_get_sec_info() reports
various security related information.
So let's remove it.
Signed-off-by: Kai-Heng Feng
---
drivers/staging/rtl8723bs/Makefile|1 -
driver
Hi Chao,
On Tue, Aug 13, 2019 at 11:20:22AM +0800, Chao Yu wrote:
> On 2019/8/13 10:30, Gao Xiang wrote:
> > Kill all the remaining BUG_ON in EROFS:
> > - one BUG_ON was used to detect xattr on-disk corruption,
> >proper error handling should be added for it instead;
> > - the other BUG_ONs
On 2019/8/13 10:30, Gao Xiang wrote:
> Kill all the remaining BUG_ON in EROFS:
> - one BUG_ON was used to detect xattr on-disk corruption,
>proper error handling should be added for it instead;
> - the other BUG_ONs are used to detect potential issues,
>use DBG_BUGON only in (eng) debuggi
On 2019/8/13 10:30, Gao Xiang wrote:
> cleancache was not fully implemented in EROFS.
> In addition, it's tend to remove the whole cleancache in
> related attempt [1].
>
> [1]
> https://lore.kernel.org/linux-fsdevel/20190527103207.13287-3-jgr...@suse.com/
> Signed-off-by: Gao Xiang
Reviewed-by:
On 2019/8/13 10:30, Gao Xiang wrote:
> As a helper in erofs_fs.h, erofs_inode_is_data_compressed()
> should be inlined.
>
> Signed-off-by: Gao Xiang
Reviewed-by: Chao Yu
Thanks,
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.lin
Kill all the remaining BUG_ON in EROFS:
- one BUG_ON was used to detect xattr on-disk corruption,
proper error handling should be added for it instead;
- the other BUG_ONs are used to detect potential issues,
use DBG_BUGON only in (eng) debugging version.
Signed-off-by: Gao Xiang
---
dri
cleancache was not fully implemented in EROFS.
In addition, it's tend to remove the whole cleancache in
related attempt [1].
[1]
https://lore.kernel.org/linux-fsdevel/20190527103207.13287-3-jgr...@suse.com/
Signed-off-by: Gao Xiang
---
drivers/staging/erofs/data.c | 6 --
drivers/stagin
As a helper in erofs_fs.h, erofs_inode_is_data_compressed()
should be inlined.
Signed-off-by: Gao Xiang
---
drivers/staging/erofs/erofs_fs.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/erofs/erofs_fs.h b/drivers/staging/erofs/erofs_fs.h
index e82e833985e4.
23.06.2019 20:07, Dmitry Osipenko пишет:
> Enable IOMMU support for the video decoder.
>
> Signed-off-by: Dmitry Osipenko
> ---
>
> No changes since v1.
>
> arch/arm/boot/dts/tegra30.dtsi | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/arch/arm/boot/dts/tegra30.dtsi b/arch/arm/boot/d
On Fri, Aug 09, 2019 at 11:18:23PM -0400, Hugo Eduardo Ziviani wrote:
> Fix checkpatch error "CHECK: Remove unecessary parenthesis in
> drivers/staging/rtl8712/rtl871x_mlme.c"
>
> Signed-off-by: Hugo Eduardo Ziviani
> ---
> drivers/staging/rtl8712/rtl871x_mlme.c | 89 +-
On Fri, Aug 09, 2019 at 10:53:43AM +0530, Nishka Dasgupta wrote:
> Change the return values in _r8712_init_xmit_priv from _SUCCESS/_FAIL to
> 0/-ENOMEM respectively. Change return type from sint to int.
>
> Signed-off-by: Nishka Dasgupta
I only received 9 patches in this series. I'll try to app
Hi!
On Mon, Aug 12, 2019 at 02:12:21PM +0200, Hans Verkuil wrote:
> On 5/30/19 11:15 PM, Jernej Skrabec wrote:
> > Here is first batch of random Cedrus improvements/cleanups. Only patch 2
> > has a change which raises a question about H264 controls.
> >
> > Changes were tested on H3 SoC using modi
On Thu, 2019-05-30 at 23:15 +0200, Jernej Skrabec wrote:
> This array is just duplicated capture buffer queue. Remove it and adjust
> code to look into capture buffer queue instead.
>
> Signed-off-by: Jernej Skrabec
> ---
> drivers/staging/media/sunxi/cedrus/cedrus.h | 4 +---
> .../staging/m
Hi Jernej,
On Mon, 2019-06-03 at 13:38 +0200, Maxime Ripard wrote:
> Hi,
>
> On Thu, May 30, 2019 at 11:15:10PM +0200, Jernej Skrabec wrote:
> > libvdpau-sunxi always disables engine after each decoded slice.
> > Do same in Cedrus driver.
> >
> > Presumably this also lowers power consumption whi
On Tue, Aug 06, 2019 at 08:41:17PM +, Dexuan Cui wrote:
> > From: linux-hyperv-ow...@vger.kernel.org
> > On Behalf Of Bjorn Helgaas
> > Sent: Tuesday, August 6, 2019 1:16 PM
> > To: Dexuan Cui
> >
> > Thanks for updating this. But you didn't update the subject line,
> > which is really stil
Good day to you,
I have decided to contact you through this medium after reviewing your
Honorable and reputable profile and it is my belief that with your
Position as a professional in your sector/ Country that you will be
In position to present us with solid investment opportunities in your
Count
Dne ponedeljek, 12. avgust 2019 ob 14:12:21 CEST je Hans Verkuil napisal(a):
> On 5/30/19 11:15 PM, Jernej Skrabec wrote:
> > Here is first batch of random Cedrus improvements/cleanups. Only patch 2
> > has a change which raises a question about H264 controls.
> >
> > Changes were tested on H3 SoC
On 5/30/19 11:15 PM, Jernej Skrabec wrote:
> Here is first batch of random Cedrus improvements/cleanups. Only patch 2
> has a change which raises a question about H264 controls.
>
> Changes were tested on H3 SoC using modified ffmpeg and Kodi.
>
> Please take a look.
This has been sitting in pat
`dt3k_ns_to_timer()` determines the prescaler and divisor to use to
produce a desired timing period. It is influenced by a rounding mode
and can round the divisor up, down, or to the nearest value. However,
the code for rounding up currently does the same as rounding down! Fix
ir by using the `D
In `dt3k_ns_to_timer()` the following lines near the end of the function
result in a signed integer overflow:
prescale = 15;
base = timer_base * (1 << prescale);
divider = 65535;
*nanosec = divider * base;
(`divider`, `base` and `prescale` are type `int`, `timer_ba
On 12/08/2019 08:37, David Binderman wrote:
Hello there,
Source code is
prescale = 15;
base = timer_base * (1 << prescale);
divider = 65535;
*nanosec = divider * base;
timer_base seems to be 500 or 100.
nanosec is a pointer to int, so it can only hold about 2,000,000,000
n
On Sun, 11 Aug 2019 13:47:04 -0300
Rodrigo Ribeiro wrote:
> Em dom, 11 de ago de 2019 às 05:43, Jonathan Cameron
> escreveu:
> >
> > On Sat, 10 Aug 2019 12:00:58 -0300
> > Rodrigo wrote:
> >
> > > From: Rodrigo Carvalho
> > >
> > > Improve readability by using GENMASK macro, changing switch
Hello there,
Source code is
prescale = 15;
base = timer_base * (1 << prescale);
divider = 65535;
*nanosec = divider * base;
timer_base seems to be 500 or 100.
nanosec is a pointer to int, so it can only hold about 2,000,000,000
nanoseconds, or about 2 seconds.
Suggest rework c
32 matches
Mail list logo