In commit 802a2f7b2fe3 ("staging: mt7621-pci: factor out
'mt7621_pcie_enable_port' function"), slot = port->slot; line was removed.
Also other dev_err() print parameter was changed from slot to port->slot.
So the same should be done here.
This also fixes compiler error:
drivers/staging/mt7621-pci/
On Wed, Jun 26, 2019 at 7:45 AM Sergio Paracuellos
wrote:
> No problem, I also miss them rewritting code. That is bad :((.
> > BTW, I applied that on top of your other recent fixes (that ones
> > you pushed to gregkh for staging). So I tested with the
> > updated GPIO reset code.
> Ok, anyway.. I
On Fri, Jun 21, 2019 at 11:45:23PM +, Dexuan Cui wrote:
>
> The commit 05f151a73ec2 itself is correct, but it exposes this
> use-after-free bug, which is caught by some memory debug options.
>
> Add a Fixes tag to indicate the dependency.
>
> Fixes: 05f151a73ec2 ("PCI: hv: Fix a memory leak
Remove function gb_i2c_device_setup as all it does is call
gb_i2c_functionality_operation.
Rename gb_i2c_functionality_operation to gb_i2c_device_setup to maintain
compatibility with call sites.
Issue found with Coccinelle.
Signed-off-by: Nishka Dasgupta
---
drivers/staging/greybus/i2c.c | 22 ++
On 05/07/19 3:56 PM, Paul Kocialkowski wrote:
Hi,
On Wed 03 Jul 19, 13:43, Nishka Dasgupta wrote:
Remove function cedrus_check_format as all it does is call
cedrus_find_format.
Rename cedrus_find_format to cedrus_check_format to maintain
compatibility with call sites.
Issue found with Coccinell
On 05/07/19 3:56 PM, Paul Kocialkowski wrote:
Hi,
On Wed 03 Jul 19, 13:43, Nishka Dasgupta wrote:
Change return type of cedrus_find_format to bool as it is only called
once, by a function whose return value is bool, and the return value of
cedrus_find_format is returned as-is at the call-site.
tree:
https://kernel.googlesource.com/pub/scm/linux/kernel/git/gregkh/driver-core.git
debugfs_cleanup
head: 8c54807642d011014627c0187798950d30c3abf4
commit: aab8ab1a5aaec133532b9fba30b1da24c08dbac3 [185/194] omap-iommu: no need
to check return value of debugfs_create functions
config: arm-al
Hi,
On Wed 03 Jul 19, 13:43, Nishka Dasgupta wrote:
> Remove function cedrus_check_format as all it does is call
> cedrus_find_format.
> Rename cedrus_find_format to cedrus_check_format to maintain
> compatibility with call sites.
> Issue found with Coccinelle.
Maybe we could have a !! or a bool
Hi,
On Wed 03 Jul 19, 13:43, Nishka Dasgupta wrote:
> Change return type of cedrus_find_format to bool as it is only called
> once, by a function whose return value is bool, and the return value of
> cedrus_find_format is returned as-is at the call-site.
> Issue found with Coccinelle.
The purpose
From: Colin Ian King
The variable res is being initialized with a value that is never
read and it is being updated later with a new value. The
initialization is redundant and can be removed.
Addresses-Coverity: ("Unused value")
Signed-off-by: Colin Ian King
---
drivers/staging/rtl8712/rtl8712_
Hi,
On Fri, Jul 5, 2019 at 4:51 AM Tobin C. Harding wrote:
>
> Hi,
>
> I am doing a tutorial at OSSNA in San Diego on getting into kernel
> hacking. I'm only a couple of years deep into kernel hacking so I
> wanted to reach out to those more experienced than myself (and those
> less experienced)
11 matches
Mail list logo