[PATCH 01/10] staging: rtl8723bs: Remove function rtw_modular64()

2019-06-30 Thread Nishka Dasgupta
Remove function rtw_modular64 as all it does is call do_div. Modify call sites accordingly. Issue found with Coccinelle. Signed-off-by: Nishka Dasgupta --- drivers/staging/rtl8723bs/core/rtw_wlan_util.c| 2 +- drivers/staging/rtl8723bs/hal/rtl8723b_hal_init.c | 2 +- drivers/staging/rtl8723b

[PATCH] staging: rtl8192u: Replace function rtl8192_rx_enable()

2019-06-30 Thread Nishka Dasgupta
Remove function rtl8192_rx_enable as all it does is call rtl8192_rx_initiate. Rename rtl8192_rx_initiate to rtl8192_rx_enable and change its type from static to non-static to maintain compatibility with call sites of rtl8192_rx_enable. Issue found with Coccinelle. Signed-off-by: Nishka Dasgupta -

[PATCH 2/2] staging: mt7621-dts: add support for second network interface

2019-06-30 Thread NeilBrown
The mt7621 has two network interfaces, one that connects to an internal switch, and one that can connect to either that switch or an external phy, or possibly an internal phy. The Gnubee-PC2 has an external phy for use with the second interface. This patch add some support for the second interfac

[PATCH 0/2] staging: update mt7621 dts for some recent driver changes

2019-06-30 Thread NeilBrown
The mt7621 MMC driver was recently removed from staging due to copyright concerns. Since then drivers/mmc/host/mtk-sd.c has been enhanced to work with the mt7621 IP. The first patch updates the dts file to match this driver. Earlier, the drivers/net/ethernet/mediatek/ driver was enhanced to work

[PATCH 1/2] staging: mt7621-dts: update sdhci config.

2019-06-30 Thread NeilBrown
The mtk-sd driver has been updated to support the IP in the mt7621, so update our configuration to work with it. Signed-off-by: NeilBrown --- drivers/staging/mt7621-dts/mt7621.dtsi | 41 +++- 1 file changed, 40 insertions(+), 1 deletion(-) diff --git a/drivers/stag

Re: [PATCH 4/4] ipvs: reduce kernel stack usage

2019-06-30 Thread Julian Anastasov
Hello, On Fri, 28 Jun 2019, Arnd Bergmann wrote: > With the new CONFIG_GCC_PLUGIN_STRUCTLEAK_BYREF_ALL option, the stack > usage in the ipvs debug output grows because each instance of > IP_VS_DBG_BUF() now has its own buffer of 160 bytes that add up > rather than reusing the stack slot

[PATCH] staging: erofs: fix LZ4 limited bounced page mis-reuse

2019-06-30 Thread Gao Xiang
From: Gao Xiang Like all lz77-based algrithms, lz4 has a dynamically populated ("sliding window") dictionary and the maximum lookback distance is 65535. Therefore the number of bounced pages could be limited by erofs based on this property. However, just now we observed some lz4 sequences in the

Investitionsmöglichkeit

2019-06-30 Thread Peter Wong
Schöne Grüße, Bitte finden Sie den Inhalt dieser Mail sehr vertraulich und legal. Ich heiße Peter Wong und arbeite mit einer Bank hier in Hongkong zusammen. Ich habe mich entschlossen, mit Ihnen Kontakt aufzunehmen, um in jedes lukrative Geschäft in Ihrem Land investieren zu können. Ich bin ber

Investitionsmöglichkeit

2019-06-30 Thread Peter Wong
Schöne Grüße, Bitte finden Sie den Inhalt dieser Mail sehr vertraulich und legal. Ich heiße Peter Wong und arbeite mit einer Bank hier in Hongkong zusammen. Ich habe mich entschlossen, mit Ihnen Kontakt aufzunehmen, um in jedes lukrative Geschäft in Ihrem Land investieren zu können. Ich bin ber

[PATCH v3] Staging: most: fix coding style issues

2019-06-30 Thread Gabriel Beauchamp
This is a patch for the core.[ch] files that fixes up warnings found with the checkpatch.pl tool. Signed-off-by: Gabriel Beauchamp --- Changes in v3: - add a break statement to preserve the control flow Changes in v2: - use a single snprintf --- drivers/staging/most/core.c | 11 --- driv

[PATCH v2] Staging: most: fix coding style issues

2019-06-30 Thread Gabriel Beauchamp
This is a patch for the core.[ch] files that fixes up warnings found with the checkpatch.pl tool. Signed-off-by: Gabriel Beauchamp --- Changes in v2: - use a single snprintf --- drivers/staging/most/core.c | 7 +-- drivers/staging/most/core.h | 2 +- 2 files changed, 6 insertions(+), 3 delet

Re: [PATCH 1/2] staging: rts5208: Rewrite redundant if statement to improve code style

2019-06-30 Thread Tobias Nießen
Am 26.06.2019 um 16:56 schrieb Dan Carpenter: > Both these patches seem fine. > > On Wed, Jun 26, 2019 at 04:28:56PM +0200, Tobias Nießen wrote: >> This commit uses the fact that >> >> if (a) { >> if (b) { >> ... >> } >> } >> >> can instead be wr

[PATCH] staging: rtl8188eu: Add 'rtl8188eufw.bin' to MODULE_FIRMWARE list

2019-06-30 Thread Alexander Dahl
This is the file loaded by the code anyway, but now you can use 'modinfo' to determine the needed firmware file for this module. Spotted when packaging firmware files for the fli4l Linux router distribution, where a script uses the information from 'modinfo' to collect all needed firmware files to