On Mon, 2019-06-17 at 12:04 +1000, Alastair D'Silva wrote:
> From: Alastair D'Silva
>
> Some buffers may only be partially filled with useful data, while the
> rest
> is padded (typically with 0x00 or 0xff).
>
> This patch introduces a flag to allow the supression of lines of
> repeated
> bytes,
Hi Brett,
On 15/6/19 11:53 pm, Brett Neumeier wrote:
[snip]
For what it's worth -- possibly nothing? -- I grabbed the most recent six
versions of the patch from this thread, including the one here, and did test
boots of all of them on both a GnuBee PC1 and PC2 (based on 5.1.7). There were
no
On Mon, 17 Jun 2019, Ming Lei wrote:
> Use the scatterlist iterators and remove direct indexing of the
> scatterlist array.
>
> This way allows us to pre-allocate one small scatterlist, which can be
> chained with one runtime allocated scatterlist if the pre-allocated one
> isn't enough for the w
From: Finn Thain
My understanding is that support for chained scatterlists is to
become mandatory for LLDs.
Use the scatterlist iterators and remove direct indexing of the
scatterlist array.
This way allows us to pre-allocate one small scatterlist, which can be
chained with one runtime allocate
Use the scatterlist iterators and remove direct indexing of the
scatterlist array.
This way allows us to pre-allocate one small scatterlist, which can be
chained with one runtime allocated scatterlist if the pre-allocated one
isn't enough for the whole request.
Signed-off-by: Ming Lei
---
drive
Use the scatterlist iterators and remove direct indexing of the
scatterlist array.
This way allows us to pre-allocate one small scatterlist, which can be
chained with one runtime allocated scatterlist if the pre-allocated one
isn't enough for the whole request.
Signed-off-by: Ming Lei
---
drive
Use the scatterlist iterators and remove direct indexing of the
scatterlist array.
This way allows us to pre-allocate one small scatterlist, which can be
chained with one runtime allocated scatterlist if the pre-allocated one
isn't enough for the whole request.
Finn added the change to replace SC
Use the scatterlist iterators and remove direct indexing of the
scatterlist array.
This way allows us to pre-allocate one small scatterlist, which can be
chained with one runtime allocated scatterlist if the pre-allocated one
isn't enough for the whole request.
Signed-off-by: Ming Lei
---
drive
Use the scatterlist iterators and remove direct indexing of the
scatterlist array.
This way allows us to pre-allocate one small scatterlist, which can be
chained with one runtime allocated scatterlist if the pre-allocated one
isn't enough for the whole request.
Signed-off-by: Ming Lei
---
drive
Use the scatterlist iterators and remove direct indexing of the
scatterlist array.
This way allows us to pre-allocate one small scatterlist, which can be
chained with one runtime allocated scatterlist if the pre-allocated one
isn't enough for the whole request.
Cc: Steffen Maier
Cc: Benjamin Blo
Use the scatterlist iterators and remove direct indexing of the
scatterlist array.
This way allows us to pre-allocate one small scatterlist, which can be
chained with one runtime allocated scatterlist if the pre-allocated one
isn't enough for the whole request.
Cc: Kim Bradley
Cc: de...@driverde
Use the scatterlist iterators and remove direct indexing of the
scatterlist array.
This way allows us to pre-allocate one small scatterlist, which can be
chained with one runtime allocated scatterlist if the pre-allocated one
isn't enough for the whole request.
Signed-off-by: Ming Lei
---
drive
Use the scatterlist iterators and remove direct indexing of the
scatterlist array.
This way allows us to pre-allocate one small scatterlist, which can be
chained with one runtime allocated scatterlist if the pre-allocated one
isn't enough for the whole request.
Cc: de...@driverdev.osuosl.org
Cc:
Use the scatterlist iterators and remove direct indexing of the
scatterlist array.
This way allows us to pre-allocate one small scatterlist, which can be
chained with one runtime allocated scatterlist if the pre-allocated one
isn't enough for the whole request.
Signed-off-by: Ming Lei
---
drive
Use the scatterlist iterators and remove direct indexing of the
scatterlist array.
This way allows us to pre-allocate one small scatterlist, which can be
chained with one runtime allocated scatterlist if the pre-allocated one
isn't enough for the whole request.
Cc: Oliver Neukum
Cc: Greg Kroah-H
Use the scatterlist iterators and remove direct indexing of the
scatterlist array.
This way allows us to pre-allocate one small scatterlist, which can be
chained with one runtime allocated scatterlist if the pre-allocated one
isn't enough for the whole request.
Reviewed-by: Ewan D. Milne
Signed-
Use the scatterlist iterators and remove direct indexing of the scatterlist
array.
This way allows us to pre-allocate one small scatterlist, which can be chained
with one runtime allocated scatterlist if the pre-allocated one isn't enough
for the whole request.
Reviewed-by: Ewan D. Milne
Signed-
Use the scatterlist iterators and remove direct indexing of the
scatterlist array.
This way allows us to pre-allocate one small scatterlist, which can be
chained with one runtime allocated scatterlist if the pre-allocated one isn't
enough for the whole request.
Reviewed by: Ewan D. Milne
Signed-
Use the scatterlist iterators and remove direct indexing of the
scatterlist array.
This way allows us to pre-allocate one small scatterlist, which can be
chained with one runtime allocated scatterlist if the pre-allocated one
isn't enough for the whole request.
Reviewed-by: Ewan D. Milne
Signed-
Hi,
Scsi MQ makes a large static allocation for the first scatter gather
list chunk for the driver to use. This is a performance headache we'd
like to fix by reducing the size of the allocation to a 2 element
array. Doing this will break the current guarantee that any driver
using SG_ALL doesn't
From: Alastair D'Silva
Similar to the previous patch, this patch separates groups by 2 spaces for
the hex fields, and 1 space for the ASCII field.
eg.
buf:: 454d414e 43415053 4e495f45 00584544 NAMESPAC E_INDEX.
buf:0010: 0002
Sign
From: Alastair D'Silva
With the wider display format, it can become hard to identify how many
bytes into the line you are looking at.
The patch adds new flags to hex_dump_to_buffer() and print_hex_dump() to
print vertical lines to separate every N groups of bytes.
eg.
buf:: 454d414e 434
From: Alastair D'Silva
The behaviour of hexdump groups is to print the data out as if
it was a native-endian number.
This patch tweaks the documentation to make this clear, and also
adds the HEXDUMP_RETAIN_BYTE_ORDER flag to allow groups of
multiple bytes to be printed without affecting the orde
From: Alastair D'Silva
This patch removes the hardcoded row limits and allows for
other lengths. These lengths must still be a multiple of
groupsize.
This allows structs that are not 16/32 bytes to display on
a single line.
This patch also expands the self-tests to test row sizes
up to 64 bytes
From: Alastair D'Silva
In order to support additional features in hex_dump_to_buffer, replace
the ascii bool parameter with flags.
Signed-off-by: Alastair D'Silva
---
drivers/gpu/drm/i915/intel_engine_cs.c| 2 +-
drivers/isdn/hardware/mISDN/mISDNisar.c | 6 --
drive
From: Alastair D'Silva
The overflow tests did not account for the situation where no
overflow occurs and len < rowsize.
This patch renames the cryptic variables and accounts for the
above case.
The selftests now pass.
Signed-off-by: Alastair D'Silva
---
lib/test_hexdump.c | 47 ++
From: Alastair D'Silva
Some buffers may only be partially filled with useful data, while the rest
is padded (typically with 0x00 or 0xff).
This patch introduces a flag to allow the supression of lines of repeated
bytes, which are replaced with '** Skipped %u bytes of value 0x%x **'
An inline wr
From: Alastair D'Silva
Apologies for the large CC list, it's a heads up for those responsible
for subsystems where a prototype change in generic code causes a change
in those subsystems.
This series enhances hexdump.
These improve the readability of the dumped data in certain situations
(eg. wi
On 2019/6/16 21:11, Jonathan Cameron wrote:
> On Fri, 14 Jun 2019 23:28:46 +0800
> YueHaibing wrote:
>
>> Fix build error:
>>
>> drivers/staging/iio/addac/adt7316.c: In function adt7316_store_update_DAC:
>> drivers/staging/iio/addac/adt7316.c:949:3: error: implicit declaration of
>> function gpi
On Fri, Jun 14, 2019 at 08:36:38PM +1000, Finn Thain wrote:
> On Fri, 14 Jun 2019, Ming Lei wrote:
>
> >
> > Follows the fixed version, could you review again?
> >
> > From f03484d4bac083c39d70665cfbadb641093b63de Mon Sep 17 00:00:00 2001
> > From: Ming Lei
> > Date: Wed, 12 Jun 2019 20:37:35 +
Good day,
I am financial consultant based in Doha Qatar. I have a client from a ruling
family Retired Qatari Government Official he is one of this people with
floating free cash for major investments Or Loan and he is also into Jets Fuel,
Oil, gold and diamond dealers
He wishes to invest in a
On Sat, 2019-06-15 at 14:29 -0700, Shobhit Kukreti wrote:
> Cleaned up the code from the following files to get rid of
> check patch error "that open brace { should be on the previous line"
It's fine you are modifying brace styles, but:
> diff --git a/drivers/staging/rtl8723bs/os_dep/mlme_linux.c
Good day,
I am financial consultant based in Doha Qatar. I have a client from a ruling
family Retired Qatari Government Official he is one of this people with
floating free cash for major investments Or Loan and he is also into Jets Fuel,
Oil, gold and diamond dealers
He wishes to invest in a
On Fri, Jun 14, 2019 at 10:53:10AM +0800, Ming Lei wrote:
> Use the scatterlist iterators and remove direct indexing of the
> scatterlist array.
>
> This way allows us to pre-allocate one small scatterlist, which can be
> chained with one runtime allocated scatterlist if the pre-allocated one
> is
Resolve indentation errors which were caused by a mix of space and tabs
for indentation. Previous patch to fix if-else brace styles revealed
the indentation error
Signed-off-by: Shobhit Kukreti
---
drivers/staging/rtl8723bs/os_dep/recv_linux.c | 6 ++---
drivers/staging/rtl8723bs/os_dep/sdio_in
This patchset fixes the following errors reported by checkpatch in the
staging/rtl8723bs driver.
Patch[1/3]: Fix check patch error "that open brace { should be on the previous
line"
Patch[2/3]: Fix the error else should follow close brace '}'
Patch[3/3]: Fix Indentation Error
version 3 chang
Cleaned up the code to resolve the checkpatch error else should follow
close brace '}' from the following files:
mlme_linux.c
recv_linux.c
sdio_intf.c
Signed-off-by: Shobhit Kukreti
---
drivers/staging/rtl8723bs/os_dep/mlme_linux.c | 6 ++
drivers/staging/rtl8723bs/os_dep/recv_linux.c | 21
Cleaned up the code from the following files to get rid of
check patch error "that open brace { should be on the previous line"
drivers/staging/rtl8723bs/os_dep/mlme_linux.c
drivers/staging/rtl8723bs/os_dep/recv_linux.c
drivers/staging/rtl8723bs/os_dep/rtw_proc.c
drivers/staging/rtl8723bs/os_dep/s
On Fri, 14 Jun 2019 13:43:02 -0600
Rob Herring wrote:
> On Fri, 24 May 2019 22:26:30 -0300, Renato Lui Geh wrote:
> > This patch adds a YAML binding for the Analog Devices AD7780/1 and
> > AD7170/1 analog-to-digital converters.
> >
> > Signed-off-by: Renato Lui Geh
> > ---
> > Changes in v2:
>
On Fri, 14 Jun 2019 23:28:46 +0800
YueHaibing wrote:
> Fix build error:
>
> drivers/staging/iio/addac/adt7316.c: In function adt7316_store_update_DAC:
> drivers/staging/iio/addac/adt7316.c:949:3: error: implicit declaration of
> function gpiod_set_value; did you mean gpio_set_value?
> [-Werror
On Sun, Jun 16, 2019 at 01:13:11AM -0700, Joe Perches wrote:
> On Sat, 2019-06-15 at 14:29 -0700, Shobhit Kukreti wrote:
> > Cleaned up the code from the following files to get rid of
> > check patch error "that open brace { should be on the previous line"
>
> It's fine you are modifying brace sty
On Fri, 14 Jun 2019 13:32:54 -0300
Melissa Wen wrote:
> Since i2c_smbus_write_byte_data returns no-positive value, this commit
> making the treatment of its return value less verbose.
>
> Signed-off-by: Melissa Wen
Applied to the togreg branch of iio.git and pushed out as testing for
the autobu
On Fri, 14 Jun 2019 13:33:19 -0300
Melissa Wen wrote:
> General cleaning of comments to remove useless information or improve
> description.
>
> Signed-off-by: Melissa Wen
Applied,
Thanks,
Jonathan
> ---
> drivers/staging/iio/cdc/ad7150.c | 11 ++-
> 1 file changed, 2 insertions(+),
On Fri, 14 Jun 2019 13:32:21 -0300
Melissa Wen wrote:
> Use the bitfield macro FIELD_GET, and GENMASK to do the shift and mask in
> one go. This makes the code more readable than explicit masking followed
> by a shift.
>
> Signed-off-by: Melissa Wen
Applied to the togreg branch of iio.git and p
On Fri, 14 Jun 2019 13:50:59 -0300
Melissa Wen wrote:
> Remove idiom and use ternary operator for consistently trigger 0/1 value
> on variable declaration.
>
> Signed-off-by: Melissa Wen
Hi Melissa,
In general I would consider this unnecessary churn as, whilst
it's no longer a favoured idiom,
On 2019/6/16 15:14, Greg Kroah-Hartman wrote:
> On Sun, Jun 16, 2019 at 03:00:38PM +0800, Gao Xiang wrote:
>> Hi Greg,
>>
>> Sorry for annoying... Could you help merge these two fixes? Thanks in
>> advance...
>
> It was only 3 days, please give me at the very least, a week or so for
> staging
On Sun, Jun 16, 2019 at 11:02:50AM +0530, Hariprasad Kelam wrote:
> rtw_malloc with memset can be replace with rtw_zmalloc.
>
> Signed-off-by: Hariprasad Kelam
> ---
> drivers/staging/rtl8723bs/os_dep/ioctl_linux.c | 12 +++-
> 1 file changed, 3 insertions(+), 9 deletions(-)
>
> diff --
On Sun, Jun 16, 2019 at 03:00:38PM +0800, Gao Xiang wrote:
> Hi Greg,
>
> Sorry for annoying... Could you help merge these two fixes? Thanks in
> advance...
It was only 3 days, please give me at the very least, a week or so for
staging patches.
> decompression inplace optimization needs these t
Hi Greg,
Sorry for annoying... Could you help merge these two fixes? Thanks in advance...
decompression inplace optimization needs these two patches and I will integrate
erofs decompression inplace optimization later for linux-next 5.3, and try to
start
making effort on moving to fs/ directory o
49 matches
Mail list logo