Re: [PATCH] Staging: emxx_udc: fix warning "sum of probable bitmasks, consider |"

2019-06-04 Thread Hariprasad Kelam
On Mon, Jun 03, 2019 at 09:04:57PM +0200, Greg Kroah-Hartman wrote: > On Tue, Jun 04, 2019 at 12:24:12AM +0530, Hariprasad Kelam wrote: > > Knowing the fact that operator '|' is faster than '+'. > > Its better we replace + with | in this case. > > > > Issue reported by coccicheck > > drivers/stagi

Re: staging: mt7621-pci: factor out 'mt7621_pcie_enable_port' function

2019-06-04 Thread Sergio Paracuellos
Hi Greg, On Wed, Jun 5, 2019 at 6:01 AM Greg Ungerer wrote: > > Hi Sergio, > > On 4/6/19 7:36 pm, Sergio Paracuellos wrote: > > On Tue, Jun 4, 2019 at 9:14 AM Greg Ungerer wrote: > >> On 4/6/19 3:06 pm, Sergio Paracuellos wrote: > >>> On Tue, Jun 4, 2019 at 3:31 AM Greg Ungerer wrote: > On

Re: staging: mt7621-pci: factor out 'mt7621_pcie_enable_port' function

2019-06-04 Thread Greg Ungerer
Hi Sergio, On 4/6/19 7:36 pm, Sergio Paracuellos wrote: On Tue, Jun 4, 2019 at 9:14 AM Greg Ungerer wrote: On 4/6/19 3:06 pm, Sergio Paracuellos wrote: On Tue, Jun 4, 2019 at 3:31 AM Greg Ungerer wrote: On 4/6/19 5:59 am, Sergio Paracuellos wrote: On Mon, Jun 3, 2019 at 2:32 PM Greg Ungere

[PATCH 4/6] staging: kpc2000: kpc_spi: remove unnecessary struct member chip_select

2019-06-04 Thread Geordan Neukum
The structure kp_spi_controller_state, defined in the kpc2000_spi driver, contains a member named chip_select which is never used after initialization. Therefore, it should be removed for simplicity's sake. Signed-off-by: Geordan Neukum --- drivers/staging/kpc2000/kpc2000_spi.c | 2 -- 1 file ch

[PATCH 6/6] staging: kpc2000: kpc_spi: remove unnecessary cast in [read|write]_reg()

2019-06-04 Thread Geordan Neukum
The kpc_spi driver unnecessarily casts from a (u64 __iomem *) to a (void *) when invoking readq and writeq which both take a (void __iomem *) arg. There is no need for this cast, and it actually harms us by discarding the sparse cookie, __iomem. Make the driver stop performing this casting operatio

[PATCH 1/6] staging: kpc2000: kpc_spi: remove unnecessary struct member phys

2019-06-04 Thread Geordan Neukum
The structure kp_spi_controller_state, defined in the kpc2000_spi driver, contains a member named phys which is never used after initialization. Therefore, it should be removed for simplicity's sake. Signed-off-by: Geordan Neukum --- drivers/staging/kpc2000/kpc2000_spi.c | 2 -- 1 file changed,

[PATCH 3/6] staging: kpc2000: kpc_spi: remove unnecessary struct member word_len

2019-06-04 Thread Geordan Neukum
The structure kp_spi_controller_state, defined in the kpc2000_spi driver, contains a member named word_len which is never used after initialization. Therefore, it should be removed for simplicity's sake. Signed-off-by: Geordan Neukum --- drivers/staging/kpc2000/kpc2000_spi.c | 3 --- 1 file chan

[PATCH 5/6] staging: kpc2000: kpc_spi: remove unnecessary ulong repr of i/o addr

2019-06-04 Thread Geordan Neukum
The kpc_spi driver stashes off an unsigned long representation of the i/o mapping returned by devm_ioremap_nocache(). This is unnecessary, as the only use of the unsigned long repr is to eventually be re-cast to an (u64 __iomem *). Instead of casting the (void __iomem *) to an (unsigned long) then

[PATCH 0/6] staging: kpc2000: kpc_spi: Assorted minor fixups

2019-06-04 Thread Geordan Neukum
Primarily just a bunch of unused / unnecessarily used struct member cleanup patches with the exception of one patch which removes an unnecessary cast to a (void *) in a couple of functions. Geordan Neukum (6): staging: kpc2000: kpc_spi: remove unnecessary struct member phys staging: kpc2000: k

[PATCH 2/6] staging: kpc2000: kpc_spi: remove unnecessary struct member pin_dir

2019-06-04 Thread Geordan Neukum
The structure kpc_spi, defined in in the kpc2000_spi driver, contains a member named pin_dir which is never used after initialization. Therefore, it should be removed for simplicity's sake. Signed-off-by: Geordan Neukum --- drivers/staging/kpc2000/kpc2000_spi.c | 2 -- 1 file changed, 2 deletion

[driver-core:platform_groups 26/27] drivers/video//fbdev/wm8505fb.c:191:1: note: in expansion of macro 'ATTRIBUTE_GROUPS'

2019-06-04 Thread kbuild test robot
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core.git platform_groups head: d770d421e93c93ceb55d6486e5ddeb65f21ca920 commit: 84cc896d582fc145f9c01b76f533707857d32d08 [26/27] video: fbdev: wm8505fb: convert platform driver to use dev_groups config: arm-allyesconfig (atta

[driver-core:platform_groups 26/27] drivers/video/fbdev/wm8505fb.c:188:21: error: 'struct device_attribute' has no member named 'addr'; did you mean 'attr'?

2019-06-04 Thread kbuild test robot
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core.git platform_groups head: d770d421e93c93ceb55d6486e5ddeb65f21ca920 commit: 84cc896d582fc145f9c01b76f533707857d32d08 [26/27] video: fbdev: wm8505fb: convert platform driver to use dev_groups config: arm-multi_v7_defconfig

[driver-core:platform_groups 28/29] drivers/video//fbdev/sm501fb.c:1283:1: note: in expansion of macro 'ATTRIBUTE_GROUPS'

2019-06-04 Thread kbuild test robot
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core.git platform_groups head: b3b12a24cfb8d0b56c0c320317e5bb02d947358c commit: 3f8fb7c8cb8571eeb00d9849710b9a8f2050ec7c [28/29] video: fbdev: sm501fb: convert platform driver to use dev_groups config: xtensa-allyesconfig (at

Re: staging: mt7621-pci: factor out 'mt7621_pcie_enable_port' function

2019-06-04 Thread Sergio Paracuellos
Hi Greg, Thanks for the traces. On Tue, Jun 4, 2019 at 9:14 AM Greg Ungerer wrote: > > Hi Sergio, > > On 4/6/19 3:06 pm, Sergio Paracuellos wrote: > > On Tue, Jun 4, 2019 at 3:31 AM Greg Ungerer wrote: > >> On 4/6/19 5:59 am, Sergio Paracuellos wrote: > >>> On Mon, Jun 3, 2019 at 2:32 PM Greg

[PATCH] staging: rtl8188eu: core: Replace function rtw_free_network_nolock

2019-06-04 Thread Nishka Dasgupta
Remove function rtw_free_network_nolock, as all it does is call _rtw_free_network_nolock, and rename _rtw_free_network_nolock to rtw_free_network_nolock. Signed-off-by: Nishka Dasgupta --- drivers/staging/rtl8188eu/core/rtw_mlme.c | 8 +--- 1 file changed, 1 insertion(+), 7 deletions(-) dif

[PATCH] staging: rtl8188eu: core: Remove initialisation of return variable

2019-06-04 Thread Nishka Dasgupta
Remove initialisation of return variable as it is never used. Issue found with Coccinelle. Signed-off-by: Nishka Dasgupta --- drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c b/drivers

[PATCH v2] staging: rtl8712: Replace function r8712_free_network_queue

2019-06-04 Thread Nishka Dasgupta
Remove function r8712_free_network_queue, as it does nothing but call _free_network queue; rename _free_network_queue to r8712_free_network_queue to enable continued functionality; change the type of r8712_free_network_queue (formerly _free_network_queue) from static to non-static to match the type

Re: staging: mt7621-pci: factor out 'mt7621_pcie_enable_port' function

2019-06-04 Thread Greg Ungerer
Hi Sergio, On 4/6/19 3:06 pm, Sergio Paracuellos wrote: On Tue, Jun 4, 2019 at 3:31 AM Greg Ungerer wrote: On 4/6/19 5:59 am, Sergio Paracuellos wrote: On Mon, Jun 3, 2019 at 2:32 PM Greg Ungerer wrote: On 3/6/19 3:34 pm, Sergio Paracuellos wrote: On Mon, Jun 3, 2019 at 3:26 AM Greg Ungere