The kpc2000 driver does not verify whether or not mapping the I/O
space succeeded during probe time. Make the driver verify that the
mapping operation was successful before potentially using that area
in the future.
Signed-off-by: Geordan Neukum
---
drivers/staging/kpc2000/kpc2000_i2c.c | 2 ++
The kpc_i2c driver attempts to map its I/O space without verifying
whether or not the result of platform_get_resource() is NULL. Make the
driver check that platform_get_resource did not return NULL before
attempting to use the value returned to map an I/O space.
Signed-off-by: Geordan Neukum
---
The i2c_device structure contains a member used to stash a pointer to
a platform_device. The driver contains no cases of this member being
used after initialization. Remove the unnecessary struct member and
the initialization of this member in the sole instance where the
driver creates a variable o
The kpc2000_i2c.c file contains instances of unnecessary consecutive
newlines which impact the readability of the file. Remove these
unnecessary newlines.
Signed-off-by: Geordan Neukum
---
drivers/staging/kpc2000/kpc2000_i2c.c | 5 -
1 file changed, 5 deletions(-)
diff --git a/drivers/stagi
In pi2c_probe, a rw_sem is initialized and stashed off in the
i2c_device private runtime state struct. This rw_sem is never used
after initialization. Remove the rw_sem and cleanup unneeded header
inclusion.
Signed-off-by: Geordan Neukum
---
drivers/staging/kpc2000/kpc2000_i2c.c | 3 ---
1 file
The kpc_i2c driver does not unmap its I/O space upon error cases in the
probe() function or upon remove(). Make the driver clean up after itself
more maintainably by using the managed resource API.
Signed-off-by: Geordan Neukum
---
drivers/staging/kpc2000/kpc2000_i2c.c | 4 +++-
1 file changed,
The kpc_i2c driver stashes private state data in the platform_data
member of its device structure. In general, the platform_data structure
is used for passing data to the driver during probe() rather than as a
storage area for runtime state data. Instead, use the drvdata member
for all state info m
The FEATURES_* symbols use bit shifting of the style (1 << k) in order
to assign a certain meaning to the value of inividual bits being set
in the value of a given variable. Instead, use the BIT() macro in
order to improve readability and maintain consistency with the rest
of the kernel.
Signed-of
This series contains some patches aimed toward:
- cleaning up unused/unneeded parts of driver state
- a couple of small style fixups
- a couple of API changes
- better error handling in probe()
in the kpc2000 i2c driver.
Geordan Neukum (8):
staging: kpc2000: kpc_i2c: Remove unused rw_sem
sta
this patch fixes below coccicheck warning
./drivers/staging/rtl8723bs/hal/odm_DIG.c:499:1-3: WARNING: possible
condition with no effect (if == else)
Signed-off-by: Hariprasad Kelam
---
drivers/staging/rtl8723bs/hal/odm_DIG.c | 9 ++---
1 file changed, 2 insertions(+), 7 deletions(-)
diff -
Fixes gcc '-Wunused-but-set-variable' warning:
drivers/staging/rtl8723bs/hal/rtl8723bs_xmit.c: In function xmit_xmitframes:
drivers/staging/rtl8723bs/hal/rtl8723bs_xmit.c:205:5: warning: variable no_res
set but not used [-Wunused-but-set-variable]
drivers/staging/rtl8723bs/hal/rtl8723bs_xmit.c: I
On Fri, May 24, 2019 at 01:19:26PM +0100, Jeremy Sowden wrote:
> kp2000_check_uio_irq contained a pair of nested ifs which each evaluated
> a bitwise operation. If both operations yielded true, the function
> returned 1; otherwise it returned 0.
>
> Replaced the whole thing with one return statem
On Fri, May 24, 2019 at 2:04 AM Nishka Dasgupta
wrote:
>
> The return variable is used only twice (in two different branches), and
> both times it is assigned the same constant value. These can therefore
> be merged into the same assignment, placed at the point that both
> these branches (and no o
On Sat, May 25, 2019 at 12:20 AM Mao Wenan wrote:
>
> The variable 'status' is not used any more, remve it.
> /* do the transfers for this message */
> list_for_each_entry(transfer, &m->transfers, transfer_list) {
> if (transfer->tx_buf == NULL && transfer->rx_buf == NULL &&
>
Hi!
Dne petek, 24. maj 2019 ob 11:36:33 CEST je Paul Kocialkowski napisal(a):
> Introduce the V4L2_PIX_FMT_HEVC_SLICE pixel format, which currently
> describes an output buffer with enough appended slice data for
> producing one decoded frame with a stateless video decoder.
>
> This will need to
Hi Hans,
On Sat, 2019-05-25 at 13:08 +0200, Hans Verkuil wrote:
> Hi Paul,
>
> This patch is missing your Signed-of-by line! Can you reply with your SoB?
Ouch, sorry about that. This is definitely:
Signed-off-by: Paul Kocialkowski
Cheers,
Paul
> Regards,
>
> Hans
>
> On 5/24/19 11:3
Hi Paul,
Besides the missing SoB I have two more comments:
On 5/24/19 11:36 AM, Paul Kocialkowski wrote:
> This introduces the required definitions for HEVC decoding support with
> stateless VPUs. The controls associated to the HEVC slice format provide
> the required meta-data for decoding slice
On 5/24/19 11:36 AM, Paul Kocialkowski wrote:
> Document the current state of the HEVC slice pixel format.
> The format will need to evolve in the future, which is why it is
> not part of the public API.
>
> Signed-off-by: Paul Kocialkowski
> ---
> .../media/uapi/v4l/pixfmt-compressed.rst |
Hi Paul,
This patch is missing your Signed-of-by line! Can you reply with your SoB?
Regards,
Hans
On 5/24/19 11:36 AM, Paul Kocialkowski wrote:
> This introduces the required definitions for HEVC decoding support with
> stateless VPUs. The controls associated to the HEVC slice format pr
On Sat, May 25, 2019 at 10:39:18AM +0200, Simon Sandström wrote:
> On Sat, May 25, 2019 at 07:00:17AM +0200, Greg KH wrote:
> >
> > This is already in linux-next (in a different form), are you sure you
> > are working against the latest kernel tree?
> >
> > thanks,
> >
> > greg k-h
>
> It's bas
On Sat, May 25, 2019 at 07:00:17AM +0200, Greg KH wrote:
> On Fri, May 24, 2019 at 10:30:58PM +0200, Simon Sandström wrote:
> > Fixes build errors:
> >
> > ERROR: "mfd_remove_devices" [kpc2000.ko] undefined!
> > ERROR: "uio_unregister_device" [kpc2000.ko] undefined!
> > ERROR: "mfd_add_devices" [k
Fixes gcc '-Wunused-but-set-variable' warning:
drivers/staging/kpc2000/kpc_spi/spi_driver.c: In function
‘kp_spi_transfer_one_message’:
drivers/staging/kpc2000/kpc_spi/spi_driver.c:282:9: warning: variable
‘status’ set but not used [-Wunused-but-set-variable]
int status = 0;
^~
T
22 matches
Mail list logo