Re: [PATCH v2] staging: erofs: fix Warning Use BUG_ON instead of if condition followed by BUG

2019-05-19 Thread Chao Yu
On 2019/5/19 17:35, Gao Xiang wrote: > From: Hariprasad Kelam > > fix below warning reported by coccicheck > > drivers/staging/erofs/unzip_pagevec.h:74:2-5: WARNING: Use BUG_ON > instead of if condition followed by BUG. > > Signed-off-by: Hariprasad Kelam > [ Gao Xiang: use DBG_BUGON instead

[Patch v2] staging: rtl8723bs: hal: odm_HWConfig: odm_HWConfig: Unneeded variable: "result". Return "HAL_STATUS_SUCCESS"

2019-05-19 Thread Hariprasad Kelam
This patch fixes below warnings reported by coccicheck drivers/staging/rtl8723bs/hal/odm_HWConfig.c:501:4-10: Unneeded variable: "result". Return "HAL_STATUS_SUCCESS" on line 526 Signed-off-by: Hariprasad Kelam - Changes in v2: - fixed typo in commit message --- --- drivers/staging/rtl87

[PATCH] staging: rtl8723bs: core: rtw_mlme_ext: fix warning Unneeded variable: "ret"

2019-05-19 Thread Hariprasad Kelam
This patch fixes below warnings reported by coccicheck drivers/staging/rtl8723bs/core/rtw_mlme_ext.c:1888:14-17: Unneeded variable: "ret". Return "_FAIL" on line 1920 drivers/staging/rtl8723bs/core/rtw_mlme_ext.c:466:5-8: Unneeded variable: "res". Return "_SUCCESS" on line 494 Signed-off-by: Hari

[PATCH] taging: rtl8723bs: hal: odm_HWConfig: odm_HWConfig: Unneeded variable: "result". Return "HAL_STATUS_SUCCESS"

2019-05-19 Thread Hariprasad Kelam
This patch fixes below warnings reported by coccicheck drivers/staging/rtl8723bs/hal/odm_HWConfig.c:501:4-10: Unneeded variable: "result". Return "HAL_STATUS_SUCCESS" on line 526 Signed-off-by: Hariprasad Kelam --- drivers/staging/rtl8723bs/hal/odm_HWConfig.c | 4 +--- 1 file changed, 1 inserti

[PATCH] Staging: mt7621-dma: Remove braces around single if statement

2019-05-19 Thread Puranjay Mohan
Fix following checkpatch.pl warning by removing unnecessary braces: WARNING: braces {} are not necessary for single statement blocks Signed-off-by: Puranjay Mohan --- drivers/staging/mt7621-dma/mtk-hsdma.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/staging/mt76

[PATCH] staging: rtl8723bs: os_dep: os_intfs: fix warning Unneeded variable: "status". Return "_SUCCESS"

2019-05-19 Thread Hariprasad Kelam
This patch fixes below warnings reported by coccicheck drivers/staging/rtl8723bs/os_dep/os_intfs.c:228:6-12: Unneeded variable: "status". Return "_SUCCESS" on line 333 drivers/staging/rtl8723bs/os_dep/os_intfs.c:607:4-7: Unneeded variable: "ret". Return "_SUCCESS" on line 669 drivers/staging/rtl87

[PATCH] staging: rtl8723bs: core: rtw_ap: fix Unneeded variable: "ret". Return "0"

2019-05-19 Thread Hariprasad Kelam
This patch fixes below warnings reported by coccicheck drivers/staging/rtl8723bs/core/rtw_ap.c:1400:5-8: Unneeded variable: "ret". Return "0" on line 1441 drivers/staging/rtl8723bs/core/rtw_ap.c:2195:5-8: Unneeded variable: "ret". Return "0" on line 2205 Signed-off-by: Hariprasad Kelam --- driv

[driver-core:debugfs_cleanup 31/55] fs/ceph/debugfs.c:267:9: warning: 'return' with a value, in function returning void

2019-05-19 Thread kbuild test robot
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core.git debugfs_cleanup head: 46014e29feaf627416cde1fd5c21b37ff7f8b245 commit: 389881a7dbe15106b1f978a35c3c032002705dfd [31/55] ceph: no need to check return value of debugfs_create functions config: x86_64-randconfig-u0-051

Re: [PATCH] dt-bindings: iio: adc: add adi,ad7780.yaml binding

2019-05-19 Thread Jonathan Cameron
On Sat, 18 May 2019 19:41:12 -0300 Renato Lui Geh wrote: > This patch adds a YAML binding for the Analog Devices AD7780/1 and > AD7170/1 analog-to-digital converters. > > Signed-off-by: Renato Lui Geh One comment inline. I'll also be needing an ack from Analog on this, preferably Michael's. T

Re: [PATCH] staging: iio: ad9832: Add device tree support

2019-05-19 Thread Jonathan Cameron
On Sat, 18 May 2019 17:48:25 -0300 João Seckler wrote: > Add a of_device_id struct variable and subsequent call to > MODULE_DEVICE_TABLE macro to support device tree. > > Signed-off-by: João Seckler > Signed-off-by: Anderson Reis > Co-developed-by: Anderson Reis > Signed-off-by: Andre Tadeu

Re: [PATCH 2/2] staging: iio: ad2s1210: Add devicetree yaml doc

2019-05-19 Thread Jonathan Cameron
On Sat, 18 May 2019 19:15:58 -0300 Tallys Martins wrote: > The driver currently has no devicetree documentation. This commit adds a > devicetree folder and documentation for it. Documentation must be moved > as well when the driver gets out of staging. > > Signed-off-by: Tallys Martins > Signed

Re: [PATCH 1/2] staging: iio: ad2s1210: Destroy mutex at remove

2019-05-19 Thread Jonathan Cameron
On Sat, 18 May 2019 19:15:57 -0300 Tallys Martins wrote: > Ensure the mutex will be destroyed on drive removal. > Also adds mutex comment description. > > Signed-off-by: Tallys Martins > Signed-off-by: Souza Guilherme > Co-developed-by: Souza Guilherme Hi. This particular 'issue' is never a

Re: [PATCH] staging: iio: ad7746: add device tree support

2019-05-19 Thread Jonathan Cameron
On Sun, 19 May 2019 12:02:50 +0100 Jonathan Cameron wrote: > On Sat, 18 May 2019 19:27:33 -0300 > João Seckler wrote: > > > Add a of_device_id struct variable and subsequent call to > > MODULE_DEVICE_TABLE macro to support device tree. > > > > Signed-off-by: João Seckler > > Signed-off-by: Lu

Re: [PATCH] staging: iio: ad7746: add device tree support

2019-05-19 Thread Jonathan Cameron
On Sat, 18 May 2019 19:27:33 -0300 João Seckler wrote: > Add a of_device_id struct variable and subsequent call to > MODULE_DEVICE_TABLE macro to support device tree. > > Signed-off-by: João Seckler > Signed-off-by: Lucas Oshiro > Co-developed-by: Lucas Oshiro Applied to the togreg branch of

Re: [PATCH v2] staging: iio: adis16240: add device to module device table

2019-05-19 Thread Jonathan Cameron
On Sat, 18 May 2019 18:44:34 -0300 Lucas Oshiro wrote: > Add a of_device_id struct and MODULE_DEVICE_TABLE call, in order to add > device-tree support for this driver. > > Signed-off-by: Lucas Oshiro > Signed-off-by: Rodrigo Ribeiro > Co-developed-by: Rodrigo Ribeiro Hi Lucas, Rodrigo, The

Re: [RESEND PATCH] staging: iio: ad7192: create of_device_id array

2019-05-19 Thread Jonathan Cameron
On Sat, 18 May 2019 19:44:35 -0300 Bárbara Fernandes wrote: > Create list of compatible device ids to be matched with those stated in > the device tree. > > Signed-off-by: Bárbara Fernandes > Signed-off-by: Wilson Sales > Co-developed by: Wilson Sales Hi Bárbara, Wilson, One minor issue inli

Re: [RESEND PATCH] staging: iio: adt7316: create of_device_id array

2019-05-19 Thread Jonathan Cameron
On Sat, 18 May 2019 19:43:33 -0300 Bárbara Fernandes wrote: > Create structure of type of_device_id in order to register all devices > the driver is able to manage. > > Signed-off-by: Bárbara Fernandes > Signed-off-by: Wilson Sales > Co-developed-by: Wilson Sales Looks good to me. Applied to

Re: [PATCH] staging: iio: adis16203: Add of_device_id table

2019-05-19 Thread Jonathan Cameron
On Sat, 18 May 2019 19:42:13 -0300 Thiago Estrela wrote: > Accomplish device tree compatibility to driver ADIS16203 > by adding of_device_id table and making a subsequent call to > MODULE_DEVICE_TABLE. > > Signed-off-by: Thiago Estrela > Signed-off-by: Tiago Napoli > Co-developed-by: Tiago Nap

Re: [PATCH] staging: iio: ad9834: add of_device_id table

2019-05-19 Thread Jonathan Cameron
On Sat, 18 May 2019 19:47:20 -0300 João Victor Marques de Oliveira wrote: > Add a of_device_id struct array of_match_table variable and subsequent > call to MODULE_DEVICE_TABLE macro to device tree support. > > Co-developed-by: Thiago L. A. Miller > Signed-off-by: Thiago L. A. Miller >

Re: [PATCH] staging:iio:ad7150: fix threshold mode config bit

2019-05-19 Thread Jonathan Cameron
On Sat, 18 May 2019 22:04:56 -0300 Melissa Wen wrote: > According to the AD7150 configuration register description, bit 7 assumes > value 1 when the threshold mode is fixed and 0 when it is adaptive, > however, the operation that identifies this mode was considering the > opposite values. > > Th

Re: [PATCH 2/2] staging: iio: cdc: ad7150: create macro for capacitance channels

2019-05-19 Thread Jonathan Cameron
On Sat, 18 May 2019 19:41:36 -0300 Bárbara Fernandes wrote: > Create macro for capacitance channels in order to remove the repeated > code and improve its readability. > > Signed-off-by: Bárbara Fernandes > Signed-off-by: Wilson Sales > Co-developed-by: Wilson Sales Not a totally clear cut ca

Re: [PATCH 1/2] staging: iio: cdc: ad7150: create of_device_id array

2019-05-19 Thread Jonathan Cameron
On Sat, 18 May 2019 19:41:35 -0300 Bárbara Fernandes wrote: > Create structure of type of_device_id in order to register all devices > the driver is able to manage. > > Signed-off-by: Bárbara Fernandes > Signed-off-by: Melissa Wen > Co-developed-by: Melissa Wen > Signed-off-by: Wilson Sales

Re: [Patch v2] staging: erofs: fix Warning Use BUG_ON instead of if condition followed by BUG

2019-05-19 Thread Hariprasad Kelam
On Sun, May 19, 2019 at 05:50:40PM +0800, Gao Xiang wrote: > > > On 2019/5/19 下午5:34, Hariprasad Kelam wrote: > > fix below warning reported by coccicheck > > > > drivers/staging/erofs/unzip_pagevec.h:74:2-5: WARNING: Use BUG_ON > > instead of if condition followed by BUG. > > > > Signed-off-b

Re: [Patch v2] staging: erofs: fix Warning Use BUG_ON instead of if condition followed by BUG

2019-05-19 Thread Gao Xiang
On 2019/5/19 下午5:34, Hariprasad Kelam wrote: > fix below warning reported by coccicheck > > drivers/staging/erofs/unzip_pagevec.h:74:2-5: WARNING: Use BUG_ON > instead of if condition followed by BUG. > > Signed-off-by: Hariprasad Kelam > - > Changes in v2: > - replace BUG_ON with DBG_

[PATCH v2] staging: erofs: fix Warning Use BUG_ON instead of if condition followed by BUG

2019-05-19 Thread Gao Xiang
From: Hariprasad Kelam fix below warning reported by coccicheck drivers/staging/erofs/unzip_pagevec.h:74:2-5: WARNING: Use BUG_ON instead of if condition followed by BUG. Signed-off-by: Hariprasad Kelam [ Gao Xiang: use DBG_BUGON instead of BUG_ON for eng version only. ] Signed-off-by: Gao Xi

[Patch v2] staging: erofs: fix Warning Use BUG_ON instead of if condition followed by BUG

2019-05-19 Thread Hariprasad Kelam
fix below warning reported by coccicheck drivers/staging/erofs/unzip_pagevec.h:74:2-5: WARNING: Use BUG_ON instead of if condition followed by BUG. Signed-off-by: Hariprasad Kelam - Changes in v2: - replace BUG_ON with DBG_BUGON - --- drivers/staging/erofs/unzip_pagevec.h | 3 +-- 1

Re: [PATCH] staging: erofs: fix Warning Use BUG_ON instead of if condition followed by BUG

2019-05-19 Thread Gao Xiang
Hi Hariprasad, On 2019/5/19 上午1:33, Hariprasad Kelam wrote: > fix below warning reported by coccicheck > > drivers/staging/erofs/unzip_pagevec.h:74:2-5: WARNING: Use BUG_ON > instead of if condition followed by BUG. > > Signed-off-by: Hariprasad Kelam > --- > drivers/staging/erofs/unzip_pagev