On Fri, Apr 05, 2019 at 10:31:17AM +0800, YueHaibing wrote:
> On 2019/4/5 9:56, Caio Salvador Rohwedder wrote:
> > if(!list_empty(pUnusedList)) {
> > (*ppTS) = list_entry(pUnusedList->next, struct
> > ts_common_info, list);
> >
Thanks!
Reviewed-by: Dan Carpenter
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
Add space between "enum TXDESC_SC" and '{' at line 86.
Fix the following error from checkpatch.pl
WARNING: missing space after enum definition
+enum TXDESC_SC{
Signed-off-by: William Tustumi
---
drivers/staging/rtl8723bs/include/rtw_xmit.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Hi!
On Fri, Apr 5, 2019 at 2:53 AM Nilesh Hase wrote:
>
> Fix checkpatch issues: "CHECK: Alignment should match open parenthesis"
>
> Signed-off-by: Nilesh Hase
> ---
> drivers/staging/mt7621-spi/spi-mt7621.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/stagi
On 2019/4/5 9:56, Caio Salvador Rohwedder wrote:
> Fix checkpatch coding style errors on rtl819x_TSProc.c
> - space required before the open parenthesis '('
> - spaces required around that '=='
>
> Signed-off-by: Caio Salvador Rohwedder
> ---
> drivers/staging/rtl8192u/ieee80211/rtl819x_TSProc
Fix checkpatch coding style errors on rtl819x_TSProc.c
- space required before the open parenthesis '('
- spaces required around that '=='
Signed-off-by: Caio Salvador Rohwedder
---
drivers/staging/rtl8192u/ieee80211/rtl819x_TSProc.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --
Remove an exceptional & on function names, otherwise they are used as
pointers without &.
Issue suggested using Coccinelle.
Signed-off-by: Madhumitha Prabakaran
---
.../vc04_services/bcm2835-camera/controls.c | 58 +--
1 file changed, 29 insertions(+), 29 deletions(-)
diff --
Function name is otherwise used as pointers without &.
Issue suggested by Coccinelle.
Signed-off-by: Madhumitha Prabakaran
---
drivers/staging/rtlwifi/pci.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtlwifi/pci.c b/drivers/staging/rtlwifi/pci.c
inde
Greg KH, le jeu. 04 avril 2019 22:35:49 +0200, a ecrit:
> On Thu, Apr 04, 2019 at 08:45:29PM +0100, Okash Khawaja wrote:
> > diff --git a/include/linux/selection.h b/include/linux/selection.h
> > index a8f5b97b216f..171d77dfc825 100644
> > --- a/include/linux/selection.h
> > +++ b/include/linux/sel
On Thu, Apr 04, 2019 at 08:45:29PM +0100, Okash Khawaja wrote:
> diff --git a/include/linux/selection.h b/include/linux/selection.h
> index a8f5b97b216f..171d77dfc825 100644
> --- a/include/linux/selection.h
> +++ b/include/linux/selection.h
> @@ -11,13 +11,12 @@
> #include
> #include
>
> -st
On Thu, Apr 04, 2019 at 12:09:00PM +0300, Dan Carpenter wrote:
> You should probably update the subject line because now it's not just
> about parentheses any more.
>
> [PATCH v2] Staging: rtlwifi: clean up crc16_ccitt()
>
> So the one thing per patch rule is a little bit about selling your
> pat
crc16_ccitt() function does "BIT(0) << i" instead of "BIT(i)".
Using !! is slightly shorter than "foo ? 1: 0" and remove unnecessary
parentheses to make the code simple.
Issue suggested by Coccinelle.
Signed-off-by: Madhumitha Prabakaran
---
Changes in v3:
- Changed subject line and commit log
This patch breaks set_selection() into two functions so that when
called from kernel, copy_from_user() can be avoided. It also exports
set_selection() and paste_selection().
These changes are used the following patch where speakup's selection
functionality calls into the above functions, thereby d
Hi,
Speakup's selection functionality parallels that of
drivers/tty/vt/selection.c. This patch set replaces speakup's
implementation with calls to vt's selection code. This is one of the
remaining items in our TODO file and it's needed for moving speakup out
of staging.
Please note that in speaku
This patch replaces speakup's implementations with calls to functions
in tty/vt/selection.c. Those functions are:
cancel_selection()
do_set_selection()
paste_selection()
Currently setting selection is done in interrupt context. However,
do_set_selection() can sleep - for instance, it requires con
Fix checkpatch issues: "CHECK: Alignment should match open parenthesis"
Signed-off-by: Nilesh Hase
---
drivers/staging/mt7621-spi/spi-mt7621.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/mt7621-spi/spi-mt7621.c
b/drivers/staging/mt7621-spi/spi-mt7621.c
i
Fix checkpatch warning "CHECK: Please don't use multiple blank lines"
on upc.h
Signed-off-by: Cesar Santos
---
drivers/staging/vt6655/upc.h | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/vt6655/upc.h b/drivers/staging/vt6655/upc.h
index d028ad2ba0d4..e086ec6e77f7 100644
---
Fix checkpatch error: "ERROR: space required after that close brace '}'".
Signed-off-by: Gabriel Siqueira
---
drivers/staging/rtl8192u/ieee80211/rtl819x_HT.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HT.h
b/drivers/staging
On Thu, Apr 04, 2019 at 10:23:44AM -0600, Keith Busch wrote:
> On Thu, Apr 04, 2019 at 06:20:37PM +0200, Greg Kroah-Hartman wrote:
> > On Thu, Apr 04, 2019 at 09:35:37AM -0600, Keith Busch wrote:
> > > A previous commit to make acpi table parsing more common to variable
> > > header types modified
On Thu, Apr 04, 2019 at 06:20:37PM +0200, Greg Kroah-Hartman wrote:
> On Thu, Apr 04, 2019 at 09:35:37AM -0600, Keith Busch wrote:
> > A previous commit to make acpi table parsing more common to variable
> > header types modified a callback type that was not intended to be
> > included. Fix the cal
On Thu, Apr 04, 2019 at 09:35:37AM -0600, Keith Busch wrote:
> A previous commit to make acpi table parsing more common to variable
> header types modified a callback type that was not intended to be
> included. Fix the callback parameter.
>
> Fixes: commit 088d0b345be1952b ("acpi: Create subtable
On Thu, Apr 04, 2019 at 01:01:07AM +0530, Nilesh Hase wrote:
> Signed-off-by: Nilesh Hase
> ---
> drivers/staging/mt7621-spi/spi-mt7621.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
I can't take patches without any changelog content, sorry.
___
Signed-off-by: Nilesh Hase
---
drivers/staging/mt7621-spi/spi-mt7621.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/mt7621-spi/spi-mt7621.c
b/drivers/staging/mt7621-spi/spi-mt7621.c
index b509f9fe3346..6fa9876f5a92 100644
--- a/drivers/staging/mt7621-spi/sp
A previous commit to make acpi table parsing more common to variable
header types modified a callback type that was not intended to be
included. Fix the callback parameter.
Fixes: commit 088d0b345be1952b ("acpi: Create subtable parsing infrastructure")
Signed-off-by: Keith Busch
---
arch/ia64/ke
On Thu, Apr 04, 2019 at 10:09:30AM -0300, Beatriz Martins de Carvalho wrote:
> Fix checkpatch error "ERROR: code indent should use tabs where possible"
> in hal_com_phycfg.c:1726.
>
> Signed-off-by: Beatriz Martins de Carvalho
>
> ---
Looks good. Thanks!
Reviewed-by: Dan Carpenter
regards,
On Wed, Apr 03, 2019 at 10:44:36AM +0200, Greg Kroah-Hartman wrote:
> On Wed, Apr 03, 2019 at 02:18:18AM +0800, kbuild test robot wrote:
> > tree:
> > https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core.git
> > driver-core-testing
> > head: 5e29ef654e7be73a579b96c1b912dac5cea33
Fix checkpatch error "ERROR: code indent should use tabs where possible"
in hal_com_phycfg.c:1726.
Signed-off-by: Beatriz Martins de Carvalho
---
Changes in v2:
- correction commit title
- added more information about the error
---
drivers/staging/rtl8723bs/hal/hal_com_phycfg.c |
On Thu, Apr 4, 2019 at 2:46 PM Antti Keränen wrote:
>
> Do not use uninitialized variable 'port' when printing an error message
>
> Signed-off-by: Antti Keränen
> ---
> drivers/staging/mt7621-pci-phy/pci-mt7621-phy.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/driver
Do not use uninitialized variable 'port' when printing an error message
Signed-off-by: Antti Keränen
---
drivers/staging/mt7621-pci-phy/pci-mt7621-phy.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/mt7621-pci-phy/pci-mt7621-phy.c
b/drivers/staging/mt7621-p
On 4/4/2019 3:02 PM, Colin King wrote:
From: Colin Ian King
The NULL check on ram->u.wpa_ie.data is redudant as data is
s/redudant/redundant
zero-length array and is not a pointer, so it can't be null.
Remove the check.
Addresses-Coverity: ("Array compared against 0")
Signed-off-by: Colin
On 4/4/2019 6:54 AM, Hariprasad Kelam wrote:
changes interupts --> interrupts to fix warning reported by checkpatch
tool
Signed-off-by: Hariprasad Kelam
Reviewed-by: Mukesh Ojha
Cheers,
-Mukesh
---
drivers/staging/comedi/drivers/dt2811.c | 2 +-
1 file changed, 1 insertion(+), 1 del
On Thu, Apr 04, 2019 at 10:32:57AM +0100, Colin King wrote:
> diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c
> b/drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c
> index 944c8894f9ff..c4a4f118f547 100644
> --- a/drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c
> ++
From: Colin Ian King
The NULL check on ram->u.wpa_ie.data is redudant as data is
zero-length array and is not a pointer, so it can't be null.
Remove the check.
Addresses-Coverity: ("Array compared against 0")
Signed-off-by: Colin Ian King
---
drivers/staging/rtl8192u/ieee80211/ieee80211_softma
On 04/04/2019 02:24, Hariprasad Kelam wrote:
changes interupts --> interrupts to fix warning reported by checkpatch
tool
Signed-off-by: Hariprasad Kelam
---
drivers/staging/comedi/drivers/dt2811.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/comedi/driv
On Wed, Apr 03, 2019 at 05:45:02PM -0300, Lucas Oshiro wrote:
> #define AD7746_VTSETUP_VTMD_INT_TEMP (0 << 5)
> -#define AD7746_VTSETUP_VTMD_EXT_TEMP (1 << 5)
> +#define AD7746_VTSETUP_VTMD_EXT_TEMP BIT(5)
No, the original is more readable. Otherwise you can't see that it's
part of a set.
Just
You should probably update the subject line because now it's not just
about parentheses any more.
[PATCH v2] Staging: rtlwifi: clean up crc16_ccitt()
So the one thing per patch rule is a little bit about selling your
patch. We never allow "Clean up whole_file.c" but we do sometimes allow
"Clean
5.0-stable review patch. If anyone has any objections, please let me know.
--
[ Upstream commit 179fb36abb097976997f50733d5b122a29158cba ]
After commit 68bb7bfb7985 ("X86/Hyper-V: Enable IPI enlightenments"),
kexec fails with a kernel panic:
kexec_core: Starting new kernel
BUG:
4.19-stable review patch. If anyone has any objections, please let me know.
--
[ Upstream commit 179fb36abb097976997f50733d5b122a29158cba ]
After commit 68bb7bfb7985 ("X86/Hyper-V: Enable IPI enlightenments"),
kexec fails with a kernel panic:
kexec_core: Starting new kernel
BUG
On Thu, Apr 04, 2019 at 08:09:51AM +0100, Rui Miguel Silva wrote:
> Hi Gustavo,
> Thanks a lot for the patch.
>
> On Wed 03 Apr 2019 at 21:58, Gustavo A. R. Silva wrote:
> > Make use of the struct_size() helper instead of an open-coded
> > version
> > in order to avoid any potential type mistakes
Hi Johan,
Thanks for the patch.
On Thu 04 Apr 2019 at 07:53, Johan Hovold wrote:
Since moving the message buffers off the stack, the dynamically
allocated get-prop-descriptor request buffer is incorrectly
sized due to
using the pointer rather than request-struct size when creating
the
operati
Hi Gustavo,
Thanks a lot for the patch.
On Wed 03 Apr 2019 at 21:58, Gustavo A. R. Silva wrote:
Make use of the struct_size() helper instead of an open-coded
version
in order to avoid any potential type mistakes, in particular in
the
context in which this code is being used.
So, replace code
41 matches
Mail list logo