On 2/7/2019 6:21 PM, Claudiu Beznea - M18063 wrote:
>
>
> On 07.02.2019 13:29, ajay.kat...@microchip.com wrote:
>> From: Ajay Singh
>>
>> Move data structure and function prototype from 'wilc_wlan_if.h file.
>> Now, this file contains constant specific to the firmware.
>>
>> Signed-off-by: Ajay
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core.git
debugfs_cleanup
head: 3cc275229e713135bfacb30ea82112f15a03d74f
commit: 3cc275229e713135bfacb30ea82112f15a03d74f [124/124] platform/x86: fix up
changelog
config: x86_64-rhel (attached as .config)
compiler: gcc-8 (Debi
On Thu, 7 Feb 2019 20:36:32 +
Dexuan Cui wrote:
> When we unload pci-hyperv, the host doesn't send us a PCI_EJECT message.
> In this case we also need to make sure the sysfs pci slot directory
> is removed, otherwise "cat /sys/bus/pci/slots/2/address" will trigger
> "BUG: unable to handle ker
From: Steve Longerbeam
The capture compose rectangle was not getting updated when setting
the source subdevice's source pad format. This causes the compose window
to be zero (or not updated) at stream start unless the capture device
format was set explicitly at the capture device node.
Fix by mo
> Sure, add these test results to the patch as well showing reduced wakeups.
>
> I would say submit the freezable_schedule as a single separate patch
> independent of the vsoc series since it can go in separately, and also
> benefits other things than vsoc.
>
> Also CC Rafael (power maintainer) o
simplify handle_vsoc_cond_wait (drivers/staging/android/vsoc.c) using newly
added wait_event_freezable_hrtimeout helper and remove duplicate include.
Signed-off-by: Hugo Lefeuvre
---
Changes in v2:
- Fix removal of necessary linux/freezer.h include.
- Make commit message more precise about th
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core.git
debugfs_cleanup
head: 3ec9bc11e2cea5023fd7bda21dd0c942f4a67b67
commit: 3ec9bc11e2cea5023fd7bda21dd0c942f4a67b67 [124/124] platform/x86: fix
changelog
config: x86_64-rhel (attached as .config)
compiler: gcc-8 (Debian
introduce wait_event_freezable_hrtimeout, an interruptible and freezable
version of wait_event_hrtimeout.
This helper will allow for simplifications in staging/android/vsoc.c, among
others.
Signed-off-by: Hugo Lefeuvre
---
Changes in v2:
- No change.
include/linux/wait.h | 25 +++
This patchset introduces a new wait_event_freezable_hrtimeout method
to the wait api.
wait_event_freezable_hrtimeout is then used to greatly simplify
handle_vsoc_cond_wait in the android vsoc driver, reducing the
size of the vsoc driver.
Changes since v1 [1]:
- Delete "[1/3] sched/wait: use free
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/driver-core.git
debugfs_cleanup
head: 3ec9bc11e2cea5023fd7bda21dd0c942f4a67b67
commit: 3ec9bc11e2cea5023fd7bda21dd0c942f4a67b67 [124/124] platform/x86: fix
changelog
config: i386-randconfig-a2-201905 (attached as .config)
compiler:
When we unload pci-hyperv, the host doesn't send us a PCI_EJECT message.
In this case we also need to make sure the sysfs pci slot directory
is removed, otherwise "cat /sys/bus/pci/slots/2/address" will trigger
"BUG: unable to handle kernel paging request". And, if we unload/reload
the driver sev
On Wed, Feb 06, 2019 at 11:31:04PM -0800, Christoph Hellwig wrote:
> The CPU may only access DMA mapped memory if ownership has been
> transferred back to the CPU using dma_sync_{single,sg}_to_cpu, and then
> before the device can access it again ownership needs to be transferred
> back to the devi
From: Lan Tianyu
On the bare metal, enabling X2APIC mode requires interrupt remapping
function which helps to deliver irq to cpu with 32-bit APIC ID.
Hyper-V doesn't provide interrupt remapping function so far and Hyper-V
MSI protocol already supports to deliver interrupt to the CPU whose
virtual
From: Lan Tianyu
Hyper-V doesn't provide irq remapping for IO-APIC. To enable x2apic,
set x2apic destination mode to physcial mode when x2apic is available
and Hyper-V IOMMU driver makes sure cpus assigned with IO-APIC irqs have
8-bit APIC id.
Signed-off-by: Lan Tianyu
---
Change since v2:
On Thu, Feb 07, 2019 at 12:30:50AM +0100, Hugo Lefeuvre wrote:
> Hi Joel,
>
> > I'm curious did you try the freezing process and see if pointless wakeups
> > are
> > reduced? That would be an added bonus if you did.
>
> I'm currently testing these changes. I hope to be able to come back with
>
Hi,
> > The result is a potential performance gain during freeze, since less
> > tasks have to be awaken.
>
> I'm curious did you try the freezing process and see if pointless wakeups are
> reduced? That would be an added bonus if you did.
Test env: fresh Debian QEMU vm with 4.19 stable kernel.
On 07.02.2019 13:29, ajay.kat...@microchip.com wrote:
> From: Ajay Singh
>
> Move data structure and function prototype from 'wilc_wlan_if.h file.
> Now, this file contains constant specific to the firmware.
>
> Signed-off-by: Ajay Singh
> ---
> drivers/staging/wilc1000/host_interface.c |
On Tue, Feb 05, 2019 at 05:49:03AM -0500, K Hodges wrote:
> Resolve "Line over 80 characters" warning from checkpatch
>
> Signed-off-by: K Hodges
Same name question here.
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriver
On Tue, Feb 05, 2019 at 11:53:54PM -0500, K Hodges wrote:
> Resolved "Line over 80 characters" warning from checkpatch
>
> Signed-off-by: K Hodges
We need a "full" name here, unless you really do sign legal documents
with just "K"?
thanks,
greg k-h
_
Thanks so much!
Reviewed-by: Dan Carpenter
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
From: Ajay Singh
Cleanup patch to rename data structure and function name to have 'wilc_'
prefix.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 54 +++
drivers/staging/wilc1000/host_interface.h | 12 ++---
drivers/staging/wilc1000
From: Ajay Singh
This series contains the following changes:
- fix to set 'vif_num' value correctly.
- use 'wilc_' prefix for variables and function names.
- avoid use of unnecessary 'linux_' prefix from file names.
Changes since v1:
- merged patch 1 & 2 and added modification as suggeste
From: Ajay Singh
Cleanup patch to avoid function forward declaration by reordering the
function.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_sdio.c | 91 +---
1 file changed, 43 insertions(+), 48 deletions(-)
diff --git a/drivers/staging/wilc100
From: Ajay Singh
Move data structure and function prototype from 'wilc_wlan_if.h file.
Now, this file contains constant specific to the firmware.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 1 +
drivers/staging/wilc1000/host_interface.h | 11 ++
drivers/s
From: Ajay Singh
Set correct value in '->vif_num' for the total number of interfaces and
set '->idx' value using 'i'.
Fixes: 735bb39ca3be ("staging: wilc1000: simplify vif[i]->ndev accesses")
Fixes: 0e490657c721 ("staging: wilc1000: Fix problem with wrong vif index")
Cc:
Suggested-by: Dan Carpe
From: Ajay Singh
Rename linux_wlan.c and linux_mon.c to wilc_netdev.c and wilc_mon.c to
include 'wilc_' prefix.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/Makefile| 2 +-
drivers/staging/wilc1000/{linux_mon.c => wilc_mon.c} | 0
drivers/staging/wilc1000/
From: Ajay Singh
Rename wilc_frmw_to_linux() to wilc_frmw_to_host() to be remove the _linux
suffix.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/linux_wlan.c | 3 ++-
drivers/staging/wilc1000/wilc_wfi_netdevice.h | 2 +-
drivers/staging/wilc1000/wilc_wlan.c | 5 ++---
From: Ajay Singh
Remove 'linux_' prefix and replace it with 'wilc_' namespace.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/linux_wlan.c | 17 -
drivers/staging/wilc1000/wilc_sdio.c | 10 +-
2 files changed, 13 insertions(+), 14 deletions(-)
diff --git a/dri
From: Ajay Singh
Cleanup patch to have proper follow clear namespace in wilc_sdio.c file.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_sdio.c | 92 ++--
1 file changed, 46 insertions(+), 46 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_
On Thu, Feb 07, 2019 at 09:39:54AM +, ajay.kat...@microchip.com wrote:
> Hi Dan,
>
> On 2/7/2019 1:42 PM, Dan Carpenter wrote:
> > This patch was very confusing to review...
>
> Apologies for the confusion.
>
> > From a process perspective, you really should fold patches 1 and 2
> > together
Hi Dan,
On 2/7/2019 1:42 PM, Dan Carpenter wrote:
> This patch was very confusing to review...
Apologies for the confusion.
> From a process perspective, you really should fold patches 1 and 2
> together. Otherwise we're re-introducing a bug.
Patch 1 and Patch 2 both are required if commit 0e4
On Thu, Feb 07, 2019 at 07:22:25AM +, ajay.kat...@microchip.com wrote:
> From: Ajay Singh
>
> Set correct interface count value in '->vif_num'.
> 'vif_num' was incorrectly set one less than total number of interfaces
> because 'i' is used to set its value, which starts from 0.
>
> Fixes: 735
This patch was very confusing to review...
>From a process perspective, you really should fold patches 1 and 2
together. Otherwise we're re-introducing a bug.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.
33 matches
Mail list logo