On Thu, Oct 25, 2018 at 4:30 PM Stefan Wahren wrote:
>
> In order to make the module bcm2835-camera load automatically, we need to
> add a module alias.
>
> Fixes: 4bebb0312ea9 ("staging/bcm2835-camera: Set ourselves up as a platform
> driver.")
> Signed-off-by: Stefan Wahren
Reviewed-by: Peter
On Thu, Oct 25, 2018 at 4:30 PM Stefan Wahren wrote:
>
> In order to have this more consistent between the vc04 services move
> the module information to the end of the file.
>
> Signed-off-by: Stefan Wahren
Reviewed-by: Peter Robinson
Tested-by: Peter Robinson
Tested with a v2 camera module.
On Tue, Dec 18, 2018 at 07:34:48PM +0100, Michael Straube wrote:
> Simplfy initialization of null arrays to improve readability
> and save some lines.
>
> Signed-off-by: Michael Straube
> ---
> drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 4 ++--
> drivers/staging/rtl8188eu/core/rtw_xmit.c
On Tue, Dec 18, 2018 at 10:30:05AM -0500, Lei Zhou wrote:
> Add local temporary variable used as buffer to pass caller pointer into
> function ieee80211_connection_loss() to avoid over 80 characters on one
> line.
>
> Signed-off-by: Lei Zhou
> ---
> drivers/staging/rtlwifi/base.c | 4 +++-
> 1 f
Hi Rob,
On Tue, Dec 18, 2018 at 4:10 PM Rob Herring wrote:
>
> On Mon, Dec 17, 2018 at 09:44:23PM +0100, Sergio Paracuellos wrote:
> > Add device-tree binding example of the ksz9477 switch managed in i2c mode.
> >
> > Cc: devicet...@vger.kernel.org
> > Signed-off-by: Sergio Paracuellos
> > ---
>
The values of these arrays in rtw_mlme_ext.c and rtw_wlan_util.c
are never changed, so make them const.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 14 +-
.../staging/rtl8188eu/core/rtw_wlan_util.c| 26 +--
drivers/staging/rtl818
Cleanup brace coding style issues reported by checkpatch.
ERROR: space required before the open brace '{'
WARNING: braces {} are not necessary for single statement blocks
CHECK: Unbalanced braces around else statement
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_cmd.c
The array REALTEK_96B_IE is already declared in rtw_mlme.h,
so remove the declaration in rtw_mlme_ext.c.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
b/drivers/
Make some arrays that are only used in rtw_mlme_ext.c static and
remove the corresponding extern declarations from rtw_mlme_ext.h.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_mlme_ext.c| 6 +++---
drivers/staging/rtl8188eu/include/rtw_mlme_ext.h | 5 -
2 files c
Simplfy initialization of null arrays to improve readability
and save some lines.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 4 ++--
drivers/staging/rtl8188eu/core/rtw_xmit.c | 6 ++
2 files changed, 4 insertions(+), 6 deletions(-)
diff --git a/dr
Add spaces around '&' to follow kernel coding style.
Reported by checkpatch.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 90 +--
1 file changed, 45 insertions(+), 45 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
b
The function is_basicrate() returns true or false, so change the
return type from int to bool.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_wlan_util.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_wlan_util.c
b/d
Change the type of some arrays from unsigned char to u8.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 16 +++---
.../staging/rtl8188eu/core/rtw_wlan_util.c| 22 +--
drivers/staging/rtl8188eu/include/rtw_mlme.h | 6 ++---
.../sta
Remove comments from 'endif's where the corresponding 'if' is just
a few lines above to improve readability.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core
Replace tabs with spaces and/or remove spaces in declarations.
Signed-off-by: Michael Straube
---
v1 -> v2
one logical thing per patch
replace some more tabs with spaces
remove some more comments
drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 482 +-
1 file changed, 241 inserti
Replace tabs with spaces where appropriate.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
b/drivers/staging/rtl8188eu/core/rtw_mlme_e
Remove blank lines between declarations in rtw_mlme_ext.c.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
b/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
index f2
Remove unnecessary parentheses, most of them reported by checkpatch.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 322 +-
1 file changed, 161 insertions(+), 161 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
b/drive
Add a missing blank line after declarations in rtw_mlme_ext.c.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
b/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
index
Change the order of array declarations in rtw_mlme_ext.c to improve
readability.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
b/drivers/staging/r
Remove unused/commented declarations.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_mlme_ext.c | 3 ---
1 file changed, 3 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
b/drivers/staging/rtl8188eu/core/rtw_mlme_ext.c
index 8c566180d808..f2eb6363
The arrays WFD_OUI and WMM_INFO_OUI are not used anywhere,
so remove them.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_mlme_ext.c| 2 --
drivers/staging/rtl8188eu/include/rtw_mlme_ext.h | 2 --
2 files changed, 4 deletions(-)
diff --git a/drivers/staging/rtl8188eu/
On Mon, Dec 17, 2018 at 08:16:09PM +, Dexuan Cui wrote:
fc96df16a1ce is good and can already fix the "return stack garbage" issue,
but let's also improve hv_ringbuffer_get_debuginfo(), which would silently
return stack garbage, if people forget to check channel->state or
ring_info->ring_buff
On 12/17/18 20:42, Liam Mark wrote:
> On Sun, 16 Dec 2018, Alexey Skidanov wrote:
>
>>
>>
>> On 12/16/18 7:20 AM, Liam Mark wrote:
>>> On Tue, 6 Feb 2018, Alexey Skidanov wrote:
>>>
On 02/07/2018 01:56 AM, Laura Abbott wrote:
> On 01/31/2018 10:10 PM, Alexey Skidanov wrote:
>
Add local temporary variable used as buffer to pass caller pointer into
function ieee80211_connection_loss() to avoid over 80 characters on one
line.
Signed-off-by: Lei Zhou
---
drivers/staging/rtlwifi/base.c | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/
On Mon, Dec 17, 2018 at 09:44:23PM +0100, Sergio Paracuellos wrote:
> Add device-tree binding example of the ksz9477 switch managed in i2c mode.
>
> Cc: devicet...@vger.kernel.org
> Signed-off-by: Sergio Paracuellos
> ---
> Changes v3:
> - No changes. Just resent patches together.
>
> Change
strncmp() stops comparing when either the end of one of the first two
arguments is reached or when 'n' characters have been compared, whichever
comes first.That means that strncmp(s1, s2, n) is equivalent to
strcmp(s1, s2) if n exceeds the length of s1 or the length of s2.
This patch avoids that t
On 2018/12/18 21:37, Dan Carpenter wrote:
> On Tue, Dec 18, 2018 at 09:25:08PM +0800, YueHaibing wrote:
>> strncmp() stops comparing when either the end of one of the first two
>> arguments is reached or when 'n' characters have been compared, whichever
>> comes first.That means that strncmp(s1, s
On Tue, Dec 18, 2018 at 09:25:08PM +0800, YueHaibing wrote:
> strncmp() stops comparing when either the end of one of the first two
> arguments is reached or when 'n' characters have been compared, whichever
> comes first.That means that strncmp(s1, s2, n) is equivalent to
> strcmp(s1, s2) if n e
strncmp() stops comparing when either the end of one of the first two
arguments is reached or when 'n' characters have been compared, whichever
comes first.That means that strncmp(s1, s2, n) is equivalent to
strcmp(s1, s2) if n exceeds the length of s1 or the length of s2.
This patch avoids that
sorry, Pls ignore this. The title need fix.
On 2018/12/18 21:09, YueHaibing wrote:
> strncmp() stops comparing when either the end of one of the first two
> arguments is reached or when 'n' characters have been compared, whichever
> comes first.That means that strncmp(s1, s2, n) is equivalent to
strncmp() stops comparing when either the end of one of the first two
arguments is reached or when 'n' characters have been compared, whichever
comes first.That means that strncmp(s1, s2, n) is equivalent to
strcmp(s1, s2) if n exceeds the length of s1 or the length of s2.
This patch avoids that
On Thu, Nov 22, 2018 at 10:39:24PM +0530, Nishad Kamdar wrote:
> Use the gpiod interface instead of the deprecated
> old non-descriptor interface.
>
> Signed-off-by: Nishad Kamdar
> ---
> Changes in v2:
> - Move comment to the same line as to what it applies to.
> ---
> drivers/staging/greybus/
From: Colin Ian King
Using snprintf without a format specifier is potentially risky if
the string device_name contains format specifiers. Replace this with
the safer and more efficient strscpy.
Cleans up clang warning:
drivers/staging/most/sound/sound.c:673:41: warning: format string is not
a st
On Thu, Nov 22, 2018 at 10:38:18PM +0530, Nishad Kamdar wrote:
> Use the gpiod interface instead of the deprecated old non-descriptor
> interface.
>
> Signed-off-by: Nishad Kamdar
> ---
> Changes in v2:
> - Resolved compilation errors.
> ---
> drivers/staging/greybus/arche-apb-ctrl.c | 159
On 17/12/2018 20:51, Alexander Schroth wrote:
According to the Linux coding guidelines, defines should be written
in uppercase. This patch converts all define-statements in the
ni_pcidio.c file to uppercase, thus matching the coding style of the
kernel.
Signed-off-by: Alexander Schroth
Signed-o
On Thu, Nov 22, 2018 at 10:37:16PM +0530, Nishad Kamdar wrote:
> Convert the GPIO driver to use the GPIO irqchip library
> GPIOLIB_IRQCHIP instead of reimplementing the same.
>
> Signed-off-by: Nishad Kamdar
> ---
> Changes in v2:
> - Retained irq.h and irqdomain.h headers.
> - Dropped function
Dear Sir/Madam,
My Names are Mr.Alfredo Gomez. I am the Administrative manager at a vault
financial & security Institution here in Madrid. I am contacting you based on a
financial opportunity I discovered here in my organization. It's about an
abandoned sum of 25,000,000.00 million US dollars (
38 matches
Mail list logo