Use the gpiod interface instead of the deprecated old non-descriptor
interface in olpc_dcon_xo_1.c.
---
Changes in v3:
- Resolve a few compilation errors.
Changes in v2:
- Resolve a few compilation errors.
- Add a level of indirection to read and write gpios.
Signed-off-by: Nishad Kamdar
---
d
On 11/5/2018 9:27 PM, Joe Perches wrote:
> On Mon, 2018-11-05 at 12:18 +, ajay.kat...@microchip.com wrote:
>> Hi Joe,
>>
>> On 11/5/2018 4:27 PM, Joe Perches wrote:
>>> On Thu, 2018-11-01 at 16:45 +, ajay.kat...@microchip.com wrote:
From: Ajay Singh
Use shorter name for 'n
Hi Greg,
On 11/5/2018 7:46 PM, Greg KH wrote:
> On Tue, Oct 30, 2018 at 05:53:40AM +, ajay.kat...@microchip.com wrote:
>> From: Ajay Singh
>>
>> We would like to update the maintainer email id's for wilc1000 driver.
>>
>> Signed-off-by: Ajay Singh
>> Signed-off-by: Adham Abozaeid
> It would
On 2018-11-06 03:14, Andrew Morton wrote:
On Mon, 05 Nov 2018 15:12:27 +0530 Arun KS
wrote:
On 2018-10-22 16:03, Arun KS wrote:
> On 2018-10-19 13:37, Michal Hocko wrote:
>> On Thu 18-10-18 19:18:25, Andrew Morton wrote:
>> [...]
>>> So this patch needs more work, yes?
>>
>> Yes, I've talked
From: Adham Abozaeid
host_if_drv.cfg_values is a write only member, and can be removed
Signed-off-by: Adham Abozaeid
---
drivers/staging/wilc1000/host_interface.c | 13 -
drivers/staging/wilc1000/host_interface.h | 1 -
2 files changed, 14 deletions(-)
diff --git a/drivers/stagin
From: Adham Abozaeid
Validate input parameters to set_wiphy_param before scheduling
handle_cfg_param() to validate them.
This way proper errors can be returned to caller.
Also cleaned up unused code in handle_cfg_param.
Changes since v1:
- Correction spelling in subject of patch#2
- Added From:
From: Adham Abozaeid
handle_cfg_param() receives a bit map that describes what to be changed.
Some of these bits flags aren't referred to from elsewhere and can be
removed.
Signed-off-by: Adham Abozaeid
---
drivers/staging/wilc1000/host_interface.c | 216 --
drivers/staging
From: Adham Abozaeid
After removing cfg_values member, cfg_values_lock that was used to protect
it can also be removed.
Signed-off-by: Adham Abozaeid
---
drivers/staging/wilc1000/host_interface.c | 9 -
drivers/staging/wilc1000/host_interface.h | 2 --
2 files changed, 11 deletions(-)
From: Adham Abozaeid
Validate cfg parameters after being called by cfg80211 in set_wiphy_params
before scheduling the work executed in handle_cfg_param
Signed-off-by: Adham Abozaeid
---
drivers/staging/wilc1000/host_interface.c | 61 ++-
.../staging/wilc1000/wilc_wfi_cfgope
Dear Friend
I am sorry to encroach into your privacy in this manner.My name is Scott Metz
an American soldier serving in the Military with the 25th Brigade Support
Battalion, 1st Stryker Brigade Combat Team, 25th Infantry Division in
Afghanistan.My reason for contacting you is that we mana
On Mon, 05 Nov 2018 15:12:27 +0530 Arun KS wrote:
> On 2018-10-22 16:03, Arun KS wrote:
> > On 2018-10-19 13:37, Michal Hocko wrote:
> >> On Thu 18-10-18 19:18:25, Andrew Morton wrote:
> >> [...]
> >>> So this patch needs more work, yes?
> >>
> >> Yes, I've talked to Arun (he is offline until ne
On Thu, 2018-11-01 at 16:45 +, ajay.kat...@microchip.com wrote:
> From: Ajay Singh
>
> Use shorter name for 'network_info' variable to avoid line over 80 chars
> issue.
I suppose this is OK, though perhaps unnecessary.
As well, perhaps there are defects in the original code
in a couple pla
This patch removes the unnecessary field int_vref_mv in ad7780_state
referring to the device's voltage.
Signed-off-by: Renato Lui Geh
---
Changes in v3:
- removed unnecessary int_vref_mv from ad7780_state
Changes in v4:
- removed voltage reading on probe
drivers/staging/iio/adc/
The ad7780 driver previously did not read the correct device output, as
it read an outdated value set at initialization. It now updates its
voltage on read.
Signed-off-by: Renato Lui Geh
---
Changes in v3:
- removed initialization (int voltage_uv = 0)
- returns error when voltage
The purpose of this series is to correct an issue in the driver's raw
read function and remove an unnecessary struct field.
Changelog:
*v2
- separated original patch into two patches
(https://marc.info/?l=linux-iio&m=154047435605492)
*v3
- reordered patches so that fixes
> -Original Message-
> From: Olaf Hering
> Sent: Monday, November 5, 2018 6:07 AM
> To: KY Srinivasan ; Michael Kelley
>
> Cc: de...@linuxdriverproject.org
> Subject: caching of FQDN in kvp_daemon
>
> In commit 58125210ab ("Tools: hv: cache FQDN in kvp_daemon to avoid
> timeouts") I c
On Mon, 05 Nov 2018 16:57:07 +0100,
Mike Brady wrote:
>
> > One another thing I'd like to point out is that the value given in the
> > patch is nothing but an estimated position, optimistically calculated
> > via the system timer. Mike and I had already discussion in another
> > thread, and anoth
On Mon, 2018-11-05 at 12:18 +, ajay.kat...@microchip.com wrote:
> Hi Joe,
>
> On 11/5/2018 4:27 PM, Joe Perches wrote:
> > On Thu, 2018-11-01 at 16:45 +, ajay.kat...@microchip.com wrote:
> > > From: Ajay Singh
> > >
> > > Use shorter name for 'network_info' variable to avoid line over 80
Thanks for the comments and suggestions.
> On 25 Oct 2018, at 08:37, Takashi Iwai wrote:
>
> Well, in the API POV, it's nothing wrong to keep hwptr sticking while
> updating only delay value. It implies that the hardware chip doesn't
> provide the hwptr update.
As I understand it, this driver
ture->true
Signed-off-by: Yangtao Li
---
drivers/staging/rtl8723bs/include/rtw_cmd.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8723bs/include/rtw_cmd.h
b/drivers/staging/rtl8723bs/include/rtw_cmd.h
index 1530d0ea1d51..7dc5bf050839 100644
--- a/driver
ture->true
Signed-off-by: Yangtao Li
---
drivers/staging/rtl8712/rtl871x_cmd.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8712/rtl871x_cmd.h
b/drivers/staging/rtl8712/rtl871x_cmd.h
index 24da2ccea04f..37960b04beee 100644
--- a/drivers/staging/rtl8712/
On Fri, Nov 02, 2018 at 07:01:26PM +, Colin King wrote:
> From: Colin Ian King
>
> Currently if count is an invalid value the v4l2_info message will
> dereference a null ctx pointer to get the dev information. Fix
> this by finding ctx first and then checking for an invalid count,
> this way
Correct spelling mistakes of "Calculate"
Signed-off-by: Yangtao Li
---
changes in v2:
-add changelog
---
drivers/staging/vt6655/baseband.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/vt6655/baseband.c
b/drivers/staging/vt6655/baseband.c
index f0b163473426
On Mon, Nov 05, 2018 at 03:27:34PM +0100, Miquel Raynal wrote:
> Hi Greg,
>
> Greg Kroah-Hartman wrote on Mon, 5 Nov
> 2018 14:29:49 +0100:
>
> > On Mon, Nov 05, 2018 at 11:12:27AM +0100, Miquel Raynal wrote:
> > > Hi Greg,
> > >
> > > Boris Brezillon wrote on Mon, 22 Oct 2018
> > > 22:10:59 +
Hi Greg,
Greg Kroah-Hartman wrote on Mon, 5 Nov
2018 14:29:49 +0100:
> On Mon, Nov 05, 2018 at 11:12:27AM +0100, Miquel Raynal wrote:
> > Hi Greg,
> >
> > Boris Brezillon wrote on Mon, 22 Oct 2018
> > 22:10:59 +0200:
> >
> > > A new SPI NAND subsystem has been added in drivers/mtd/nand/spi/
On Thu, Nov 01, 2018 at 11:52:51AM -0400, Yangtao Li wrote:
> Signed-off-by: Yangtao Li
> ---
> drivers/staging/vt6655/baseband.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
I can not accept patches without any changelog text :(
___
devel m
On Fri, Nov 02, 2018 at 08:53:32AM -0400, Yangtao Li wrote:
> ture->true
>
> Signed-off-by: Yangtao Li
> ---
> Change in v2:
> -add changelog
> ---
> drivers/staging/rtl8712/rtl871x_cmd.h | 2 +-
> drivers/staging/rtl8723bs/include/rtw_cmd.h | 2 +-
> 2 files changed, 2 insertions(+), 2 de
On Tue, Oct 30, 2018 at 04:22:55AM +, adham.aboza...@microchip.com wrote:
> From: Adham Abozaeid
>
> handle_cfg_param() receives a bit map that describes what to be changed.
> Some of these bits flags aren't referred to from elsewhere and can be
> removed.
>
> Signed-off-by: Adham Abozaeid
On Tue, Oct 30, 2018 at 05:53:40AM +, ajay.kat...@microchip.com wrote:
> From: Ajay Singh
>
> We would like to update the maintainer email id's for wilc1000 driver.
>
> Signed-off-by: Ajay Singh
> Signed-off-by: Adham Abozaeid
It would be good to get the current maintainer's signed off by
In commit 58125210ab ("Tools: hv: cache FQDN in kvp_daemon to avoid timeouts")
I changed the code to lookup the hostname just once during start. While this
works most of the time, there is still a slim chance that name resolution does
not work properly at that time. As a result the host will alw
On Mon, Nov 05, 2018 at 11:12:27AM +0100, Miquel Raynal wrote:
> Hi Greg,
>
> Boris Brezillon wrote on Mon, 22 Oct 2018
> 22:10:59 +0200:
>
> > A new SPI NAND subsystem has been added in drivers/mtd/nand/spi/ and
> > Micron's MT29F devices are now supported in
> > drivers/mtd/nand/spi/micron.c.
Hi Joe,
On 11/5/2018 4:27 PM, Joe Perches wrote:
> On Thu, 2018-11-01 at 16:45 +, ajay.kat...@microchip.com wrote:
>> From: Ajay Singh
>>
>> Use shorter name for 'network_info' variable to avoid line over 80 chars
>> issue.
>
> I suppose this is OK, though perhaps unnecessary.
>
> As well, pe
Hi Greg,
Boris Brezillon wrote on Mon, 22 Oct 2018
22:10:59 +0200:
> A new SPI NAND subsystem has been added in drivers/mtd/nand/spi/ and
> Micron's MT29F devices are now supported in
> drivers/mtd/nand/spi/micron.c.
>
> Remove the old driver.
>
> Signed-off-by: Boris Brezillon
> ---
> Hello,
On 2018-10-22 16:03, Arun KS wrote:
On 2018-10-19 13:37, Michal Hocko wrote:
On Thu 18-10-18 19:18:25, Andrew Morton wrote:
[...]
So this patch needs more work, yes?
Yes, I've talked to Arun (he is offline until next week) offlist and
he
will play with this some more.
Converted totalhigh_
On Sun, Nov 4, 2018 at 11:51 AM Sergio Paracuellos
wrote:
>
> Function 'mt7621_pcie_init_ports' is never called in atomic context.
> It calls mdelay() to busily wait, which is not necessary. mdelay()
> can be replaced with msleep().
>
> Signed-off-by: Sergio Paracuellos
> ---
> drivers/staging/m
35 matches
Mail list logo