Re: [PATCH] staging: olpc_dcon: olpc_dcon_xo_1.c: Switch to the gpio descriptor interface

2018-10-27 Thread kbuild test robot
Hi Nishad, Thank you for the patch! Yet something to improve: [auto build test ERROR on staging/staging-testing] [also build test ERROR on v4.19 next-20181019] [if your patch is applied to the wrong git tree, please drop us a note to help improve the system] url: https://github.com/0day-ci/

Re: [PATCH v5 2/2] staging: iio: ad2s1210: Add device tree support.

2018-10-27 Thread Nishad Kamdar
On Sat, Oct 27, 2018 at 05:49:03PM +0200, Slawomir Stepien wrote: > Hi > > On paź 26, 2018 18:55, Nishad Kamdar wrote: > > Add device tree table for matching vendor ID > > and support for retrieving platform data > > from device tree. > > So maybe you should make 2 commits? > Ok. I'll do that. >

Re: [Outreachy kernel] [RESEND PATCH 2/2] staging: vboxvideo: Use unsigned int instead bool

2018-10-27 Thread Julia Lawall
On Sat, 27 Oct 2018, Joe Perches wrote: > On Fri, 2018-10-26 at 22:54 +0200, Julia Lawall wrote: > > [Adding Joe Perches] > > > > On Fri, 26 Oct 2018, Sasha Levin wrote: > > > > > On Fri, Oct 26, 2018 at 04:04:45PM -0300, Shayenne da Luz Moura wrote: > > > > This change was suggested by checkpa

[PATCH] staging: olpc_dcon: olpc_dcon_xo_1.c: Switch to the gpio descriptor interface

2018-10-27 Thread Nishad Kamdar
Use the gpiod interface instead of the deprecated old non-descriptor interface in olpc_dcon_xo_1.c. Signed-off-by: Nishad Kamdar --- drivers/staging/olpc_dcon/olpc_dcon.h | 12 drivers/staging/olpc_dcon/olpc_dcon_xo_1.c | 74 ++ 2 files changed, 44 insertions(+), 42

[PATCH] staging: rtl8712: fix CamelCase in fw_priv struct

2018-10-27 Thread Robert Eshleman
Rename fields in fw_priv struct from CamelCase to snake_case. Reported by checkpatch. Signed-off-by: Robert Eshleman --- drivers/staging/rtl8712/hal_init.c| 10 +- drivers/staging/rtl8712/rtl8712_hal.h | 8 2 files changed, 9 insertions(+), 9 deletions(-) diff --git a/driv

Re: [PATCH 4/5] staging: rtl8188eu: change return type of rtw_hal_xmit()

2018-10-27 Thread Joe Perches
On Sat, 2018-10-27 at 22:28 +0200, Michael Straube wrote: > The function rtw_hal_xmit() returns true or false. > Change the return type from s32 to bool. [] > diff --git a/drivers/staging/rtl8188eu/hal/rtl8188eu_xmit.c > b/drivers/staging/rtl8188eu/hal/rtl8188eu_xmit.c [] > @@ -598,7 +598,7 @@ boo

Re: [Outreachy kernel] [RESEND PATCH 2/2] staging: vboxvideo: Use unsigned int instead bool

2018-10-27 Thread Joe Perches
On Fri, 2018-10-26 at 22:54 +0200, Julia Lawall wrote: > [Adding Joe Perches] > > On Fri, 26 Oct 2018, Sasha Levin wrote: > > > On Fri, Oct 26, 2018 at 04:04:45PM -0300, Shayenne da Luz Moura wrote: > > > This change was suggested by checkpath.pl. Use unsigned int with bitfield > > > allocate onl

[PATCH 3/5] staging: rtl8188eu: change return type of rtl8188eu_xmitframe_complete()

2018-10-27 Thread Michael Straube
The function rtl8188eu_xmitframe_complete() returns true or false. Change the return type from s32 to bool. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/rtl8188eu_xmit.c| 3 ++- drivers/staging/rtl8188eu/include/rtl8188e_xmit.h | 4 ++-- 2 files changed, 4 insertions(+),

[PATCH 4/5] staging: rtl8188eu: change return type of rtw_hal_xmit()

2018-10-27 Thread Michael Straube
The function rtw_hal_xmit() returns true or false. Change the return type from s32 to bool. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/rtl8188eu_xmit.c | 2 +- drivers/staging/rtl8188eu/include/hal_intf.h | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) diff --gi

[PATCH 5/5] staging: rtl8188eu: cleanup long line in rtw_hal_xmit()

2018-10-27 Thread Michael Straube
Cleanup a line over 80 characters in rtw_hal_xmit() by using if(x) instead of if(x == true). Also clears a missing spaces around '|' checkpatch issue. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/hal/rtl8188eu_xmit.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --g

[PATCH 2/5] staging: rtl8188eu: change type of a struct field

2018-10-27 Thread Michael Straube
The field enable of struct recv_reorder_ctrl is only used for boolean values, so change the type from u8 to bool. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/include/rtw_recv.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/rtl8188eu/include/

[PATCH 1/5] staging: rtl8188eu: remove unnecessary ternary operator

2018-10-27 Thread Michael Straube
The field accept_addba_req of struct mlme_ext_info has type bool. Use the value of accept_addba_req directly instead of the ternary operator in an asignment. Signed-off-by: Michael Straube --- drivers/staging/rtl8188eu/core/rtw_wlan_util.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-)

Re: [PATCH v5 2/2] staging: iio: ad2s1210: Add device tree support.

2018-10-27 Thread Slawomir Stepien
Hi On paź 26, 2018 18:55, Nishad Kamdar wrote: > Add device tree table for matching vendor ID > and support for retrieving platform data > from device tree. So maybe you should make 2 commits? > Signed-off-by: Nishad Kamdar > --- > drivers/staging/iio/resolver/ad2s1210.c | 43 +

[PATCH] staging: rtl8723bs: fix typo in function name rtw_sctx_chk_waring_status

2018-10-27 Thread Colin King
From: Colin Ian King Trivial fix to typo in function name, rename it to rtw_sctx_chk_warning_status. Signed-off-by: Colin Ian King --- drivers/staging/rtl8723bs/core/rtw_xmit.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/rtl8723bs/core/rtw_xmit.c b/

[PATCH] staging: rtl8188eu: fix typo in function name rtw_sctx_chk_waring_status

2018-10-27 Thread Colin King
From: Colin Ian King Trivial fix to typo in function name, rename it to rtw_sctx_chk_warning_status. Signed-off-by: Colin Ian King --- drivers/staging/rtl8188eu/core/rtw_xmit.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/rtl8188eu/core/rtw_xmit.c b/