From: Haiyang Zhang
Date: Mon, 15 Oct 2018 19:06:15 +
> From: Haiyang Zhang
>
> The VF device's serial number is saved as a string in PCI slot's
> kobj name, not the slot->number. This patch corrects the netvsc
> driver, so the VF device can be successfully paired with synthetic
> NIC.
>
>
From: Colin Ian King
Trivial fix to common spelling mistakes in some rtl* drivers
Signed-off-by: Colin Ian King
---
drivers/staging/rtl8188eu/hal/odm.c | 8
drivers/staging/rtl8723bs/hal/odm_EdcaTurboCheck.c | 8
drivers/staging/rtlwifi/phydm/phydm_edcaturb
This patch adds 3 comments in 2 different files.
These comments warn to don't correct the checks of type:
"CHECK: spaces preferred around that '-'"
Signed-off-by: Gabriel Capella
---
drivers/staging/iio/adc/ad7192.c | 1 +
drivers/staging/iio/adc/ad7280a.c | 2 ++
2 files changed, 3 insertions(
This patch adds driver for Nordic Semiconductor nRF24L01+ radio module.
Signed-off-by: Marcin Ciupak
---
drivers/staging/Kconfig | 2 +
drivers/staging/Makefile | 1 +
drivers/staging/nrf24/Kconfig | 16 +
drivers/staging/nrf24/Make
On Mon, Oct 15, 2018 at 12:34 AM Greg Kroah-Hartman
wrote:
>
> On Sun, Oct 14, 2018 at 09:59:17PM -0700, Todd Poynor wrote:
> > From: Todd Poynor
> >
> > Add debug logs for device enable/disable events,
>
> Why?
>
> What is going to need this?
As one of the few people actually developing for Ape
On Mon, 15 Oct 2018 19:06:15 +
Haiyang Zhang wrote:
> From: Haiyang Zhang
>
> The VF device's serial number is saved as a string in PCI slot's
> kobj name, not the slot->number. This patch corrects the netvsc
> driver, so the VF device can be successfully paired with synthetic
> NIC.
>
> F
From: Haiyang Zhang
The VF device's serial number is saved as a string in PCI slot's
kobj name, not the slot->number. This patch corrects the netvsc
driver, so the VF device can be successfully paired with synthetic
NIC.
Fixes: 00d7ddba1143 ("hv_netvsc: pair VF based on serial number")
Reported-
On Wed, Oct 10, 2018 at 2:14 PM Laurence Rochfort
wrote:
>
> Remove the coherent buffer __iomem cookie because the buffer is
> allocated from dma_alloc_coherent().
>
> warning: incorrect type in assignment (different address spaces)
>expected unsigned char [noderef] [usertype] *virt_base
>
checkpatch script is complaining about the use of printk instead
of use more proper dev_* kernel functions. Replace all of them
removing warnings.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 14 --
1 file changed, 8 insertions(+), 6 deletions(-)
d
Driver is using reset_control kernel API's to manage this so this
two macros are not needed anymore. Remove them.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 15 ---
1 file changed, 15 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt762
Add missing system control registers address in pcie node of
the device tree.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-dts/mt7621.dtsi | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/mt7621-dts/mt7621.dtsi
b/drivers/staging/mt7621-dts/
Factor out a new function 'mt7621_enable_phy' for enabling the
pcie phy for each port and call it from 'mt7621_pcie_enable_port'.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 13 ++---
1 file changed, 10 insertions(+), 3 deletions(-)
diff --git a/drive
Function 'bypass_pipe_rst' and 'set_phy_for_ssc' can be
written in a cleaner way. Instead of use comments to see which
bits are the ones which are being enabled add new macros with
that information using BIT and GENMASK kernel macros. Avoid the
use of set_pcie_phy which is kind of dark and use new
This file has a valid SPDX license line added so reamining
GPL2+ boilerplate text is not needed at all. Remove it.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 31 +++
1 file changed, 3 insertions(+), 28 deletions(-)
diff --git a/dr
Move debug for the port N_FTS from driver probe function to the more
appropiate one 'mt7621_pcie_enable_port'.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt
Rename function 'mt7621_pcie_enable_port' with a name which is better
for what the function is really doing calling it 'mt7621_pcie_init_port'.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/dr
This two lines whch are commented are not needed at all.
Remove them.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 5 -
1 file changed, 5 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
b/drivers/staging/mt7621-pci/pci-mt7621.c
index d61
Reset bits related macros are in different parts. Reagroup
all of them together to improve readability.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
Chackpatch script is compalining about one comment which
is not following the kernel style. Fix it.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 6 --
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
b/d
There are three macros which are not being used at all.
Remove them.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 4
1 file changed, 4 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
b/drivers/staging/mt7621-pci/pci-mt7621.c
index c4adf
There are some pointer read and writes which can be replaced
properly using sysctl registers readed from device tree. Remap
sysctl registers and replace in proper places.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 38 -
1 file
Add initialization of each PCIe port reading and initializing
data using device tree.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 75 +++--
1 file changed, 71 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pc
mt7621-pcie_port data structure has filed 'base' as the base address for
read and write related port registers. Create two inline functions
'pcie_port_read' and 'pcie_port_write' to make this task easier and
code more readable.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci
Driver probe function calls 'devm_pci_alloc_host_bridge'. If this call fails
it is returning -ENODEV. Return -ENOMEM instead which is more accurate for
this.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff
Driver probe function is a mess and shall be refactored a lot. At first
make use of assert and deassert control factoring out a new function
called 'mt7621_pcie_enable_port'.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 88 +++--
1 f
This patch series parse remaining port info from device tree storing
it in mt7621_pcie_port struct created for this.
Also minor cleanups are performed here:
- Remove not used macros.
- Use kernel reset_control functions.
- Remove unused code.
Changes in v5:
- Patch 18 removed from
Dear Sir, Madam,
A Strictly Confidential Business Proposal
I am Mr.John Woods, a Consultant with the Department of Power and Steel here in
Spain . I have been contracted by a wealthy individual and serving government
official from somewhere in Africa who is interested in engaging your service
Dear Sir, Madam,
A Strictly Confidential Business Proposal
I am Mr.John Woods, a Consultant with the Department of Power and Steel here in
Spain . I have been contracted by a wealthy individual and serving government
official from somewhere in Africa who is interested in engaging your service
Stefan Wahren writes:
> Hi Tuomas,
>
>> Tuomas Tynkkynen hat am 4. Oktober 2018 um 11:37
>> geschrieben:
>>
>>
>> Drop various pieces of dead code from here and there to get rid of
>> the remaining users of VCHI_CONNECTION_T. After that we get to drop
>> entire header files worth of unused co
On Thu, Oct 11, 2018 at 04:00:29PM -0700, Andy Lutomirski wrote:
> On Thu, Oct 11, 2018 at 3:28 PM Marcelo Tosatti wrote:
> >
> > On Tue, Oct 09, 2018 at 01:09:42PM -0700, Andy Lutomirski wrote:
> > > On Tue, Oct 9, 2018 at 8:28 AM Marcelo Tosatti
> > > wrote:
> > > >
> > > > On Mon, Oct 08, 201
Hi Paolo:
Thanks for your review.
On Mon, Oct 15, 2018 at 6:04 PM Paolo Bonzini wrote:
>
> On 13/10/2018 16:53, lantianyu1...@gmail.com wrote:
> > + bool flush = false;
> > int i;
> >
> > spin_lock(&kvm->mmu_lock);
> > @@ -5654,18 +5655,27 @@ void kvm_zap_gfn_range(s
On 13/10/2018 16:53, lantianyu1...@gmail.com wrote:
> From: Lan Tianyu
>
> For nested memory virtualization, Hyper-v doesn't set write-protect
> L1 hypervisor EPT page directory and page table node to track changes
> while it relies on guest to tell it changes via HvFlushGuestAddressLlist
> hype
On 14/10/2018 10:16, Thomas Gleixner wrote:
>>> +static inline bool kvm_available_flush_tlb_with_range(void)
>>> +{
>>> + return kvm_x86_ops->tlb_remote_flush_with_range;
>>> +}
>> Seems that kvm_available_flush_tlb_with_range() is not used in this patch…
> What's wrong with that?
>
> It provid
On 13/10/2018 16:53, lantianyu1...@gmail.com wrote:
> @@ -1781,6 +1781,11 @@ static int kvm_set_pte_rmapp(struct kvm *kvm, struct
> kvm_rmap_head *rmap_head,
> }
> }
>
> + if (need_flush && kvm_available_flush_tlb_with_range()) {
> + kvm_flush_remote_tlbs_with
On 13/10/2018 16:54, lantianyu1...@gmail.com wrote:
> while (mmu_unsync_walk(parent, &pages)) {
> bool protected = false;
> + LIST_HEAD(flush_list);
>
> - for_each_sp(pages, sp, parents, i)
> + for_each_sp(pages, sp, parents, i) {
>
On Mon, Oct 15, 2018 at 03:29:49AM -0700, Christoph Hellwig wrote:
> On Sun, Oct 14, 2018 at 09:59:16PM -0700, Todd Poynor wrote:
> > From: Todd Poynor
> >
> > Various fixes for gasket/apex drivers.
>
> I still can't find any explanation in the staging tree or in your
> comments what gasket even
On 13/10/2018 16:54, lantianyu1...@gmail.com wrote:
>
> +static int fill_flush_list(union hv_gpa_page_range gpa_list[],
> + int offset, u64 start_gfn, u64 pages)
Pass the entire struct hv_guest_mapping_flush_list to this function,
it's simpler and it hides the gpa_list argument from
r
On Sun, Oct 14, 2018 at 09:59:16PM -0700, Todd Poynor wrote:
> From: Todd Poynor
>
> Various fixes for gasket/apex drivers.
I still can't find any explanation in the staging tree or in your
comments what gasket even is.
___
devel mailing list
de...@lin
On Mon, Oct 15, 2018 at 12:33 AM Greg Kroah-Hartman
wrote:
>
> On Sun, Oct 14, 2018 at 09:59:16PM -0700, Todd Poynor wrote:
> > From: Todd Poynor
> >
> > Various fixes for gasket/apex drivers.
>
> For some reason you seem to have ignored/missed this patch:
> Subject: [PATCH v3] staging: g
On 13/10/2018 16:54, lantianyu1...@gmail.com wrote:
> From: Lan Tianyu
>
> PV EPT tlb flush function will accept a list of flush ranges and
> use struct kvm_mmu_page as the list entry.
>
> Signed-off-by: Lan Tianyu
> ---
> arch/x86/include/asm/kvm_host.h | 1 +
> 1 file changed, 1 insertion(+)
On 13/10/2018 16:53, lantianyu1...@gmail.com wrote:
> + bool flush = false;
> int i;
>
> spin_lock(&kvm->mmu_lock);
> @@ -5654,18 +5655,27 @@ void kvm_zap_gfn_range(struct kvm *kvm, gfn_t
> gfn_start, gfn_t gfn_end)
> slots = __kvm_memslots(kvm, i);
>
Sent to email: driverdev-devel@linuxdriverproject.org
Greetings ,
I appreciate your interest on this, I'm the investment broker to
Mr. Von Johannes 79yrs a successful politician, He's married to
Liu Chuo Johannes.She is a Chinese, They been married for 48yrs
with a daughter whom they lost last
On Sun, Oct 14, 2018 at 09:59:21PM -0700, Todd Poynor wrote:
> From: Nick Ewalt
>
> Rearrange gasket_page_table entry to reduce padding slop.
In the future, defining exactly what "slop" is here would be nice :)
thanks,
greg k-h
___
devel mailing list
On Sun, Oct 14, 2018 at 09:59:17PM -0700, Todd Poynor wrote:
> From: Todd Poynor
>
> Add debug logs for device enable/disable events,
Why?
What is going to need this?
> remove logs for
> callbacks (the called functions can generate their own logs if needed).
That's a different thing than "add
On Sun, Oct 14, 2018 at 09:59:16PM -0700, Todd Poynor wrote:
> From: Todd Poynor
>
> Various fixes for gasket/apex drivers.
For some reason you seem to have ignored/missed this patch:
Subject: [PATCH v3] staging: gasket: Fix sparse "incorrect type in
assignment" warnings.
that was sent
45 matches
Mail list logo