On Wed, Sep 26, 2018 at 08:49:15AM +0200, Greg Kroah-Hartman wrote:
> On Tue, Sep 25, 2018 at 11:44:37PM -0700, Nathan Chancellor wrote:
> > On Wed, Sep 26, 2018 at 08:22:45AM +0200, Greg Kroah-Hartman wrote:
> > > On Tue, Sep 25, 2018 at 10:39:10PM -0700, Nathan Chancellor wrote:
> > > > Clang war
On Tue, Sep 25, 2018 at 11:44:37PM -0700, Nathan Chancellor wrote:
> On Wed, Sep 26, 2018 at 08:22:45AM +0200, Greg Kroah-Hartman wrote:
> > On Tue, Sep 25, 2018 at 10:39:10PM -0700, Nathan Chancellor wrote:
> > > Clang warns that the acpi_id declaration is not going to be emitted
> > > in the fina
On Wed, Sep 26, 2018 at 08:22:45AM +0200, Greg Kroah-Hartman wrote:
> On Tue, Sep 25, 2018 at 10:39:10PM -0700, Nathan Chancellor wrote:
> > Clang warns that the acpi_id declaration is not going to be emitted
> > in the final assembly:
> >
> > drivers/staging/rtl8723bs/os_dep/sdio_intf.c:25:36: wa
On Tue, Sep 25, 2018 at 10:39:10PM -0700, Nathan Chancellor wrote:
> Clang warns that the acpi_id declaration is not going to be emitted
> in the final assembly:
>
> drivers/staging/rtl8723bs/os_dep/sdio_intf.c:25:36: warning: variable
> 'acpi_ids' is not needed and will not be emitted
> [-Wunneed
Clang warns that the acpi_id declaration is not going to be emitted
in the final assembly:
drivers/staging/rtl8723bs/os_dep/sdio_intf.c:25:36: warning: variable
'acpi_ids' is not needed and will not be emitted
[-Wunneeded-internal-declaration]
static const struct acpi_device_id acpi_ids[] = {
How about making it selected based on COMEDI_NI_TIO? This will impact
all the *mio* (except ATMIO16D) and 660x drivers. This seems to be
everything that fits into the e-series, m-series, and 660x series
devices for which we know the register values. It also doesn't look
like anything else depend
On Tue, Sep 25, 2018 at 01:52:57PM -0400, Stephen Smalley wrote:
> On 09/25/2018 01:27 PM, Tong Zhang wrote:
> > Kernel Version: 4.18.5
> >
> > Problem Description:
> >
> > When setting nice value, it is checked by LSM function
> > security_task_setnice().
> > see kernel/sched/core.c:3972 SYSCAL
On Tue, Sep 25 2018, Joe Perches wrote:
> On Tue, 2018-09-25 at 20:49 +0200, Greg Kroah-Hartman wrote:
>> On Sun, Sep 23, 2018 at 06:31:32AM -0700, Joe Perches wrote:
>> > On Sun, 2018-09-23 at 15:08 +0530, Nishad Kamdar wrote:
>> > > This patch fixes a few single statement macros in sd.c.
>> > >
On Tue, Sep 25, 2018 at 6:26 AM Ian Abbott wrote:
>
> On 25/09/18 05:47, Spencer E. Olson wrote:
>
> [N.B. top-posting is frowned upon on the kernel mailing lists.]
Sorry :-)
>
> > These static arrays are
> >(1) not expressed with as much "const"ness as suggested
> >(2) included into one
Looks good now.
On 18-09-25 01:33 AM, Aymen Qader wrote:
Update the bcm2835-camera driver to remove a TODO and an unused header
include. These were made unnecessary in
commit 7e8dbea41032 ("staging: bcm2835-camera: Remove explicit cache
flush operations")
Aymen Qader (2):
staging: bcm2835-
Replace Kconfig help header and text to match other modules. Issue found
by checkpatch.
Spacing adjusted to match Documentation/process/coding-style.rst. Issue
reported by rdun...@infradead.org.
Reported-by: Randy Dunlap
Signed-off-by: Sehro Rautenkranz
---
drivers/staging/dgnc/Kconfig | 14 ++
On Tue, Sep 25, 2018 at 4:27 AM Ian Abbott wrote:
>
> On 19/09/18 17:38, Spencer E. Olson wrote:
> > Implement device-global config interface for ni_mio devices. In
> > particular, this patch implements:
> > INSN_DEVICE_CONFIG_TEST_ROUTE,
> > INSN_DEVICE_CONFIG_CONNECT_ROUTE,
> > INSN_DEVICE_CONF
On Tue, 2018-09-25 at 20:49 +0200, Greg Kroah-Hartman wrote:
> On Sun, Sep 23, 2018 at 06:31:32AM -0700, Joe Perches wrote:
> > On Sun, 2018-09-23 at 15:08 +0530, Nishad Kamdar wrote:
> > > This patch fixes a few single statement macros in sd.c.
> > > It converts two macros to inline functions. It
> Aymen Qader hat am 25. September 2018 um 10:33
> geschrieben:
>
>
> Update the bcm2835-camera driver to remove a TODO and an unused header
> include. These were made unnecessary in
>
> commit 7e8dbea41032 ("staging: bcm2835-camera: Remove explicit cache
> flush operations")
>
> Aymen Qade
On 9/25/18 11:46 AM, Greg Kroah-Hartman wrote:
> On Tue, Sep 25, 2018 at 10:22:24AM -0600, sehro rautenkranz wrote:
>> Replace Kconfig help header and text to match other modules. Issue found
>> my checkpatch.
>>
>> Spacing adjusted to match Documentation/process/coding-style.rst. Issue
>> reported
On Tue, Sep 25, 2018 at 09:07:11PM +0200, Greg Kroah-Hartman wrote:
> On Thu, Sep 20, 2018 at 05:22:21PM -0700, Nathan Chancellor wrote:
> > Clang generates a warning when it sees a logical not followed by a
> > conditional operator like ==, >, or < because it thinks that the logical
> > not should
Clang generates a warning when it sees a logical not followed by a
conditional operator like ==, >, or < because it thinks that the logical
not should be applied to the whole statement:
drivers/staging/rtl8188eu/core/rtw_ieee80211.c:293:8: warning: logical
not is only applied to the left hand side
On Thu, Sep 20, 2018 at 05:22:21PM -0700, Nathan Chancellor wrote:
> Clang generates a warning when it sees a logical not followed by a
> conditional operator like ==, >, or < because it thinks that the logical
> not should be applied to the whole statement:
>
> drivers/staging/rtl8188eu/core/rtw_
On Sun, Sep 23, 2018 at 06:31:32AM -0700, Joe Perches wrote:
> On Sun, 2018-09-23 at 15:08 +0530, Nishad Kamdar wrote:
> > This patch fixes a few single statement macros in sd.c.
> > It converts two macros to inline functions. It removes
> > five other macros and replaces their usages with calls to
On Tue, Sep 25, 2018 at 10:22:24AM -0600, sehro rautenkranz wrote:
> Replace Kconfig help header and text to match other modules. Issue found
> my checkpatch.
>
> Spacing adjusted to match Documentation/process/coding-style.rst. Issue
> reported by rdun...@infradead.org. (try 2)
The "try 2" needs
Good day,
Pls find here attached notice of arrival, cargo details,and cargo
manifest for the above vsl.
Thanks & B.rgds,
Abas Rifai
Export Department
YUSEN LOGISTICS INDONESIA
Soewarna Business Park Block A Lot 1-2 Soekarno Hatta Intl Airport,
Jakarta
T : +6221- 55912914 EXT : 454 M : +62812
On Tue 25-09-18 11:59:09, Vlastimil Babka wrote:
[...]
> This seems like almost complete copy of __free_pages_boot_core(), could
> you do some code reuse instead? I think Michal Hocko also suggested that.
Yes, please try to reuse as much code as possible
--
Michal Hocko
SUSE Labs
___
On 09/25/2018 01:27 PM, Tong Zhang wrote:
Kernel Version: 4.18.5
Problem Description:
When setting nice value, it is checked by LSM function security_task_setnice().
see kernel/sched/core.c:3972 SYSCALL_DEFINE1(nice, int, increment)
We discovered a leaking path in android binder which allows u
On Tue, Sep 25, 2018 at 01:27:11PM -0400, Tong Zhang wrote:
> Kernel Version: 4.18.5
>
> Problem Description:
>
> When setting nice value, it is checked by LSM function
> security_task_setnice().
> see kernel/sched/core.c:3972 SYSCALL_DEFINE1(nice, int, increment)
>
> We discovered a leaking pa
Kernel Version: 4.18.5
Problem Description:
When setting nice value, it is checked by LSM function security_task_setnice().
see kernel/sched/core.c:3972 SYSCALL_DEFINE1(nice, int, increment)
We discovered a leaking path in android binder which allows using binder’s
interface to change
a proces
Replace Kconfig help header and text to match other modules. Issue found
my checkpatch.
Spacing adjusted to match Documentation/process/coding-style.rst. Issue
reported by rdun...@infradead.org. (try 2)
Signed-off-by: sehro rautenkranz
---
drivers/staging/dgnc/Kconfig | 14 +-
1 fil
On Sun, Sep 23, 2018 at 06:31:32AM -0700, Joe Perches wrote:
> On Sun, 2018-09-23 at 15:08 +0530, Nishad Kamdar wrote:
> > This patch fixes a few single statement macros in sd.c.
> > It converts two macros to inline functions. It removes
> > five other macros and replaces their usages with calls to
On 9/25/18 8:53 AM, sehro rautenkranz wrote:
> Replace Kconfig help header and text to match other modules. Issue found
> my checkpatch.
by checkpatch.
>
> Spacing adjusted to match Documentation/process/coding-style.rst. Issue
> reported by rdun...@infradead.org.
Reported-by: Randy Dunlap
Replace Kconfig help header and text to match other modules. Issue found
my checkpatch.
Spacing adjusted to match Documentation/process/coding-style.rst. Issue
reported by rdun...@infradead.org.
Signed-off-by: sehro rautenkranz
---
drivers/staging/dgnc/Kconfig | 8
1 file changed, 4 in
On 9/24/18 11:20 PM, sehro rautenkranz wrote:
> Replace Kconfig help header and text to match other modules. Issue found
> by checkpatch.
>
> Signed-off-by: sehro rautenkranz
> ---
Hi,
Documentation/process/coding-style.rst says:
Lines under a ``config`` definition
are indented with one tab, w
Fixes the following sparse warning:
drivers/android/binder.c:3312:1: warning:
symbol 'binder_free_buf' was not declared. Should it be static?
Signed-off-by: Wei Yongjun
---
drivers/android/binder.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/android/binder.c b/d
On 25/09/18 05:47, Spencer E. Olson wrote:
[N.B. top-posting is frowned upon on the kernel mailing lists.]
These static arrays are
(1) not expressed with as much "const"ness as suggested
(2) included into one compile unit
because
- ni_device_routes.routes and ni_route_set.src are sorted
On Tue, Sep 25, 2018 at 11:14:56AM +0200, David Hildenbrand wrote:
> Let's perform all checking + offlining + removing under
> device_hotplug_lock, so nobody can mess with these devices via
> sysfs concurrently.
>
> Cc: Benjamin Herrenschmidt
> Cc: Paul Mackerras
> Cc: Michael Ellerman
> Cc: Ra
The function rtw_scan_abort() is never used, so remove it.
Discovered by cppcheck.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_mlme.c| 23
drivers/staging/rtl8188eu/include/rtw_mlme.h | 1 -
2 files changed, 24 deletions(-)
diff --git a/driver
There is only one struct in rtw_qos.h and it is only included from
drv_types.h. Move the struct into drv_types.h to reduce the number
of header files.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/include/drv_types.h | 7 ++-
drivers/staging/rtl8188eu/include/rtw_qos.h | 18
On 19/09/18 17:38, Spencer E. Olson wrote:
Adds interface and associated unittests for accessing/looking-up/validating
the new ni routing table information.
Signed-off-by: Spencer E. Olson
---
drivers/staging/comedi/Kconfig| 4 +
drivers/staging/comedi/drivers/Makefile
On 19/09/18 17:38, Spencer E. Olson wrote:
Implement device-global config interface for ni_mio devices. In
particular, this patch implements:
INSN_DEVICE_CONFIG_TEST_ROUTE,
INSN_DEVICE_CONFIG_CONNECT_ROUTE,
INSN_DEVICE_CONFIG_DISCONNECT_ROUTE,
INSN_DEVICE_CONFIG_GET_ROUTES
for the ni mio devices
On 9/25/18 7:42 AM, Arun KS wrote:
> When free pages are done with higher order, time spend on
> coalescing pages by buddy allocator can be reduced. With
> section size of 256MB, hot add latency of a single section
> shows improvement from 50-60 ms to less than 1 ms, hence
> improving the hot add l
device_online() should be called with device_hotplug_lock() held.
Cc: Benjamin Herrenschmidt
Cc: Paul Mackerras
Cc: Michael Ellerman
Cc: Rashmica Gupta
Cc: Balbir Singh
Cc: Michael Neuling
Reviewed-by: Pavel Tatashin
Reviewed-by: Rashmica Gupta
Signed-off-by: David Hildenbrand
---
arch/p
There seem to be some problems as result of 30467e0b3be ("mm, hotplug:
fix concurrent memory hot-add deadlock"), which tried to fix a possible
lock inversion reported and discussed in [1] due to the two locks
a) device_lock()
b) mem_hotplug_lock
While add_memory() first takes b), f
Let's document the magic a bit, especially why device_hotplug_lock is
required when adding/removing memory and how it all play together with
requests to online/offline memory from user space.
Cc: Jonathan Corbet
Cc: Michal Hocko
Cc: Andrew Morton
Reviewed-by: Pavel Tatashin
Reviewed-by: Rashmi
Let's perform all checking + offlining + removing under
device_hotplug_lock, so nobody can mess with these devices via
sysfs concurrently.
Cc: Benjamin Herrenschmidt
Cc: Paul Mackerras
Cc: Michael Ellerman
Cc: Rashmica Gupta
Cc: Balbir Singh
Cc: Michael Neuling
Reviewed-by: Pavel Tatashin
R
Reading through the code and studying how mem_hotplug_lock is to be used,
I noticed that there are two places where we can end up calling
device_online()/device_offline() - online_pages()/offline_pages() without
the mem_hotplug_lock. And there are other places where we call
device_online()/device_o
add_memory() currently does not take the device_hotplug_lock, however
is aleady called under the lock from
arch/powerpc/platforms/pseries/hotplug-memory.c
drivers/acpi/acpi_memhotplug.c
to synchronize against CPU hot-remove and similar.
In general, we should hold the device_hotplug
remove_memory() is exported right now but requires the
device_hotplug_lock, which is not exported. So let's provide a variant
that takes the lock and only export that one.
The lock is already held in
arch/powerpc/platforms/pseries/hotplug-memory.c
drivers/acpi/acpi_memhotplug.c
Remove the TODO item to remove manual cache flushing from bulk_receive.
This was previously done in this commit:
commit 7e8dbea41032 ("staging: bcm2835-camera: Remove explicit cache
flush operations")
Signed-off-by: Aymen Qader
---
drivers/staging/vc04_services/bcm2835-camera/TODO | 6 --
1
Update the bcm2835-camera driver to remove a TODO and an unused header
include. These were made unnecessary in
commit 7e8dbea41032 ("staging: bcm2835-camera: Remove explicit cache
flush operations")
Aymen Qader (2):
staging: bcm2835-camera: Update TODO
staging: bcm2835-camera: Remove unused h
Remove the TODO item to remove manual cache flushing from bulk_receive.
This was previously done in this commit:
commit 7e8dbea41032 ("staging: bcm2835-camera: Remove explicit cache
flush operations")
Signed-off-by: Aymen Qader
---
drivers/staging/vc04_services/bcm2835-camera/TODO | 6 --
1
Update the bcm2835-camera driver to remove a TODO and an unused header
include. These were made unnecessary in
commit 7e8dbea41032 ("staging: bcm2835-camera: Remove explicit cache
flush operations")
Aymen Qader (2):
staging: bcm2835-camera: Update TODO
staging: bcm2835-camera: Remove unused h
Remove the asm/cacheflush.h header include from mmal-vchiq.c. This
dependency was removed in:
commit 7e8dbea41032 ("staging: bcm2835-camera: Remove explicit cache
flush operations")
Signed-off-by: Aymen Qader
---
drivers/staging/vc04_services/bcm2835-camera/mmal-vchiq.c | 1 -
1 file changed, 1
Remove the asm/cacheflush.h header include from mmal-vchiq.c. This
dependency was removed in:
commit 7e8dbea41032 ("staging: bcm2835-camera: Remove explicit cache
flush operations")
Signed-off-by: Aymen Qader
---
drivers/staging/vc04_services/bcm2835-camera/mmal-vchiq.c | 1 -
1 file changed, 1
Looks fine, thanks.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
Hi Aymen,
there are more than one TODO file in vc04_services (contains 3 drivers),
so here is my suggestion for the subject:
staging: bcm2835-camera: Update TODO
Am 25.09.2018 um 01:34 schrieb Aymen Qader:
> Remove the TODO item to remove manual cache flushing from bulk_receive.
> This was pre
53 matches
Mail list logo