On 2018/8/31 0:32, Gao Xiang via Linux-erofs wrote:
>
>
> On 2018/8/31 0:09, Gao Xiang via Linux-erofs wrote:
>> Hi Pavel,
>>
>> On 2018/8/30 23:13, Pavel Zemlyanoy wrote:
>>> This patch does not change the logic, it only
>>> corrects the formatting and checkpatch checks by
>>> to NULL comparison
On Wed, 2018-08-29 at 22:55 +0100, John Whitmore wrote:
> On Wed, Aug 29, 2018 at 04:21:54PM -0500, Larry Finger wrote:
> > On 08/29/2018 04:14 PM, Joe Perches wrote:
[]
> > > Perhaps support for the chipset could be converted to use
> > > mac80211 and moved into the directory with the other realte
Hi all,
On 08/07/2018 02:57 PM, Steve Longerbeam wrote:
On 08/06/2018 01:34 AM, Daniel Vetter wrote:
On Fri, Jul 20, 2018 at 10:17:29AM -0700, Steve Longerbeam wrote:
Adds crtc page-flip support by passing the new requested framebuffer
to vbox_crtc_do_set_base().
There is no attempt to supp
On Thu, Aug 30, 2018 at 11:26:28AM +0300, Dan Carpenter wrote:
> On Thu, Aug 30, 2018 at 11:23:05AM +0300, Dan Carpenter wrote:
> > On Wed, Aug 29, 2018 at 09:35:27PM +0100, John Whitmore wrote:
> > > Rename the bit field element AdvCoding, as it causes a checkpatch issue
> > > with CamelCase namin
Signed-off-by: Thomas Weißschuh
---
drivers/staging/erofs/data.c | 4 +--
drivers/staging/erofs/dir.c | 14
drivers/staging/erofs/inode.c | 6 ++--
drivers/staging/erofs/namei.c | 28
drivers/staging/erofs/super.c | 2 +-
dri
Reviewed-by: Pavel Tatashin
On 8/21/18 6:44 AM, David Hildenbrand wrote:
> Let's perform all checking + offlining + removing under
> device_hotplug_lock, so nobody can mess with these devices via
> sysfs concurrently.
>
> Cc: Benjamin Herrenschmidt
> Cc: Paul Mackerras
> Cc: Michael Ellerman
Reviewed-by: Pavel Tatashin
On 8/21/18 6:44 AM, David Hildenbrand wrote:
> device_online() should be called with device_hotplug_lock() held.
>
> Cc: Benjamin Herrenschmidt
> Cc: Paul Mackerras
> Cc: Michael Ellerman
> Cc: Rashmica Gupta
> Cc: Balbir Singh
> Cc: Michael Neuling
> Signed-off
Reviewed-by: Pavel Tatashin
On 8/21/18 6:44 AM, David Hildenbrand wrote:
> Let's document the magic a bit, especially why device_hotplug_lock is
> required when adding/removing memory and how it all play together with
> requests to online/offline memory from user space.
>
_
On 8/21/18 6:44 AM, David Hildenbrand wrote:
> There seem to be some problems as result of 30467e0b3be ("mm, hotplug:
> fix concurrent memory hot-add deadlock"), which tried to fix a possible
> lock inversion reported and discussed in [1] due to the two locks
> a) device_lock()
> b) mem
On 8/21/18 6:44 AM, David Hildenbrand wrote:
> add_memory() currently does not take the device_hotplug_lock, however
> is aleady called under the lock from
> arch/powerpc/platforms/pseries/hotplug-memory.c
> drivers/acpi/acpi_memhotplug.c
> to synchronize against CPU hot-remove and simi
> +
> +void __ref remove_memory(int nid, u64 start, u64 size)
Remove __ref, otherwise looks good:
Reviewed-by: Pavel Tatashin
> +{
> + lock_device_hotplug();
> + __remove_memory(nid, start, size);
> + unlock_device_hotplug();
> +}
> EXPORT_SYMBOL_GPL(remove_memory);
> #endif /* CO
> -Original Message-
> From: mhkelle...@gmail.com
> Sent: Wednesday, August 29, 2018 10:22 AM
> To: will.dea...@arm.com; catalin.mari...@arm.com;
> mark.rutl...@arm.com; marc.zyng...@arm.com; linux-arm-
> ker...@lists.infradead.org; gre...@linuxfoundation.org; linux-
> ker...@vger.kerne
> -Original Message-
> From: mhkelle...@gmail.com
> Sent: Wednesday, August 29, 2018 10:22 AM
> To: will.dea...@arm.com; catalin.mari...@arm.com;
> mark.rutl...@arm.com; marc.zyng...@arm.com; linux-arm-
> ker...@lists.infradead.org; gre...@linuxfoundation.org; linux-
> ker...@vger.kerne
> From: KY Srinivasan
> Sent: Thursday, August 30, 2018 10:32
> > > */
> > >if (version >= VERSION_WIN8_1) {
> > >msg->target_vcpu =
> > > -hv_cpu_number_to_vp_number(smp_processor_id());
> > > - vmbus_connection.connect_cpu = smp_processor_id();
> >
> > > +
> -Original Message-
> From: Dexuan Cui
> Sent: Thursday, August 30, 2018 12:27 PM
> To: KY Srinivasan ; 'gre...@linuxfoundation.org'
> ; Stephen Hemminger
> ; Haiyang Zhang
> Cc: 'linux-ker...@vger.kernel.org' ;
> 'driverdev-devel@linuxdriverproject.org' de...@linuxdriverproject.org>;
> From: KY Srinivasan
> Sent: Thursday, August 30, 2018 09:28
> ...
> diff --git a/drivers/hv/connection.c b/drivers/hv/connection.c
> @@ -119,8 +119,9 @@ static int vmbus_negotiate_version(struct
> vmbus_channel_msginfo *msginfo,
> */
>if (version >= VERSION_WIN8_1) {
>msg->ta
> -Original Message-
> From: Dexuan Cui
> Sent: Thursday, August 23, 2018 3:31 PM
> To: 'gre...@linuxfoundation.org' ; KY
> Srinivasan ; Stephen Hemminger
> ; Haiyang Zhang
> Cc: 'linux-ker...@vger.kernel.org' ;
> 'driverdev-devel@linuxdriverproject.org' de...@linuxdriverproject.org>; 'o.
On 2018/8/31 0:09, Gao Xiang via Linux-erofs wrote:
> Hi Pavel,
>
> On 2018/8/30 23:13, Pavel Zemlyanoy wrote:
>> This patch does not change the logic, it only
>> corrects the formatting and checkpatch checks by
>> to NULL comparison.
>>
>> The patch fixes 5 checks of type:
>> "Comparison to NU
Hi Pavel,
On 2018/8/30 23:13, Pavel Zemlyanoy wrote:
> This patch does not change the logic, it only
> corrects the formatting and checkpatch checks by
> to NULL comparison.
>
> The patch fixes 5 checks of type:
> "Comparison to NULL could be written".
>
> Signed-off-by: Pavel Zemlyanoy
Sorry
On 8/30/18 8:31 AM, David Hildenbrand wrote:
> On 21.08.2018 12:44, David Hildenbrand wrote:
>> This is the same approach as in the first RFC, but this time without
>> exporting device_hotplug_lock (requested by Greg) and with some more
>> details and documentation regarding locking. Tested only
On Wed, Aug 29, 2018 at 12:00 AM Christoph Hellwig wrote:
>
> > config ANDROID_BINDER_IPC
> > bool "Android Binder IPC Driver"
> > - depends on MMU
> > + depends on MMU && !CPU_CACHE_VIVT
>
> Thats is a purely arm specific symbol which should not be
> used in common code. Nevermind
From: Miguel Ojeda
> Sent: 30 August 2018 12:11
...
> > + unsigned long value_bitmap[1]; /* for DATA[0-7], RS, RW */
>
> (I read your comments in the other email)
>
> I still find this odd, but if everyone is going to have this change
> done like this, consistency is better.
Maybe there o
This patch does not change the logic, it only
corrects the formatting and checkpatch check by
adding spaces around '*'.
The patch fixes 1 check of type:
"Check: spaces preferred around that '*'".
Signed-off-by: Pavel Zemlyanoy
---
drivers/staging/erofs/unzip_vle_lz4.c | 2 +-
1 file changed, 1
This patch does not change the logic, it only
corrects the formatting and checkpatch checks by
adding spaces around '-'.
The patch fixes 4 checks of type:
"Check: spaces preferred around that '-'".
Signed-off-by: Pavel Zemlyanoy
---
drivers/staging/erofs/unzip_vle_lz4.c | 8
1 file cha
This patch does not change the logic, it only
corrects the formatting and checkpatch checks by
to NULL comparison.
The patch fixes 5 checks of type:
"Comparison to NULL could be written".
Signed-off-by: Pavel Zemlyanoy
---
drivers/staging/erofs/unzip_vle_lz4.c | 10 +-
1 file changed, 5
This patch does not change the logic, it only
corrects the formatting and checkpatch checks by
braces {} should be used on all arms of this statement,
unbalanced braces around else statement and warning by
braces {} are not necessary for any arm of this statement.
The patch fixes 9 checks of type:
This patch does not change the logic, it only
corrects the formatting and checkpatch check by
alignment should match open parenthesis.
The patch fixes 2 check of type:
"Check: Alignment should match open parenthesis".
Signed-off-by: Pavel Zemlyanoy
---
drivers/staging/erofs/unzip_vle_lz4.c | 4
This patch does not change the logic, it only
corrects the formatting and checkpatch warnings by
adding "int" to the unsigned type.
The patch fixes 11 warnings of the type:
"WARNING: Prefer 'unsigned int' to bare use of 'unsigned'"
Signed-off-by: Pavel Zemlyanoy
---
drivers/staging/erofs/unzi
Functions port_vlans_add() and port_vlans_del() could,
in theory, return an uninitialized variable. Fix this
by initializing the variable in question at declaration.
Signed-off-by: Ioana Radulescu
Reported-by: Dan Carpenter
---
drivers/staging/fsl-dpaa2/ethsw/ethsw.c | 4 ++--
1 file changed, 2
On Thu, 2018-08-30 at 11:28 +0300, Dan Carpenter wrote:
> On Wed, Aug 29, 2018 at 06:03:26PM -0400, Nicholas Krause wrote:
> > Fix a checkpatch warning for the file, fwserial.c that warns about
> > alignment between parentheses and the line belows code not being
> > properly aligned with each other
On 21.08.2018 12:44, David Hildenbrand wrote:
> This is the same approach as in the first RFC, but this time without
> exporting device_hotplug_lock (requested by Greg) and with some more
> details and documentation regarding locking. Tested only on x86 so far.
>
I'll be on vacation for two weeks
k...@linuxonhyperv.com writes:
> From: Stephen Hemminger
>
> For unsupported device types, the vmbus channel ringbuffer is never
> initialized, and therefore reading the sysfs files will return garbage
> or cause a kernel OOPS.
>
> Fixes: c2e5df616e1a ("vmbus: add per-channel sysfs info")
>
> Sig
Hi Janusz,
On Wed, Aug 29, 2018 at 10:48 PM, Janusz Krzysztofik
wrote:
> Most users of get/set array functions iterate consecutive bits of data,
> usually a single integer, while processing array of results obtained
> from, or building an array of values to be passed to those functions.
> Save ti
On Thu, Aug 30, 2018 at 01:40:07PM +0300, Pavel Zemlyanoy wrote:
> This patch changes the coding style for unzip_vle_lz4.c,
> following the accepted formatting rules.
>
> Signed-off-by: Pavel Zemlyanoy
> ---
> drivers/staging/erofs/unzip_vle_lz4.c | 72
> ++-
> 1
This patch changes the coding style for unzip_vle_lz4.c,
following the accepted formatting rules.
Signed-off-by: Pavel Zemlyanoy
---
drivers/staging/erofs/unzip_vle_lz4.c | 72 ++-
1 file changed, 37 insertions(+), 35 deletions(-)
diff --git a/drivers/staging/ero
On Wed, Aug 29, 2018 at 02:37:36PM +0300, Dan Carpenter wrote:
> On Tue, Aug 28, 2018 at 08:26:13PM +0100, Tim Collier wrote:
> > checkpatch reported a number of "Avoid CamelCase" issues for macros
> > defined in p80211metadef.h (and for files that used these macros).
> >
> > Renamed the macros to
On Wed, Aug 29, 2018 at 02:39:30PM +0300, Dan Carpenter wrote:
> On Tue, Aug 28, 2018 at 08:26:22PM +0100, Tim Collier wrote:
> > Remove braces from an if statement with only a single line in the if
> > block.
> >
> > Signed-off-by: Tim Collier
> > ---
> > drivers/staging/wlan-ng/hfa384x_usb.c |
On Mon, Aug 13, 2018 at 04:50:16PM +0200, Thierry Reding wrote:
> static void tegra_vde_setup_iram_tables(struct tegra_vde *vde,
> + unsigned int num_ref_pics,
> struct video_frame *dpb_frames,
>
On Wed, Aug 29, 2018 at 06:03:26PM -0400, Nicholas Krause wrote:
> Fix a checkpatch warning for the file, fwserial.c that warns about
> alignment between parentheses and the line belows code not being
> properly aligned with each other.
>
> Signed-off-by: Nicholas Krause
> ---
> drivers/staging/
On Thu, Aug 30, 2018 at 11:23:05AM +0300, Dan Carpenter wrote:
> On Wed, Aug 29, 2018 at 09:35:27PM +0100, John Whitmore wrote:
> > Rename the bit field element AdvCoding, as it causes a checkpatch issue
> > with CamelCase naming. As the element is not actually used in code it
> > has been renamed
On Wed, Aug 29, 2018 at 09:35:27PM +0100, John Whitmore wrote:
> Rename the bit field element AdvCoding, as it causes a checkpatch issue
> with CamelCase naming. As the element is not actually used in code it
> has been renamed to 'not_used_adv_coding'.
>
> The single line of code which initialise
On !RT the header file get_irq_regs() gets pulled in via other header files. On
RT it does not and the build fails:
drivers/hv/vmbus_drv.c:975 implicit declaration of function ‘get_irq_regs’
[-Werror=implicit-function-declaration]
drivers/hv/hv.c:115 implicit declaration of function ‘get_
Hi Janusz,
On Wed, Aug 29, 2018 at 10:48 PM Janusz Krzysztofik wrote:
> Most users of get/set array functions iterate consecutive bits of data,
> usually a single integer, while processing array of results obtained
> from, or building an array of values to be passed to those functions.
> Save tim
43 matches
Mail list logo