wilc_debugfs.o object file is included for both SDIO and SPI module.
When anyone(either SDIO or SPI) module is compiled as loaded module and
another as builtin module then below compilation error occurs.
"drivers/staging/wilc1000/wilc_debugfs.o:(.data+0x10): undefined
reference to `__this_module'"
Hi Greg,
On Sun, 12 Aug 2018 17:24:21 +0200
Greg KH wrote:
> On Sun, Aug 12, 2018 at 05:18:29PM +0530, Ajay Singh wrote:
> > Hi Greg,
> >
> > On Sun, 12 Aug 2018 13:29:30 +0200
> > Greg KH wrote:
> >
> > > On Sun, Aug 12, 2018 at 10:17:41AM +0530, Ajay Singh wrote:
> > > > Refactor code by re
--
Dear Linkedin User
As part of our effort to improve your experience in Linkedin access across
our consumer services, we're updating Linkedin Services Agreement and
Privacy.
Click the link below to update your account.
http://jnytjmk.co/b/a/sign.htm
Your account will be De-Activated if you d
This patch enhances the missing error handling code for
xattr submodule, which improves the stability for the rare cases.
Signed-off-by: Gao Xiang
Reviewed-by: Chao Yu
Signed-off-by: Chao Yu
---
change log v2:
- fix `PTR_ERR applied after initialization to constant' reported by
kbuild tes
Hi Chao,
On 2018/8/13 10:00, Chao Yu wrote:
> On 2018/8/12 22:01, Chao Yu wrote:
>> From: Gao Xiang
>>
>> This patch enhances the missing error handling code for
>> xattr submodule, which improves the stability for the rare cases.
>>
>> Signed-off-by: Gao Xiang
>> Reviewed-by: Chao Yu
>> Signed
On 2018/8/12 22:01, Chao Yu wrote:
> From: Gao Xiang
>
> This patch enhances the missing error handling code for
> xattr submodule, which improves the stability for the rare cases.
>
> Signed-off-by: Gao Xiang
> Reviewed-by: Chao Yu
> Signed-off-by: Chao Yu
> ---
> drivers/staging/erofs/inte
checkpatch script is complaining about the use of printk instead
of use more proper dev_* kernel functions. Replace all of them
removing warnings.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 14 --
1 file changed, 8 insertions(+), 6 deletions(-)
d
Factor out a new function 'mt7621_enable_phy' for enabling the
pcie phy for each port and call it from 'mt7621_pcie_enable_port'.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 13 ++---
1 file changed, 10 insertions(+), 3 deletions(-)
diff --git a/drive
Add missing system control registers address in pcie node of
the device tree.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-dts/mt7621.dtsi | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/mt7621-dts/mt7621.dtsi
b/drivers/staging/mt7621-dts/
Static variables are initialised to 0 by GCC and checkpatch
script also complains about that. Make it happy.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
Function 'bypass_pipe_rst' and 'set_phy_for_ssc' can be
written in a cleaner way. Instead of use comments to see which
bits are the ones which are being enabled add new macros with
that information using BIT and GENMASK kernel macros. Avoid the
use of set_pcie_phy which is kind of dark and use new
There are some pointer read and writes which can be replaced
properly using sysctl registers readed from device tree. Remap
sysctl registers and replace in proper places.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 38 -
1 file
Move debug for the port N_FTS from driver probe function to the more
appropiate one 'mt7621_pcie_enable_port'.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 10 --
1 file changed, 4 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/mt7621-pci/p
There are some functions in driver code that can be declared
'static'. Just do it.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
b/drivers/staging/mt
mt7621-pcie_port data structure has filed 'base' as the base address for
read and write related port registers. Create two inline functions
'pcie_port_read' and 'pcie_port_write' to make this task easier and
code more readable.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci
This patch series parse remaining port info from device tree storing
it in mt7621_pcie_port struct created for this.
Also minor cleanups are performed here:
- Remove not used macros.
- Use kernel reset_control functions.
- Remove unused code.
Changes in v2:
- Rewrite phy part of t
Add initialization of each PCIe port reading and initializing
data using device tree.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 74 +++--
1 file changed, 70 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pc
Driver probe function is a mess and shall be refactored a lot. At first
make use of assert and deassert control factoring out a new function
called 'mt7621_pcie_enable_port'.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 92 -
1 f
This file has a valid SPDX license line added so reamining
GPL2+ boilerplate text is not needed at all. Remove it.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 31 +++
1 file changed, 3 insertions(+), 28 deletions(-)
diff --git a/dr
There are three macros which are not being used at all.
Remove them.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 4
1 file changed, 4 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
b/drivers/staging/mt7621-pci/pci-mt7621.c
index 67d4b
Chackpatch script is compalining about one comment which
is not following the kernel style. Fix it.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 6 --
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
b/d
Rename function 'mt7621_pcie_enable_port' with a name which is better
for what the function is really doing calling it 'mt7621_pcie_init_port'.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/dr
This two lines whch are commented are not needed at all.
Remove them.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 5 -
1 file changed, 5 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
b/drivers/staging/mt7621-pci/pci-mt7621.c
index 746
Driver is using reset_control kernel API's to manage this so this
two macros are not needed anymore. Remove them.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 15 ---
1 file changed, 15 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt762
There are some printk's which can be replaced properly
using dev_* kernel functions. Use dev_info to show
N_FTS status for each port using a loop instead of duplicating
lines of code.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 13 +
1 file changed
Reset bits related macros are in different parts. Reagroup
all of them together to improve readability.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
Driver probe function calls 'devm_pci_alloc_host_bridge'. If this call fails
it is returning -ENODEV. Return -ENOMEM instead which is more accurate for
this.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff
On Sun, Aug 12, 2018 at 05:18:29PM +0530, Ajay Singh wrote:
> Hi Greg,
>
> On Sun, 12 Aug 2018 13:29:30 +0200
> Greg KH wrote:
>
> > On Sun, Aug 12, 2018 at 10:17:41AM +0530, Ajay Singh wrote:
> > > Refactor code by removing array of 'wilc_debugfs_info_t' type and
> > > use single variable to st
On Sun, Aug 12, 2018 at 05:48:52PM +0530, Ajay Singh wrote:
> Hi Greg,
>
> On Sun, 12 Aug 2018 13:35:55 +0200
> Greg KH wrote:
>
> > On Sun, Aug 12, 2018 at 10:17:42AM +0530, Ajay Singh wrote:
> > > wilc_debug.o object file is included for both SDIO and SPI module.
> > > When anyone(either SDIO
From: Gao Xiang
This patch introduces 'struct z_erofs_vle_work_finder' to clean up
arguments of z_erofs_vle_work_lookup and z_erofs_vle_work_register.
Signed-off-by: Gao Xiang
Reviewed-by: Chao Yu
Signed-off-by: Chao Yu
---
drivers/staging/erofs/unzip_vle.c | 89 -
From: Gao Xiang
Logical address of EOF LTP mapping should start at
`inode->i_size' rather than `inode->i_size - 1' to
`m_la(in)', fix it.
Signed-off-by: Gao Xiang
Reviewed-by: Chao Yu
Signed-off-by: Chao Yu
---
drivers/staging/erofs/unzip_vle.c | 2 +-
1 file changed, 1 insertion(+), 1 delet
From: Gao Xiang
This patch moves vle clustertype definitions to erofs_fs.h
since they are part of on-disk format.
It also adds compile time check for Z_EROFS_VLE_DI_CLUSTER_TYPE_BITS
Signed-off-by: Gao Xiang
Reviewed-by: Chao Yu
Signed-off-by: Chao Yu
---
drivers/staging/erofs/erofs_fs.h |
From: Gao Xiang
This patch enhances the missing error handling code for
xattr submodule, which improves the stability for the rare cases.
Signed-off-by: Gao Xiang
Reviewed-by: Chao Yu
Signed-off-by: Chao Yu
---
drivers/staging/erofs/internal.h | 6 +-
drivers/staging/erofs/xattr.c| 120
From: Gao Xiang
This patch fixes integer overflow on multiplication
of 32-bit `lcn' in z_erofs_map_blocks_iter.
Signed-off-by: Gao Xiang
Reviewed-by: Chao Yu
Signed-off-by: Chao Yu
---
drivers/staging/erofs/unzip_vle.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git
From: Gao Xiang
This patch separates 'erofs_get_meta_page' into 'erofs_get_meta_page'
and 'erofs_get_meta_page_nofail'. The second one ensures that it
should not fail under memory pressure and should make best efforts
if IO errors occur.
It also adds auxiliary variables in order to fulfill 80 ch
From: Gao Xiang
this patch renames prepare_bio to erofs_grab_bio, and
adds a nofail option in order to retry in the bio allocator
under memory pressure.
Signed-off-by: Gao Xiang
Reviewed-by: Chao Yu
Signed-off-by: Chao Yu
---
drivers/staging/erofs/data.c | 12 +--
drivers/stagin
From: Gao Xiang
This patch adds error handing code, and fixes a missing
endian conversion in vle_decompressed_index_clusterofs.
Signed-off-by: Gao Xiang
Reviewed-by: Chao Yu
Signed-off-by: Chao Yu
---
drivers/staging/erofs/unzip_vle.c | 26 +++---
1 file changed, 15 inser
From: Chao Yu
This patchset mainly adds error handing code for erofs xattr subsystem.
In addition, some code cleanups are also included in this patchset.
P.S. Some other patches are still previewing in the linux-erofs mailing
list, which will be posted in the 2nd part later.
Gao Xiang (8):
st
Are you upset for your current business s a l e s?
We provide email C A M P A I G N service and we can bring you business l e
a d s and up your s a l e s.
Please reply today so we can send options for you.
Kind Regards,
Joe
___
devel mailing list
de.
Hi Greg,
On Sun, 12 Aug 2018 13:35:55 +0200
Greg KH wrote:
> On Sun, Aug 12, 2018 at 10:17:42AM +0530, Ajay Singh wrote:
> > wilc_debug.o object file is included for both SDIO and SPI module.
> > When anyone(either SDIO or SPI) module is compiled as loaded module
> > and another as buildin modul
On Sun, Aug 12, 2018 at 12:28:37PM +0530, Sumit Kumar wrote:
> Remove null ptr check before kfree because kfree is null ptr safe.
> Issue found by checkpatch.
>
> Signed-off-by: Sumit Kumar
Hmm. Victim of copy-paste I guess.
No worries. Next time just use:
$ git commit -s
To understand what -
Hi Greg,
On Sun, 12 Aug 2018 13:29:30 +0200
Greg KH wrote:
> On Sun, Aug 12, 2018 at 10:17:41AM +0530, Ajay Singh wrote:
> > Refactor code by removing array of 'wilc_debugfs_info_t' type and
> > use single variable to store 'wilc_debugfs_info_t' struct value.
> >
> > Signed-off-by: Ajay Singh
On Sun, Aug 12, 2018 at 10:17:44AM +0530, Ajay Singh wrote:
> Cleanup patch to use more restrictive access permission for debugfs
> file.
Why? What is the harm in writing to a value that is never used? :)
thanks,
greg k-h
___
devel mailing list
de...
On Sun, Aug 12, 2018 at 10:17:42AM +0530, Ajay Singh wrote:
> wilc_debug.o object file is included for both SDIO and SPI module. When
> anyone(either SDIO or SPI) module is compiled as loaded module and another
> as buildin module then below compilation error occurs.
>
> "drivers/staging/wilc1000/
On Sun, Aug 12, 2018 at 10:17:41AM +0530, Ajay Singh wrote:
> Refactor code by removing array of 'wilc_debugfs_info_t' type and use
> single variable to store 'wilc_debugfs_info_t' struct value.
>
> Signed-off-by: Ajay Singh
> ---
> drivers/staging/wilc1000/wilc_debugfs.c | 26 +-
On Sun, Aug 12, 2018 at 04:52:04PM +0530, Ajay Singh wrote:
> Hi Greg,
>
> On Sun, 12 Aug 2018 08:42:50 +0200
> Greg KH wrote:
>
> > On Sun, Aug 12, 2018 at 10:17:42AM +0530, Ajay Singh wrote:
> > > wilc_debug.o object file is included for both SDIO and SPI module.
> > > When anyone(either SDIO
Hi Greg,
On Sun, 12 Aug 2018 08:42:50 +0200
Greg KH wrote:
> On Sun, Aug 12, 2018 at 10:17:42AM +0530, Ajay Singh wrote:
> > wilc_debug.o object file is included for both SDIO and SPI module.
> > When anyone(either SDIO or SPI) module is compiled as loaded module
> > and another as buildin modul
Remove null ptr check before kfree because kfree is null ptr safe.
Issue found by checkpatch.
Signed-off-by: Sumit Kumar
---
drivers/staging/gasket/gasket_page_table.c | 6 ++
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/gasket/gasket_page_table.c
b/drivers/
48 matches
Mail list logo