On Tue, Aug 7, 2018 at 4:20 PM Paul Kocialkowski
wrote:
>
> Hi,
>
> On Mon, 2018-08-06 at 23:10 +0900, Tomasz Figa wrote:
> > Hi Paul,
> >
> > On Mon, Aug 6, 2018 at 10:50 PM Paul Kocialkowski
> > wrote:
> > >
> > > Hi Hans and thanks for the review!
> > >
> > > On Sat, 2018-08-04 at 14:18 +0200,
Fix warnings generated by checkpatch.pl for alignment should match open
parenthesis. This is a coding style change only.
Signed-off-by: Greg Gallagher
---
.../staging/vc04_services/bcm2835-audio/bcm2835-ctl.c | 18 +-
1 file changed, 9 insertions(+), 9 deletions(-)
diff --git
Fix warnings generated by checkpatch.pl for alignment should match open
parenthesis. This is a coding style change only.
Signed-off-by: Greg Gallagher
---
Changes in v2:
- Clean up all the alignment warnings in the file
---
.../staging/vc04_services/bcm2835-audio/bcm2835-ctl.c | 18 +++
Uses default macro BIT(n) instead (1 << n)
Signed-off-by: Leonardo Brás
---
drivers/staging/fbtft/fbtft.h | 56 +--
1 file changed, 28 insertions(+), 28 deletions(-)
diff --git a/drivers/staging/fbtft/fbtft.h b/drivers/staging/fbtft/fbtft.h
index f771271d497a..2b
Changes custom macro to dev_dbg to avoid parameter multiple usage and use of
typeof().
Signed-off-by: Leonardo Brás
---
drivers/staging/fbtft/fbtft.h | 17 +
1 file changed, 5 insertions(+), 12 deletions(-)
diff --git a/drivers/staging/fbtft/fbtft.h b/drivers/staging/fbtft/fbtf
Avoids a very long line of index, improving readability.
Signed-off-by: Leonardo Brás
---
drivers/staging/fbtft/fbtft-sysfs.c | 6 +-
1 file changed, 5 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/fbtft/fbtft-sysfs.c
b/drivers/staging/fbtft/fbtft-sysfs.c
index 2a5c630dab87..9c
Puts spaces around the /.
Signed-off-by: Leonardo Brás
---
drivers/staging/fbtft/fbtft-core.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/fbtft/fbtft-core.c
b/drivers/staging/fbtft/fbtft-core.c
index 8b79353c722a..83076eca9760 100644
--- a/drivers/staging
Erases some blank lines.
Signed-off-by: Leonardo Brás
---
drivers/staging/fbtft/fb_s6d02a1.c | 1 -
drivers/staging/fbtft/fb_s6d1121.c | 1 +
drivers/staging/fbtft/fb_ssd1289.c | 1 +
drivers/staging/fbtft/fbtft_device.c | 2 --
4 files changed, 2 insertions(+), 3 deletions(-)
diff --git
This nesting level was removed to improve readability.
Signed-off-by: Leonardo Brás
---
drivers/staging/fbtft/flexfb.c | 27 +++
1 file changed, 15 insertions(+), 12 deletions(-)
diff --git a/drivers/staging/fbtft/flexfb.c b/drivers/staging/fbtft/flexfb.c
index af6c330c
Includes description to mutex and spinlocks, as recommended by checkpatch.pl.
Signed-off-by: Leonardo Brás
---
drivers/staging/fbtft/fbtft.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/fbtft/fbtft.h b/drivers/staging/fbtft/fbtft.h
index 6ee9ff320567..
Adds a bit more information on debug.
The line break was to avoid obfuscating the parameters on the end of a large
line.
Signed-off-by: Leonardo Brás
---
drivers/staging/fbtft/fb_ssd1351.c | 6 --
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/fbtft/fb_ssd135
Changes this functions to avoid using "blank" on debug twice. Improves log
readability.
Signed-off-by: Leonardo Brás
---
drivers/staging/fbtft/fb_sh1106.c | 2 +-
drivers/staging/fbtft/fb_ssd1306.c | 2 +-
drivers/staging/fbtft/fb_ssd1325.c | 2 +-
drivers/staging/fbtft/fb_ssd1331.c | 2 +-
dr
Fixing some styles as recommended by checkpatch.pl.
Signed-off-by: Leonardo Brás
---
drivers/staging/fbtft/fbtft-bus.c | 10 ++
drivers/staging/fbtft/fbtft-core.c | 6 --
drivers/staging/fbtft/fbtft.h | 4 ++--
3 files changed, 12 insertions(+), 8 deletions(-)
diff --git a/d
Fixes (most) alignment issues pointed by checkpatch.pl.
Signed-off-by: Leonardo Brás
---
drivers/staging/fbtft/fb_ssd1289.c | 6 ++---
drivers/staging/fbtft/fb_ssd1351.c | 31 ++
drivers/staging/fbtft/fb_st7735r.c | 13 +++---
drivers/staging/fbtft/fb_st7789v.c |
Most of other "Gamma Tables" were already boxed on a define, just did the same
to PIOLED.
Signed-off-by: Leonardo Brás
---
drivers/staging/fbtft/fbtft_device.c | 13 +
1 file changed, 5 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/fbtft/fbtft_device.c
b/drivers/stagi
Trying to keep the code in the 80-char line limit.
Signed-off-by: Leonardo Brás
diff --git a/drivers/staging/fbtft/fb_ssd1306.c
b/drivers/staging/fbtft/fb_ssd1306.c
index 9276be499303..f5e0ec1c01dc 100644
--- a/drivers/staging/fbtft/fb_ssd1306.c
+++ b/drivers/staging/fbtft/fb_ssd1306.c
@@ -184,
Puts macro arguments in parenthesis to avoid precedence issues.
Some large lines were broken to fit the 80-char limit.
Signed-off-by: Leonardo Brás
---
drivers/staging/fbtft/fb_hx8347d.c | 2 +-
drivers/staging/fbtft/fb_ili9163.c | 2 +-
drivers/staging/fbtft/fb_ili9320.c | 2 +-
driver
Changes some udelay(n) for n >= 10 to usleep_range(n, n+x) as recommended by
checkpatch.pl.
Signed-off-by: Leonardo Brás
---
drivers/staging/fbtft/fb_agm1264k-fl.c | 2 +-
drivers/staging/fbtft/fb_ra8875.c | 4 ++--
drivers/staging/fbtft/fb_tinylcd.c | 2 +-
drivers/staging/fbtft/fb
Fixes some issues found with checkpatch.pl, and other issues found browsing the
code.
Leonardo Brás (15):
staging: fbtft: Changes udelay(n) to usleep_range(n, n + x). - Style
staging: fbtft: Puts macro arguments in parenthesis to avoid
precedence issues - Style
staging: fbtft: Fixes som
On 08/06/2018 01:34 AM, Daniel Vetter wrote:
On Fri, Jul 20, 2018 at 10:17:29AM -0700, Steve Longerbeam wrote:
Adds crtc page-flip support by passing the new requested framebuffer
to vbox_crtc_do_set_base().
There is no attempt to support vblank interrupts, so this page-flip
implementation d
The function dot11d_update_country_ie() uses parameter names which
cause a checkpatch issue de to the use of CamelCase naming.
This is a coding style change which should have no impact on runtime
code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/dot11d.h | 6 ++
The function DOT11D_ScanComplete causes a checkpatch issue due to its
use of CamelCase naming. The function has been renamed to
dot11d_scan_complete.
This is a coding style change which should have no impact on runtime
code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ie
The function IsLegalChannel causes a checkpatch issue due to its use
of CamelCase naming. The function has been renamed to is_legal_channel.
This is a coding style change which should have no impact on runtime
code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/d
The function DOT11D_GetMaxTxPwrInDbm causes a checkpatch issue due to
its use of CamelCase naming. The function has been renamed to
dot11d_get_max_tx_pwr_in_dbm.
This is a coding style change which should have no impact on runtime
code execution.
Signed-off-by: John Whitmore
---
drivers/staging
The function Dot11d_UpdateCountryIe causes a checkpatch issue due to
its use of CamelCase naming, the function has been renamed to
dot11d_update_country_ie.
This is a coding style change which should have no impact on runtime
code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8
The function Dot11d_Reset causes a checkpatch issue due to its use of
CamelCase naming, so has been rename to dot11d_reset.
This is a coding style change which should have no impact on runtime
code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/dot11d.c
Multiple macros, defined in dot11d.h, use the variable __pIeeeDev as a
parameter. This name causes a checkpatch issue due to its use of
CamelCase naming. The parameter name has been changed to ieee_dev to
clear this issue.
This is a coding style change which should have no impact on runtime
code e
Rename the function ToLegalChannel, which causes a checkpatch issue due
to its use of CamelCase naming. The function has been renamed to
to_legal_channel.
This is a coding style change which should have no impact on runtime
code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl819
Removed unused macro definitions as they add nothing to the code.
This is a coding style change which should have no impact on runtime
code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/dot11d.h | 8
1 file changed, 8 deletions(-)
diff --git a/drivers/
A number of function prototypes cause a checkpatch issue - "Lines
should not end with a '(' ". This issue has been cleared by moving
function prototype parameters to the same line as the function name.
This is a coding style change which should have no impact on runtime
code execution.
Signed-off
Remove a comment which appears to be from a previous version of code.
This is a coding style change which should have no impact on runtime
code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/dot11d.h | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/st
Add spaces around '+' operator as required by the coding standard.
This clears the checkpatch issue.
This change is purely coding style in nature and should have not
effect on runtime code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/dot11d.h | 4 ++--
1 file c
The macro parameter __pTa causes a checkpatch issue because of its use
of CamelCase naming. The parameter has this been renamed to addr.
This is a coding style change which should have no impact on runtime
code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/dot11
The function dot11d_get_max_tx_pwr_in_dbm() uses a parameter name,
Channel, which causes a checkpatch issue with CamelCase naming. The
parameter has been renamed to channel.
The change is a coding style change which should have no impact on
runtime code execution.
Signed-off-by: John Whitmore
--
This series includes a number of simple coding style changes.
There are a number of patches which rename symbols which are
exported with EXPORT_SYMBOL. This may be a problem, as code
using those symbols will have to be changed accordingly.
John Whitmore (17):
staging:rtl8192u: Remove stale comm
The function Dot11d_Init() causes a checkpatch issue due to its use
of CamelCase naming. The function has been renamed to dot11d_init.
This is a coding style change which should have no impact on runtime
code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/dot11d.
The eqMacAddr(a, b) macro causes a checkpatch issue, due to CamelCase
naming, so has been renamed to eq_mac_addr(a, b).
This is a coding style change which should not impact on runtime code
execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/dot11d.h | 4 ++--
drivers
Rename the Macro cpMacAddr(des, src), as it causes a checkpatch issue
due its use of CamelCase naming, to cp_mac_addr(des, src).
This is a coding style change so should have no impact on runtime
code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/dot11d.h |
Use rate-limited debug messages where userspace can trigger
excessive log spams.
Acked-by: Arve Hjønnevåg
Signed-off-by: Sherry Yang
---
v2: rebase onto char-misc-next to resolve include order
difference from master
drivers/android/binder.c | 5 +++--
drivers/android/binder_alloc.c | 41
On Tue, Aug 07, 2018 at 09:33:03AM -0700, Nick Desaulniers wrote:
> On Tue, Aug 7, 2018 at 5:07 AM Mauro Carvalho Chehab
> wrote:
> >
> > As Ian pointed out, adding a '-' to the fallthrough seems to meet
> > the regex requirements at level 3 of the warning, at least when
> > the comment fits into
Hi,
On Sat, 2018-08-04 at 13:42 +0200, Hans Verkuil wrote:
> On 07/25/2018 12:02 PM, Paul Kocialkowski wrote:
> > This introduces support for Allwinner's MB32-tiled NV12 format, where
> > each plane is divided into macroblocks of 32x32 pixels. Hence, the size
> > of each plane has to be aligned to
On Wed, Aug 8, 2018 at 12:05 AM Jernej Škrabec wrote:
>
> Dne torek, 07. avgust 2018 ob 14:31:03 CEST je Paul Kocialkowski napisal(a):
> > Hi,
> >
> > On Fri, 2018-07-27 at 16:58 +0200, Jernej Škrabec wrote:
> > > Dne petek, 27. julij 2018 ob 16:03:41 CEST je Jernej Škrabec napisal(a):
> > > > Hi!
Dne torek, 07. avgust 2018 ob 14:31:03 CEST je Paul Kocialkowski napisal(a):
> Hi,
>
> On Fri, 2018-07-27 at 16:58 +0200, Jernej Škrabec wrote:
> > Dne petek, 27. julij 2018 ob 16:03:41 CEST je Jernej Škrabec napisal(a):
> > > Hi!
> > >
> > > Dne sreda, 25. julij 2018 ob 12:02:52 CEST je Paul Koc
> -Original Message-
> From: Andrew Lunn [mailto:and...@lunn.ch]
> Sent: Friday, August 3, 2018 7:43 PM
> To: Ioana Ciocoi Radulescu
> Cc: net...@vger.kernel.org; da...@davemloft.net;
> gre...@linuxfoundation.org; de...@driverdev.osuosl.org; linux-
> ker...@vger.kernel.org; Ioana Ciornei ;
Hi,
On Fri, 2018-07-27 at 16:58 +0200, Jernej Škrabec wrote:
> Dne petek, 27. julij 2018 ob 16:03:41 CEST je Jernej Škrabec napisal(a):
> > Hi!
> >
> > Dne sreda, 25. julij 2018 ob 12:02:52 CEST je Paul Kocialkowski napisal(a):
> > > This introduces the Cedrus VPU driver that supports the VPU fou
Hi,
On Fri, 2018-07-27 at 16:03 +0200, Jernej Škrabec wrote:
> Hi!
>
> Dne sreda, 25. julij 2018 ob 12:02:52 CEST je Paul Kocialkowski napisal(a):
> > This introduces the Cedrus VPU driver that supports the VPU found in
> > Allwinner SoCs, also known as Video Engine. It is implemented through
> >
Hi,
On Sun, 2018-07-29 at 09:58 +0200, Jernej Škrabec wrote:
> Hi!
>
> Dne sreda, 25. julij 2018 ob 12:02:52 CEST je Paul Kocialkowski napisal(a):
> > This introduces the Cedrus VPU driver that supports the VPU found in
> > Allwinner SoCs, also known as Video Engine. It is implemented through
> >
As Ian pointed out, adding a '-' to the fallthrough seems to meet
the regex requirements at level 3 of the warning, at least when
the comment fits into a single line.
So, replace by a single line the comments that were broken into
multiple lines just to make gcc -Wimplicit-fallthrough=3 happy.
Su
Em Tue, 7 Aug 2018 12:00:46 +0100
Ian Arkver escreveu:
> Hi Mauro,
>
> On 07/08/18 10:58, Mauro Carvalho Chehab wrote:
> > With imx, gcc produces a false positive warning:
> >
> > drivers/staging/media/imx/imx-media-csi.c: In function
> > 'csi_idmac_setup_channel':
> > drivers/staging/
Hi Mauro,
On 07/08/18 10:58, Mauro Carvalho Chehab wrote:
With imx, gcc produces a false positive warning:
drivers/staging/media/imx/imx-media-csi.c: In function
'csi_idmac_setup_channel':
drivers/staging/media/imx/imx-media-csi.c:457:6: warning: this
statement may fall throug
Fixed a coding style issue related to indentation. Reported by
checkpatch.pl
Signed-off-by: Sumit Pundir
---
drivers/staging/gasket/gasket_page_table.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/gasket/gasket_page_table.c
b/drivers/staging/gasket/gasket_
With imx, gcc produces a false positive warning:
drivers/staging/media/imx/imx-media-csi.c: In function
'csi_idmac_setup_channel':
drivers/staging/media/imx/imx-media-csi.c:457:6: warning: this
statement may fall through [-Wimplicit-fallthrough=]
if (passthrough) {
On Mon, Aug 06, 2018 at 09:35:52PM +0200, Arkadiusz Lis wrote:
> Add SPDX-License-Identifier to the source files.
> Remove redundant, old license.
>
> Signed-off-by: Arkadiusz Lis
> ---
> drivers/staging/olpc_dcon/olpc_dcon.c| 5 +
> drivers/staging/olpc_dcon/olpc_dcon_xo_1.c | 5 +
Split this up into two patches. One which changes alignment and one
which does the 80 character limit...
On Tue, Aug 07, 2018 at 01:05:33AM -0300, Leonardo Brás wrote:
> Signed-off-by: Leonardo Brás
> ---
> drivers/staging/fbtft/fb_ssd1289.c | 6 +--
> drivers/staging/fbtft/fb_ssd1306.c |
On Tue, Aug 07, 2018 at 01:07:41AM -0300, Leonardo Brás wrote:
> Signed-off-by: Leonardo Brás
> ---
> drivers/staging/fbtft/fbtft.h | 18 +++---
> 1 file changed, 11 insertions(+), 7 deletions(-)
>
> diff --git a/drivers/staging/fbtft/fbtft.h b/drivers/staging/fbtft/fbtft.h
> index 4
Hi,
On Mon, 2018-08-06 at 23:10 +0900, Tomasz Figa wrote:
> Hi Paul,
>
> On Mon, Aug 6, 2018 at 10:50 PM Paul Kocialkowski
> wrote:
> >
> > Hi Hans and thanks for the review!
> >
> > On Sat, 2018-08-04 at 14:18 +0200, Hans Verkuil wrote:
> > > Hi Paul,
> > >
> > > See below for my review comm
56 matches
Mail list logo