On Wed, 2018-07-25 at 12:02 +0200, Paul Kocialkowski wrote:
> This introduces the Cedrus VPU driver that supports the VPU found in
> Allwinner SoCs, also known as Video Engine. It is implemented through
> a v4l2 m2m decoder device and a media device (used for media requests).
> So far, it only supp
> +static int dpaa2_eth_probe(struct fsl_mc_device *dpni_dev)
> +{
> + struct device *dev;
> + struct net_device *net_dev = NULL;
> + struct dpaa2_eth_priv *priv = NULL;
> + int err = 0;
> +
> + dev = &dpni_dev->dev;
> +
> + /* Net device */
> + net_dev = alloc_etherdev_
Hi Carlos,
> Carlos Maiolino hat am 30. Juli 2018 um 11:57
> geschrieben:
>
>
> On Mon, Jul 30, 2018 at 11:49 AM, Stefan Wahren
> wrote:
> > Am 30.07.2018 um 11:43 schrieb Carlos Maiolino:
> >> On Mon, Jul 30, 2018 at 11:34 AM, Stefan Wahren
> >> wrote:
> >>> i think easiest the way would
Do you have photos for editing?
We are image team and we can process 500+ images each day.
We edit ecommerce photo, jewelry photos, and beauty model photos.
also wedding photos.
We do cut out and clipping path for photos, also retouching.
You may send us a test photo to check our quality.
Than
Hallo, ich bin Herr Tayeb Souami, New Jersey, Vereinigte Staaten von Amerika,
Sie haben eine Wohltätigkeitsspende in Höhe von € 2.000.000,00, ich habe die
America Lotterie in Amerika im Wert von $ 315 Millionen gewonnen, und ich gebe
einen Teil davon an fünf glückliche Menschen und wohltätige Hä
On 08/02/18 18:45, Rui Miguel Silva wrote:
> Hi Hans,
> On Thu 02 Aug 2018 at 13:37, Hans Verkuil wrote:
>> Hi Rui,
>>
>> On 05/22/18 16:52, Rui Miguel Silva wrote:
>>> Hi,
>>> This series introduces the Media driver to work with the i.MX7
>>> SoC. it uses the
>>> already existing imx media core d
Cleanup the copyright notice header from the WILC1000 files.
Replace copyright header of 'Atmel' & 'NewportMedia' with 'Microchip & its
subsidiaries'. Also added the same copyright notice header for all
wilc1000 driver source and header files.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc10
Remove below item from TODO as these changes were included as part of
previous submitted patch series.
'rework comments and function headers(also coding style)'
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/TODO | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/wilc100
Cleanup patch to avoid below checkpatch issue by replacing the macro
with inline function.
Macro argument 'id' may be better as '(id)' to avoid precedence issues.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wlan.c | 9 +++--
drivers/staging/wilc1000/wilc_wlan.h | 2 --
2 fil
This patch series contains the remaining patches from [1]. Included the
updated copyright information for all source and header file.
Also included the patch to remove checkpatch error and updated the TODO item.
After this patch only 3 checkpatch related warning are remaining(2 will be
remove after
Hi Greg,
On Thu, 2 Aug 2018 09:34:15 +0200
Greg KH wrote:
> On Sun, Jul 29, 2018 at 11:36:56AM +0530, Ajay Singh wrote:
> > Cleanup patch to avoid the below checkpatch reported issue.
> >
> > "usleep_range is preferred over udelay; see
> > Documentation/timers/timers-howto.txt".
> >
> > Signed
Instead of custom macros use pcie_read and pcie_write functions.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 67 -
1 file changed, 32 insertions(+), 35 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
b/driver
Use pcie_[read|write] fucntions to read and write controller registers.
Define those only by offset and pass controller offset + register offset
relative to base address to functions.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 70 -
RALINK_PCI_BASE has no sense and this driver has base address readed
and mapped from device tree. Remove remaining uses of it and
change code to use pcie_read and pcie_write functions in places
where this was being used.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621
map_bus callback is called before every .read/.write operation.
Implement it and change custom read write operations for the
pci subsystem generics. Make the probe function to don't use
legacy stuff and request bus resources directly. Get pci register
base and ranges from device tree.
The driver is
Driver is using now pci subsystem generics reads and writes and requesting
bus resources without using legacy code functions. Because of this there is
a lot of dead code that can be removed.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 128 -
The pcie node of the device tree only contains registers
for the host-bridge and pcie port 0. Add the pcie port 1
and pcie port 2 also.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-dts/mt7621.dtsi | 6 --
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/drivers/s
RALINK_PCI_PCICFG_ADDR and RALINK_PCI_PCIMSK_ADDR are defined to be directly
referenced for read and write. Use pcie_read and pcie_write instead changing
its definition to a simple relative offset to pcie base address.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c
RALINK_PCI_CONFIG_DATA_VIRTUAL_REG is a very long name. Make it a bit
shorter renaming it to RALINK_PCI_CONFIG_DATA.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/mt7621-pc
There some macros that are not being used. Remove them.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 24 +---
1 file changed, 1 insertion(+), 23 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
b/drivers/staging/mt7621-pci
There are some includes that are being used that are not really
needed to correct driver compilation. Remove them and reorder the
rest alphabetically.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 22 --
1 file changed, 8 insertions(+), 14 de
write_config function is always called with bus and func
being 0. Avoid those params and just use 0 inside the
function. Review parameter types changing for more proper
ones.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 20 +---
1 file changed,
pcibios_* remaining code is not neccessary at all. We can use
map_irq set to of_irq_parse_and_map_pci driver 'probe' function.
Remove this code.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 33 +
1 file changed, 1 insertion(+), 3
Some preprocessor definitions are using a custom implementation of
BIT macro. Just use linux kernel BIT macro instead.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 20 ++--
1 file changed, 10 insertions(+), 10 deletions(-)
diff --git a/drivers/
read_config function is always called with bus and func
being 0. Avoid those params and just use 0 inside the
function. Return readed value instead pass a reference
parameter.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 32 +++-
1 f
This patch series include an attempt to avoid the use of custom
read and writes in driver code and use PCI subsystem common ones.
In order to do this 'map_bus' callback is implemented and also
data structures for driver are included. The regs base address
ranges and data is being readed from devic
Introdice this functions to make easier to write/read to/from
an offset relative to base address
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 10 ++
1 file changed, 10 insertions(+)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
b/drivers/stagin
Remove the following unused definitions from p80211types.h:
* struct p80211enum
* struct p80211enumpair
* struct catlistitem declaration and associated function pointer
typedefs (along with preceding block comment)
Signed-off-by: Tim Collier
---
drivers/staging/wlan-ng/p80211types.h | 27
28 matches
Mail list logo