This patch series contains changes to address below TODO items.
- rework comments and function headers(also coding style)
All checkpatch reported issues related to coding style are addressed
except DT compatible string un-documented. Checkpatch warning related to
DT compatible string warni
Cleanup patch to update the debug logs message to provide correct
information. Also added the function name tag for same description log
to help identify the place from where log was captured.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 134 +++--
Cleanup patch to use shorter name for 'rcvd_ch_cnt' to 'ch_cnt' to avoid
line over 80 character issue reported by checkpatch.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 12 ++--
drivers/staging/wilc1000/host_interface.h | 2 +-
2 files changed, 7 insertion
Added comments for 'hif_cs' mutex to avoid checkpatch.pl reported
issues.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wfi_netdevice.h | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/wilc1000/wilc_wfi_netdevice.h
b/drivers/staging/wilc1000/wilc_wfi_netdevice.h
Cleanup patch to remove the unnecessary copyright information in
the file, as it already has SPDX License Identifier.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_debugfs.c | 10 --
drivers/staging/wilc1000/wilc_sdio.c | 5 -
drivers/staging/wilc1000/wilc_spi.c
Cleanup patch to avoid the below checkpatch reported issue.
"usleep_range is preferred over udelay; see
Documentation/timers/timers-howto.txt".
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/wilc_wlan.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/
Cleanup patch to fix below checkpatch reported issue:
Macro argument 'id' may be better as '(id)' to avoid precedence issues
Also updated the TODO file to remove the below item
'rework comments and function headers(also coding style)'
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/TOD
Cleanup patch to remove the unnecessary comments and commented code.
Also updated description for few of comments.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 4 ++--
drivers/staging/wilc1000/linux_mon.c | 15 ---
drivers/staging/wilc1000/w
Changes to compile module component along with SPI and SDIO module.
Previously 'wilc1000.ko' used to generate along with wilc-spi.ko or
wilc1000-sdio.ko module. After these changes only wilc1000-spi.ko or
wilc1000-sdio.ko modules are required for SPI and SDIO respectively.
These changes are done to
This patch fixes incorrect code snippets due to spilt code
into small patches by mistake.
Link: https://lists.01.org/pipermail/kbuild-all/2018-July/050747.html
Link: https://lists.01.org/pipermail/kbuild-all/2018-July/050750.html
Reported-by: kbuild test robot
Signed-off-by: Gao Xiang
---
I tes
This patch adds error handling code for
z_erofs_map_blocks_iter to fix the compiler blame.
Signed-off-by: Gao Xiang
---
let's solve the compiler warning first, more error handling code
for other functions will be added in the future patch.
drivers/staging/erofs/unzip_vle.c | 25 +++
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git
staging-next
head: 6d4abf1c0e265d8e99c155b91c1cf44e37793e53
commit: e7e9a307be9d75ecc3bf20b362af88140dfb4304 [560/569] staging: erofs:
introduce workstation for decompression
config: x86_64-randconfig-s0-07291008 (attach
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git
staging-next
head: 6d4abf1c0e265d8e99c155b91c1cf44e37793e53
commit: e7e9a307be9d75ecc3bf20b362af88140dfb4304 [560/569] staging: erofs:
introduce workstation for decompression
config: x86_64-randconfig-ws0-07290820 (attac
The union ACM_PARAM is never actually used in code so removed. This
is a coding style change which should have no impact on runtime code
execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h | 15 ---
1 file changed, 15 deletions(-)
diff --git
The union ECW is never used in code so has simply been removed.
This is a coding style change which should have no impact on runtime
code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h | 12
1 file changed, 12 deletions(-)
diff --git a/
These are a few coding style changes to the file
drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h
I had more patches in the list but had to dump some of the later
patches as I made a mistake. Thought I'd send these 8.
John Whitmore (8):
staging:rtl8192u: Add spaces around operators - Style
sta
Rename the member variables of union aci_aifsn, which should be named
in lowercase. The only member variable, of this union, which is
actually used is 'acm'.
This are coding style changes which should have no impact on runtime
code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl
The union QOS_TSINFO, as a type, should have a lowercase name. The
union has therefore been renamed to qos_tsinfo. Additionally the
'typedef' directive has been removed to clear the checkpatch issue
with defining new types.
These are coding style changes which should have no impact on runtime
code
Rename the union ACI_AIFSN to aci_aifsn and remove the typedef directive.
The removal of the typedef clears the checkpatch issue with defining
new types. The renaming is to adhere to the coding style where types
are name in lower case.
These changes are coding style changes which should have no i
Remove defined constants from code, since they are never actually
used in code. This is a simple coding style change which should have
no impact on runtime code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h | 7 ---
1 file changed, 7 deletions(-
Add the required spaces around '+' and '*' operators. This is a
coding style change to clear the checkpatch issue. There should be
no impact on runtime code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h | 2 +-
1 file changed, 1 insertion(+), 1 dele
The enumerated type DIRECTION_VALUE should be named in lowercase to
comply with coding standard so is renamed to direction_value. In
addition the 'typedef' directive has been removed to clear the
checkpatch issue with defining new types.
These changes are coding style changes which should have no
On Sun, Jul 29, 2018 at 12:02:52AM +0100, John Whitmore wrote:
> These are a few coding style changes to the file
> drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h
> I had more patches in the list but had to dump some of the later
> patches as I made a mistake. Thought I'd send these 8.
>
> John
These are a few coding style changes to the file
drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h
I had more patches in the list but had to dump some of the later
patches as I made a mistake. Thought I'd send these 8.
John Whitmore (8):
staging:rtl8192u: Add spaces around operators - Style
sta
Add the required spaces around '+' and '*' operators. This is a
coding style change to clear the checkpatch issue. There should be
no impact on runtime code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h | 2 +-
1 file changed, 1 insertion(+), 1 dele
The enumerated type DIRECTION_VALUE should be named in lowercase to
comply with coding standard so is renamed to direction_value. In
addition the 'typedef' directive has been removed to clear the
checkpatch issue with defining new types.
These changes are coding style changes which should have no
The union ECW is never used in code so has simply been removed.
This is a coding style change which should have no impact on runtime
code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h | 12
1 file changed, 12 deletions(-)
diff --git a/
Remove defined constants from code, since they are never actually
used in code. This is a simple coding style change which should have
no impact on runtime code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h | 7 ---
1 file changed, 7 deletions(-
The union QOS_TSINFO, as a type, should have a lowercase name. The
union has therefore been renamed to qos_tsinfo. Additionally the
'typedef' directive has been removed to clear the checkpatch issue
with defining new types.
These are coding style changes which should have no impact on runtime
code
The union ACM_PARAM is never actually used in code so removed. This
is a coding style change which should have no impact on runtime code
execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_Qos.h | 15 ---
1 file changed, 15 deletions(-)
diff --git
Rename the union ACI_AIFSN to aci_aifsn and remove the typedef directive.
The removal of the typedef clears the checkpatch issue with defining
new types. The renaming is to adhere to the coding style where types
are name in lower case.
These changes are coding style changes which should have no i
Rename the member variables of union aci_aifsn, which should be named
in lowercase. The only member variable, of this union, which is
actually used is 'acm'.
This are coding style changes which should have no impact on runtime
code execution.
Signed-off-by: John Whitmore
---
drivers/staging/rtl
Fixes sparse warning: Using plain integer as NULL pointer
Signed-off-by: Dmitriy Cherkasov
---
drivers/staging/gasket/gasket_page_table.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/gasket/gasket_page_table.c
b/drivers/staging/gasket/gasket_page_table.c
i
From: Stephen Hemminger
Being able to find the numa_node for a device is useful for userspace
drivers (DPDK) and also for diagnosing performance issues. This makes
vmbus similar to pci.
Signed-off-by: Stephen Hemminger
Signed-off-by: K. Y. Srinivasan
---
Documentation/ABI/stable/sysfs-bus-vm
From: Sunil Muthuswamy
The check to free the Hyper-V control table header was reversed. This
fixes it.
Fixes: 81b18bce48af ("Drivers: HV: Send one page worth of kmsg dump over
Hyper-V during panic")
Signed-off-by: Sunil Muthuswamy
Signed-off-by: K. Y. Srinivasan
---
drivers/hv/vmbus_drv.c |
From: Sunil Muthuswamy
Get rid of ISA specific code from vmus_drv.c which is common code.
Fixes: 81b18bce48af ("Drivers: HV: Send one page worth of kmsg dump over
Hyper-V during panic")
Signed-off-by: Sunil Muthuswamy
Signed-off-by: K. Y. Srinivasan
---
arch/x86/include/asm/mshyperv.h | 3 +
From: Sunil Muthuswamy
The code to support panic control message was checking the return was
checking the return value from kmsg_dump_get_buffer as error value, which
is not what the routine returns. This fixes it.
Fixes: 81b18bce48af ("Drivers: HV: Send one page worth of kmsg dump over
Hyper-V
From: "K. Y. Srinivasan"
Miscellaneous fixes/enhancements
Stephen Hemminger (1):
Drivers: hv: vmbus: add numa_node to sysfs
Sunil Muthuswamy (3):
Drivers: hv: vmus: Fix the check for return value from kmsg get dump
buffer
Drivers: hv: vmbus: Fix the issue with freeing up hv_ctl_table_
> -Original Message-
> From: Sunil Muthuswamy
> Sent: Thursday, July 26, 2018 5:28 PM
> To: KY Srinivasan ; Michael Kelley (EOSG)
>
> Cc: Stephen Hemminger ; Haiyang Zhang
> ; de...@linuxdriverproject.org
> Subject: RE: [PATCH] Drivers: HV: panic kmsg dump, move MSR access to arch
> spe
From: Todd Poynor
Hold a reference on the struct device while a pointer to that
device is in use by gasket.
Reported-by: Greg Kroah-Hartman
Signed-off-by: Todd Poynor
---
drivers/staging/gasket/gasket_core.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/stagi
From: Todd Poynor
The fun continues with gasket+apex: remove dead code and unnecessary
stuff, fixup apex PCI class for devices that advertise class 0
(undefined), and make sure the struct device doesn't go away on us.
Most of these from review comments of previous patch series.
Changed patches i
From: sepehrdad sh
Fixed multiple coding style issue
Signed-off-by: Sepehrdad Sh
---
drivers/staging/fbtft/fbtft-sysfs.c | 6 --
drivers/staging/fbtft/flexfb.c | 22 +++---
2 files changed, 19 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/fbtft/fbtft-sys
I will change it into function, as i checked so far i will need to
change USB_SET_FIELD32 for the same reason.
On Fri, 27 Jul 2018 at 18:15, Greg Kroah-Hartman
wrote:
>
> On Thu, Jul 26, 2018 at 06:41:52PM +0300, Georgios Tsotsos wrote:
> > Fixing coding style for CVMX_WAIT_FOR_FIELD32 was confus
The function rtw_calculate_wlan_pkt_size_by_attribue() also defined as
rtw_wlan_pkt_size() is never used, so remove it. Discovered by cppcheck.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_xmit.c| 18 --
drivers/staging/rtl8188eu/include/rtw_xmit.h |
Use !x instead of x == NULL.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_xmit.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_xmit.c
b/drivers/staging/rtl8188eu/core/rtw_xmit.c
index 89843201a338..03b6
Replace tabs with spaces, clears a checkpatch 'line over 80 characters'
warning.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_xmit.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_xmit.c
b/drivers/staging/rtl
On 2018/7/28 15:10, Gao Xiang wrote:
> There is a type mismatch in the definition of
> Z_EROFS_VLE_VMAP_ONSTACK_PAGES, let's fix it.
>
> Link: https://lists.01.org/pipermail/kbuild-all/2018-July/050707.html
> Reported-by: kbuild test robot
> Signed-off-by: Gao Xiang
Reviewed-by: Chao Yu
Thank
Hello Greg,
On 2018/7/28 15:25, Greg Kroah-Hartman wrote:
>
> Thanks for submitting this, the filesystem looks very interesting. I've
> queued it all up now in the staging-next tree.
Thanks very much for queuing erofs filesystem, that's actually excellent news
for us that it can be upstreamed s
On 2018/7/28 15:25, Greg Kroah-Hartman wrote:
> Thanks for submitting this, the filesystem looks very interesting. I've
> queued it all up now in the staging-next tree.
Thanks for applying, we are continuously optimizing further and hope to attract
more fs guys :)
Thanks,
Gao Xiang
_
On Thu, Jul 26, 2018 at 08:21:43PM +0800, Gao Xiang wrote:
> Hi,
>
> This is actually the 2nd patchset of erofs file system,
> the original patchset can be found at
>
> Link: https://marc.info/?l=linux-fsdevel&m=152776480425624
>
> In order to keep up with the mainline linux-kernel changes and
>
On Fri, Jul 27, 2018 at 10:22:00PM -0700, Todd Poynor wrote:
> From: Todd Poynor
>
> Hold a reference on the struct device kobject while a pointer to that
> device is in use by gasket.
>
> Reported-by: Greg Kroah-Hartman
> Signed-off-by: Todd Poynor
> ---
> drivers/staging/gasket/gasket_core.
There is a type mismatch in the definition of
Z_EROFS_VLE_VMAP_ONSTACK_PAGES, let's fix it.
Link: https://lists.01.org/pipermail/kbuild-all/2018-July/050707.html
Reported-by: kbuild test robot
Signed-off-by: Gao Xiang
---
drivers/staging/erofs/unzip_vle.h | 2 +-
1 file changed, 1 insertion(+),
52 matches
Mail list logo