[RFC PATCH v5] Xilinx AXI-Stream FIFO v4.1 IP core

2018-07-22 Thread Jacob Feder
This IP core has read and write AXI-Stream FIFOs, the contents of which can be accessed from the AXI4 memory-mapped interface. This is useful for transferring data from a processor into the FPGA fabric. The driver creates a character device that can be read/written to with standard open/read/write/

[PATCH 20/20] staging:rtl8192u: Remove unused RTL8258 bit mask definitions - Style

2018-07-22 Thread John Whitmore
Remove the unused 'RTL8258' bit mask definitions. These definitions fail the checkpatch CamelCase naming tests. Since the definitions are unused in code they have been removed, rather then renaming. This is a coding style change which should have no impact on runtime code execution. Signed-off-by

[PATCH 16/20] staging:rtl8192u: Remove unused page e Bit Mask definitions - Style

2018-07-22 Thread John Whitmore
Remove the unused 'page e' Bit Mask definitions. These definitions will fail the checkpatch CamelCase naming tests. As they are unused in code they have simply been removed rather then renaming. This is a coding style change which should have no impact on runtime code execution. Signed-off-by: Jo

[PATCH 15/20] staging:rtl8192u: Remove unused page d Bit Mask definitions - Style

2018-07-22 Thread John Whitmore
Remove the unused 'page d' Bit Mask definitions. These definitions will fail the checkpatch CamelCase naming test. Since the definitions are unused in code they have been removed, rather then renaming. This is a coding style change which should not impact runtime code execution. Signed-off-by: Jo

[PATCH 17/20] staging:rtl8192u: Remove unused Rx Pseduo noise Bit Mask defs - Style

2018-07-22 Thread John Whitmore
Remove the unused 'Rx Pseduo noise' Bit Mask definitions. These definitions will fail the checkpatch CamelCase naming test. Since the definitions are unused in code they have simply been removed, rather then renaming. This is a coding style change which should have no impact on runtime code execut

[PATCH 07/20] staging:rtl8192u: Remove unused Zebra1 definitions - Style

2018-07-22 Thread John Whitmore
Remove unused 'Zebra1' definitions. These definitions fail the checkpatch CamelCase test, rather then rename, these unused definitions have simply been removed. This is a coding style change which should have not impact on runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/

[PATCH 19/20] staging:rtl8192u: Remove unused Zebra4 bit mask definitions - Style

2018-07-22 Thread John Whitmore
Remove the unused 'Zebra4' bit mask definitions. These definitions fail the checkpatch CamelCase naming tests. Rather then renaming, as the definitions are unused they have simply been removed. This is a coding style change which should not impact runtime code execution. Signed-off-by: John Whitm

[PATCH 02/20] staging:rtl8192u: Remove unused page 8 definitions - Style

2018-07-22 Thread John Whitmore
Remove page 8 definitions which are never used in code. Many of these definitions, if not all, fail the checkpatch CamelCase checks. To avoid the effort of renaming unused definitions they have been removed. This is a style change which should have no impact on runtime execution. Signed-off-by: J

[PATCH 06/20] staging:rtl8192u: Remove unused page d definitions - Style

2018-07-22 Thread John Whitmore
Remove the unused 'page d' definitions. These definitions fail the checkpatch CamelCase naming test. Rather then renaming unused definitions they have simply been removed. This change is a coding style change and should have no impact on runtime code execution. Signed-off-by: John Whitmore --- d

[PATCH 05/20] staging:rtl8192u: Remove unused page c definitions - Style

2018-07-22 Thread John Whitmore
Remove unused 'page c' definitions. These definitions fail the checkpatch CamelCase test, to save renaming, these unused definitions have simply been removed. This is a coding style change which should not have an impact on runtime code execution. Signed-off-by: John Whitmore --- drivers/staging

[PATCH 04/20] staging:rtl8192u: Remove unused page a definitions - Style

2018-07-22 Thread John Whitmore
Remove unused 'page a' definitions. These definitions fail the checkpatch CamelCase naming test, rather then renaming these unused definitions they have simply been removed. This is a coding style change only, and should have no impact on runtime code execution. Signed-off-by: John Whitmore ---

[PATCH 03/20] staging:rtl8192u: Remove unused page 9 definitions - Style

2018-07-22 Thread John Whitmore
Remove the unused definitions from page 9 section. These definitions will fail the checkpatch CamelCase test, to save renaming these unused definitions they have simply been removed. This is a coding style change which should not impact runtime code execution. Signed-off-by: John Whitmore --- d

[PATCH 12/20] staging:rtl8192u: Remove unused page-9 Bit Mask definitions - Style

2018-07-22 Thread John Whitmore
Remove the unused page-9 Bit Mask definitions. These definitions fail the checkpatch CamelCase naming tests. Since the definitions are unused in code they have simply been removed, rather then renaming. The change is purely a coding style change and should not impact runtime code execution. Signed

[PATCH 11/20] staging:rtl8192u: Remove unused page-8 Bit Mask definitions - Style

2018-07-22 Thread John Whitmore
Remove unused 'page-8' Bit Mask definitions. These definitions fail the checkpatch CamelCase naming test, since they are unused in code they have simply been removed from code, rather then renamed. This is a coding style change which should not impact runtime code execution. * page-8 */ Signed-o

[PATCH 09/20] staging:rtl8192u: Remove unused RTL8258 definitions - Style

2018-07-22 Thread John Whitmore
Remove the unused RTL8258 definitions. These definitions fail the checkpatch CamelCase naming test, rather then renaming, as the definitions are unused they have simply been removed. This is a coding style change which should not impact runtime code execution. Signed-off-by: John Whitmore --- dr

[PATCH 14/20] staging:rtl8192u: Remove unused page c Bit Mask definitions - Style

2018-07-22 Thread John Whitmore
Remove the unused 'page c' Bit Mask definitions. These definitions will fail the checkpatch CamelCase naming test. Rather then renaming, as the definitions are unused in code, they have simply been removed. The change is a coding style change which should not impact runtime code execution. Signed

[PATCH 13/20] staging:rtl8192u: Remove unused page-a Bit Mask definitions - Style

2018-07-22 Thread John Whitmore
Remove the unused 'page-a' Bit Mask definitions. These definitions will fail the checkpatch CamelCase naming tests, rather then renaming, as the definitions are unused, they have simply been removed. This is a coding style change and should have no impact on runtime code execution. Signed-off-by:

[PATCH 08/20] staging:rtl8192u: Remove unused Zebra4 definitions - Style

2018-07-22 Thread John Whitmore
Remove the unused 'Zebra4' definitions. These definitions fail the checkpatch CamelCase naming test, rather then rename as they are unused definitions they have simply been removed. This is a coding style change which should not impact runtime code execution. Signed-off-by: John Whitmore --- dri

[PATCH 00/20] staging:rtl8192u: Remove unused definitions - Style

2018-07-22 Thread John Whitmore
I went through this header file removing unused definitions, rather then renaming them all. I know somebody went to the effort of entering these definitions in the code, and it might be viewed as lazy simply to removed the definitions rather then renaming them all, as they fail the checkpatch Camel

[PATCH 10/20] staging:rtl8192u: Remove unused page-1 Bit Masks - Style

2018-07-22 Thread John Whitmore
Remove the unused 'page-1' Bit Masks. These definitions fail the checkpatch CamelCase naming test. To avoid renaming the definitions have simply been removed. This is a coding style change which should have no impact on runtime code execution. Signed-off-by: John Whitmore --- drivers/staging/rtl

[PATCH 18/20] staging:rtl8192u: Remove unused RF Zebra1 Bit Mask definitions - Style

2018-07-22 Thread John Whitmore
Remove the unused 'RF Zebra1' bit mask definitions. These definitions fail the checkpatch CamelCase naming tests. Since the definitions are unused in code they have simply been removed, rather then renaming. This is a coding style change which will have no impact on runtime code execution. Signed

[PATCH 01/20] staging:rtl8192u: Remove unused page 1 definitions - Style

2018-07-22 Thread John Whitmore
Remove all the "page 1" definitions as they are not used in code. A lot of these definitions, if not all, fail checkpatch because of CamelCase issues. Rather then change the names of unused constants simply remove. This is a coding style change which should have no impact on runtime execution. Si

[PATCH v2] staging: dgnc: dgnc_tty.c: Avoid '(' at the end of line

2018-07-22 Thread Nishad Kamdar
Bring the first argument to the previous line, remove a superfluous () in the second argument by using !, and align the lines to match open parenthesis. Issue found by checkpatch. Signed-off-by: Nishad Kamdar --- Changes since v1: - Remove a superfluous () and use ! instead, in the second argume

Re: [RFC PATCH v4] Xilinx AXI-Stream FIFO v4.1 IP core driver

2018-07-22 Thread Stephen Hemminger
On Sat, 21 Jul 2018 20:14:55 -0400 Jacob Feder wrote: > diff --git a/drivers/staging/axis-fifo/Kconfig > b/drivers/staging/axis-fifo/Kconfig > new file mode 100644 > index 000..77d5701 > --- /dev/null > +++ b/drivers/staging/axis-fifo/Kconfig > @@ -0,0 +1,9 @@ > +# > +# "Xilinx AXI-Stream FI

Re: [PATCH] staging: dgnc: dgnc_tty.c: Avoid '(' at the end of line

2018-07-22 Thread Nishad Kamdar
On Sun, Jul 22, 2018 at 12:50:25AM -0700, Joe Perches wrote: > On Sun, 2018-07-22 at 09:39 +0530, Nishad Kamdar wrote: > > Bring the first argument to the previous line and > > align the other lines to match open parenthesis. > [] > > diff --git a/drivers/staging/dgnc/dgnc_tty.c > > b/drivers/stag

Re: [PATCH] staging: dgnc: dgnc_tty.c: Avoid '(' at the end of line

2018-07-22 Thread Joe Perches
On Sun, 2018-07-22 at 09:39 +0530, Nishad Kamdar wrote: > Bring the first argument to the previous line and > align the other lines to match open parenthesis. [] > diff --git a/drivers/staging/dgnc/dgnc_tty.c b/drivers/staging/dgnc/dgnc_tty.c [] > @@ -883,10 +883,9 @@ static int dgnc_tty_open(struc