On Fri, Jul 13, 2018 at 09:48:16AM +0300, Dan Carpenter wrote:
> On Fri, Jul 13, 2018 at 12:54:16AM +0300, Tuomas Tynkkynen wrote:
> > @@ -424,7 +411,9 @@ int bcm2835_audio_open(struct bcm2835_alsa_stream
> > *alsa_stream)
> > int status;
> > int ret;
> >
> > - my_workqueue_init(alsa_s
On Fri, Jul 13, 2018 at 12:54:16AM +0300, Tuomas Tynkkynen wrote:
> @@ -424,7 +411,9 @@ int bcm2835_audio_open(struct bcm2835_alsa_stream
> *alsa_stream)
> int status;
> int ret;
>
> - my_workqueue_init(alsa_stream);
> + alsa_stream->my_wq = alloc_workqueue("my_queue", WQ_HIG
On Fri, Jul 13, 2018 at 06:56:20AM +0200, Sergio Paracuellos wrote:
> On Thu, Jul 12, 2018 at 09:28:15PM +0300, Dan Carpenter wrote:
> > On Thu, Jul 12, 2018 at 08:15:00PM +0200, Sergio Paracuellos wrote:
> > > map_bus callback is called before every .read/.write operation.
> > > Implement it and c
Before setting channel->rescind in vmbus_rescind_cleanup(), we should make
sure the channel callback won't run any more, otherwise a high-level
driver like pci_hyperv, which may be infinitely waiting for the host VSP's
response and notices the channel has been rescinded, can't safely give
up: e.g
On Thu, Jul 12, 2018 at 09:28:15PM +0300, Dan Carpenter wrote:
> On Thu, Jul 12, 2018 at 08:15:00PM +0200, Sergio Paracuellos wrote:
> > map_bus callback is called before every .read/.write operation.
> > Implement it and change custom read write operations for the
> > pci subsystem generics. Make
'hostif_mib_set_request_bool' function receives a bool as value and
send the received value with MIB_VALUE_TYPE_BOOL type. There is
one case where the value passed is not a boolean one but
'MCAST_FILTER_PROMISC' which is '2'. Call hostif_mib_set_request_int
instead. This changes original code behav
On Thu, Jul 12, 2018 at 10:11:25PM +0300, Dan Carpenter wrote:
> On Thu, Jul 12, 2018 at 08:20:16PM +0200, Sergio Paracuellos wrote:
> > On Thu, Jul 12, 2018 at 2:13 PM, Dan Carpenter
> > wrote:
> > > On Thu, Jul 12, 2018 at 06:57:42AM +0200, Sergio Paracuellos wrote:
> > >> 'hostif_mib_set_reque
Hello,
Even after asking again, I never did hear from the customer why it matters if
the name changes. The case is being closed, and I am assuming that the
information you gave (that I passed onto the customer) was sufficient to answer
the customer's question.
Thank you Greg, Vitaly, and Peter
Changed logging statements to use %s and __func__ instead of hard coding
the function name in a string.
Signed-off-by: Felix Siegel
---
drivers/staging/gasket/apex_driver.c | 7 ---
drivers/staging/gasket/gasket_core.c | 8 +---
drivers/staging/gasket/gasket_ioctl.c |
Remove log messages that solely print the function's name
everytime it is called.
Signed-off-by: Felix Siegel
---
drivers/staging/gasket/apex_driver.c | 8
1 file changed, 8 deletions(-)
diff --git a/drivers/staging/gasket/apex_driver.c
b/drivers/staging/gasket/apex_driver.c
index 395
> Function calls that do nothing but log "Look at this function I just
> entered/exited!" need to just be deleted entirely, as ftrace should be
> used instead.
>
> Care to do that here, and then send a patch for the remaining messages
> that do need __func__?
Sure. I hope this is how you meant it.
On Fri, Jul 13, 2018 at 12:29:36AM +0200, Jann Horn wrote:
> From: Samuel Thibault
>
> From: Samuel Thibault
>
> If softsynthx_read() is called with `count < 3`, `count - 3` wraps, causing
> the loop to copy as much data as available to the provided buffer. If
> softsynthx_read() is invoked thr
Currently, if bcm2835_audio_open() fails partway, the allocated
workqueue is leaked. Avoid that.
While at it, propagate the return value of
bcm2835_audio_open_connection() on failure instead of returning -1.
Signed-off-by: Tuomas Tynkkynen
---
.../staging/vc04_services/bcm2835-audio/bcm2835-vch
Currently, if allocating a workqueue fails, the driver will probe
successfully but it will silently do nothing, which is rather silly.
So instead bail out with -ENOMEM in bcm2835_audio_open() if
alloc_workqueue() fails, and remove the now pointless checks for a NULL
workqueue.
While at it, get rid
On Thu, 12 Jul 2018 21:53:54 +0200
Greg Kroah-Hartman wrote:
> On Thu, Jul 12, 2018 at 09:27:14PM +0200, Felix Siegel wrote:
> > This patch fixes checkpatch.pl warnings:
> >
> > WARNING: Block comments should align the * on each line
> > Signed-off-by: Felix Siegel
>
> So close, I need a blank
On Thu, 12 Jul 2018 21:42:49 +0200
Greg Kroah-Hartman wrote:
> On Thu, Jul 12, 2018 at 09:27:12PM +0200, Felix Siegel wrote:
> > Use GPL-2.0 based on the license text in each of the files.
> > Remove license "boiler-plate".
> >
> > Signed-off-by: Felix Siegel
>
> I sent this same patch 1 1/2 d
On Thu, Jul 12, 2018 at 09:27:14PM +0200, Felix Siegel wrote:
> This patch fixes checkpatch.pl warnings:
>
> WARNING: Block comments should align the * on each line
> Signed-off-by: Felix Siegel
So close, I need a blank line before the signed-of-by line :(
I'll go edit it by hand, but be more c
On Thu, Jul 12, 2018 at 09:27:15PM +0200, Felix Siegel wrote:
> Changed logging statements to use %s and __func__ instead of hard coding
> the function name in a string.
>
> Signed-off-by: Felix Siegel
> ---
> drivers/staging/gasket/apex_driver.c | 15 ---
> drivers/staging/gas
This patch fixes checkpatch.pl warnings:
WARNING: Block comments should align the * on each line
Signed-off-by: Felix Siegel
---
drivers/staging/gasket/gasket_core.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/gasket/gasket_core.c
b/drivers/stagin
Changed logging statements to use %s and __func__ instead of hard coding
the function name in a string.
Signed-off-by: Felix Siegel
---
drivers/staging/gasket/apex_driver.c | 15 ---
drivers/staging/gasket/gasket_core.c | 11 ++-
drivers/staging/gasket/gasket_ioct
Move open open-curly brace to the next line following function
definition to match the kernel's coding style
Signed-off-by: Felix Siegel
---
drivers/staging/gasket/gasket_core.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/gasket/gasket_core.c
b/drivers/
On Thu, Jul 12, 2018 at 09:27:12PM +0200, Felix Siegel wrote:
> Use GPL-2.0 based on the license text in each of the files.
> Remove license "boiler-plate".
>
> Signed-off-by: Felix Siegel
I sent this same patch 1 1/2 days ago :)
sorry,
greg k-h
___
Use GPL-2.0 based on the license text in each of the files.
Remove license "boiler-plate".
Signed-off-by: Felix Siegel
---
drivers/staging/gasket/apex.h | 1 +
drivers/staging/gasket/apex_driver.c | 9 +
drivers/staging/gasket/gasket.h| 9 +
drivers
On Thu, Jul 12, 2018 at 08:20:16PM +0200, Sergio Paracuellos wrote:
> On Thu, Jul 12, 2018 at 2:13 PM, Dan Carpenter
> wrote:
> > On Thu, Jul 12, 2018 at 06:57:42AM +0200, Sergio Paracuellos wrote:
> >> 'hostif_mib_set_request_bool' function receives a bool as value and
> >> send the received val
There's no need to explicitly cast DPAA2_ETH_MFL to u16,
so remove it.
Signed-off-by: Ioana Radulescu
Suggested-by: Dan Carpenter
---
drivers/staging/fsl-dpaa2/ethernet/dpaa2-eth.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/fsl-dpaa2/ethernet/dpaa2-eth.c
On Thu, Jul 12, 2018 at 08:15:00PM +0200, Sergio Paracuellos wrote:
> map_bus callback is called before every .read/.write operation.
> Implement it and change custom read write operations for the
> pci subsystem generics. Make the probe function to assign data
> for controller data and get pci reg
On Thu, Jul 12, 2018 at 2:13 PM, Dan Carpenter wrote:
> On Thu, Jul 12, 2018 at 06:57:42AM +0200, Sergio Paracuellos wrote:
>> 'hostif_mib_set_request_bool' function receives a bool as value and
>> send the received value with MIB_VALUE_TYPE_BOOL type. There is
>> one case where the value passed i
Driver is using now pci subsystem generics reads and writes. Because
of this there is a lot of dead code that can be removed.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 128
1 file changed, 128 deletions(-)
diff --git a/drive
This patch series include an attempt to avoid the use of custom
read and writes in driver code and use PCI subsystem common ones.
In order to do this 'map_bus' callback is implemented and also
data structures for driver are included. The regs base address
is being readed from device tree and the d
map_bus callback is called before every .read/.write operation.
Implement it and change custom read write operations for the
pci subsystem generics. Make the probe function to assign data
for controller data and get pci register base from device tree.
Signed-off-by: Sergio Paracuellos
---
driver
> > Linux kernel coding style: spaces are never used for
> > indentation.
> >
...
> > struct goldfish_audio {
> > char __iomem *reg_base;
> > int irq;
> > +
>
> That's not a space/tab issue?
Thank you for looking. I separated the new line change into a separate patch.
Use strlcpy instead of strncpy to avoid gcc 8 warning:
warning: '__builtin_strncpy' specified bound 16 equals destination size
[-Wstringop-truncation]
The maximum length of the source string including terminating null is 5.
Hence it always fits in the destination buffer of length 16.
Signed-off-
On Wed, Jul 11, 2018 at 04:36:28PM -0700, r...@google.com wrote:
> From: Roman Kiryanov
>
> Linux kernel coding style: spaces are never used for
> indentation.
This patch is good but that's not strictly true... I don't think the
code here causes a checkpatch.pl warning, and checkpatch is pretty
On Thu, Jul 12, 2018 at 06:57:42AM +0200, Sergio Paracuellos wrote:
> 'hostif_mib_set_request_bool' function receives a bool as value and
> send the received value with MIB_VALUE_TYPE_BOOL type. There is
> one case where the value passed is not a boolean one but
> 'MCAST_FILTER_PROMISC' which is '2
Refactor rtw_is_cckratesonly_included() to improve readability and
slightly reduce object file size.
Suggested-by: Joe Perches
Signed-off-by: Michael Straube
---
drivers/staging/rtl8723bs/core/rtw_ieee80211.c | 9 -
1 file changed, 4 insertions(+), 5 deletions(-)
diff --git a/drivers/s
Use if(x) instead of if(x == true).
Signed-off-by: Michael Straube
---
.../staging/rtl8723bs/core/rtw_ieee80211.c| 6 ++--
.../staging/rtl8723bs/os_dep/ioctl_linux.c| 28 +--
2 files changed, 17 insertions(+), 17 deletions(-)
diff --git a/drivers/staging/rtl8723bs/core/
Both rtw_is_cckrates_included() and rtw_is_cckratesonly_included()
return true or false. Change the return type from uint to bool.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8723bs/core/rtw_ieee80211.c | 4 ++--
drivers/staging/rtl8723bs/include/ieee80211.h | 4 ++--
2 files changed,
Refactor rtw_is_cckrates_included() to improve readability and
slightly reduce object file size.
Suggested-by: Joe Perches
Signed-off-by: Michael Straube
---
drivers/staging/rtl8723bs/core/rtw_ieee80211.c | 9 -
1 file changed, 4 insertions(+), 5 deletions(-)
diff --git a/drivers/stagi
Remove commented rtw_is_cckrates_included() and
rtw_is_cckratesonly_included() from os_dep/ioctl_linux.c.
Both are defined in core/rtw_ieee80211.c.
Signed-off-by: Michael Straube
---
.../staging/rtl8723bs/os_dep/ioctl_linux.c| 32 ---
1 file changed, 32 deletions(-)
diff --g
Break too long line to follow kernel coding style.
Signed-off-by: Kacper Kołodziej
---
drivers/staging/rtl8188eu/core/rtw_ap.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_ap.c
b/drivers/staging/rtl8188eu/core/rtw_ap.c
index 454a975a14
40 matches
Mail list logo