On Wed, Jul 11, 2018 at 09:24:09PM +0200, Kacper Kołodziej wrote:
> Signed-off-by: Kacper Kołodziej
Sorry, but I need a changelog text in order to be able to take a patch.
thanks,
greg k-h
___
devel mailing list
de...@linuxdriverproject.org
http://dri
A: http://en.wikipedia.org/wiki/Top_post
Q: Were do I find info about this thing called top-posting?
A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing in e-mail?
A: No.
Q: Should I incl
'hostif_mib_set_request_bool' function receives a bool as value and
send the received value with MIB_VALUE_TYPE_BOOL type. There is
one case where the value passed is not a boolean one but
'MCAST_FILTER_PROMISC' which is '2'. Pass 'int' instead to avoid
the problem.
Fixes: 8ce76bff0e6a ("staging:
On Wed, Jul 11, 2018 at 05:19:15PM +0300, Dan Carpenter wrote:
> Hello Sergio Paracuellos,
>
> The patch 8ce76bff0e6a: "staging: ks7010: add new helpers to achieve
> mib set request and simplify code" from May 4, 2018, leads to the
> following static checker warning:
>
> drivers/staging/ks7
From: Roman Kiryanov
To separate data members and the comment for better readability.
Signed-off-by: Roman Kiryanov
---
drivers/staging/goldfish/goldfish_audio.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/goldfish/goldfish_audio.c
b/drivers/staging/goldfish/goldfish_a
From: Sunil Muthuswamy Sent: Wednesday, July 11, 2018 9:59 AM
> Thanks, Michael. In which branch should I fix these now that the changes have
> been
> merged with the char-misc-next branch?
If the original code is already in char-misc-next, you should probably submit a
completely new patch for ch
Signed-off-by: Kacper Kołodziej
---
drivers/staging/rtl8188eu/core/rtw_ap.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_ap.c
b/drivers/staging/rtl8188eu/core/rtw_ap.c
index 454a975a14f2..220b4bbe1f84 100644
--- a/drivers/staging/rtl818
The file r8192U.h defines the structure for holding private data for the
driver (typedef struct r8192_priv). This structure includes a member Rf_Mode
which is defined to be of type "u8".
Whilst the variable Rf_Mode is defined to be of type "u8" it is being assigned
enumerated values defined by the
Change structure rx_desc_819x_usb from being typedef to being a simple
structure, without the typedef.
Clears a checkpatch issue, definging new types in the code.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/r8192U.h | 4 ++--
drivers/staging/rtl8192u/r8192U_core.c | 14 +
The first 9 patches in this series are coding style changes, including a
number of patches to remove the "typedef" directive from a number of data
structure definitions. This clears the checkpatch warning about defining new
data types in the code.
The last patch in the series, however, changes the
Change structure tx_desc_cmd_819x_usb from being typedef to being a simple
structure, without the typedef.
checkpatch warns about defining new types in the code.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/r8192U.h | 4 ++--
drivers/staging/rtl8192u/r8192U_core.c | 2 +-
2 fi
Change structure tx_fwinfo_819x_usb from being typedef to being a simple
structure, without the typedef.
Clears the coding style issue flagged by checkpatch, (new type definitions)
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/r8192U.h | 6 +++---
drivers/staging/rtl8192u/r819
Removed the typedef from the struct rx_drvinfo_819x_usb to leave it as a
simple structure.
This clears the issue flagged by checkpatch, defining new types.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/r8192U.h | 4 ++--
drivers/staging/rtl8192u/r8192U_core.c | 10 +-
Trim the extra blank lines from the code, to clear checkpatch messages.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/r8192U.h | 20
1 file changed, 20 deletions(-)
diff --git a/drivers/staging/rtl8192u/r8192U.h
b/drivers/staging/rtl8192u/r8192U.h
index fa451c6
Structure tx_desc_819x_usb_aggr_subframe is defined in a local header file but
is not used outside of the header file. Removed from the code as a result.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/r8192U.h | 28
1 file changed, 28 deletions(-)
diff --
Removal of structure rx_desc_819x_usb_aggr_subframe from local header file,
which is not used outside the header file.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/r8192U.h | 18 --
1 file changed, 18 deletions(-)
diff --git a/drivers/staging/rtl8192u/r8192U.h
b/dr
Simple rename of the preprosessor switch, protecting against multiple
inclusion of the header file. Change to clear the checkpatch coding style
issue.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/r8192U.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/driver
Change structure tx_desc_819x_usb from being typedef to being a simple
structure, without the typedef.
checkpatch warns about defining new types in code.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/r8192U.h | 6 +++---
drivers/staging/rtl8192u/r8192U_core.c | 4 ++--
2 files
On 07/11/18 18:03, Joe Perches wrote:
On Wed, 2018-07-11 at 15:57 +0200, Michael Straube wrote:
On 07/08/18 19:36, Michael Straube wrote:
On 07/08/18 18:46, Joe Perches wrote:
On Sun, 2018-07-08 at 12:38 +0200, Michael Straube wrote:
uint rtw_is_cckratesonly_included(u8 *rate)
{
while (*
On Wed, 2018-07-11 at 15:57 +0200, Michael Straube wrote:
> On 07/08/18 19:36, Michael Straube wrote:
> > On 07/08/18 18:46, Joe Perches wrote:
> > > On Sun, 2018-07-08 at 12:38 +0200, Michael Straube wrote:
> > >
> > > uint rtw_is_cckratesonly_included(u8 *rate)
> > > {
> > > while (*rate) {
On 11/07/18 11:32, Colin King wrote:
From: Colin Ian King
Variable segpos is being assigned but is never used hence it is redundant
and can be removed.
Cleans up clang warning:
warning: variable 'segpos' set but not used [-Wunused-but-set-variable]
Signed-off-by: Colin Ian King
---
drivers
Thanks, Michael. In which branch should I fix these now that the changes have
been
merged with the char-misc-next branch?
Comments inline.
> -Original Message-
> From: Michael Kelley (EOSG)
> Sent: Tuesday, July 10, 2018 6:05 PM
> To: KY Srinivasan ; gre...@linuxfoundation.org; linux-
>
On Mon, Jul 09, 2018 at 05:25:21PM +0300, Dan Carpenter wrote:
> On Sat, Jul 07, 2018 at 10:19:40PM -0400, Jacob Feder wrote:
> > +static ssize_t sysfs_write(struct device *dev, const char *buf,
> > + size_t count, unsigned int addr_offset)
> > +{
> > + struct axis_fifo_local
On Wed, Jul 11, 2018 at 05:29:43PM +0300, Dan Carpenter wrote:
> On Wed, Jul 11, 2018 at 03:27:11PM +0100, John Whitmore wrote:
> > On Wed, Jul 11, 2018 at 04:22:50PM +0200, Greg KH wrote:
> > > On Wed, Jul 11, 2018 at 03:09:37PM +0100, John Whitmore wrote:
> > > > On Wed, Jul 11, 2018 at 01:13:49P
On Wed, Jul 11, 2018 at 03:27:11PM +0100, John Whitmore wrote:
> On Wed, Jul 11, 2018 at 04:22:50PM +0200, Greg KH wrote:
> > On Wed, Jul 11, 2018 at 03:09:37PM +0100, John Whitmore wrote:
> > > On Wed, Jul 11, 2018 at 01:13:49PM +0200, Greg KH wrote:
> > > > On Tue, Jul 10, 2018 at 04:05:18PM +010
On Wed, Jul 11, 2018 at 04:22:50PM +0200, Greg KH wrote:
> On Wed, Jul 11, 2018 at 03:09:37PM +0100, John Whitmore wrote:
> > On Wed, Jul 11, 2018 at 01:13:49PM +0200, Greg KH wrote:
> > > On Tue, Jul 10, 2018 at 04:05:18PM +0100, John Whitmore wrote:
> > > > Corrected coding style issues aroung op
On Wed, Jul 11, 2018 at 03:09:37PM +0100, John Whitmore wrote:
> On Wed, Jul 11, 2018 at 01:13:49PM +0200, Greg KH wrote:
> > On Tue, Jul 10, 2018 at 04:05:18PM +0100, John Whitmore wrote:
> > > Corrected coding style issues aroung opening and closed parenthesis.
> > > Spaces, or blank line, remov
Hello Sergio Paracuellos,
The patch 8ce76bff0e6a: "staging: ks7010: add new helpers to achieve
mib set request and simplify code" from May 4, 2018, leads to the
following static checker warning:
drivers/staging/ks7010/ks_hostif.c:1845 hostif_sme_multicast_set()
warn: '2' cannot fi
On Wed, Jul 11, 2018 at 01:13:49PM +0200, Greg KH wrote:
> On Tue, Jul 10, 2018 at 04:05:18PM +0100, John Whitmore wrote:
> > Corrected coding style issues aroung opening and closed parenthesis.
> > Spaces, or blank line, removed from after '(' or before ')'
>
> Wrap your changelog text at 72 col
On 07/08/18 19:36, Michael Straube wrote:
On 07/08/18 18:46, Joe Perches wrote:
On Sun, 2018-07-08 at 12:38 +0200, Michael Straube wrote:
uint rtw_is_cckratesonly_included(u8 *rate)
{
while (*rate) {
u8 r = *rate & 0x7f;
if (r != 2 && r != 4 && r != 11 && r != 22)
Fix to return a negative error code from the kthread_run() error
handling case instead of 0, as done elsewhere in this function.
Signed-off-by: Wei Yongjun
---
drivers/staging/pi433/pi433_if.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/pi433/pi433_if.c b/drivers/staging/
Colin King, le mer. 11 juil. 2018 12:26:07 +0100, a ecrit:
> From: Colin Ian King
>
> Variable l is being assigned but is never used hence it is redundant
> and can be removed.
>
> Cleans up clang warning:
> warning: variable 'l' set but not used [-Wunused-but-set-variable
>
> Signed-off-by: Co
Remove unrequired blank lines as reported by checkpatch.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_ap.c| 6 --
drivers/staging/rtl8188eu/core/rtw_wlan_util.c | 1 -
2 files changed, 7 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_ap.c
b/dr
Fix lines over 80 characters by adding appropriate line breaks.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_wlan_util.c | 18 --
1 file changed, 12 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_wlan_util.c
b/drivers/stag
Add spaces around '|' to follow kernel coding style.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_wlan_util.c | 16
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_wlan_util.c
b/drivers/staging/rtl8188eu/
On Wed, Jul 11, 2018 at 10:29:43AM +0300, Dan Carpenter wrote:
> On Tue, Jul 10, 2018 at 09:33:47PM +0200, Sergio Paracuellos wrote:
> > +static int mt7621_pcie_parse_dt(struct mt7621_pcie_port *port)
> > +{
> > + struct device *dev = port->dev;
> > + struct device_node *node = dev->of_node;
>
On Wed, Jul 11, 2018 at 11:16:14AM +0200, Greg KH wrote:
> On Tue, Jul 10, 2018 at 09:33:47PM +0200, Sergio Paracuellos wrote:
> > map_bus callback is called before every .read/.write operation.
> > Implement it and change custom read write operations for the
> > pci subsystem generics. Make the pr
On Wed, Jul 11, 2018 at 07:51:05PM +1000, NeilBrown wrote:
> On Wed, Jul 11 2018, Greg KH wrote:
>
> > On Wed, Jul 11, 2018 at 10:29:43AM +0300, Dan Carpenter wrote:
> >> On Tue, Jul 10, 2018 at 09:33:47PM +0200, Sergio Paracuellos wrote:
> >> > +static int mt7621_pcie_parse_dt(struct mt7621_pcie_
From: Colin Ian King
Variables rx_sts, sq, frame and is_pspoll are being assigned but are
never used hence they are redundant and can be removed.
Cleans up clang warnings:
warning: variable 'sq' set but not used [-Wunused-but-set-variable]
warning: variable 'rx_sts' set but not used [-Wunused-bu
Now that the files are all properly tagged with SPDX lines, and the
boilerplate license text is gone, remove the TODO item.
Cc: Rob Springer
Cc: John Joseph
Cc: Ben Chan
Signed-off-by: Greg Kroah-Hartman
---
drivers/staging/gasket/TODO | 2 --
1 file changed, 2 deletions(-)
diff --git a/driv
It's good to have SPDX identifiers in all files to make it easier to
audit the kernel tree for correct licenses.
Fix up the all of the staging gasket files to have a proper SPDX
identifier, based on the license text in the file itself. The SPDX
identifier is a legally binding shorthand, which can
Now that the SPDX tag is in all gasket files, that identifies the
license in a specific and legally-defined manner. So the extra GPL text
wording can be removed as it is no longer needed at all.
This is done on a quest to remove the 700+ different ways that files in
the kernel describe the GPL li
From: Colin Ian King
Pointer 'output' is being assigned but is never used hence it is redundant
and can be removed.
Cleans up clang warning:
warning: variable 'output' set but not used [-Wunused-but-set-variable]
Signed-off-by: Colin Ian King
---
drivers/staging/sm750fb/sm750.c | 2 --
1 file
Fix lines over 80 characters by adding appropriate line breaks.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8723bs/core/rtw_wlan_util.c | 9 ++---
1 file changed, 6 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/rtl8723bs/core/rtw_wlan_util.c
b/drivers/staging/rtl8723
Remove unrequired blank lines as reported by checkpatch.
Signed-off-by: Michael Straube
---
.../staging/rtl8723bs/core/rtw_wlan_util.c| 30 ---
1 file changed, 30 deletions(-)
diff --git a/drivers/staging/rtl8723bs/core/rtw_wlan_util.c
b/drivers/staging/rtl8723bs/core/rtw_w
Fix comparsions to NULL to follow kernel coding style.
x == NULL -> !x
x != NULL -> x
Signed-off-by: Michael Straube
---
drivers/staging/rtl8723bs/core/rtw_wlan_util.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/rtl8723bs/core/rtw_wlan_util.
From: Colin Ian King
Variable l is being assigned but is never used hence it is redundant
and can be removed.
Cleans up clang warning:
warning: variable 'l' set but not used [-Wunused-but-set-variable
Signed-off-by: Colin Ian King
---
drivers/staging/speakup/varhandlers.c | 5 ++---
1 file ch
Add spaces around '|' to follow kernel coding style.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8723bs/core/rtw_wlan_util.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/rtl8723bs/core/rtw_wlan_util.c
b/drivers/staging/rtl8723bs/core/rtw_
Simplify ratetbl_val_2wifirate() by not using extra variable
for the return value.
Signed-off-by: Michael Straube
---
.../staging/rtl8723bs/core/rtw_wlan_util.c| 53 +--
1 file changed, 14 insertions(+), 39 deletions(-)
diff --git a/drivers/staging/rtl8723bs/core/rtw_wlan_ut
On Tue, Jul 10, 2018 at 04:05:18PM +0100, John Whitmore wrote:
> Corrected coding style issues aroung opening and closed parenthesis. Spaces,
> or blank line, removed from after '(' or before ')'
Wrap your changelog text at 72 columns like your editor asked you to :(
I'll fix it up this time...
Trivial fix to remove sparse warnings:
drivers/staging/gasket/gasket_page_table.c:884:40: warning: Using plain
integer as NULL pointer
drivers/staging/gasket/gasket_page_table.c:1743:57: warning: Using plain
integer as NULL pointer
drivers/staging/gasket/gasket_page_table.c:1768:57: warnin
From: Colin Ian King
Variable eth_proto is being assigned but is never used hence it is
redundant and can be removed.
Cleans up clang warning:
warning: variable 'eth_proto' set but not used [-Wunused-but-set-variable]
Signed-off-by: Colin Ian King
---
drivers/staging/ks7010/ks_hostif.c | 2 --
The following changes since commit 021c91791a5e7e85c567452f1be3e4c2c6cb6063:
Linux 4.18-rc3 (2018-07-01 16:04:53 -0700)
are available in the Git repository at:
git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git/
tags/staging-4.18-rc5
for you to fetch changes up to d59d2f9995d
From: Colin Ian King
Variable idProduct and idVendor are being assigned but are never used
hence they are redundant and can be removed.
Cleans up clang warnings:
warning: variable 'idProduct' set but not used [-Wunused-but-set-variable]
warning: variable 'idVendor' set but not used [-Wunused-but
From: Colin Ian King
Pointer bar_data is being assigned but is never used hence it is redundant
and can be removed.
Cleans up clang warning:
warning: variable 'bar_data' set but not used [-Wunused-but-set-variable]
Signed-off-by: Colin Ian King
---
drivers/staging/gasket/gasket_core.c | 3 ---
From: Colin Ian King
Variable segpos is being assigned but is never used hence it is redundant
and can be removed.
Cleans up clang warning:
warning: variable 'segpos' set but not used [-Wunused-but-set-variable]
Signed-off-by: Colin Ian King
---
drivers/staging/comedi/drivers/pcl816.c | 4 ++-
Lines have been split where it makes sense to shorten them in order
to comply with the coding standards and fix checkpatch.pl warnings.
There are still lines left that are too long, however breaking
those would impair readability.
Changes in v2:
- now working on staging-next branch of the staging
On Wed, Jul 11 2018, Greg KH wrote:
> On Wed, Jul 11, 2018 at 10:29:43AM +0300, Dan Carpenter wrote:
>> On Tue, Jul 10, 2018 at 09:33:47PM +0200, Sergio Paracuellos wrote:
>> > +static int mt7621_pcie_parse_dt(struct mt7621_pcie_port *port)
>> > +{
>> > + struct device *dev = port->dev;
>> > + s
For multi-line comments, the preferred commenting style from the
coding style Documentation was applied to the comments, meaning
almost blank lines at the beginning and end of the comment.
One changed comment includes a line over 80 characters, causing
checkpatch.pl to complain, however breaking th
Lines containing multiple statements were broken into multiple
lines, increasing readability and complying with the coding standard.
This also fixes several checkpatch.pl errors complaining about
the lines being too long.
Signed-off-by: Sophie Matter
Signed-off-by: Rico Schrage
---
drivers/stag
Hello,
Jann Horn, le mar. 10 juil. 2018 13:34:33 -0700, a ecrit:
> On Sat, Jul 7, 2018 at 1:29 AM Samuel Thibault
> wrote:
> > Could you review, test, and resubmit the patch below instead?
>
> Er... you mean, you want me to take your patch, add my Signed-off-by
> below yours, and then send that?
On Tue, Jul 10, 2018 at 01:34:59PM -0700, Jann Horn wrote:
> On Sat, Jul 7, 2018 at 7:03 AM Greg Kroah-Hartman
> wrote:
> >
> > On Sat, Jul 07, 2018 at 10:29:26AM +0200, Samuel Thibault wrote:
> > > Re,
> > >
> > > Could you review, test, and resubmit the patch below instead?
> > >
> > > Samuel
>
On Tue, Jul 10, 2018 at 09:33:47PM +0200, Sergio Paracuellos wrote:
> map_bus callback is called before every .read/.write operation.
> Implement it and change custom read write operations for the
> pci subsystem generics. Make the probe function to assign data
> for controller data and get pci reg
On Wed, Jul 11, 2018 at 10:29:43AM +0300, Dan Carpenter wrote:
> On Tue, Jul 10, 2018 at 09:33:47PM +0200, Sergio Paracuellos wrote:
> > +static int mt7621_pcie_parse_dt(struct mt7621_pcie_port *port)
> > +{
> > + struct device *dev = port->dev;
> > + struct device_node *node = dev->of_node;
>
On Tue, Jul 10, 2018 at 09:33:46PM +0200, Sergio Paracuellos wrote:
> Add new 'mt7621_pcie_port' struct as data for the pci controller.
>
> Signed-off-by: Sergio Paracuellos
> ---
> drivers/staging/mt7621-pci/pci-mt7621.c | 10 ++
> 1 file changed, 10 insertions(+)
>
> diff --git a/driv
On Tue, Jul 10, 2018 at 09:33:47PM +0200, Sergio Paracuellos wrote:
> +static int mt7621_pcie_parse_dt(struct mt7621_pcie_port *port)
> +{
> + struct device *dev = port->dev;
> + struct device_node *node = dev->of_node;
> + struct resource regs;
> + const char *type;
> + int err
66 matches
Mail list logo