Hi Michael:
Thanks for your review.
On 7/11/2018 5:29 AM, Michael Kelley (EOSG) wrote:
> From: Tianyu Lan Monday, July 9, 2018 2:03 AM
>> Hyper-V supports a pv hypercall HvFlushGuestPhysicalAddressSpace to
>> flush nested VM address space mapping in l1 hypervisor and it's to
>> reduce ove
>From k...@linuxonhyperv.com Sent: Saturday, July 7,
>2018 7:57 PM
>
> From: Sunil Muthuswamy
>
> In the VM mode on Hyper-V, currently, when the kernel panics, an error
> code and few register values are populated in an MSR and the Hypervisor
> notified. This information is collected on the h
On Tue, 3 Jul 2018 15:01:42 +0300
Dan Carpenter wrote:
> Hello stephen hemminger,
>
> The patch 9749fed5d43d: "netvsc: use ERR_PTR to avoid dereference
> issues" from Jul 19, 2017, leads to the following static checker
> warning:
>
> drivers/net/hyperv/rndis_filter.c:1344 rndis_filter_dev
From: Tianyu Lan Monday, July 9, 2018 2:03 AM
> Hyper-V supports a pv hypercall HvFlushGuestPhysicalAddressSpace to
> flush nested VM address space mapping in l1 hypervisor and it's to
> reduce overhead of flushing ept tlb among vcpus. This patch is to
> implement it.
>
> Signed-off-by: Lan Tiany
> -Original Message-
> From: Dan Carpenter [mailto:dan.carpen...@oracle.com]
> Sent: Monday, July 9, 2018 10:28 PM
> To: Ioana Ciocoi Radulescu
> Cc: gre...@linuxfoundation.org; de...@driverdev.osuosl.org; linux-
> ker...@vger.kernel.org; Ioana Ciornei
> Subject: Re: [PATCH 5/5] staging:
From: Vitaly Kuznetsov Monday, July 9, 2018 10:40 AM
> Commit 1268ed0c474a ("x86/hyper-v: Fix the circular dependency in IPI
> enlightenment") pre-filled hv_vp_index with VP_INVAL so it is now
> (theoretically) possible to observe hv_cpu_number_to_vp_number()
> returning VP_INVAL. We need to che
From: Vitaly Kuznetsov Monday, July 9, 2018 10:40 AM
> Commit 1268ed0c474a ("x86/hyper-v: Fix the circular dependency in IPI
> enlightenment") made cpumask_to_vpset() return '-1' when there is a CPU
> with unknown VP index in the supplied set. This needs to be checked before
> we pass 'nr_bank' to
map_bus callback is called before every .read/.write operation.
Implement it and change custom read write operations for the
pci subsystem generics. Make the probe function to assign data
for controller data and get pci register base from device tree.
Signed-off-by: Sergio Paracuellos
---
driver
Driver is using now pci subsystem generics reads and writes. Because
of this there is a lot of dead code that can be removed.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 128
1 file changed, 128 deletions(-)
diff --git a/drive
This patch series include an attempt to avoid the use of custom
read and writes in driver code and use PCI subsystem common ones.
In order to do this map_bus callback is implemented and also a
data structure for driver is included. registers base address
is being readed from device tree and the d
Add new 'mt7621_pcie_port' struct as data for the pci controller.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 10 ++
1 file changed, 10 insertions(+)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
b/drivers/staging/mt7621-pci/pci-mt7621.c
index
On Tue, Jul 10, 2018 at 03:55:32PM +, Ioana Ciocoi Radulescu wrote:
> > -Original Message-
> > From: Dan Carpenter [mailto:dan.carpen...@oracle.com]
> > Sent: Monday, July 9, 2018 10:28 PM
> > To: Ioana Ciocoi Radulescu
> > Cc: gre...@linuxfoundation.org; de...@driverdev.osuosl.org; li
On Tue, Jul 10, 2018 at 05:18:48PM +0200, Arnd Bergmann wrote:
> The gpio-mt7621 driver has graduated out of staging and got accepted
> into the gpio tree. Since they both use the same Kconfig symbol,
> we could run into conflicts, e.g. I got this failure when the staging
> driver got enabled with
The gpio-mt7621 driver has graduated out of staging and got accepted
into the gpio tree. Since they both use the same Kconfig symbol,
we could run into conflicts, e.g. I got this failure when the staging
driver got enabled with the other one being unavailable but using the
same Kconfig symbol:
dri
Simple changes to correct indentation issues.
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/ieee80211_softmac.c| 76 +--
1 file changed, 37 insertions(+), 39 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c
b/drivers/staging/rtl8192
Coding style change to correct the indentation of the function
ieee80211_softmac_new_net(). A large proportion of the function's if statements
were incorrectly indented.
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/ieee80211_softmac.c| 101 +-
1 file changed, 50 in
Coding standard requires that the conditional statement is not on the same
line as the 'if' or 'else' but on the following line. Statements moved
accordingly.
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/ieee80211_softmac.c| 25 +--
1 file changed, 17 insertions(+)
Simple style change to fix the indentaiton and spacing of the braces around
multiline code blocks.
Braces removed from code block with a single line.
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/ieee80211_softmac.c| 254 --
1 file changed, 107 insertions(+), 147 d
Simple removal of spaces prohibited by the coding standard.
Signed-off-by: John Whitmore
---
.../staging/rtl8192u/ieee80211/ieee80211_softmac.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c
b/drivers/sta
checkpatch.pl flags unnecessary parentheses, so removed from code.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c
b/drivers
Corrected coding style issues aroung opening and closed parenthesis. Spaces, or
blank line, removed from after '(' or before ')'
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/ieee80211_softmac.c| 78 +--
1 file changed, 36 insertions(+), 42 deletions(-)
diff --git
Coding style change to simply remove the unrequired blanks lines before a
closing brace or after an opening brace.
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/ieee80211_softmac.c | 18 --
1 file changed, 18 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee8
My last attempt saw some patches applied but a bad commit message resulted in a
rejection and subsequent patches not applying. These patches are more or less
the same but the numbers have changed from 3, 5, 7, 8, 9, 10, 11 & 12 to 1-8.
___
devel mail
On Tue, Jul 10, 2018 at 12:58:18PM +0200, Greg KH wrote:
> On Tue, Jul 10, 2018 at 12:55:10PM +0200, Greg KH wrote:
> > On Mon, Jul 09, 2018 at 10:21:02PM +0200, Sergio Paracuellos wrote:
> > > This patch series clean up a bit mt7621-pci driver.
> > >
> > > Chnages in v3:
> > > - PATCH 1 has b
On Tue, Jul 10, 2018 at 2:09 PM, Tetsuo Handa
wrote:
> I don't have benchmark data (I'm not an Android user). But an example log at
> https://syzkaller.appspot.com/text?tag=CrashLog&x=12f316fc40 got
> about 13214 messages in 124 seconds (over 100 messages per a second).
I meant data for the c
On 2018/07/09 23:29, Tetsuo Handa wrote:
> On 2018/07/09 23:02, Martijn Coenen wrote:
>> On Mon, Jul 9, 2018 at 3:27 PM, Dmitry Vyukov wrote:
>>> I know almost nothing about binder. How these debug messages are
>>> enabled? I don't see anything like CONFIG_BINDER_VERBOSE_DEBUG in the
>>> config:
On Tue, Jul 10, 2018 at 12:55:10PM +0200, Greg KH wrote:
> On Mon, Jul 09, 2018 at 10:21:02PM +0200, Sergio Paracuellos wrote:
> > This patch series clean up a bit mt7621-pci driver.
> >
> > Chnages in v3:
> > - PATCH 1 has been splited in several patches for better review
> > - PATCH "avo
On Mon, Jul 09, 2018 at 10:21:02PM +0200, Sergio Paracuellos wrote:
> This patch series clean up a bit mt7621-pci driver.
>
> Chnages in v3:
> - PATCH 1 has been splited in several patches for better review
> - PATCH "avoid pointer arithmetics in some macros" gets back
> a needed swi
On Mon, Jul 09, 2018 at 10:21:05PM +0200, Sergio Paracuellos wrote:
> Add new 'mt7621_pci_base' variable as a pointer to definition
> RALINK_PCI_BASE to use it along the code.
>
> Signed-off-by: Sergio Paracuellos
> ---
> drivers/staging/mt7621-pci/pci-mt7621.c | 3 +++
> 1 file changed, 3 inser
On Mon, Jul 09, 2018 at 10:21:06PM +0200, Sergio Paracuellos wrote:
> The logic for this functions is kind of mess calling to other
> functions which ends up in using very ugly macros. Reimplement
> this two using kernel write[b,w,l] and read[b,w,l] and the variable
> 'mt7621_pci_base'. Function pr
On Tue, Jul 10, 2018 at 12:03:16PM +0200, Sophie Matter wrote:
> The missing SPDX tag was added to the top of the files of this
> driver, according to the comments on top of each file (GPL license
> or higher).
>
> Signed-off-by: Sophie Matter
> Signed-off-by: Rico Schrage
What tree are you wor
On Tue, Jul 10, 2018 at 12:03:17PM +0200, Sophie Matter wrote:
> Lines have been split where it makes sense to shorten them in order
> to comply with the coding standards and fix checkpatch.pl warnings.
> There are still lines left that are too long, however breaking
> those would impair readabilit
On Mon, Jul 09, 2018 at 06:05:48PM +0200, Sergio Paracuellos wrote:
> Remove driver from staging. It has been accepted in
> the linux-gpio tree.
>
> Signed-off-by: Sergio Paracuellos
> ---
>
> Refer to commits in linux-gpio:
> -
> https://git.kernel.org/pub/scm/linux/kernel/git/linusw/linux-gp
For multi-line comments, the preferred commenting style from the
coding style Documentation was applied to the comments, meaning
almost blank lines at the beginning and end of the comment.
One changed comment includes a line over 80 characters, causing
checkpatch.pl to complain, however breaking th
Lines have been split where it makes sense to shorten them in order
to comply with the coding standards and fix checkpatch.pl warnings.
There are still lines left that are too long, however breaking
those would impair readability.
Signed-off-by: Sophie Matter
Signed-off-by: Rico Schrage
---
dri
The missing SPDX tag was added to the top of the files of this
driver, according to the comments on top of each file (GPL license
or higher).
Signed-off-by: Sophie Matter
Signed-off-by: Rico Schrage
---
drivers/staging/pi433/pi433_if.c | 1 +
drivers/staging/pi433/pi433_if.h | 1 +
Lines containing multiple statements were broken into multiple
lines, increasing readability and complying with the coding standard.
This also fixes several checkpatch.pl errors complaining about
the lines being too long.
Signed-off-by: Sophie Matter
Signed-off-by: Rico Schrage
---
drivers/stag
37 matches
Mail list logo