This driver uses the same unregistered vendor id that the
firewire core does (0xd00d1e). Hence it is exposed as a
define in firewire.h.
Signed-off-by:Janani Sankara Babu
---
drivers/staging/fwserial/fwserial.c | 1 -
include/linux/firewire.h| 2 ++
2 files changed, 2 insertions(+), 1
pinctrl_utils_reserve_map() calls krealloc() on *map. Because of this
*map need to be initialized to NULL before calling it.
Fixes: 62b6215c11ea ("staging: mt7621-pinctrl: make use of
pinctrl_utils_reserve_map")
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pinctrl/pinctrl-rt2880
On Mon, Jul 09, 2018 at 11:08:58AM +1000, NeilBrown wrote:
> On Sun, Jul 08 2018, Sergio Paracuellos wrote:
>
> > This patch series clean up a bit mt7621-pci driver.
> >
> > Changes from v2:
> > - It includes new 17 patches from PATCH 2 to PATCH 18
> > - PATCH 1 was send before alone and i
On Mon, Jul 09, 2018 at 09:13:02AM +1000, NeilBrown wrote:
> On Sun, Jul 08 2018, Sergio Paracuellos wrote:
>
> > RALINK_PCI_MEMBASE, RALINK_PCI_IOBASE, RALINK_PCI_PCICFG_ADDR and
> > RALINK_PCI_PCIMSK_ADDR are using very ugly pointer arithmetics to
> > read and write along the code. Instead of do
On Mon, Jul 09, 2018 at 07:16:41AM +1000, NeilBrown wrote:
> On Sun, Jul 08 2018, Sergio Paracuellos wrote:
> >
> > I can try to split this a bit but I don't really know how to do atomic
> > changes because
> > of the related things included here.
>
> Some suggestions:
>
> 1/ MV_READ_DATA is not
On Mon, Jul 09, 2018 at 09:40:18AM +1000, NeilBrown wrote:
> On Thu, Jun 28 2018, Sergio Paracuellos wrote:
>
> > We don't really need initialization of this at such an early stage.
> > Just use builtin_platform_driver to initialize this driver.
> >
> > Signed-off-by: Sergio Paracuellos
> > ---
>
On Mon, Jul 09, 2018 at 08:48:14AM +1000, NeilBrown wrote:
> On Thu, Jun 07 2018, Sergio Paracuellos wrote:
>
> > Function rt2880_pinctrl_dt_node_to_map was using 'kzalloc' to
> > reserve map memory. There is a 'pinctrl_utils_reserve_map' to
> > do this function. Just use it.
> >
> > Signed-off-by
On 07/08/18 at 08:48pm, Andy Shevchenko wrote:
> On Sun, Jul 8, 2018 at 5:59 AM, Baoquan He wrote:
> > On 07/05/18 at 01:00am, kbuild test robot wrote:
>
> > However, I didn't find below branch. And tried to open it in web
> > broswer, also failed.
>
> While this is kinda valid point...
>
> > C
>From 62ddef96020cb397dcbf4b8574f1859b32f983de Mon Sep 17 00:00:00 2001
From: Tetsuo Handa
Date: Mon, 9 Jul 2018 09:54:01 +0900
Subject: [PATCH] ANDROID: binder: Latelimit binder_debug().
syzbot is reporting hung tasks [1] [2]. This might be due to flooding of
printk() messages from binder subsys
On Sun, Jul 08 2018, Sergio Paracuellos wrote:
> This patch series clean up a bit mt7621-pci driver.
>
> Changes from v2:
> - It includes new 17 patches from PATCH 2 to PATCH 18
> - PATCH 1 was send before alone and is being included
> as it is in this new series.
>
> Hope this helps
On Sun, 2018-07-08 at 12:38 +0200, Michael Straube wrote:
> Remove unrequired extra indentations.
[]
> diff --git a/drivers/staging/rtl8723bs/core/rtw_ieee80211.c
> b/drivers/staging/rtl8723bs/core/rtw_ieee80211.c
[]
> @@ -69,16 +69,16 @@ int rtw_get_bit_value_from_ieee_value(u8 val)
>
> uint r
On Thu, Jun 28 2018, Sergio Paracuellos wrote:
> We don't really need initialization of this at such an early stage.
> Just use builtin_platform_driver to initialize this driver.
>
> Signed-off-by: Sergio Paracuellos
> ---
> drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 7 +--
> 1 file c
On Sun, Jul 08 2018, Sergio Paracuellos wrote:
> RALINK_PCI_MEMBASE, RALINK_PCI_IOBASE, RALINK_PCI_PCICFG_ADDR and
> RALINK_PCI_PCIMSK_ADDR are using very ugly pointer arithmetics to
> read and write along the code. Instead of doing this, use the
> mt7621_pci_reg_read and mt7621_pci_reg_write func
On Thu, Jun 07 2018, Sergio Paracuellos wrote:
> Function rt2880_pinctrl_dt_node_to_map was using 'kzalloc' to
> reserve map memory. There is a 'pinctrl_utils_reserve_map' to
> do this function. Just use it.
>
> Signed-off-by: Sergio Paracuellos
> ---
> drivers/staging/mt7621-pinctrl/pinctrl-rt2
On Sun, Jul 08 2018, Sergio Paracuellos wrote:
>
> I can try to split this a bit but I don't really know how to do atomic
> changes because
> of the related things included here.
Some suggestions:
1/ MV_READ_DATA is not used. Discard that any anything else that is
not used.
2/ MV_WRITE is re
On Sun, Jul 08, 2018 at 03:28:16PM +0200, Greg KH wrote:
> On Sat, Jul 07, 2018 at 10:19:40PM -0400, Jacob Feder wrote:
> > Hi all,
> > I have developed this driver for a Xilinx-provided IP block for their Zynq
> > SoC. I fixed all of the checkpatch.pl problems I knew how to. If someone
> > could c
On Sun, Jul 8, 2018 at 5:59 AM, Baoquan He wrote:
> On 07/05/18 at 01:00am, kbuild test robot wrote:
> However, I didn't find below branch. And tried to open it in web
> broswer, also failed.
While this is kinda valid point...
> Could you help have a look at this?
...isn't obvious that you did
On 07/08/18 18:46, Joe Perches wrote:
On Sun, 2018-07-08 at 12:38 +0200, Michael Straube wrote:
Remove unrequired extra indentations.
[]
diff --git a/drivers/staging/rtl8723bs/core/rtw_ieee80211.c
b/drivers/staging/rtl8723bs/core/rtw_ieee80211.c
[]
@@ -69,16 +69,16 @@ int rtw_get_bit_value_
This patch add description for the module parameters and remove the task
to do it from the TODO file.
Signed-off-by: Kamal Heib
---
drivers/staging/gasket/TODO | 1 -
drivers/staging/gasket/apex_driver.c | 8
2 files changed, 8 insertions(+), 1 deletion(-)
diff --git a/drivers
On Sun, Jul 8, 2018 at 5:36 PM, Greg KH wrote:
> On Sat, Jul 07, 2018 at 09:48:37PM +0200, Sergio Paracuellos wrote:
>> This commit simplifies and clean a lot of stuff related with pci
>> reads and writes. It deletes a lot of not needed at all functions
>> and use kernel arch operations read[b,w,l
On Sun, Jul 08, 2018 at 05:38:11PM +0200, Greg KH wrote:
> On Sat, Jul 07, 2018 at 03:55:04PM +0100, John Whitmore wrote:
> > Coding style change to simply remove the unrequired spaces before a closing
> > brace or before an opening brace.
>
> That would be good, but that's not what this patch doe
On Sat, Jul 07, 2018 at 03:55:04PM +0100, John Whitmore wrote:
> Coding style change to simply remove the unrequired spaces before a closing
> brace or before an opening brace.
That would be good, but that's not what this patch does :(
It removes lines, not spaces, as the subject line said. You
On Sat, Jul 07, 2018 at 09:48:37PM +0200, Sergio Paracuellos wrote:
> This commit simplifies and clean a lot of stuff related with pci
> reads and writes. It deletes a lot of not needed at all functions
> and use kernel arch operations read[b,w,l] and write[b,w,l] instead
> of use custom macros. It
On Sun, Jul 8, 2018 at 4:22 PM, Greg KH wrote:
> On Sun, Jul 08, 2018 at 04:06:08PM +0200, Sergio Paracuellos wrote:
>> On Sun, Jul 8, 2018 at 3:16 PM, Greg KH wrote:
>> > On Sun, Jul 08, 2018 at 02:57:26PM +0200, Sergio Paracuellos wrote:
>> >> It's good to have SPDX identifiers in driver files
On Sun, Jul 08, 2018 at 04:06:08PM +0200, Sergio Paracuellos wrote:
> On Sun, Jul 8, 2018 at 3:16 PM, Greg KH wrote:
> > On Sun, Jul 08, 2018 at 02:57:26PM +0200, Sergio Paracuellos wrote:
> >> It's good to have SPDX identifiers in driver files to make it easier to
> >> audit the kernel tree for c
On Sun, Jul 8, 2018 at 3:16 PM, Greg KH wrote:
> On Sun, Jul 08, 2018 at 02:57:26PM +0200, Sergio Paracuellos wrote:
>> It's good to have SPDX identifiers in driver files to make it easier to
>> audit the kernel tree for correct licenses.
>>
>> Fix up the one of staging pci-mt7621.c file to have a
On Sun, Jul 8, 2018 at 3:14 PM, Greg KH wrote:
> On Sun, Jul 08, 2018 at 02:57:08PM +0200, Sergio Paracuellos wrote:
>> This patch series clean up a bit mt7621-pci driver.
>
> Your subject line for the 00/XX email needs some work (like putting what
> driver and subsystem it is for in it please...)
On Sat, Jul 07, 2018 at 10:19:40PM -0400, Jacob Feder wrote:
> Hi all,
> I have developed this driver for a Xilinx-provided IP block for their Zynq
> SoC. I fixed all of the checkpatch.pl problems I knew how to. If someone
> could chime in on how to fix the remaining few it would be appreciated.
>
WIN a lottery today and be a millionaire tomorrow. I am a software
programmer and i work with a lottery company. I can give you the lucky
numbers in our Admin so that you can play and win the lottery and we
will share the winnings 50/50% each. If you are interested in making
quick money rep
On Sun, Jul 08, 2018 at 02:57:26PM +0200, Sergio Paracuellos wrote:
> It's good to have SPDX identifiers in driver files to make it easier to
> audit the kernel tree for correct licenses.
>
> Fix up the one of staging pci-mt7621.c file to have a proper SPDX
> identifier, based on the license text
On Sun, Jul 08, 2018 at 02:57:08PM +0200, Sergio Paracuellos wrote:
> This patch series clean up a bit mt7621-pci driver.
Your subject line for the 00/XX email needs some work (like putting what
driver and subsystem it is for in it please...)
For future patch series.
thanks,
greg k-h
__
This two functions are called with bus and func being always 0.
Remove non sensense 'bus' and 'func' parameters and pass '0' to
other calls inside the function. Review return and parameter types
also to be more proper with the rest of the code. Adapt properly
calls to those function to match the ne
RALINK_PCI_CONFIG_DATA_VIRTUAL_REG is a very long name and makes
lines to be very long when it is used. Rename it to a shorter one
RALINK_PCI_CONFIG_DATA.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-
There was a missing line between declarations and code statements in function
setup_cm_memory_region. this improves readability.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621
This commit simplifies and clean a lot of stuff related with pci
reads and writes. It deletes a lot of not needed at all functions
and use kernel arch operations read[b,w,l] and write[b,w,l] instead
of use custom macros. It also include one function helper called
'mt7621_pci_get_cfgaddr' to easily
Driver probe function is a mess and need a very big refactor.
Factor out mt7621_pci_enable_irqs and mt7621_pci_disable to
handle interrupts if pci status is as expected. To get the correct
bits for each controller define a new 'pcie_controller_data'
including clk_en, rst, irq and offset fields. Con
In places where function mt7621_pci_get_cfgaddr is being used, there
is a common pattern that could be included inside mt7621_pci_get_cfgaddr.
Include it improving readability.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 20
1 file changed
set_pcie_phy can be refactor to use mt7621_pci_reg_write and
mt7621_pci_reg_read functions intead of use pointer arithmetics.
Use them and simplify implicated calls and definitions along the
code.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 122 +++
There are a lot of definitions that are not being used at all.
Just remove them cleaning the code a bit.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 20 ++--
1 file changed, 2 insertions(+), 18 deletions(-)
diff --git a/drivers/staging/mt7621-
There are some comments not needed at all. Remove them.
Adjust one comment to follow kernel style.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 11 ++-
1 file changed, 6 insertions(+), 5 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
Factor out mt7621_pci_enable function to avoid duplicate code
in driver probe function. This increase readability.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 36 ++---
1 file changed, 15 insertions(+), 21 deletions(-)
diff --git a
ASSERT_SYSRST_PCIE and DEASSERT_SYSRST_PCIE are defined as preprocessor
macros and can be defined as inline functions instead which are preferred.
Do it and rename to mt7621_pcie_assert_sysrst and mt7621_pcie_deassert_sysrst
respectively.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7
Use a for loop to check pci port N_FTS in each controller.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 12
1 file changed, 4 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/mt7621-pci/pci-mt7621.c
b/drivers/staging/mt7621-pci/pci-mt76
In driver probe function there are some ugly initialization to
use gpios. Factor out to mt7621_pci_init_gpios function making
use of readl and writel to read and write memory.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 35 +++--
1
This patch series clean up a bit mt7621-pci driver.
Changes from v2:
- It includes new 17 patches from PATCH 2 to PATCH 18
- PATCH 1 was send before alone and is being included
as it is in this new series.
Hope this helps.
Best regards,
Sergio Paracuellos
Sergio Paracuellos (1
PCI controller dependant register was handled with different
custom macros including very ugly pointer aritmethics. Simplify
them adding an array of offset per controller and a macro to get
the relative offset for each register for the controller. To avoid
arithmetics add two simple mt7621_pci_reg_
RALINK_PCI_MEMBASE, RALINK_PCI_IOBASE, RALINK_PCI_PCICFG_ADDR and
RALINK_PCI_PCIMSK_ADDR are using very ugly pointer arithmetics to
read and write along the code. Instead of doing this, use the
mt7621_pci_reg_read and mt7621_pci_reg_write functions making
this a bit cleaner.
Signed-off-by: Sergio
It's good to have SPDX identifiers in driver files to make it easier to
audit the kernel tree for correct licenses.
Fix up the one of staging pci-mt7621.c file to have a proper SPDX
identifier, based on the license text in the file itself. The SPDX
identifier is a legally binding shorthand, which
There are some definitions which are using its custom
implementation of BIT macro. Just just BIT macro instead.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 31 ---
1 file changed, 16 insertions(+), 15 deletions(-)
diff --git a/driv
Factor out mt7621_pci_configure function to avoid a lot of
duplicated code in driver probe function.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pci/pci-mt7621.c | 35 -
1 file changed, 17 insertions(+), 18 deletions(-)
diff --git a/drivers/stagi
Use ether_addr_copy() instead of memcpy() to copy the mac address.
Using is_broadcast_ether_addr() and is_zero_ether_addr() instead of
testing each byte of the mac[] array for 0xff and 0x00 shortens the
code and improves readability.
Instead of a fixed default mac address use a random one to redu
Replace tabs with spaces in some function definitions and variable
declarations.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_ieee80211.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_ieee80211.c
b/dr
Remove unrequired extra indentations.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8723bs/core/rtw_ieee80211.c | 16
1 file changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/rtl8723bs/core/rtw_ieee80211.c
b/drivers/staging/rtl8723bs/core/rtw_ieee80
Simplify rtw_get_rateset_len() by replacing the while loop
with a shorter for loop.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8723bs/core/rtw_ieee80211.c | 12 +++-
1 file changed, 3 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/rtl8723bs/core/rtw_ieee80211.c
b
Replace tabs with spaces in some function definitions.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8723bs/core/rtw_ieee80211.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/rtl8723bs/core/rtw_ieee80211.c
b/drivers/staging/rtl8723bs/core/rtw_
Remove unrequired blank lines as reported by checkpatch.
Signed-off-by: Michael Straube
---
.../staging/rtl8723bs/core/rtw_ieee80211.c| 31 ---
1 file changed, 31 deletions(-)
diff --git a/drivers/staging/rtl8723bs/core/rtw_ieee80211.c
b/drivers/staging/rtl8723bs/core/rtw_i
Remove braces from single if statement to follow kernel coding style.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8723bs/core/rtw_ieee80211.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8723bs/core/rtw_ieee80211.c
b/drivers/staging/rtl8723b
Add missing blank lines after declarations as reported by checkpatch.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8723bs/core/rtw_ieee80211.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/drivers/staging/rtl8723bs/core/rtw_ieee80211.c
b/drivers/staging/rtl8723bs/core/rtw_ieee8
We would like to introduce our image editing services for you.
We would appreciate if you can reply with your requirements and can give us
a chance to serve you.
Our mainly services are:
. Cut out, masking, clipping path, deep etching, transparent background
. Colour correction, black and white
We would like to introduce our image editing services for you.
We would appreciate if you can reply with your requirements and can give us
a chance to serve you.
Our mainly services are:
. Cut out, masking, clipping path, deep etching, transparent background
. Colour correction, black and white
60 matches
Mail list logo