On Thu, Jul 05, 2018 at 04:27:31PM +1000, NeilBrown wrote:
> On Thu, Jul 05 2018, Sergio Paracuellos wrote:
>
> > This series fix problem related with the last changes included
> > to use only one node in the device tree and some gpio banks
> > naming issues.
> >
> > Hope this helps.
>
> It sure
On Thu, Jul 05 2018, Sergio Paracuellos wrote:
> This series fix problem related with the last changes included
> to use only one node in the device tree and some gpio banks
> naming issues.
>
> Hope this helps.
It sure does. Everything looks and works as expected now.
all:
Reviewed-by: NeilBr
Instead of using a custom function to return desired name for gpio
use the default assigned one and concat it '-bankN' suffix using
devm_kasprintf kernel function.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-gpio/gpio-mt7621.c | 12 ++--
1 file changed, 2 insertions(+),
The default gpio.of_xlate function assumes there is one gpio chip
for each devicetree node. Device tree had changed to only use one node,
which corresponds to 3 different gpio chips now. For that approach
to work we need a custom xlate function.
Signed-off-by: Sergio Paracuellos
---
drivers/stag
There is only one irq chip so set its name only once
in driver probe function.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-gpio/gpio-mt7621.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/mt7621-gpio/gpio-mt7621.c
b/drivers/staging/mt7621-g
bgpio_init function set different data of the gpio chip, like the name.
We want specific name for each bank so to get that not overwritten
move all custom changes after the bgpio_init function call.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-gpio/gpio-mt7621.c | 7 ---
1 fi
This series fix problem related with the last changes included
to use only one node in the device tree and some gpio banks
naming issues.
Hope this helps.
Best regards,
Sergio Paracuellos
Sergio Paracuellos (4):
staging: mt7621-gpio: set irq chip name only once
staging: mt7621-gpio: use
Fix for static checker warning inconsistent returns of
'hif_deinit_lock'(more details [1]).
"drivers/staging/wilc1000/host_interface.c:3390 wilc_deinit()
warn: inconsistent returns 'hif_deinit_lock'."
Introduced in "ff52a57a7a42: staging: wilc1000: move the allocation of
cmd out of
On Thu, Jul 05, 2018 at 10:51:39AM +1000, NeilBrown wrote:
> On Sat, Jun 30 2018, Sergio Paracuellos wrote:
>
> > On Sat, Jun 30, 2018 at 7:47 AM, NeilBrown wrote:
> >> On Mon, Jun 18 2018, Sergio Paracuellos wrote:
> >>
> >>> Banks shouldn't be defined in DT if number of resources
> >>> per bank
Updated printk() of i18n messages to include KERN_INFO facility level to
improve debuggin.
then later noticed that I forgot to add a space on printk.
Signed-off-by: Tamir Suliman
---
drivers/staging/speakup/kobjects.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/s
On Sat, Jun 30 2018, Sergio Paracuellos wrote:
> On Sat, Jun 30, 2018 at 7:47 AM, NeilBrown wrote:
>> On Mon, Jun 18 2018, Sergio Paracuellos wrote:
>>
>>> Banks shouldn't be defined in DT if number of resources
>>> per bank is not variable. We actually know that this SoC
>>> has three banks so t
Yes I did ..the misalignment and indentations were not intentional
forgot to fix that but It was added to the patch.. will fix that on v 2
my first patch still working on how to do things properly :(
On a different note , I made some changes to the function.
Thanks for your message.
On 6/30
Interesting construct... Yeah I'm little bit rusty on my C
/programming . I understand proper coding style may be should end with
else so I wasn't sure .. however this resolved the warnings. :)
Did you compile this?
Yes I did compile however the only issue i found when I'm compiling is
As already done treewide, switch from open-coded multiplication to using
2-factor allocator helpers.
Signed-off-by: Kees Cook
---
drivers/staging/gasket/gasket_core.c | 6 +++---
drivers/staging/gasket/gasket_interrupt.c | 15 +--
drivers/staging/gasket/gasket_page_table.c |
Hi Baoquan,
I love your patch! Yet something to improve:
[auto build test ERROR on linus/master]
[also build test ERROR on v4.18-rc3 next-20180704]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day-ci/linux
Hi Baoquan,
I love your patch! Yet something to improve:
[auto build test ERROR on linus/master]
[also build test ERROR on v4.18-rc3 next-20180704]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day-ci/linux
On Wed, Jul 4, 2018 at 7:10 AM, Baoquan He wrote:
> reparent_resources() is duplicated in arch/microblaze/pci/pci-common.c
> and arch/powerpc/kernel/pci-common.c, so move it to kernel/resource.c
> so that it's shared.
With couple of comments below,
Reviewed-by: Andy Shevchenko
P.S. In some com
* k...@linuxonhyperv.com wrote:
> From: "K. Y. Srinivasan"
>
> The IPI hypercalls depend on being able to map the Linux notion of CPU ID
> to the hypervisor's notion of the CPU ID. The array hv_vp_index[] provides
> this mapping. Code for populating this array depends on the IPI functionality.
On Wed, Jul 4, 2018 at 10:13 AM, Larry Finger wrote:
> We will have to agree to disagree.
>
> I have no idea what the vendors are doing that cause some motherboards to
> need a different aspm value. What I do know is that we have had to live with
> the idiocy of some vendors saving a few pennies b
On 07/04/2018 09:09 AM, Dan Carpenter wrote:
On Wed, Jul 04, 2018 at 08:55:00AM -0500, Larry Finger wrote:
I do not think this is a bug.
It's obviously a bug. The driver should just work by default.
As a last resort, we would do something like add quirk or something. I
haven't looked at how
checkpatch requires a space after ',' - Added.
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/ieee80211_softmac.c| 57 ++-
1 file changed, 31 insertions(+), 26 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c
b/drivers/staging/rtl819
Truncated header file removing definitions which aren't used.
Signed-off-by: John Whitmore
---
.../staging/rtl8192u/ieee80211/rtl819x_HT.h | 117 --
1 file changed, 117 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HT.h
b/drivers/staging/rtl8192u/ieee80
Additon of the coding style required spaces around the '||' operator.
Signed-off-by: John Whitmore
---
.../staging/rtl8192u/ieee80211/ieee80211_softmac.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c
b/d
checkpatch requires spaces around '=' operator so added.
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/ieee80211_softmac.c| 50 +--
1 file changed, 25 insertions(+), 25 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c
b/drivers/stag
According to checkpatch - No space is necessary after a cast.
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/ieee80211_softmac.c| 30 +--
1 file changed, 15 insertions(+), 15 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c
b/drivers
Simple addition of the coding style required spaces around '==' operator.
Signed-off-by: John Whitmore
---
.../staging/rtl8192u/ieee80211/ieee80211_softmac.c | 14 +++---
1 file changed, 7 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c
Replaced memory initialising loop with memset instead.
Suggested-by: Andy Shevchenko
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c | 5 +
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
b
Removal of extra blank lines from the ieee80211_softmac.c file
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/ieee80211_softmac.c| 105 --
1 file changed, 105 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211_softmac.c
b/drivers/staging/rtl8192
Changed logging statements to use %s and __func__ instead of hard coding the
function name in a string.
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/rtl819x_HTProc.c | 24 ++-
1 file changed, 18 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/rtl8192u
On Wed, Jul 04, 2018 at 08:55:00AM -0500, Larry Finger wrote:
> I do not think this is a bug.
It's obviously a bug. The driver should just work by default.
As a last resort, we would do something like add quirk or something. I
haven't looked at how quirks would be handled for this driver but gr
On Sun, Jul 01, 2018 at 06:22:23PM +, Dexuan Cui wrote:
>
> Commit de0aa7b2f97d ("PCI: hv: Fix 2 hang issues in hv_compose_msi_msg()")
> uses local_bh_disable()/enable(), because hv_pci_onchannelcallback() can
> also run in tasklet context as the channel event callback, and here we
> want to a
On 07/04/2018 03:03 AM, Jian-Hong Pan wrote:
Hi,
We have an ASUS X530UN (Intel(R) Core(TM) i7-8550U CPU @ 1.80GHz)
laptop equipped with Realtek rtl8822be wireless which cannot find any
access point after WiFi is launched.
Realtek rtl8822be wireless' information:
dev@endless:~/linux-eos$ sudo ls
On Wed, Jul 4, 2018 at 8:04 AM, Dan Carpenter wrote:
> I really prefer to see the whole dmesg instead of an edited ... in the
> middle.
Full log:
https://gist.github.com/dsd/20c05f0c6d66ee2ef9bfbb17f93f18ba
> I agree that it feels like the default aspm setting should be 2 (use
> what the chip sa
On Wed, Jul 04, 2018 at 04:03:33PM +0800, Jian-Hong Pan wrote:
> Hi,
>
> We have an ASUS X530UN (Intel(R) Core(TM) i7-8550U CPU @ 1.80GHz)
> laptop equipped with Realtek rtl8822be wireless which cannot find any
> access point after WiFi is launched.
>
> Realtek rtl8822be wireless' information:
>
On Wed, Jul 04, 2018 at 12:59:25PM +0100, John Whitmore wrote:
> Changes to indentation and witespace issues in the ieee80211_softmac.c file.
>
You're doing too much stuff in one patch.
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverpr
On Wed, Jul 04, 2018 at 12:59:23PM +0100, John Whitmore wrote:
> Removed the unused variable from previously removed loop.
>
> Signed-off-by: John Whitmore
This is fixing a warning that was introduced in a previous patch in this
series. That's not allowed. Just fix the original patch instead.
Hope you are doing well.
We provide you below imaging services today:
Such as ecommerce photos retouching, jewelry photos retouching, beauty and
skin image retouching,
and wedding photo editing, image cut out and clipping path, masking.
Our strength:
Quality is good
Turnaround time fast
7/24/365
Changes to indentation and witespace issues in the ieee80211_softmac.c file.
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/ieee80211_softmac.c| 1015 +++--
1 file changed, 443 insertions(+), 572 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211_sof
Replaced memory initialising loop with memset instead.
Suggested-by: Andy Shevchenko
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
b/d
Changed logging statements to use %s and __func__ instead of hard coding the
function name in a string.
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/rtl819x_HTProc.c | 24 ++-
1 file changed, 18 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/rtl8192u
Truncated header file removing definitions which aren't used.
Signed-off-by: John Whitmore
---
.../staging/rtl8192u/ieee80211/rtl819x_HT.h | 117 --
1 file changed, 117 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HT.h
b/drivers/staging/rtl8192u/ieee80
Removed the unused variable from previously removed loop.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
b/drivers/staging/rtl8192u/ieee80211/rtl819x_HT
Rename header file to avoid CamelCase.
Hal8188EPhyCfg.h -> hal8188e_phy_cfg.h
Signed-off-by: Michael Straube
---
.../rtl8188eu/include/{Hal8188EPhyCfg.h => hal8188e_phy_cfg.h} | 0
drivers/staging/rtl8188eu/include/hal_intf.h| 2 +-
drivers/staging/rtl8188eu/include/rtl8188
Rename header file to avoid CamelCase.
Hal8188EPhyReg.h -> hal8188e_phy_reg.h
Signed-off-by: Michael Straube
---
.../rtl8188eu/include/{Hal8188EPhyReg.h => hal8188e_phy_reg.h} | 0
drivers/staging/rtl8188eu/include/rtl8188e_hal.h| 2 +-
2 files changed, 1 insertion(+), 1 deleti
Rename header and source file to avoid CamelCase.
Hal8188ERateAdaptive.h -> hal8188e_rate_adaptive.h
Hal8188ERateAdaptive.c -> hal8188e_rate_adaptive.c
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/Makefile | 2 +-
.../hal/{Hal8188ERateAdaptive.c => h
k...@linuxonhyperv.com writes:
> From: "K. Y. Srinivasan"
>
> The IPI hypercalls depend on being able to map the Linux notion of CPU ID
> to the hypervisor's notion of the CPU ID. The array hv_vp_index[] provides
> this mapping. Code for populating this array depends on the IPI functionality.
> B
Hi Dan,
On Tue, 3 Jul 2018 14:56:55 +0300
Dan Carpenter wrote:
> Hello Ajay Singh,
>
> The patch ff52a57a7a42: "staging: wilc1000: move the allocation of
> cmd out of wilc_enqueue_cmd()" from Jun 26, 2018, leads to the
> following static checker warning:
>
> drivers/staging/wilc1000/hos
Removing myself as the maintainer for this driver and adding Ioana R.
and Ioana C.
Signed-off-by: Razvan Stefanescu
Acked-by: Ioana Radulescu
Acked-by: Ioana Ciornei
---
Changelog
v2
- add commit message and ack lines
MAINTAINERS | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-
Hi,
We have an ASUS X530UN (Intel(R) Core(TM) i7-8550U CPU @ 1.80GHz)
laptop equipped with Realtek rtl8822be wireless which cannot find any
access point after WiFi is launched.
Realtek rtl8822be wireless' information:
dev@endless:~/linux-eos$ sudo lspci -nnvs 02:00.0
02:00.0 Network controller [0
49 matches
Mail list logo