On 07/03/18 at 11:57pm, Andy Shevchenko wrote:
> On Tue, Jul 3, 2018 at 5:55 PM, Baoquan He wrote:
> > On 06/12/18 at 05:24pm, Andy Shevchenko wrote:
> >> On Tue, Jun 12, 2018 at 5:20 PM, Andy Shevchenko
> >> wrote:
>
> >> > I briefly looked at the code and error codes we have, so, my proposal
>
This function, being a variant of walk_system_ram_res() introduced in
commit 8c86e70acead ("resource: provide new functions to walk through
resources"), walks through a list of all the resources of System RAM
in reversed order, i.e., from higher to lower.
It will be used in kexec_file code.
Signe
For kexec_file loading, if kexec_buf.top_down is 'true', the memory which
is used to load kernel/initrd/purgatory is supposed to be allocated from
top to down. This is what we have been doing all along in the old kexec
loading interface and the kexec loading is still default setting in some
distrib
reparent_resources() is duplicated in arch/microblaze/pci/pci-common.c
and arch/powerpc/kernel/pci-common.c, so move it to kernel/resource.c
so that it's shared.
Signed-off-by: Baoquan He
---
arch/microblaze/pci/pci-common.c | 37 -
arch/powerpc/kernel/pci-com
The struct resource uses singly linked list to link siblings, implemented
by pointer operation. Replace it with list_head for better code readability.
Based on this list_head replacement, it will be very easy to do reverse
iteration on iomem_resource's sibling list in later patch.
Besides, type o
This patchset is doing:
1) Replace struct resource's sibling list from singly linked list to
list_head. Clearing out those pointer operation within singly linked
list for better code readability.
2) Based on list_head replacement, add a new function
walk_system_ram_res_rev() which can does reversed
From: "K. Y. Srinivasan"
The IPI hypercalls depend on being able to map the Linux notion of CPU ID
to the hypervisor's notion of the CPU ID. The array hv_vp_index[] provides
this mapping. Code for populating this array depends on the IPI functionality.
Break this circular dependency.
Fixes: 68bb
> -Original Message-
> From: k...@linuxonhyperv.com
> Sent: Tuesday, July 3, 2018 3:37 PM
> To: x...@kernel.org; gre...@linuxfoundation.org; linux-
> ker...@vger.kernel.org; de...@linuxdriverproject.org; o...@aepfle.de;
> a...@canonical.com; jasow...@redhat.com; t...@linutronix.de;
> h.
From: "K. Y. Srinivasan"
The IPI hypercalls depend on being able to map the Linux notion of CPU ID
to the hypervisor's notion of the CPU ID. The array hv_vp_index[] provides
this mapping. Code for populating this array depends on the IPI functionality.
Break this circular dependency.
Fixes: 68bb
On Tue, Jul 3, 2018 at 5:55 PM, Baoquan He wrote:
> On 06/12/18 at 05:24pm, Andy Shevchenko wrote:
>> On Tue, Jun 12, 2018 at 5:20 PM, Andy Shevchenko
>> wrote:
>> > I briefly looked at the code and error codes we have, so, my proposal
>> > is one of the following
>>
>> > - use -ECANCELED (not
Hi Andy,
On 06/12/18 at 05:24pm, Andy Shevchenko wrote:
> On Tue, Jun 12, 2018 at 5:20 PM, Andy Shevchenko
> wrote:
> >> Hmm, I just copied it from arch/powerpc/kernel/pci-common.c. The
> >> function interface expects an integer returned value, not sure what a
> >> real error codes look like, cou
On Tue, Jul 03, 2018 at 05:05:24PM +0300, Razvan Stefanescu wrote:
> Signed-off-by: Razvan Stefanescu
No changelog text?
> ---
> MAINTAINERS | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/MAINTAINERS b/MAINTAINERS
> index b6d0cc0..0d36546 100644
> --- a/MAINTAINERS
Signed-off-by: Razvan Stefanescu
---
MAINTAINERS | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/MAINTAINERS b/MAINTAINERS
index b6d0cc0..0d36546 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -4434,7 +4434,8 @@ S:Maintained
F: drivers/staging/fsl-dpaa2/ethernet
Hello stephen hemminger,
The patch 9749fed5d43d: "netvsc: use ERR_PTR to avoid dereference
issues" from Jul 19, 2017, leads to the following static checker
warning:
drivers/net/hyperv/rndis_filter.c:1344 rndis_filter_device_add()
warn: passing zero to 'ERR_PTR'
drivers/net/hyperv
Hello Ajay Singh,
The patch ff52a57a7a42: "staging: wilc1000: move the allocation of
cmd out of wilc_enqueue_cmd()" from Jun 26, 2018, leads to the
following static checker warning:
drivers/staging/wilc1000/host_interface.c:3390 wilc_deinit()
warn: inconsistent returns 'hif_deinit
> On 03 July 2018 at 08:31 Tamir Suliman wrote:
> +++ b/drivers/staging/speakup/keyhelp.c
> @@ -167,7 +167,7 @@ int spk_handle_help(struct vc_data *vc, u_char type,
> u_char ch, u_short key)
> synth_printf("%s\n", spk_msg_get(MSG_HELP_INFO));
> build_key_data(); /*
On Tue, Jul 03, 2018 at 07:31:20AM +, Tamir Suliman wrote:
> Fixed the following style/coding issues:
> *updated ---help to the prefered new help texts which reduces the code/file
> size and fixes the warning messages
> *Used else if instead of elese as else is not generally useful after a bre
Fixed the following style/coding issues:
*updated ---help to the prefered new help texts which reduces the code/file
size and fixes the warning messages
*Used else if instead of elese as else is not generally useful after a break or
return, not sure if this is the acceptable but it resolved the w
18 matches
Mail list logo