On 06/29/2018 01:55 AM, Karim Eshapa wrote:
> Use GFP_ATOMIC rather GFP_KERNEL in interrupt handler,
> as GFP_KERNEL may sleep according to slab allocator.
This is a threaded interrupt. Sleeping is OK.
>
> Signed-off-by: Karim Eshapa
> ---
> drivers/staging/iio/adc/ad7280a.c | 2 +-
> 1 file c
Use GFP_ATOMIC rather GFP_KERNEL in interrupt handler,
as GFP_KERNEL may sleep according to slab allocator.
Signed-off-by: Karim Eshapa
---
drivers/staging/iio/adc/ad7280a.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/iio/adc/ad7280a.c
b/drivers/staging/i
Use GFP_ATOMIC rather GFP_KERNEL in interrupt handler,
as GFP_KERNEL may sleep according to slab allocator.
Signed-off-by: Karim Eshapa
---
drivers/staging/iio/adc/ad7280a.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/iio/adc/ad7280a.c
b/drivers/staging/i
Use GFP_ATOMIC rather GFP_KERNEL in interrupt handler,
as GFP_KERNEL may sleep according to slab allocator.
Signed-off-by: Karim Eshapa
---
drivers/staging/iio/adc/ad7280a.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/iio/adc/ad7280a.c
b/drivers/staging/i
On Thu, 2018-06-28 at 11:34 +0200, Bastien Nocera wrote:
> On Thu, 2018-06-28 at 10:22 +0200, Hans de Goede wrote:
> > On 28-06-18 09:43, Michael Straube wrote:
> > > ret = rtw_resume_process(padapter)
> > > Is this a bug or is the if else construct just pointless?
> > It probably is just pointless
On Thu, Jun 28, 2018 at 11:39:53AM -0700, Roman Kiryanov wrote:
> Hi Greg,
>
> we wanted to include our changes into this year LTS.
Great, then get the audio driver cleaned up this week and all is fine,
it shouldn't take you very long, right?
> > get the existing code cleaned up and out of the s
We don't really need initialization of this at such an early stage.
Just use builtin_platform_driver to initialize this driver.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 7 +--
1 file changed, 1 insertion(+), 6 deletions(-)
diff --git a/drivers/
Trivial change to have only one return in 'rt2880_get_group_name'
function using a ternary operator instead of an if statement and
two returns.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 5 +
1 file changed, 1 insertion(+), 4 deletions(-)
diff --
Using 'function' and 'group' bindings in the device tree give the
posibility of refactor 'rt2880_pinctrl_dt_node_to_map' and simplify
it a lot. Make use of 'for_each_node_with_property' function to count
number of groups for the node and iterate over the groups using
'of_property_for_each_string' c
There was a custom 'rt2880_pinctrl_dt_free_map' function which
it was doing the same as pinctrl_utils_free_map defined in
'pinctrl-utils.h' header file. Use it instead avoiding
code duplications.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 16 ++---
The debug information provided by this function does not make
sense at all, so just remove it.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 8
1 file changed, 8 deletions(-)
diff --git a/drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c
b/drive
According to documentation 'pinctrl-bindings.txt' bindings 'group'
and 'function' can be used directly. So replace all of them.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-dts/mt7621.dtsi | 48 +-
1 file changed, 24 insertions(+), 24 deletions(-)
Function rt2880_pinctrl_dt_node_to_map was using 'kzalloc' to
reserve map memory. There is a 'pinctrl_utils_reserve_map' to
do this function. Just use it.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 12 +---
1 file changed, 9 insertions(+), 3 d
Struct 'rt2880_priv' contains a field 'gpio' which is defined
as uint8_t and should be defined with 'u8' which is preferred.
Update some cast along the code related with this new change.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 7 +++
1 file cha
This commit silence checkpatch warnings about lines which
exceeds 80 chars.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 26 ++---
1 file changed, 15 insertions(+), 11 deletions(-)
diff --git a/drivers/staging/mt7621-pinctrl/pinctrl
Kernel coding style use tabs for indent code instead of spaces.
Fix some places where spaces were being used silencing also
checkpatch script complains.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(
Function parameters along the code has different alignment styles.
Just unify all of them making style consistent.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 29 -
1 file changed, 14 insertions(+), 15 deletions(-)
diff --git a
For a constant format without additional arguments, use seq_puts()
instead of seq_printf() fixing also the following checkpatch.pl
warning: 'Prefer seq_puts to seq_printf'
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 2 +-
1 file changed, 1 insertion(+)
Adding spaces between if condition and parenthesis are not
needed at all and checkpatch script complains about them.
Fix one in driver code.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-pinctrl/pinctrl-rt2880.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/d
This patch series add remaining cleanups from previous series
which had problems to applied from here:
http://driverdev.linuxdriverproject.org/pipermail/driverdev-devel/2018-June/121744.html
Just send remaining patches in a new patch serie.
Hope this helps.
Best regards,
Sergio Paracuellos
Hi Greg,
we wanted to include our changes into this year LTS.
> get the existing code cleaned up and out of the staging tree?
Is this drivers/staging/goldfish? After I deleted the nand driver I
see only goldfish_audio there.
> Also, this code causes a bunch of build warnings, I could not take i
On Tue, May 08, 2018 at 10:49:46PM +0100, Colin King wrote:
> From: Colin Ian King
>
> Trivial fix to spelling mistake in dev_err error message
>
> Signed-off-by: Colin Ian King
> ---
> drivers/pci/host/pci-hyperv.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
Hi Colin,
patch chan
Whether any of the conditions is true or not, the return variable
is always set to rtw_resume_process(padapter). Replace the if else
construct with a single call to rtw_resume_process(). Also remove
the now unused local variable pwrpriv.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8723
Vitaly Kuznetsov writes:
> Wanpeng Li writes:
>
>> Hi Vitaly, (fix my reply mess this time)
>> On Sat, 23 Jun 2018 at 01:09, Vitaly Kuznetsov wrote:
>>>
>>> When reviewing my "x86/hyper-v: use cheaper HVCALL_FLUSH_VIRTUAL_ADDRESS_
>>> {LIST,SPACE} hypercalls when possible" patch Michael suggest
Try building this on a 32 bit system. I bet that's the build warnings
which Greg saw...
On Wed, Jun 27, 2018 at 02:50:52PM -0700, r...@google.com wrote:
> From: Roman Kiryanov
>
> This is kernel driver for controlling the Goldfish sync
> device on the host. It is used to maintain ordering
> in
On Wed, Jun 27, 2018 at 02:50:52PM -0700, r...@google.com wrote:
> From: Roman Kiryanov
>
> This is kernel driver for controlling the Goldfish sync
> device on the host. It is used to maintain ordering
> in critical OpenGL state changes while using
> GPU emulation.
Why are you adding new feature
On Wed, Jun 27, 2018 at 02:47:55PM -0700, r...@google.com wrote:
> From: Roman Kiryanov
>
> Add functions
> * to read and write u64 to be used in the goldfish sync driver.
Why not just keep these in the sync driver? No need to put them in a .h
file if only one .c file uses it, right?
thanks,
On Tue, Jun 19, 2018 at 06:23:52PM +0200, Vitor Fernandes Ferreira wrote:
> Signed-off-by: Vitor Fernandes Ferreira
> ---
> drivers/staging/comedi/comedi_fops.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
Hi,
This is the friendly patch-bot of Greg Kroah-Hartman. You have sent h
Hi,
On 28-06-18 17:00, Michael Straube wrote:
On 06/28/18 11:34, Bastien Nocera wrote:
On Thu, 2018-06-28 at 10:22 +0200, Hans de Goede wrote:
Hi,
On 28-06-18 09:43, Michael Straube wrote:
Hi,
I stumbled upon the following if else construct in
drivers/staging/rtl8723bs/os_dep/sdio_intf.c:61
On 06/28/18 11:34, Bastien Nocera wrote:
On Thu, 2018-06-28 at 10:22 +0200, Hans de Goede wrote:
Hi,
On 28-06-18 09:43, Michael Straube wrote:
Hi,
I stumbled upon the following if else construct in
drivers/staging/rtl8723bs/os_dep/sdio_intf.c:618
if (pwrpriv->bInternalAutoSuspend)
On Thu, Jun 28, 2018 at 01:32:41PM +0100, John Whitmore wrote:
> On Thu, Jun 28, 2018 at 10:38:28AM +0300, Dan Carpenter wrote:
> > On Wed, Jun 27, 2018 at 09:22:50PM +0100, John Whitmore wrote:
> > > On Tue, Jun 26, 2018 at 11:56:24AM +0800, Greg KH wrote:
> > > > On Sun, Jun 24, 2018 at 04:34:51P
On Fri, Jun 08, 2018 at 02:16:35PM +0200, Sergio Paracuellos wrote:
> Adding spaces between if condition and parenthesis are not
> needed at all and checkpatch script complains about them.
> Fix one in driver code.
>
> Signed-off-by: Sergio Paracuellos
> ---
> drivers/staging/mt7621-pinctrl/pinc
On Thu, Jun 28, 2018 at 10:38:28AM +0300, Dan Carpenter wrote:
> On Wed, Jun 27, 2018 at 09:22:50PM +0100, John Whitmore wrote:
> > On Tue, Jun 26, 2018 at 11:56:24AM +0800, Greg KH wrote:
> > > On Sun, Jun 24, 2018 at 04:34:51PM +0100, John Whitmore wrote:
> > > > Changed a number of hard coded fu
On Thu, Jun 28, 2018 at 09:43:47AM +0200, Michael Straube wrote:
> Hi,
>
> I stumbled upon the following if else construct in
> drivers/staging/rtl8723bs/os_dep/sdio_intf.c:618
>
> if (pwrpriv->bInternalAutoSuspend)
> {
> ret = rtw_resume_process(padapter);
>
On Thu, 2018-06-28 at 10:22 +0200, Hans de Goede wrote:
> Hi,
>
> On 28-06-18 09:43, Michael Straube wrote:
> > Hi,
> >
> > I stumbled upon the following if else construct in
> > drivers/staging/rtl8723bs/os_dep/sdio_intf.c:618
> >
> > if (pwrpriv->bInternalAutoSuspend)
> > {
>
Hi,
On 28-06-18 09:43, Michael Straube wrote:
Hi,
I stumbled upon the following if else construct in
drivers/staging/rtl8723bs/os_dep/sdio_intf.c:618
if (pwrpriv->bInternalAutoSuspend)
{
ret = rtw_resume_process(padapter);
}
else
{
Hi,
I stumbled upon the following if else construct in
drivers/staging/rtl8723bs/os_dep/sdio_intf.c:618
if (pwrpriv->bInternalAutoSuspend)
{
ret = rtw_resume_process(padapter);
}
else
{
if (pwrpriv->wowlan_mode || pwrpriv->w
On Wed, Jun 27, 2018 at 09:22:50PM +0100, John Whitmore wrote:
> On Tue, Jun 26, 2018 at 11:56:24AM +0800, Greg KH wrote:
> > On Sun, Jun 24, 2018 at 04:34:51PM +0100, John Whitmore wrote:
> > > Changed a number of hard coded function names to use %s and __func__
> > >
> > > Mailing list response
38 matches
Mail list logo