Item [1] in TODO list is already addressed, so removed it from TODO file.
[1]. Move handling for each individual members of 'union message_body' out
into a separate 'struct work_struct' and completely remove the
multiplexerthat is currently part of host_if_work(), allowing movement
of the implemen
Remove multiplexing of command at host_if_work().
Make use of function pointer instead of command ID to track individual
work_struct separately.
Modified the handler function to take work_struct pointer as argument
and its return type is changes to void. Now prototype of 'handle_'
function is same
Instead of allocating the host_if_cmd in wilc_enqueue_cmd() now moved
the allocation of cmd in the caller. Added the NULL check for
'hif_workqueue' before posting the work queue in wilc_enqueue_cmd().
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 943 +
The current patch series contains changes to address TODO item [1].
[1]. Move handling for each individual members of 'union message_body' out
into a separate 'struct work_struct' and completely remove the multiplexer
that is currently part of host_if_work(), allowing movement of the
implementatio
Avoided the use of static variable 'inactive_time' and move it as part of
'sta_inactive_t' structure.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/wilc1000/host_interface.c
b/dri
Instead of static variable now allocating the data and passing to
handle_get_rssi() to fill the rssi information.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 12 +---
1 file changed, 9 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/wilc1000/host
Handle freeing of memory allocated to keep 'key' & 'seq' in wilc_add_rx_gtk().
Once completion event is received, free the memory allocated for
to avoid missing of free in work function.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 4
1 file changed, 4 deletions
Handle freeing of memory allocated to store the 'key' in wilc_add_ptk()
function. Once work completion notification is received, free the
memory allocated to avoid missing of free in work function sepecially
for error scenario.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interfac
Added 'work_comp' completion in 'host_if_msg'. It allows handling the
sync call to wait for sepecific completion event.
The commands can be run in sync way waiting for their specific
completion event.
Added is_sync flag in wilc_create_work_queue() to handle the sync call to
host interface.
After a
Modified the code to free the allocated memory, used to store the key in
wilc_add_wep_key_bss_sta() and wilc_add_wep_key_bss_ap().
After work completion notification is received, free the
memory allocated to avoid missing of free in work function.
Signed-off-by: Ajay Singh
---
drivers/staging/wi
Remove 'hif_thread_comp' completions as its not required after adding
completion event as part work data to handle each sync call.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 35 ---
1 file changed, 35 deletions(-)
diff --git a/drivers/s
Rename wilc_enqueue_cmd() to wilc_enqueue_work() because its used to
enqueue the work queue. Also removed the function header comment for
wilc_enqueue_cmd() as its not correct.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 90 +++
1 file ch
After removing the multiplexing of hif commands in hif_if_work()
macros prefix with 'HOST_IF_MSG_' are not required. Also 'id' field in
host_if_msg is not required anymore.
Signed-off-by: Ajay Singh
---
drivers/staging/wilc1000/host_interface.c | 36 ---
1 file change
On Mon, Jun 25, 2018 at 08:50:26PM +0100, John Whitmore wrote:
> On Mon, Jun 25, 2018 at 02:05:04PM +0100, Justin Skists wrote:
> >
> > > On 25 June 2018 at 13:36 John Whitmore wrote:
> > >
> > >
> > > On Mon, Jun 25, 2018 at 12:06:30PM +0300, Andy Shevchenko wrote:
> > > > On Sun, Jun 24, 2018
On Sun, Jun 24, 2018 at 04:34:51PM +0100, John Whitmore wrote:
> Changed a number of hard coded function names to use %s and __func__
>
> Mailing list response suggest that there is a better method for debugging
> using netdev_dbg(). I can't argue with that, but for the moment this change
> will c
On Thu 07 Jun 11:42 PDT 2018, Ard Biesheuvel wrote:
> On 7 June 2018 at 20:21, Bjorn Andersson wrote:
> > On Thu 07 Jun 09:33 PDT 2018, Greg Kroah-Hartman wrote:
[..]
> >>
> >> Why not just use kmalloc, it will always return a DMAable buffer.
> >>
> >
> > For the buffers being targeted by request
> -Original Message-
> From: Vitaly Kuznetsov
> Sent: Friday, June 22, 2018 10:06 AM
> To: x...@kernel.org
> Cc: de...@linuxdriverproject.org; linux-ker...@vger.kernel.org; KY Srinivasan
> ; Haiyang Zhang ; Stephen
> Hemminger
> ; Thomas Gleixner ; Ingo Molnar
> ; H. Peter Anvin ; Tianyu
Thank you everybody for your help. I have passed this information along to the
customer and asked for the reason they want to refer to the name of the
clocksource.
エアー・アルマ
Professional Direct Delivery Manager
Email: v-ale...@microsoft.com
Microsoft Azure Professional Direct Services
日本 +81 1-20
> -Original Message-
> From: Vitaly Kuznetsov
> Sent: Friday, June 22, 2018 10:06 AM
> To: x...@kernel.org
> Cc: de...@linuxdriverproject.org; linux-ker...@vger.kernel.org; KY Srinivasan
> ; Haiyang Zhang ; Stephen
> Hemminger
> ; Thomas Gleixner ; Ingo Molnar
> ; H. Peter Anvin ; Tianyu
This satisfies a checkpatch warning and is the preferred
method for notating the license.
The SPDX identifier is a legally binding shorthand, which
can be used instead of the full boiler plate text.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8188eu/core/rtw_ap.c| 10 +
On Mon, Jun 25, 2018 at 02:05:04PM +0100, Justin Skists wrote:
>
> > On 25 June 2018 at 13:36 John Whitmore wrote:
> >
> >
> > On Mon, Jun 25, 2018 at 12:06:30PM +0300, Andy Shevchenko wrote:
> > > On Sun, Jun 24, 2018 at 6:34 PM, John Whitmore
> > > wrote:
> > > > Replaced memory initialisin
Doing some macro replacement to start an array of structures
so it can be reused by manipulating it with different values.
Signed-off-by: Karim Eshapa
---
.../staging/iio/impedance-analyzer/ad5933.c | 57 +++
1 file changed, 19 insertions(+), 38 deletions(-)
diff --git a/drive
Use ether_addr_copy() instead of memcpy() to copy the mac address.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8723bs/core/rtw_ieee80211.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/rtl8723bs/core/rtw_ieee80211.c
b/drivers/staging/rtl8723
Use the mac_pton() helper to convert the mac address string.
The functions key_char2num() and key_2char2num() are not used
anywhere else and can be removed.
This also has the benefit of validating the input since mac_pton()
returns false if the string is not valid.
Signed-off-by: Michael Straube
Using is_broadcast_ether_addr() and is_zero_ether_addr() instead of
testing each byte of the mac[] array for 0xff and 0x00 shortens the
code and improves readability.
If np == NULL, of_get_property() returns NULL, hence the "np" check
is not needed.
Instead of a fixed default mac address use a ra
Fix comparsion to NULL issues found by checkpatch.
Use !x instead of x == NULL.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8723bs/core/rtw_ieee80211.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8723bs/core/rtw_ieee80211.c
b/drivers/stag
The function rtw_set_tx_chksum_offload() has empty definition.
Signed-off-by: Michael Straube
---
drivers/staging/rtl8723bs/core/rtw_xmit.c | 2 --
drivers/staging/rtl8723bs/include/xmit_osdep.h | 2 --
drivers/staging/rtl8723bs/os_dep/xmit_linux.c | 5 -
3 files changed, 9 deletions(-
Hi Daniel,
Thank you for the patch.
On Monday, 25 June 2018 16:21:32 EEST Daniel Graefe wrote:
> Added missing SPDX license identifiers to all files of the omap4iss
> driver.
>
> Most files already have license texts which clearly state them to be
> licensed under GPL 2.0 or later. SPDX identifi
If there are going to be actual users in the specific near term then
that's fine. Otherwise if we're talking a year out, then it's too far
away to predict what will happen a year from now so we should delete
the dead weight.
regards,
dan carpenter
___
Hi Dan,
I'd like to mention once more, that the idea of the abstraction was to
support multiple modules of Hope-RF.
If the decision of the "team" of developer of this driver is, that it
should be reduced to a Pi433 or RFM69CW driver only, I fully agree,
that the abstraction layer isn't necessar
Added missing SPDX license identifiers to all files of the omap4iss
driver.
Most files already have license texts which clearly state them to be
licensed under GPL 2.0 or later. SPDX identifiers were added accordingly.
Some files do not have any license text. SPDX identifiers for GPL 2.0
were add
> On 25 June 2018 at 13:36 John Whitmore wrote:
>
>
> On Mon, Jun 25, 2018 at 12:06:30PM +0300, Andy Shevchenko wrote:
> > On Sun, Jun 24, 2018 at 6:34 PM, John Whitmore
> > wrote:
> > > Replaced memory initialising loop with memset, as suggested by Andy
> > > Shevchenko
> > >
> >
> > Sugg
I'd still prefer if we just removed this abstraction entirely and used
OPMODE_MODE_TRANSMIT everywhere instead of bringing "transmit" into it.
I know that every author thinks their abstraction will definitely be
useful in the future, but generally kernel style is to remove
abstractions.
But I gue
On Mon, Jun 25, 2018 at 12:06:30PM +0300, Andy Shevchenko wrote:
> On Sun, Jun 24, 2018 at 6:34 PM, John Whitmore
> wrote:
> > Replaced memory initialising loop with memset, as suggested by Andy
> > Shevchenko
> >
>
> Suggested-by ?
>
Em, not sure how to respond, it certainly wasn't my idea. I
On Mon, Jun 25, 2018 at 12:47:44PM +0300, Andy Shevchenko wrote:
> On Fri, Jun 22, 2018 at 1:28 PM, Dan Carpenter
> wrote:
> > On Thu, Jun 21, 2018 at 08:21:55PM +0200, Michael Straube wrote:
> >> Remove braces from single line if statements.
> >> Also fix a comparsion to NULL in one of the condi
Fixes checkpatch warning:
WARNING: line over 80 characters
Signed-off-by: Valentin Vidic
---
drivers/staging/pi433/rf69.h | 9 +
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/drivers/staging/pi433/rf69.h b/drivers/staging/pi433/rf69.h
index c131ffbdc2db..d80c41966d39 1
Use GPL-2.0+ based on the license text in each of the files.
Signed-off-by: Valentin Vidic
---
drivers/staging/pi433/pi433_if.c | 1 +
drivers/staging/pi433/pi433_if.h | 3 ++-
drivers/staging/pi433/rf69.c | 1 +
drivers/staging/pi433/rf69.h | 3 ++-
drivers/stagi
On Sun, Jun 24, 2018 at 08:59:22AM -0700, Joe Perches wrote:
> Rather than doing individual patches for each line
> with a whitespace issue, I think it'd be better to
> do a single driver wide patch.
>
> Perhaps use a tool like:
>
> $ git ls-files drivers/staging/rtl8192u |
> xargs ./scripts/ch
Reviewed-by: Marcus Wolf
Thank you Valentin, very nice patch :-)
Valentin Vidic schrieb am 24.06.2018 18:31:
Use const array to map switch cases to resulting values.
Signed-off-by: Valentin Vidic
---
v2: use correct type for const arrays
v3: add missing static keyword for af_map
drivers/sta
On Sat, Jun 23, 2018 at 12:45 PM, Michael Straube
wrote:
> Using is_broadcast_ether_addr() and is_zero_ether_addr() instead of
> testing each byte of the mac[] array for 0xff and 0x00 shortens the
> code and improves readability.
>
> If np == NULL, of_get_property() returns NULL, hence the "np" ch
On Fri, Jun 22, 2018 at 8:28 PM, Joe Perches wrote:
> On Fri, 2018-06-22 at 14:48 +0200, Michael Straube wrote:
>> On 06/22/18 12:57, Dan Carpenter wrote:
> Output from checkpatch is not gospel and can be ignored
> whenever appropriate.
>
> I think the below is ok:
>
> if ((is_broadcast_e
On Fri, Jun 22, 2018 at 1:28 PM, Dan Carpenter wrote:
> On Thu, Jun 21, 2018 at 08:21:55PM +0200, Michael Straube wrote:
>> Remove braces from single line if statements.
>> Also fix a comparsion to NULL in one of the conditions.
>> Issues found by checkpatch.
>>
>> Signed-off-by: Michael Straube
On Sun, Jun 24, 2018 at 6:34 PM, John Whitmore wrote:
> Replaced memory initialising loop with memset, as suggested by Andy Shevchenko
>
Suggested-by ?
> Signed-off-by: John Whitmore
> ---
> drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c | 5 +
> 1 file changed, 1 insertion(+), 4 dele
43 matches
Mail list logo