Doing some macro replacment to start an array of structures
so it can be reused by manipulating it with different values.
Signed-off-by: Karim Eshapa
---
.../staging/iio/impedance-analyzer/ad5933.c | 57 +++
1 file changed, 19 insertions(+), 38 deletions(-)
diff --git a/driver
On Sun, 2018-06-24 at 10:57 +0100, John Whitmore wrote:
> Replaced memory initialising loop with memset, as suggested by Andy Shevchenko
[]
> diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
> b/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
[]
> @@ -742,8 +742,6 @@ void HTCon
Use const array to map switch cases to resulting values.
Signed-off-by: Valentin Vidic
---
v2: use correct type for const arrays
v3: add missing static keyword for af_map
drivers/staging/pi433/rf69.c | 233 ++-
1 file changed, 93 insertions(+), 140 deletions(-)
Use const array to map switch cases to resulting values.
Signed-off-by: Valentin Vidic
---
v2: use correct type for const arrays
drivers/staging/pi433/rf69.c | 233 ++-
1 file changed, 93 insertions(+), 140 deletions(-)
diff --git a/drivers/staging/pi433/rf69.c
On Sun, 2018-06-24 at 11:42 +0200, Valentin Vidic wrote:
> Use const array to map switch cases to resulting values.
I suggest you make the const arrays the same type
as the argument in the function being called.
> diff --git a/drivers/staging/pi433/rf69.c b/drivers/staging/pi433/rf69.c
[]
> @@ -1
On Sun, 2018-06-24 at 16:34 +0100, John Whitmore wrote:
> Corrected the coding style of if statement.
[]
> diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
> b/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
[]
> @@ -732,7 +732,7 @@ void HTConstructRT2RTAggElement(struct ieee80
Sorry having difficulty getting the full v3 patch set sent using git
send-email. Only one seems to be going out. Sorry about the noise.
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-
Corrected the coding style of if statement.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
b/drivers/staging/rtl8192u/ieee80211/rtl819x_H
Changed a number of hard coded function names to use %s and __func__
Mailing list response suggest that there is a better method for debugging
using netdev_dbg(). I can't argue with that, but for the moment this change
will clear the checkpatch.pl Warning.
Signed-off-by: John Whitmore
---
drive
Removed the unrequired braces from single statement blocks - Coding Style.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c | 12
1 file changed, 4 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
b/
Simple spelling correction.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
b/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
index 07
Replaced memory initialising loop with memset, as suggested by Andy Shevchenko
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c | 5 +
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
b/drive
Where possible truncation of block comments to the 80 character length
preferred by the coding style.
In a previous version of this commit some of the comments were contentious so
those have not been touched in this version.
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/rtl819x_HTProc
Simple coding style changes to single file
drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
Given feedback on some of the comments, I truncated to the 80 character limit,
in code, (as opposed to function block comments). I have left a number of the
contentious comments as they are.
Another pie
Some of the comment blocks are commening out code so have been left for the
moment.
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/rtl819x_HTProc.c | 366 ++
1 file changed, 195 insertions(+), 171 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819
Removed an extra indentation from the code of the various case options in a
switch statement.
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/rtl819x_HTProc.c | 30 +--
1 file changed, 15 insertions(+), 15 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee8021
Changed a number of hard coded function names to use %s and __func__
Mailing list response suggest that there is a better method for debugging
using netdev_dbg(). I can't argue with that, but for the moment this change
will clear the checkpatch.pl Warning.
Signed-off-by: John Whitmore
---
drive
Removed an extra indentation from the code of the various case options in a
switch statement.
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/rtl819x_HTProc.c | 30 +--
1 file changed, 15 insertions(+), 15 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee8021
Corrected the coding style of if statement.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
b/drivers/staging/rtl8192u/ieee80211/rtl819x_H
Where possible truncation of block comments to the 80 character length
preferred by the coding style.
In a previous version of this commit some of the comments were contentious so
those have not been touched in this version.
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/rtl819x_HTProc
Some of the comment blocks are commening out code so have been left for the
moment.
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/rtl819x_HTProc.c | 366 ++
1 file changed, 195 insertions(+), 171 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819
Removed the unrequired braces from single statement blocks - Coding Style.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c | 12
1 file changed, 4 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
b/
Simple spelling correction.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
b/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
index 07
Simple coding style changes to single file
drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
Given feedback on some of the comments, I truncated to the 80 character limit,
in code, (as opposed to function block comments). I have left a number of the
contentious comments as they are.
Another pi
Replaced memory initialising loop with memset, as suggested by Andy Shevchenko
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c | 5 +
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
b/drive
On Sun, Jun 24, 2018 at 07:26:41AM -0700, Joe Perches wrote:
> On Sun, 2018-06-24 at 10:57 +0100, John Whitmore wrote:
> > Replaced memory initialising loop with memset, as suggested by Andy
> > Shevchenko
> []
> > diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
> > b/drivers/sta
On Sun, Jun 24, 2018 at 07:26:41AM -0700, Joe Perches wrote:
> On Sun, 2018-06-24 at 10:57 +0100, John Whitmore wrote:
> > Replaced memory initialising loop with memset, as suggested by Andy
> > Shevchenko
> []
> > diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
> > b/drivers/sta
On Mon, 18 Jun 2018 19:44:50 +0200
Karim Eshapa wrote:
> Use sign_extend32 kernel function instead of code duplication,
> Safe also for 16 bit. and remove declaration of bits variable not needed.
>
> Signed-off-by: Karim Eshapa
Applied, thanks.
Jonathan
> ---
> drivers/staging/iio/accel/adi
On Sun, Jun 24, 2018 at 06:53:24PM +0800, Greg KH wrote:
> On Sun, Jun 24, 2018 at 10:57:24AM +0100, John Whitmore wrote:
> > Simple coding style changes to single file
> > drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
>
> Nit, please include the driver and subsystem in your 00/XX emails,
>
On Sun, Jun 24, 2018 at 10:57:24AM +0100, John Whitmore wrote:
> Simple coding style changes to single file
> drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
Nit, please include the driver and subsystem in your 00/XX emails,
otherwise they get lost in my filters and I see an odd semi-completed
Simple spelling correction.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
b/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
index 26
Corrected the coding style of if statement.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
b/drivers/staging/rtl8192u/ieee80211/rtl819x_H
Where possible truncation of block comments to the 80 character length
preferred by the coding style.
In a previous version of this commit some of the comments were contentious so
those have not been touched in this version.
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/rtl819x_HTProc
Removed an extra indentation from the code of the various case options in a
switch statement.
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/rtl819x_HTProc.c | 30 +--
1 file changed, 15 insertions(+), 15 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee8021
Removed the unrequired braces from single statement blocks - Coding Style.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c | 12
1 file changed, 4 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
b/
Some of the comment blocks are commening out code so have been left for the
moment.
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/rtl819x_HTProc.c | 366 ++
1 file changed, 195 insertions(+), 171 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819
Simple coding style changes to single file
drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
Given feedback on some of the comments, I truncated to the 80 character limit,
in code, (as opposed to function block comments). I have left a number of the
contentious comments as they are.
Another pie
Replaced memory initialising loop with memset, as suggested by Andy Shevchenko
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c | 5 +
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
b/drive
Changed a number of hard coded function names to use %s and __func__
Mailing list response suggest that there is a better method for debugging
using netdev_dbg(). I can't argue with that, but for the moment this change
will clear the checkpatch.pl Warning.
Signed-off-by: John Whitmore
---
drive
Use const array to map switch cases to resulting values.
Signed-off-by: Valentin Vidic
---
drivers/staging/pi433/rf69.c | 233 ++-
1 file changed, 93 insertions(+), 140 deletions(-)
diff --git a/drivers/staging/pi433/rf69.c b/drivers/staging/pi433/rf69.c
index 90
40 matches
Mail list logo