On Wed, Jun 20, 2018 at 08:52:19PM +0200, Christian König wrote:
> Fixup for "dma_buf: remove device parameter from attach callback v2".
>
> I missed this driver, sorry for the noise. Patch is not even compile
> tested.
>
> Signed-off-by: Christian König
Reviewed-by: Daniel Vetter
Also
Fixes
Hi Dan,
I agree completely. I was concerned whether the preprocessor definitions in
p80211metadef.h were named according to some convention as there are
many definitions named similarly there.
I am considering renaming this specific definition to "p80211_dot11_keyid",
would that be more accepta
On Wed, Jun 20, 2018 at 02:21:57PM -0700, Daniel Colascione wrote:
> On Tue, Jun 19, 2018 at 9:32 PM, Joel Fernandes
> wrote:
> > On Tue, Jun 19, 2018 at 05:57:35PM -0700, Alistair Strachan wrote:
> > > The ashmem driver did not check that the size/offset of the vma passed
> > > to its .mmap() fu
I am Vice Chairman of Hang Seng Bank, I have Important Matter to Discuss with
you concerning my late client. Died without a NEXT OF KIN. Send me your private
email for full details information. email me at E-Mail: dray...@gmail.com
Regards
Mr.Fung
___
Hi Christian,
I love your patch! Yet something to improve:
[auto build test ERROR on staging/staging-testing]
[also build test ERROR on v4.18-rc1 next-20180620]
[if your patch is applied to the wrong git tree, please drop us a note to help
improve the system]
url:
https://github.com/0day
On Wed, Jun 20, 2018 at 07:10:26PM +0200, Chris Opperman wrote:
> b) Added temporary "key" variable to reduce line length.
No, that's nonsense. Just fix the original variable so that it's not a
million characters long.
Using a shorter variable is good if it simplifies the code like so:
Missing 'e' on "signatur". This fixes the build presumably? My guess
is that kbuild caught the warning?
On Wed, Jun 20, 2018 at 08:52:19PM +0200, Christian König wrote:
> Fixup for "dma_buf: remove device parameter from attach callback v2".
>
I don't think we've applied this? Can't you just r
I am Vice Chairman of Hang Seng Bank, I have Important Matter to Discuss with
you concerning my late client. Died without a NEXT OF KIN. Send me your private
email for full details information. email me at E-Mail: dray...@gmail.com
Regards
Mr.Fung
__
Fixup for "dma_buf: remove device parameter from attach callback v2".
I missed this driver, sorry for the noise. Patch is not even compile
tested.
Signed-off-by: Christian König
---
drivers/staging/android/ion/ion.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers
> -Original Message-
> From: Vitaly Kuznetsov
> Sent: Wednesday, June 20, 2018 1:24 AM
> To: Michael Kelley (EOSG)
> Cc: x...@kernel.org; de...@linuxdriverproject.org; linux-
> ker...@vger.kernel.org; KY Srinivasan ; Haiyang Zhang
> ; Stephen Hemminger
> ; Thomas Gleixner ; Ingo
> Moln
Improve readability of prism2_add_key:
a) Reduce nesting and removed goto statement by using more return statements.
b) Added temporary "key" variable to reduce line length.
Signed-off-by: Chris Opperman
---
Improve readability of prism2_add_key:
a) Reduce nesting and removed goto statement by u
Dear Beneficiary,
I am Steven Terner Mnuchin, the Secretary of the Treasury. You can get more
details about me here;
https://www.treasury.gov/about/Pages/Secretary.aspx
I have been saddled with the responsibility of liaising with beneficiaries
regarding all previously unpaid/unclaimed funds
On Tue, Jun 19, 2018 at 04:14:40PM -0700, Stephen Hemminger wrote:
> On Wed, 20 Jun 2018 08:01:50 +0900
> Greg KH wrote:
>
> > On Tue, Jun 19, 2018 at 03:19:41PM -0400, Thomas Walker wrote:
> > > Upon updating some internal kernels from 4.14.18 to 4.14.49, our hyper-v
> > > guests failed to brin
On Fri, Jun 15, 2018 at 01:30:32PM -0300, Mauro Carvalho Chehab wrote:
> The script:
> ./scripts/documentation-file-ref-check --fix
>
> Gives multiple hints for broken references on some files.
> Manually use the one that applies for some files.
>
> Acked-by: Steven Rostedt (VMware)
> Sign
I am Vice Chairman of Hang Seng Bank, I have Important Matter to Discuss with
you concerning my late client. Died without a NEXT OF KIN. Send me your private
email for full details information. email me at E-Mail: dray...@gmail.com
Regards
Mr.Fung
__
I am Vice Chairman of Hang Seng Bank, I have Important Matter to Discuss with
you concerning my late client. Died without a NEXT OF KIN. Send me your private
email for full details information. email me at E-Mail: dray...@gmail.com
Regards
Mr.Fung
___
Looks good.
Reviewed-by: Dan Carpenter
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
On Wed, Jun 20, 2018 at 11:34:39AM +0300, Dan Carpenter wrote:
> On Tue, Jun 19, 2018 at 10:33:26PM -0400, Hugo Lefeuvre wrote:
> > @@ -1178,6 +1152,11 @@ static int pi433_probe(struct spi_device *spi)
> > device->tx_active = false;
> > device->interrupt_rx_allowed = false;
> >
> > + /*
The device structure contains a useless non-atomic users counter which
is subject to race conditions. It has probably been created to handle
the case where remove is executed while operations are still executing
on open fds but this will never happen because of reference counts.
Drop the users cou
Use eth_hw_addr_random() to set a random dev_addr and update
addr_assign_type.
Fixes: e3cbf478f846 ('staging: mt7621-eth: add the drivers core files')
Signed-off-by: Kamal Heib
---
drivers/staging/mt7621-eth/mtk_eth_soc.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/driv
On Wed, Jun 20, 2018 at 06:05:06PM +0800, Jia-Ju Bai wrote:
> > Thanks! It occurs to me that another way to detect this bug is that
> > one of the allocations in this function already uses GFP_ATOMIC. It
> > doesn't normally make sense to mix GFP_ATOMIC and GFP_KERNEL when there
> > isn't any loc
Thanks!
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
On 2018/6/20 17:56, Dan Carpenter wrote:
On Wed, Jun 20, 2018 at 05:50:16PM +0800, Jia-Ju Bai wrote:
The driver may sleep with holding a spinlock.
The function call paths (from bottom to top) in Linux-4.16.7 are:
[FUNC] kzalloc(GFP_KERNEL)
drivers/staging/rtl8723bs/os_dep/ioctl_linux.c, 323:
The driver may sleep with holding a spinlock.
The function call paths (from bottom to top) in Linux-4.16.7 are:
[FUNC] kzalloc(GFP_KERNEL)
drivers/staging/rtl8188eu/core/rtw_cmd.c, 502:
kzalloc in rtw_disassoc_cmd
drivers/staging/rtl8188eu/core/rtw_ioctl_set.c, 256:
On Wed, Jun 20, 2018 at 05:50:16PM +0800, Jia-Ju Bai wrote:
> The driver may sleep with holding a spinlock.
> The function call paths (from bottom to top) in Linux-4.16.7 are:
>
> [FUNC] kzalloc(GFP_KERNEL)
> drivers/staging/rtl8723bs/os_dep/ioctl_linux.c, 323:
> kzalloc in translat
The driver may sleep with holding a spinlock.
The function call paths (from bottom to top) in Linux-4.16.7 are:
[FUNC] kzalloc(GFP_KERNEL)
drivers/staging/rtl8723bs/os_dep/ioctl_linux.c, 323:
kzalloc in translate_scan
drivers/staging/rtl8723bs/os_dep/ioctl_linux.c, 1554:
Nice...
Reviewed-by: Dan Carpenter
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
On Tue, Jun 19, 2018 at 08:56:03PM +0100, John Whitmore wrote:
> @@ -734,16 +734,15 @@ void HTConstructRT2RTAggElement(struct ieee80211_device
> *ieee, u8 *posRT2RTAgg,
> #ifdef TODO
> #if (HAL_CODE_BASE == RTL8192 && DEV_BUS_TYPE == USB_INTERFACE)
> /*
> - //Emily. If it is required t
On Tue, Jun 19, 2018 at 10:33:26PM -0400, Hugo Lefeuvre wrote:
> @@ -1178,6 +1152,11 @@ static int pi433_probe(struct spi_device *spi)
> device->tx_active = false;
> device->interrupt_rx_allowed = false;
>
> + /* init rx buffer */
> + device->rx_buffer = kmalloc(MAX_MSG_SIZE,
KY Srinivasan writes:
>> -Original Message-
>> From: Michael Kelley (EOSG)
>> Sent: Tuesday, June 19, 2018 10:57 AM
>> To: Vitaly Kuznetsov ; x...@kernel.org
>> Cc: de...@linuxdriverproject.org; linux-ker...@vger.kernel.org; KY
>> Srinivasan ; Haiyang Zhang
>> ; Stephen Hemminger
>> ; Tho
"Michael Kelley (EOSG)" writes:
>> -Original Message-
>> From: linux-kernel-ow...@vger.kernel.org
>> On Behalf
>> Of Vitaly Kuznetsov
>> Sent: Friday, June 15, 2018 9:30 AM
>> To: x...@kernel.org
>> Cc: de...@linuxdriverproject.org; linux-ker...@vger.kernel.org; KY Srinivasan
>> ; Haiya
Dear Sir/Madam,
I am Ansel Theodore a financial administrator and I Represent a late politician
whose family is in need of a foreign partner who can receive their funds that
is stashed in a security company abroad. They need a fund manager who can put
the funds in a lucrative venture for mutual
Hi,
On Tue, Jun 19, 2018 at 02:23:11PM -0700, Michael Kelley wrote:
> Add slow_virt_to_phys() function for ARM64 that parallels the same
> function on x86/x64. This is needed by the architecture independent
> Hyper-V VMbus driver at drivers/hv/channel.c. The implementation
> directly translates t
33 matches
Mail list logo