On Tue, Jun 19, 2018 at 05:57:34PM -0700, Alistair Strachan wrote:
> There is no speed difference, and it makes the code harder to read.
>
> Cc: Greg Kroah-Hartman
> Cc: Arve Hjønnevåg
> Cc: Todd Kjos
> Cc: Martijn Coenen
> Cc: de...@driverdev.osuosl.org
> Cc: linux-ker...@vger.kernel.org
> Cc
On Tue, Jun 19, 2018 at 05:57:35PM -0700, Alistair Strachan wrote:
> The ashmem driver did not check that the size/offset of the vma passed
> to its .mmap() function was not larger than the ashmem object being
> mapped. This could cause mmap() to succeed, even though accessing parts
> of the mappin
The driver may sleep with holding a spinlock.
The function call path (from bottom to top) in Linux-4.16.7 is:
[FUNC] schedule
drivers/staging/rtlwifi/halmac/rtl_halmac.c, 884:
schedule in _is_fw_read_cmd_down
drivers/staging/rtlwifi/halmac/rtl_halmac.c, 912:
_is_f
The device structure contains a useless non-atomic users counter which
is subject to race conditions. It has probably been created to handle
the case where remove is executed while operations are still executing
on open fds but this will never happen because of reference counts.
Drop the users cou
The ashmem driver did not check that the size/offset of the vma passed
to its .mmap() function was not larger than the ashmem object being
mapped. This could cause mmap() to succeed, even though accessing parts
of the mapping would later fail with a segmentation fault.
Ensure an error is returned
There is no speed difference, and it makes the code harder to read.
Cc: Greg Kroah-Hartman
Cc: Arve Hjønnevåg
Cc: Todd Kjos
Cc: Martijn Coenen
Cc: de...@driverdev.osuosl.org
Cc: linux-ker...@vger.kernel.org
Cc: kernel-t...@android.com
Cc: Joel Fernandes
Suggested-by: Greg Kroah-Hartman
Signe
HI Greg,
On Tue, Jun 19, 2018 at 4:01 PM Greg Kroah-Hartman
wrote:
>
> On Tue, Jun 19, 2018 at 03:24:44PM -0700, Alistair Strachan wrote:
> > The ashmem driver did not check that the size/offset of the vma passed
> > to its .mmap() function was not larger than the ashmem object being
> > mapped.
On Wed, 20 Jun 2018 08:01:50 +0900
Greg KH wrote:
> On Tue, Jun 19, 2018 at 03:19:41PM -0400, Thomas Walker wrote:
> > Upon updating some internal kernels from 4.14.18 to 4.14.49, our hyper-v
> > guests failed to bring up network interfaces on boot, logging "A link
> > change request failed wit
On Wed, 20 Jun 2018 08:01:50 +0900
Greg KH wrote:
> On Tue, Jun 19, 2018 at 03:19:41PM -0400, Thomas Walker wrote:
> > Upon updating some internal kernels from 4.14.18 to 4.14.49, our hyper-v
> > guests failed to bring up network interfaces on boot, logging "A link
> > change request failed wit
On Tue, Jun 19, 2018 at 03:19:41PM -0400, Thomas Walker wrote:
> Upon updating some internal kernels from 4.14.18 to 4.14.49, our hyper-v
> guests failed to bring up network interfaces on boot, logging "A link change
> request failed with some changes committed already. Interface eth0 may have
>
On Tue, Jun 19, 2018 at 03:24:44PM -0700, Alistair Strachan wrote:
> The ashmem driver did not check that the size/offset of the vma passed
> to its .mmap() function was not larger than the ashmem object being
> mapped. This could cause mmap() to succeed, even though accessing parts
> of the mappin
The ashmem driver did not check that the size/offset of the vma passed
to its .mmap() function was not larger than the ashmem object being
mapped. This could cause mmap() to succeed, even though accessing parts
of the mapping would later fail with a segmentation fault.
Ensure an error is returned
Hello My Dear Friend...
I sincerely apologize for intruding into your privacy, especially by contacting
you through these means for a business proposal of this magnitude. I am Dr
Helen Galloway,a medical doctor currently serving on a special peacekeeping
Mission in Syria.. I have summed up cour
Add ARM64-specific code to enable Hyper-V. This code includes:
* Detecting Hyper-V and initializing the guest/Hyper-V interface
* Setting up Hyper-V's synthetic clocks
* Making hypercalls using the HVC instruction
* Setting up VMbus and stimer0 interrupts
* Setting up kexec and crash handlers
This
Add slow_virt_to_phys() function for ARM64 that parallels the same
function on x86/x64. This is needed by the architecture independent
Hyper-V VMbus driver at drivers/hv/channel.c. The implementation
directly translates the virtual address using the ARM64 'at'
instruction.
Signed-off-by: Michael
This patch series enables Linux guests running on Hyper-V on ARM64
hardware. New ARM64-specific code in arch/arm64/hyperv initializes
Hyper-V, including its synthetic clocks and hypercall mechanism.
Existing architecture independent drivers for Hyper-V's VMbus and
synthetic devices just work when b
hyperv-tlfs.h defines Hyper-V interfaces from the Hyper-V Top Level
Functional Spec (TLFS). The TLFS is distinctly oriented to x86/x64,
and Hyper-V has not separated out the architecture-dependent parts into
x86/x64 vs. ARM64. So hyperv-tlfs.h includes information for ARM64
that is not yet formally
Add hooks to enable/disable a per-CPU IRQ for VMbus. These hooks
are in the architecture independent setup and shutdown paths for
Hyper-V, and are needed by Linux guests on Hyper-V on ARM64. The
x86/x64 implementation is null because VMbus interrupts on x86/x64
don't use an IRQ.
Signed-off-by: Mi
Update drivers/hv/Kconfig so CONFIG_HYPERV can be selected on ARM64,
causing the Hyper-V specific code to be built.
Signed-off-by: Michael Kelley
Reviewed-by: James Morris
---
drivers/hv/Kconfig | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/hv/Kconfig b/drivers/h
On Tue, Jun 19, 2018 at 10:56 PM, John Whitmore wrote:
> Changed a number of hard coded function names to use %s and __func__
Oh.
Looking at the code, much better fix would be...
Move IEEE80211_DEBUG() to use netdev_dbg() [dev_dbg() or pr_dbg() as
last resort) and actually drop it completely in
On Tue, Jun 19, 2018 at 10:55 PM, John Whitmore wrote:
> Where possible truncation of block comments to the 80 character length
> prefered by the coding style.
Is it somehow automated?!
> /*
> -* 8190 only, Realtek proprietary aggregation mode
> -* Set MPDUDensity=2, 1:
On Tue, Jun 19, 2018 at 10:55 PM, John Whitmore wrote:
> Removed an extra indentation from the code of the various case options in a
> switch statement.
> + //no MCS rate
> + for (i = 0; i <= 15; i++)
> + pOperateMCS[i] = 0;
This would be just me
Simple spelling correction.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
b/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
index 05
Removed an extra indentation from the code of the various case options in a
switch statement.
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/rtl819x_HTProc.c | 30 +--
1 file changed, 15 insertions(+), 15 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee8021
Changed a number of hard coded function names to use %s and __func__
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
b/driver
Removed the unrequired braces from single statement blocks - Coding Style.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c | 11 ---
1 file changed, 4 insertions(+), 7 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
b/dr
Simple coding style changes to single file
drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
Correcton of a few block comments to comply with Coding Style.
Signed-off-by: John Whitmore
---
.../staging/rtl8192u/ieee80211/rtl819x_HTProc.c | 17 -
1 file changed, 8 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
b/drivers/sta
Some of the comment blocks are commening out code so have been left for the
moment.
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/rtl819x_HTProc.c | 366 ++
1 file changed, 195 insertions(+), 171 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl81
Where possible truncation of block comments to the 80 character length
prefered by the coding style.
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/rtl819x_HTProc.c | 157 +++---
1 file changed, 98 insertions(+), 59 deletions(-)
diff --git a/drivers/staging/rtl8192u/i
Corrected the coding style of if statement.
Signed-off-by: John Whitmore
---
drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/rtl8192u/ieee80211/rtl819x_HTProc.c
b/drivers/staging/rtl8192u/ieee80211/rtl81
Previous truncation of comment blocks to 80 character line length resulted in
some white space at endof line.
Signed-off-by: John Whitmore
---
.../rtl8192u/ieee80211/rtl819x_HTProc.c | 26 +--
1 file changed, 13 insertions(+), 13 deletions(-)
diff --git a/drivers/staging/r
Upon updating some internal kernels from 4.14.18 to 4.14.49, our hyper-v guests
failed to bring up network interfaces on boot, logging "A link change request
failed with some changes committed already. Interface eth0 may have been left
with an inconsistent configuration, please check." Running
Use structs ethhdr, iphdr and tcphdr instead of manual parsing in
tcp_process.
This commit fix handling of ip packets containing options.
It also fixes the following sparse warning:
drivers/staging/wilc1000//wilc_wlan.c:201:19: warning: cast to restricted __be16
Signed-off-by: Thibaut Robert
---
> -Original Message-
> From: Michael Kelley (EOSG)
> Sent: Tuesday, June 19, 2018 10:57 AM
> To: Vitaly Kuznetsov ; x...@kernel.org
> Cc: de...@linuxdriverproject.org; linux-ker...@vger.kernel.org; KY
> Srinivasan ; Haiyang Zhang
> ; Stephen Hemminger
> ; Thomas Gleixner ; Ingo
> Molnar
> -Original Message-
> From: linux-kernel-ow...@vger.kernel.org
> On Behalf
> Of Vitaly Kuznetsov
> Sent: Friday, June 15, 2018 9:30 AM
> To: x...@kernel.org
> Cc: de...@linuxdriverproject.org; linux-ker...@vger.kernel.org; KY Srinivasan
> ; Haiyang Zhang ; Stephen
> Hemminger
> ; Thomas
On Tue, Jun 19, 2018 at 6:25 PM, Anton Vasilyev wrote:
> If rtsx_probe() fails to allocate dev->chip, then release_everything()
> will crash on uninitialized dev->cmnd_ready complete
Period is missed at the end.
>
> Patch adds error handling into rtsx_probe.
an error
>
> Found by Linux Driver
Fix memory leak in error path of mtk_add_mac() by make sure to free
the allocated netdev.
Fixes: e3cbf478f846 ('staging: mt7621-eth: add the drivers core files')
Signed-off-by: Kamal Heib
---
Changes from v2:
No need to print error when allocation failed.
Changes from v1:
No need
On Mon, Jun 18, 2018 at 10:52:01AM +0200, Greg Kroah-Hartman wrote:
> On Sat, Jun 16, 2018 at 01:01:27PM +0300, Kamal Heib wrote:
> > Fix memory leak in error path of mtk_add_mac() by make sure to free
> > the allocated netdev.
> >
> > Fixes: e3cbf478f846 ('staging: mt7621-eth: add the drivers cor
Signed-off-by: Vitor Fernandes Ferreira
---
drivers/staging/comedi/comedi_fops.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/comedi/comedi_fops.c
b/drivers/staging/comedi/comedi_fops.c
index 1f3b1106f478..e18b61cdbdeb 100644
--- a/drivers/staging/comed
If rtsx_probe() fails to allocate dev->chip, then release_everything()
will crash on uninitialized dev->cmnd_ready complete
Patch adds error handling into rtsx_probe.
Found by Linux Driver Verification project (linuxtesting.org).
Signed-off-by: Anton Vasilyev
---
v4: rename labels baced on Dan
On Tue, Jun 19, 2018 at 09:42:20AM -0400, Hugo Lefeuvre wrote:
> This TODO seems to be related to this misunderstanding too:
>
> 890 /* TODO? guard against device removal before, or while,
> 891 * we issue this ioctl. --> device_get()
> 892 */
>
> Device removal can't
> > It would be great to get rid of this counter, indeed. But how to do it
> > properly without breaking things ? It seems to be useful to me...
>
> These things are refcounted so you can't unload the module while a file
> is open. When we do an open it does a cdev_get(). When we call the
> dele
Thomas Gleixner writes:
> On Tue, 19 Jun 2018, Vitaly Kuznetsov wrote:
>> Thomas Gleixner writes:
>>
>> > On Fri, 15 Jun 2018, Vitaly Kuznetsov wrote:
>> >> * Fills in gva_list starting from offset. Returns the number of items
>> >> added.
>> >> @@ -93,10 +95,19 @@ static void hyperv_flush_t
On Tue, 19 Jun 2018, Vitaly Kuznetsov wrote:
> Thomas Gleixner writes:
>
> > On Fri, 15 Jun 2018, Vitaly Kuznetsov wrote:
> >> * Fills in gva_list starting from offset. Returns the number of items
> >> added.
> >> @@ -93,10 +95,19 @@ static void hyperv_flush_tlb_others(const struct
> >> cpuma
Thomas Gleixner writes:
> On Fri, 15 Jun 2018, Vitaly Kuznetsov wrote:
>> * Fills in gva_list starting from offset. Returns the number of items
>> added.
>> @@ -93,10 +95,19 @@ static void hyperv_flush_tlb_others(const struct cpumask
>> *cpus,
>> if (cpumask_equal(cpus, cpu_present_mask)
On Fri, 15 Jun 2018, Vitaly Kuznetsov wrote:
> * Fills in gva_list starting from offset. Returns the number of items added.
> @@ -93,10 +95,19 @@ static void hyperv_flush_tlb_others(const struct cpumask
> *cpus,
> if (cpumask_equal(cpus, cpu_present_mask)) {
> flush->flags |=
On Mon, Jun 18, 2018 at 11:11:36PM -0400, Hugo Lefeuvre wrote:
> Hi Dan,
>
> > We need to decrement device->users-- on the error paths as well.
> > This function was already slightly broken with respect to counting the
> > users, but let's not make it worse.
> >
> > I think it's still a tiny bit
Hi Hugo,
sorry for the late response and thank you for all that deep
investigation in the pi433 driver!
> According to the datasheet[0], the deviation should always be smaller
> than 300kHz, and the following equation should be respected:
>
> (1) FDA + BRF/2 =< 500 kHz
>
> Why did you choose
On Tue, Jun 19, 2018 at 09:51:44AM +0200, Geert Uytterhoeven wrote:
> On Tue, Jun 19, 2018 at 9:37 AM Dan Carpenter
> wrote:
> > On Mon, Jun 18, 2018 at 08:53:19PM +0200, Nicholas Mc Guire wrote:
> > > The call to of_find_compatible_node() returns irqc_node with refcount
> > > incremented thus i
On Tue, Jun 19, 2018 at 9:18 AM, Quytelda Kahja wrote:
> I'm fairly sure this doesn't matter functionally (yet), but perhaps
> 'notify_timestamp' should be updated to an 's64' type since ktime_to_us()
> returns a signed type?
I think it's fine either way, ktime_t is only signed to deal with
diffe
On Tue, Jun 19, 2018 at 9:37 AM Dan Carpenter wrote:
> On Mon, Jun 18, 2018 at 08:53:19PM +0200, Nicholas Mc Guire wrote:
> > The call to of_find_compatible_node() returns irqc_node with refcount
> > incremented thus it must be explicitly decremented here after it was
> > checked for non-NULL.
>
Thanks for this. This is a lot of work.
On Wed, Jun 13, 2018 at 08:31:28PM +0300, Anton Vasilyev wrote:
> diff --git a/drivers/staging/rts5208/rtsx.c b/drivers/staging/rts5208/rtsx.c
> index 70e0b8623110..69e6abe14abf 100644
> --- a/drivers/staging/rts5208/rtsx.c
> +++ b/drivers/staging/rts5208/r
On Mon, Jun 18, 2018 at 08:53:19PM +0200, Nicholas Mc Guire wrote:
> The call to of_find_compatible_node() returns irqc_node with refcount
> incremented thus it must be explicitly decremented here after it was
> checked for non-NULL.
>
> Signed-off-by: Nicholas Mc Guire
> Fixes: commit 72ee8626e
I'm fairly sure this doesn't matter functionally (yet), but perhaps
'notify_timestamp' should be updated to an 's64' type since ktime_to_us()
returns a signed type?
That note aside, I think this is good.
On Mon, Jun 18, 2018 at 05:06:50PM +0200, Arnd Bergmann wrote:
> get_monotonic_boottime() is
55 matches
Mail list logo