From: Haiyang Zhang
Date: Thu, 14 Jun 2018 18:29:09 -0700
> From: Haiyang Zhang
>
> These fields in struct ndis_ipsecv2_offload and struct ndis_rsc_offload
> are one byte according to the specs. This patch defines them with the
> right size. These structs are not in use right now, but will be u
> -Original Message-
> From: David Miller
> Sent: Thursday, June 14, 2018 8:00 PM
> To: Haiyang Zhang ; haiya...@linuxonhyperv.com
> Cc: net...@vger.kernel.org; KY Srinivasan ; Stephen
> Hemminger ; o...@aepfle.de;
> vkuzn...@redhat.com; de...@linuxdriverproject.org; linux-
> ker...@vge
From: Haiyang Zhang
These fields in struct ndis_ipsecv2_offload and struct ndis_rsc_offload
are one byte according to the specs. This patch defines them with the
right size. These structs are not in use right now, but will be used soon.
Signed-off-by: Haiyang Zhang
---
drivers/net/hyperv/hyper
Bug fixes should be targetted at net, not net-next. Furthermore,
net-next is closed.
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
* in github.com/neilbrown/linux) so we can get it ready for
>> merging properly.
>> I've added you patch to my tree.
>
> You need to add this patch in your tree as well.
> https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/commit/?h=next-20180614&am
Fix memory leaks in error path of mtk_add_mac() by make sure to free
the allocated resources.
Fixes: e3cbf478f846 ('staging: mt7621-eth: add the drivers core files')
Signed-off-by: Kamal Heib
---
drivers/staging/mt7621-eth/mtk_eth_soc.c | 16 +---
1 file changed, 13 insertions(+), 3
From: Haiyang Zhang
These fields in struct ndis_ipsecv2_offload and struct ndis_rsc_offload
are one byte according to the specs. This patch defines them with the
right size.
Signed-off-by: Haiyang Zhang
---
drivers/net/hyperv/hyperv_net.h | 26 +-
1 file changed, 13 ins
On Thu, Jun 14, 2018 at 01:19:12PM -0400, Javier Martinez wrote:
> Removal of a comment that was not needed at all.
> We can clearly see that they are include/header files.
>
> Signed-off-by: Javier Martinez
> ---
> drivers/staging/comedi/drivers/ssv_dnp.c | 1 -
> 1 file changed, 1 deletion(-)
On Thu, Jun 14, 2018 at 06:17:18PM +0200, Chris Opperman wrote:
> Hi Ian,
>
> Thank you! Are there any more steps for me to take to complete this
> patch process?
>
No. You're done... Greg will apply the patch in a week or two and
you'll get an email.
regards,
dan carpenter
_
PIN_MASK macro was being used because of the fact we were only
using one interrupt controller for all of the gpio chips. This
has been changed to use one per gpio chip and each has 32 irqs.
Because of this this macro is not needed anymore. Use BIT macro
instead.
Signed-off-by: Sergio Paracuellos
Instead of create a custom irq_domain for this chip, use
'gpiochip_set_chained_irqchip' from GPIOLIB_IRQCHIP. It
is ok to call this function several times. We have to
manually mark the line with 'IRQF_SHARED' and then loop
over the three banks until you find a hit. There were
some problems with rem
Including file '' should be avoided in
new drivers code, so just remove it because it is
no necessary at all.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-gpio/gpio-mt7621.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/mt7621-gpio/gpio-mt7621.c
b/drivers/st
This driver was being registered using 'module_platform_driver'
but it is not a module at all. Instead of this use
'builtin_platform_driver' which seems to be the correct one.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-gpio/gpio-mt7621.c | 2 +-
1 file changed, 1 insertion(+),
If there is no interrupt defined in the dts 'irq_of_parse_and_map'
returns 0 and we should't set up interrupts for each gpio chip in
that case.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-gpio/gpio-mt7621.c | 42 ---
1 file changed, 22 insertions(+),
Update kernel doc for mtk_data and also remove no needed
documentation for mtk_gc which is clear enough to don't
need it.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-gpio/gpio-mt7621.c | 15 +++
1 file changed, 3 insertions(+), 12 deletions(-)
diff --git a/drivers/s
Kconfig is using a generic 'Mediatek GPIO Support' in
description and help which is not specific at all about
the current SoC which is MT7621. Update it.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-gpio/Kconfig | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --gi
This commit adds kerneldoc for the two data containers in
order to better understanding of its existence.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-gpio/gpio-mt7621.c | 18 ++
1 file changed, 18 insertions(+)
diff --git a/drivers/staging/mt7621-gpio/gpio-mt762
This chip support high level and low level interrupts. Those
have to be implemented also to get a complete and clean driver.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-gpio/gpio-mt7621.c | 47 ---
1 file changed, 37 insertions(+), 10 deletions(-)
di
When implementing custom irqchips it is important to also
implement .irq_request_resources() and .irq_release_resources()
and make sure these call gpiochip_[un]lock_as_irq().
Add those two for this driver. Also store struct device pointer
in global state structure to be able to use 'dev_err' with t
Currently the driver defines 3 gpiochips, one for each bank.
/sys/class/gpio/gpiochip416/label:1e000600.gpio
/sys/class/gpio/gpiochip448/label:1e000600.gpio
/sys/class/gpio/gpiochip480/label:1e000600.gpio
Unfortunately they all have the same label
Interrupts from /proc/interrupt show the same na
After submiting this driver to try to get mainlined and get
out of staging some new cleanups seems to be necessary.
According to this mail of Linus Walleij:
http://driverdev.linuxdriverproject.org/pipermail/driverdev-devel/2018-June/121742.html
and this mail os Rob Herring:
http://driverdev.linu
There is no need to check for 'pending' before loop over the
interrupts using 'for_each_set_bit' if nothing is set the
return values will be the same so just avoid this check avoiding
also one level intentation and improving readability.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt76
Function 'to_mediatek_gpio' cannot return NULL, so this NULL
checkings are pointless.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-gpio/gpio-mt7621.c | 9 -
1 file changed, 9 deletions(-)
diff --git a/drivers/staging/mt7621-gpio/gpio-mt7621.c
b/drivers/staging/mt7621-gp
This driver is actually platform-agnostic. Add COMPILE_TEST for
the compilation test coverage.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-gpio/Kconfig | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/mt7621-gpio/Kconfig
b/drivers/staging/mt7
Banks shouldn't be defined in DT if number of resources
per bank is not variable. We actually know that this SoC
has three banks so take that into account in order to don't
overspecify the device tree. Device tree will only have one
node making it simple. Update device tree, binding doc and
code ac
Gpio complexity is just masking the fact that offset is always
0..n and writes to bits 0..n of some memory address. Because
of this whole thing can just me converted to use GPIO_GENERIC
and avoid duplications of a lot of driver custom functions.
So use bgpio_init instead of custom code adding GPIO_
There was two remaining defines which weren't properly
aligned with the rest. Align them improving readability.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-gpio/gpio-mt7621.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/mt7621-gpio/gpio
Checkpatch script is complaining about a comment line
which exceeds 80 characteres. Just silence it.
Signed-off-by: Sergio Paracuellos
---
drivers/staging/mt7621-gpio/gpio-mt7621.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/mt7621-gpio/gpio-mt7621.c
Removal of a comment that was not needed at all.
We can clearly see that they are include/header files.
Signed-off-by: Javier Martinez
---
drivers/staging/comedi/drivers/ssv_dnp.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/staging/comedi/drivers/ssv_dnp.c
b/drivers/staging/comed
On Thu, 14 Jun 2018 13:08:49 -0300
Mauro Carvalho Chehab wrote:
> +++ b/Documentation/trace/events.rst
> @@ -8,7 +8,7 @@ Event Tracing
> 1. Introduction
> ===
>
> -Tracepoints (see Documentation/trace/tracepoints.txt) can be used
> +Tracepoints (see Documentation/trace/tracepoints
On Thu, Jun 14, 2018 at 4:17 PM, Linus Walleij wrote:
> On Thu, Jun 14, 2018 at 6:45 AM, Sergio Paracuellos
> wrote:
>
>> Ok, so... does the following single node sounds acceptable?
>>
>> gpio: gpio@600 {
>> #gpio-cells = <2>;
>> #interrupt-cells = <2>;
>> compatible = "mediatek,mt7621-gpio
Hi Ian/Dan,
In that case I'll stick to the cut-off line format in future. Thanks!
Kind Regards,
Chris Opperman
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
Hi Ian,
Thank you! Are there any more steps for me to take to complete this
patch process?
Kind Regards,
Chris Opperman
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
As we move stuff around, some doc references are broken. Fix some of
them via this script:
./scripts/documentation-file-ref-check --fix
Manually checked if the produced result is valid, removing a few
false-positives.
Acked-by: Takashi Iwai
Acked-by: Masami Hiramatsu
Acked-by: Stephen B
There are several places pointing to old documentation files:
Documentation/video4linux/API.html
Documentation/video4linux/bttv/
Documentation/video4linux/cx2341x/fw-encoder-api.txt
Documentation/video4linux/m5602.txt
Documentation/video4linux/v4l2-framework.txt
Documentation/video4lin
The script:
./scripts/documentation-file-ref-check --fix-rst
Gives multiple hints for broken references on some files.
Manually use the one that applies for some files.
Signed-off-by: Mauro Carvalho Chehab
---
Documentation/ABI/obsolete/sysfs-gpio | 2 +-
.../devicet
Move open braces of two structs to the declaration line,
as criticized by checkpatch.
Signed-off-by: Henriette Hofmeier
Signed-off-by: Florian Harbecke
---
drivers/w1/masters/ds2490.c | 6 ++
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/drivers/w1/masters/ds2490.c b/drivers
Remove unnecessary spaces, add required spaced and
move braces to fix errors reported by checkpatch.
Henriette Hofmeier (3):
ds2490.c: Add required spaces
ds2490.c: Remove unnecessary whitespace
ds2490.c: Move struct open braces to previous line
drivers/w1/masters/ds2490.c | 16 +++---
Add missing spaces in for- and while-loops
reported missing by checkpatch.
Signed-off-by: Henriette Hofmeier
Signed-off-by: Florian Harbecke
---
drivers/w1/masters/ds2490.c | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/w1/masters/ds2490.c b/drivers/w1/maste
Remove unnecessary whitespace criticized by
checkpatch.
Signed-off-by: Henriette Hofmeier
Signed-off-by: Florian Harbecke
---
drivers/w1/masters/ds2490.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/w1/masters/ds2490.c b/drivers/w1/masters/ds2490.c
index 917a5f1..
On Thu, Jun 14, 2018 at 4:33 PM, Rob Herring wrote:
> On Thu, Jun 14, 2018 at 8:14 AM, Linus Walleij
> wrote:
>> On Wed, Jun 13, 2018 at 9:28 PM, Rob Herring wrote:
>>
"Some system-on-chips (SoCs) use the concept of GPIO banks. ...
Usually each such bank is
exposed in the device
On Thu, Jun 14, 2018 at 8:14 AM, Linus Walleij wrote:
> On Wed, Jun 13, 2018 at 9:28 PM, Rob Herring wrote:
>
>>> "Some system-on-chips (SoCs) use the concept of GPIO banks. ...
>>> Usually each such bank is
>>> exposed in the device tree as an individual gpio-controller node. ..."
>>
>> This sho
Also I think the email list is rejecting your replies because they're
in html?
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
On Thu, Jun 14, 2018 at 6:45 AM, Sergio Paracuellos
wrote:
> Ok, so... does the following single node sounds acceptable?
>
> gpio: gpio@600 {
> #gpio-cells = <2>;
> #interrupt-cells = <2>;
> compatible = "mediatek,mt7621-gpio";
> gpio-controller;
> interrupt-controller;
> reg = <0x600
On Wed, Jun 13, 2018 at 9:28 PM, Rob Herring wrote:
>> "Some system-on-chips (SoCs) use the concept of GPIO banks. ...
>> Usually each such bank is
>> exposed in the device tree as an individual gpio-controller node. ..."
>
> This should be conditioned on being able to divide up the registers by
On Thu, Jun 14, 2018 at 11:27:26AM +0800, Zhouyang Jia wrote:
> Hi,
>
> I reported this bug since more than 95% callsites of nlmsg_put are
> well handled in kernel, and many of them also allocated skb before.
>
That's probably true, but the NULL check is not required *here*.
Just mark it as a f
On Thu, Jun 14, 2018 at 07:31:51PM +0800, Zhouyang Jia wrote:
> When nlmsg_put fails, the lack of error-handling code may
> cause unexpected results.
>
> This patch adds error-handling code after calling nlmsg_put.
>
> Signed-off-by: Zhouyang Jia
> ---
> v1->v2:
> - Add some cleanup
> ---
> dri
Perfect. Thanks!
regards,
dan carpenter
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
On Wed, Jun 13, 2018 at 03:01:08PM -0400, Javier Martinez wrote:
> Fixed style line length warning detected by checkpatch.pl in the file
> ssv_dnp.c.
>
> Signed-off-by: Javier Martinez
> ---
> drivers/staging/comedi/drivers/ssv_dnp.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> d
Since 'filled' member in station_info changed to u64, BIT_ULL macro
should be used with NL80211_STA_INFO_* attribute types instead of BIT.
The BIT macro uses unsigned long type which some architectures handle as 32bit
and this results in compilation warnings such as:
net/mac80211/sta_info.c:2223:
> Thank you for the patch! Yet something to improve:
>
> [auto build test ERROR on staging/staging-testing]
> [also build test ERROR on v4.17 next-20180613]
> [if your patch is applied to the wrong git tree, please drop us a note to
> help improve the system]
Already fixed in v4. Sorry for the n
On Thu, 2018-06-14 at 13:13 +0300, Omer Efrat wrote:
> Since 'filled' member in station_info changed to u64, BIT_ULL macro
> should be used with NL80211_STA_INFO_* attribute types instead of BIT.
>
> The BIT macro uses unsigned long type which some architectures handle as 32bit
> and this results
When nlmsg_put fails, the lack of error-handling code may
cause unexpected results.
This patch adds error-handling code after calling nlmsg_put.
Signed-off-by: Zhouyang Jia
---
v1->v2:
- Add some cleanup
---
drivers/staging/gdm724x/netlink_k.c | 5 +
1 file changed, 5 insertions(+)
diff --
On 13/06/18 20:01, Javier Martinez wrote:
Fixed style line length warning detected by checkpatch.pl in the file
ssv_dnp.c.
Signed-off-by: Javier Martinez
---
drivers/staging/comedi/drivers/ssv_dnp.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/comedi/dr
ou have undoubtedly noticed, lustre is no longer in Linus' tree.
> I'm experimenting with maintaining a branch which retains the code
> (lustre/* in github.com/neilbrown/linux) so we can get it ready for
> merging properly.
> I've added you patch to my tree.
You need to ad
On 13/06/18 20:05, Dan Carpenter wrote:
On Wed, Jun 13, 2018 at 08:26:43PM +0200, Chris Opperman wrote:
Hi Dan/Ian,
Noted your comments regarding additional text, thanks! Just curious whether
the "scissors" format given at the link below is valid?
https://kernelnewbies.org/PatchTipsAndTricks
On 14/06/18 08:57, Zhouyang Jia wrote:
Hi,
I reported this bug since more than 90% callsites of vmap are
well handled in kernel. The caller function __comedi_buf_alloc
has no return value, so I don't know how the error is handled in
its caller.
I believe there would be a better error handling m
On Tue, Jun 12 2018, Souptick Joarder wrote:
> On 12-Jun-2018 2:21 AM, "Greg KH" wrote:
>>
>> On Tue, Jun 12, 2018 at 02:00:47AM +0530, Souptick Joarder wrote:
>> > On Mon, May 21, 2018 at 11:39 PM, Souptick Joarder
>> >
>> > If no further comment, we would like to get this patch in 4.18-rc-X.
>
58 matches
Mail list logo